after update: no notifications from telegram

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
Haringstad
Posts: 26
Joined: Tuesday 22 November 2016 10:54
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: after update: no notifications from telegram

Post by Haringstad » Friday 25 August 2017 15:05

@JulzJulz, we just have to wait :-) And I bet that this issue will be solved before the weekend is over! :!:

lukbe
Posts: 18
Joined: Saturday 06 May 2017 22:46
Target OS: Raspberry Pi
Domoticz version: 3.8153
Contact:

Re: after update: no notifications from telegram

Post by lukbe » Friday 25 August 2017 16:30

Hello guys, I have probably same problem with last beta Version: 3.8364 of the domoticz on my RPI 3.

I use in domoticz script for sending temperature to the thingspeak. Script worked fine, only after last update it does not work and in the log i have error. Error: Error opening url.

Is there any solution ?

My script here:
Spoiler: show
-- script_time_misc.lua
-------------------------------------


local sensor_name1 = 'Loznice' -- name of the sensor
local sensor_name2 = 'Venku' -- name of the sensor
local Thingspeak_API= 'xxxxx' -- your thingspeak api key

local set_time= 10 -- time in min

commandArray = {}
local m = os.date('%M')
if (m % set_time == 0) then
--print('Ubehl nastaveny cas: ' .. set_time .. ' min')

Temp_loznice, Humidity_loznice, sHumFeelsLike_loznice = otherdevices_svalues[sensor_name1]:match("([^;]+);([^;]+);([^;]+)") -- save values from the sensor in to each variable
Temp_loznice = tonumber(Temp_loznice)
Humidity_loznice = tonumber(Humidity_loznice)

Temp_venku, Humidity_venku, sHumFeelsLike_venku = otherdevices_svalues[sensor_name2]:match("([^;]+);([^;]+);([^;]+)") -- save values from the sensor in to each variable
Temp_venku = tonumber(Temp_venku)
Humidity_venku = tonumber(Humidity_venku)

-- print('Teplota - Obyvaci pokoj:' ..Temp_loznice )
--print('Vlhkost - Obyvaci pokoj:' .. Humidity_loznice)

commandArray['OpenURL']=('https://api.thingspeak.com/update?api_key='..
Thingspeak_API.. '&field1=' ..Temp_loznice.. '&field2=' ..Humidity_loznice..
'&field3='..Temp_venku..'&field4='.. Humidity_venku)
--print('Odesilani na Thingspeak')

end


return commandArray


Odesláno z mého MI 4W pomocí Tapatalk


Freemann
Posts: 88
Joined: Thursday 24 November 2016 15:55
Target OS: Raspberry Pi
Domoticz version: >=Béta
Location: Netherlands
Contact:

Re: after update: no notifications from telegram

Post by Freemann » Friday 25 August 2017 17:05

Here also connection issues;

Code: Select all

2017-08-25 17:00:16.741 Error: Netatmo: Error connecting to Server...
2017-08-25 17:00:21.799 Error: DarkSky: Error getting http data!.
2017-08-25 17:00:46.773 Error: Netatmo: Error connecting to Server...
2017-08-25 17:00:46.801 Error: Netatmo: Error connecting to Server...
2017-08-25 17:01:01.932 Error: SMTP Mailer: Error sending Email to: !
2017-08-25 17:01:01.932 Error: Failed to send Email notification!
2017-08-25 17:01:01.932 Error: Notification sent (email) => Failed
<...>
2017-08-25 17:04:07.462 Error: GCM: Could not send message, HTTP Error
2017-08-25 17:04:07.462 Error: Notification sent (gcm) => Failed
Here issues with;
NetAtmo,
DarkSky,
SMTP,
GCM

Build Hash: 1ba40be6
Build Date: 2017-08-25 07:34:01
Build version: V3.8364

Looks like domoticz can't connect to external sources :!: :?: :| :shock: :o

Created an issue on Github :
Since 3.8360 Totally none (http?) external connection possible #1782
Domotica/graphs "freak" :)
Rpi3
Amazon Alexa (2 Echo Dots)
Aeotec Z-Stick S2(Gen5)
HarmonyElite
ETHRelayBoard
HUE(5 bulbs, 2 blooms)
NetAtmo(complete setup)
MiLight iboxV6(2 MiLightBulbs)
IP-Cam

https://www.frijduurzaam.nl

vanputten80
Posts: 13
Joined: Sunday 04 January 2015 17:04
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: after update: no notifications from telegram

Post by vanputten80 » Saturday 26 August 2017 7:19

Issue with email notifications. Errol already mentioned in this topic.

Use the latest stable Windows version. Triest bèta yesterday, same.

lukbe
Posts: 18
Joined: Saturday 06 May 2017 22:46
Target OS: Raspberry Pi
Domoticz version: 3.8153
Contact:

Re: after update: no notifications from telegram

Post by lukbe » Saturday 26 August 2017 7:51

Today I updated to 3.8365 and still same problem. :-( is here any developer?

Odesláno z mého MI 4W pomocí Tapatalk


roblom
Posts: 561
Joined: Wednesday 26 February 2014 16:28
Target OS: Raspberry Pi
Domoticz version:
Location: the Netherlands
Contact:

Re: after update: no notifications from telegram

Post by roblom » Saturday 26 August 2017 8:29

3.8365 is a beta version. Beta versions can contain bugs. If you can't want that use the latest stable version.

Freemann
Posts: 88
Joined: Thursday 24 November 2016 15:55
Target OS: Raspberry Pi
Domoticz version: >=Béta
Location: Netherlands
Contact:

Re: after update: no notifications from telegram

Post by Freemann » Saturday 26 August 2017 10:22

roblom wrote:
Saturday 26 August 2017 8:29
3.8365 is a beta version. Beta versions can contain bugs. If you can't want that use the latest stable version.
Great post!
Bugs OK, but this is a major show stopper which prevents almost all API's to work with Domoticz.
This "bug" makes my installation totally useless.

Atleast 10 (sub)system/devices are down due to this "bug".

:lol:
Domotica/graphs "freak" :)
Rpi3
Amazon Alexa (2 Echo Dots)
Aeotec Z-Stick S2(Gen5)
HarmonyElite
ETHRelayBoard
HUE(5 bulbs, 2 blooms)
NetAtmo(complete setup)
MiLight iboxV6(2 MiLightBulbs)
IP-Cam

https://www.frijduurzaam.nl

SweetPants
Posts: 2099
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.9701
Location: The Netherlands
Contact:

Re: after update: no notifications from telegram

Post by SweetPants » Saturday 26 August 2017 12:12

Freemann wrote:
Saturday 26 August 2017 10:22
Great post!
Bugs OK, but this is a major show stopper which prevents almost all API's to work with Domoticz.
This "bug" makes my installation totally useless.

Atleast 10 (sub)system/devices are down due to this "bug".

:lol:
I kinda agree with roblom, this is why I have a second test system to test major functionality of a new Beta before putting it on my production system.
Ubuntu 16.04.3 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (source)

Freemann
Posts: 88
Joined: Thursday 24 November 2016 15:55
Target OS: Raspberry Pi
Domoticz version: >=Béta
Location: Netherlands
Contact:

Re: after update: no notifications from telegram

Post by Freemann » Saturday 26 August 2017 13:25

SweetPants wrote:
Saturday 26 August 2017 12:12
Freemann wrote:
Saturday 26 August 2017 10:22
Great post!
Bugs OK, but this is a major show stopper which prevents almost all API's to work with Domoticz.
This "bug" makes my installation totally useless.

Atleast 10 (sub)system/devices are down due to this "bug".

:lol:
I kinda agree with roblom, this is why I have a second test system to test major functionality of a new Beta before putting it on my production system.
You guys are so TOTALLY right!

But;
1. Its a big open door to say that here....
2. It nearly impossible to debug a system without running it full-swing in a production like situation (guess there nobody here with an (D)TAP "street" :?: )
3. if nobody test Domoticz in a production like situation bug will enter "stable"

For now I'm going back to stable and will see if/when and how this will be solved from the sideline :)
Domotica/graphs "freak" :)
Rpi3
Amazon Alexa (2 Echo Dots)
Aeotec Z-Stick S2(Gen5)
HarmonyElite
ETHRelayBoard
HUE(5 bulbs, 2 blooms)
NetAtmo(complete setup)
MiLight iboxV6(2 MiLightBulbs)
IP-Cam

https://www.frijduurzaam.nl

JuanUil
Posts: 283
Joined: Friday 22 May 2015 12:21
Target OS: Raspberry Pi
Domoticz version: 2.xx
Location: Asten NB Nederland
Contact:

Re: after update: no notifications from telegram

Post by JuanUil » Sunday 27 August 2017 8:06

Freemann wrote:
Saturday 26 August 2017 13:25
SweetPants wrote:
Saturday 26 August 2017 12:12
Freemann wrote:
Saturday 26 August 2017 10:22
Great post!
Bugs OK, but this is a major show stopper which prevents almost all API's to work with Domoticz.
This "bug" makes my installation totally useless.

Atleast 10 (sub)system/devices are down due to this "bug".

:lol:
I kinda agree with roblom, this is why I have a second test system to test major functionality of a new Beta before putting it on my production system.
You guys are so TOTALLY right!

But;
1. Its a big open door to say that here....
2. It nearly impossible to debug a system without running it full-swing in a production like situation (guess there nobody here with an (D)TAP "street" :?: )
3. if nobody test Domoticz in a production like situation bug will enter "stable"

For now I'm going back to stable and will see if/when and how this will be solved from the sideline :)
I agree
Your mind is like a parachute,
It only works when it is opened!

User avatar
Varazir
Posts: 225
Joined: Friday 20 February 2015 23:23
Target OS: Raspberry Pi
Domoticz version: Beta
Contact:

Re: after update: no notifications from telegram

Post by Varazir » Sunday 27 August 2017 19:28

I tested the WEB API I'm using from the shell and it works there with wget
1x Raspberry PI A with a RaZberry board
1x GreenWave 6 port Power node
1x tellstick
1x Qubino ZMNHOD1 ( controlling a Ikea blinder )
1x ZW075 Smart Switch Gen5
Several nexa/proove devices

Live Long and Prosper \\//_

User avatar
emme
Posts: 819
Joined: Monday 27 June 2016 11:02
Target OS: Raspberry Pi
Domoticz version: latest
Location: Milano, Italy
Contact:

Re: after update: no notifications from telegram

Post by emme » Monday 28 August 2017 10:47

Hi,
RPi3 updated to new kernel....
Notification (Telegram BOT) --> Notification sent (http) => Failed
eMail notification (gMail) --> SMTP Mailer: Error sending Email to: !
NetATMO (Home Coach) --> Cannot Connect to server
DarkSky --> Erro getting data
thanks
ciao
M
:(
That's one small step for a programmer, one giant leap for me!
- - - - -
Raspberry Pi3 + AeonStick G5 + RFXCOMM433 + iRTrans Server + NodeJS
There's no stress in the mess!!

SweetPants
Posts: 2099
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.9701
Location: The Netherlands
Contact:

Re: after update: no notifications from telegram

Post by SweetPants » Monday 28 August 2017 11:45

emme wrote:
Monday 28 August 2017 10:47
Hi,
RPi3 updated to new kernel....
Notification (Telegram BOT) --> Notification sent (http) => Failed
eMail notification (gMail) --> SMTP Mailer: Error sending Email to: !
NetATMO (Home Coach) --> Cannot Connect to server
DarkSky --> Erro getting data
thanks
ciao
M
:(
If you had read the forum first, you would have known that there is an issue with latest Beta(s).
Ubuntu 16.04.3 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (source)

Freemann
Posts: 88
Joined: Thursday 24 November 2016 15:55
Target OS: Raspberry Pi
Domoticz version: >=Béta
Location: Netherlands
Contact:

Re: after update: no notifications from telegram

Post by Freemann » Monday 28 August 2017 12:19

emme wrote:
Monday 28 August 2017 10:47
Hi,
RPi3 updated to new kernel....
Notification (Telegram BOT) --> Notification sent (http) => Failed
eMail notification (gMail) --> SMTP Mailer: Error sending Email to: !
NetATMO (Home Coach) --> Cannot Connect to server
DarkSky --> Erro getting data
thanks
ciao
M
:(
Devs don't know where it comes from, so advice for now; move back to stable.
Domotica/graphs "freak" :)
Rpi3
Amazon Alexa (2 Echo Dots)
Aeotec Z-Stick S2(Gen5)
HarmonyElite
ETHRelayBoard
HUE(5 bulbs, 2 blooms)
NetAtmo(complete setup)
MiLight iboxV6(2 MiLightBulbs)
IP-Cam

https://www.frijduurzaam.nl

User avatar
emme
Posts: 819
Joined: Monday 27 June 2016 11:02
Target OS: Raspberry Pi
Domoticz version: latest
Location: Milano, Italy
Contact:

Re: after update: no notifications from telegram

Post by emme » Monday 28 August 2017 12:35

no rush.... :D
I can wait
mine was just a notification :P

ciao
M
That's one small step for a programmer, one giant leap for me!
- - - - -
Raspberry Pi3 + AeonStick G5 + RFXCOMM433 + iRTrans Server + NodeJS
There's no stress in the mess!!

SweetPants
Posts: 2099
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.9701
Location: The Netherlands
Contact:

Re: after update: no notifications from telegram

Post by SweetPants » Monday 28 August 2017 13:02

Freemann wrote:
Monday 28 August 2017 12:19
Devs don't know where it comes from, so advice for now; move back to stable.
@Dev's, I'm on last Beta but compile from source (Ubuntu 14.04LTS), there everything is working fine, maybe this helps finding the solution
Ubuntu 16.04.3 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (source)

gennapium
Posts: 78
Joined: Thursday 18 August 2016 10:06
Target OS: Raspberry Pi
Domoticz version: beta
Location: Netherlands
Contact:

Re: after update: no notifications from telegram

Post by gennapium » Monday 28 August 2017 13:08

Hi,


Same here i am on Ubuntu 16.04.3 and compiled from source, Nest working sending email working and sending pushover messages is working.
Ubuntu server, Raspberry Pi, PiFace 2, RFXCom, Z-wave Stick, Kaku, Sensor

User avatar
BUSHA
Posts: 12
Joined: Tuesday 13 June 2017 17:18
Target OS: Raspberry Pi
Domoticz version: 3.8367
Location: Kharkiv, Ukraine
Contact:

Re: after update: no notifications from telegram

Post by BUSHA » Tuesday 29 August 2017 10:46

Version: 3.8369 - still no notifications :(

SweetPants
Posts: 2099
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.9701
Location: The Netherlands
Contact:

Re: after update: no notifications from telegram

Post by SweetPants » Tuesday 29 August 2017 19:17

BUSHA wrote:
Tuesday 29 August 2017 10:46
Version: 3.8369 - still no notifications :(
Where did you read that the problem was found?
Ubuntu 16.04.3 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (source)

sysedit
Posts: 17
Joined: Saturday 05 October 2013 21:55
Target OS: Linux
Domoticz version:
Contact:

Re: after update: no notifications from telegram

Post by sysedit » Tuesday 29 August 2017 20:04

Is there anything we can do to help finding the issue ?
I'm for instance thinking of extra logging that could be added to the next beta build - as long as reverting to stable is still working I don't mind upgrading, testing, gathering logs.

As the issue is quite wide spread and can easily be reproduced it shouldn't be super hard to find the root cause (that said, as a dev I know it's always easier to say than to do ;) )

Thanks !

Post Reply

Who is online

Users browsing this forum: JoergZ and 5 guests