Cant reach web interface (Raspberry PI) Topic is solved

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
Douwe63
Posts: 3
Joined: Thursday 19 May 2016 13:00
Target OS: -
Domoticz version:
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by Douwe63 » Tuesday 22 August 2017 0:47

Got the same issues as described above and I can confirm that the 'fix' of D'rMorris seems to work (at least, the service starts without issues and I can connect to the UI via the browser).

darrepac
Posts: 158
Joined: Tuesday 04 February 2014 22:31
Target OS: Raspberry Pi
Domoticz version:
Location: Isère, France
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by darrepac » Tuesday 22 August 2017 8:41

Strange that it crashes domoticz on my side

User avatar
gizmocuz
Posts: 8721
Joined: Thursday 11 July 2013 18:59
Target OS: Raspberry Pi
Domoticz version: beta
Location: Top of the world
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by gizmocuz » Tuesday 22 August 2017 8:48

Updating to the latest beta solves it too

Code: Select all

cd domoticz
./updatebeta
Quality outlives Quantity!

darrepac
Posts: 158
Joined: Tuesday 04 February 2014 22:31
Target OS: Raspberry Pi
Domoticz version:
Location: Isère, France
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by darrepac » Tuesday 22 August 2017 8:55

gizmocuz wrote:
Tuesday 22 August 2017 8:48
Updating to the latest beta solves it too

Code: Select all

cd domoticz
./updatebeta
Yep!

ulrikk
Posts: 2
Joined: Wednesday 23 August 2017 17:32
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by ulrikk » Wednesday 23 August 2017 18:25

I have no success with Raspian Stretch version. it worked for a short while with the betaupgrade, but then the same error.
I downgraded to jessie, that works

Hoeven
Posts: 1
Joined: Thursday 24 August 2017 9:24
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by Hoeven » Thursday 24 August 2017 9:50

Hello all ,

I have a two rasp pi2 +b with domoticz , one works perfect for some years , but the other one i have frequently problems that i can not reach it .
So i took a new SD card started to install the latest noobs , it works fine , update and upgrade and then install the latest stable domoticz version . all run OK , no failures . But domoticz does not start or is able the connect. I use the pi with a RFXcom 433E

Any suggestions , how to solve this ?

Jacco
Posts: 1
Joined: Monday 08 December 2014 21:11
Target OS: Raspberry Pi
Domoticz version: V3.8153
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by Jacco » Saturday 02 September 2017 16:59

I have added the row below to /etc/apt/sources.list
deb http://ftp.de.debian.org/debian jessie main

after that I try to install the lib and it worked for me

apt-get install libssl1.0.0

You get a warning from that source but i ignored that.
stop domoticz
sudo service domoticz.sh stop
start domoticz
sudo service domoticz.sh start
And it is working.

Rebooted to be sure it is still working.

arjanhulst
Posts: 1
Joined: Tuesday 05 September 2017 20:02
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by arjanhulst » Tuesday 05 September 2017 20:46

Did a new install of Domoticz easy way on a raspberry pi3 with stretch. Ran into the problem of the libssl1.0.0 error and tryng to installing it via apt-get install did not work. So after some searching i found this link with a solution to reinstall libssl1.0.0 on Stretch.
https://diyprojects.io/domoticz-install ... a7rFshJYuU
Hope it helps.

Cheers.

AntoonvdOetelaar
Posts: 8
Joined: Thursday 24 August 2017 14:15
Target OS: Windows
Domoticz version:
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by AntoonvdOetelaar » Wednesday 06 September 2017 13:22

Probably I'm not helping... But Yesterday after a fresh install I couldn't reach the webinterface of domoticz running on the same windows machine.
This was with Internet Explorer.
After installing firefox, it did work as expected...

Skorpion
Posts: 33
Joined: Thursday 15 January 2015 10:51
Target OS: Raspberry Pi
Domoticz version:
Location: The Netherlands
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by Skorpion » Sunday 24 September 2017 17:59

arjanhulst wrote:
Tuesday 05 September 2017 20:46
Did a new install of Domoticz easy way on a raspberry pi3 with stretch. Ran into the problem of the libssl1.0.0 error and tryng to installing it via apt-get install did not work. So after some searching i found this link with a solution to reinstall libssl1.0.0 on Stretch.
https://diyprojects.io/domoticz-install ... a7rFshJYuU
Hope it helps.

Cheers.
This fixed it for me. Thanks!

mox69
Posts: 1
Joined: Sunday 24 September 2017 5:42
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by mox69 » Sunday 24 September 2017 20:29

For those of you having issues on the Raspberry PI 1 (original model A/ model B), here is a version of libssl1.0.0 that I compiled myself on my Pi last night. I'm running the Raspbian OS, September 2017 (Raspbian GNU/Linux 9 )

Working for me.

http://moxmobile.com/libssl1.0.0_1.0.1t ... _armhf.deb

ZatarraNL
Posts: 4
Joined: Saturday 16 September 2017 9:02
Target OS: -
Domoticz version:
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by ZatarraNL » Thursday 05 October 2017 15:33

Mox69, didn't work for me. Tried about everything in this post. Had a clean install earlier this day, but can't get it working.

First I got the "error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory"
After installing manually libssl, got an "Invalid" error.
After installing domoticz beta, no effect.
After manually downloading your version of libssl.so.1.0.0, Mox69, I got the "Trace/breakpoint trap" error.

Distro and packages are up-to-date.

I'm using Rpi1 with the latest Raspbian stretch lite.

Only thing left is to install 2017-07-05-raspbian-jessie-lite.

Riba
Posts: 1
Joined: Friday 06 October 2017 23:47
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by Riba » Friday 06 October 2017 23:55

Thanks Rs3b !!!

I just get my pi3, and tried to install strech with a tutorial and at the end the connection was refused.

The only thing that worked for me was using Rs3b method.
Use Jessie 05.07.2017
Connect wifi with wpa_supplicant.conf file
set MAC adresse in the rooter
updated/upgraded
install last domoticz version

TheWoodenGamer
Posts: 7
Joined: Sunday 29 January 2017 23:03
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by TheWoodenGamer » Saturday 07 October 2017 20:59

D'rMorris wrote:
Sunday 20 August 2017 9:03
I had the same issue and I fixed it by downloading the libssl1.0.0 and manually installing it. In SSH do:
wget http://ftp.nl.debian.org/debian/pool/ma ... _armhf.deb

Then:
sudo dpkg -i libssl1.0.0_1.0.1t-1+deb8u6_armhf.deb
Thanks! That fixed it for me.

EveningStarNM
Posts: 3
Joined: Friday 20 October 2017 10:03
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by EveningStarNM » Friday 20 October 2017 10:19

The problem here is that Domoticz has a hard-coded dependency on an obsolete, insecure, and already exploited version of OpenSSL, namely libssl1.0.0. Instead of calling external library routines dynamically, Domoticz hard-links to specific libraries that are no longer available in the current stable Debian repository because they are obsolete. The latest LTS version of OpenSSL for Debian-based operating systems is in libssl1.0.2 (version 1.0.2m), and the latest stable version is libssl1.1.0 (v1.1.0g). (More information about the vulnerabilities these versions address is given in CVE-2017-3735.)

The upshot is, if you're writing code that is dependent on other code that has a CVE, you're doing it wrong.

Unfortunately, Domoticz is not the only widely used IoT application to suffer from this fatal flaw. Eclipse's implementation of the MQTT protocol, named "Mosquitto", suffers from exactly the same vulnerabilities. (A known exploit is in the wild for Mosquitto 1.4.10, which comes pre-installed on Raspbian Stretch. The version that is supposed to fix it (v1.4.12) cannot be installed for the same reason that Domoticz can't be installed, and, even if it could be, it is still hard-coded to use the old, exploited version of OpenSSL.) While it is possible to download and install the obsolete version of OpenSSL, this serves more to convince the world not only that Domoticz and Mosquitto can't be trusted, but also that IoT developers, in general, cannot be trusted to produce secure software.

As time passes and these problems are ignored during development, the problem becomes harder to solve, leaving the only solution to be the nearly complete abandonment of existing code and a complete rewrite from scratch. In the end, it turns out to be cheaper to do it the right way from the beginning. It is hoped that Domoticz's (and Mosquitto's) developers will address these problems soon.

BIRD
Posts: 2
Joined: Monday 31 October 2016 13:09
Target OS: Linux
Domoticz version:
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by BIRD » Thursday 09 November 2017 19:43

Hi,
I found a solution that works for me.
I'm working with RPi B+ under Raspbian Stretch Desktop + Domoticz v.3.8153.
My solution:
Add "Jessie" in file "sources.list".

Code: Select all

sudo nano /etc/apt/sources.list
Add line:

Code: Select all

deb http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi
Then:

Code: Select all

sudo apt-get update
sudo apt-get install libssl1.0.0
sudo /etc/init.d/domoticz.sh stop
sudo /etc/init.d/domoticz.sh start
sudo /etc/init.d/domoticz.sh status
I have then => active (running) :D

Hope it can help someone.

woody4165
Posts: 530
Joined: Monday 14 March 2016 14:55
Target OS: Linux
Domoticz version: beta
Location: Rome, Italy
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by woody4165 » Friday 17 November 2017 14:35

Hi @BIRD

just testing a Domoticz installation for a friend on a RPi B+ and had issue described in this 3d.
Tested all the solutions described before your post, but none worked for me.

Removed the previously installed libssl1.0.0 and followed with success your suggestions.

Thanks!

PS: little OT, is it possible to have a second Domoticz on my network, just for test, that insists on the same devices (to test it, I would like to restore a previously backup from my main Domoticz)?
Cubietruck - Linux cubietruck 4.13.16 (Debian GNU/Linux 8 (jessie)) + Domoticz + RFLink, Xiaomi Gateway, Owl USB, Yeelight Color and B/W, ESP8266, Broadlink RM2, Netatmo Thermostat

stanv
Posts: 10
Joined: Monday 24 November 2014 23:17
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by stanv » Saturday 18 November 2017 23:27

a big +1 for BIRD.
this was the first solution that fully solved the issue.

nickous
Posts: 9
Joined: Wednesday 28 January 2015 17:42
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by nickous » Sunday 19 November 2017 9:40

gizmocuz wrote:
Tuesday 22 August 2017 8:48
Updating to the latest beta solves it too
In fact gizmocusz gave the solution 6 months ago:
  1. fresh install domoticz on stretch with the easy way
  2. updatebeta
and nothing else to do, it's working perfectly for me!

That's so simple...that I missed that and try a lot of things...before I read this thread for almost the tenth time :idea:
So I started again from the beginning and you know now the issue 8-)

User avatar
jannl
Posts: 955
Joined: Thursday 02 October 2014 6:36
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Geleen
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by jannl » Sunday 19 November 2017 10:05

The updatebeta is a rather recent solution, did not work a few months ago. And I am not sure about installing a jessie library on stretch.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests