Cant reach web interface (Raspberry PI) Topic is solved

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post
User avatar
Bernd
Posts: 56
Joined: Tuesday 04 February 2014 9:44
Target OS: Raspberry Pi
Domoticz version: 3.8153
Location: The Netherlands, De Wijk
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by Bernd » Friday 15 December 2017 18:11

gizmocuz wrote:
Tuesday 22 August 2017 8:48
Updating to the latest beta solves it too

Code: Select all

cd domoticz
./updatebeta
Would be good to add this in the wiki.
Raspberry Pi B3
RFXCOM RFXtrx433E, firmware version = 1022

User avatar
BobdeBouwer
Posts: 15
Joined: Saturday 10 May 2014 13:45
Target OS: Raspberry Pi
Domoticz version:
Location: Netherlands
Contact:

Re: Cant reach web interface (Raspberry PI)

Post by BobdeBouwer » Wednesday 03 January 2018 22:38

Thank you BIRD. (+1)
And for those wondering.. a Jessie lib works well in Stretch.. didn't break my installation (on Raspberry Pi 2)
The 'status' command showed me why the webserver did not start:
sudo /etc/init.d/domoticz.sh status
<output with cut> ... domoticz.sh[885]: /home/pi/domoticz/domoticz: error while loading shared libraries: libssl.so.1.0.0: cannot open shared â¦r directory

Next stop for me would be the update to the beta.. but I also like stable versions.
Regards,
Bob

dmtcaz
Posts: 2
Joined: Monday 02 October 2017 22:17
Target OS: Raspberry Pi
Domoticz version: 3.8153
Location: Netherlands

Re: Cant reach web interface (Raspberry PI) SOLVED

Post by dmtcaz » Saturday 13 January 2018 20:06

For those of you who get an error after installing domoticz "the easy way" that says: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory and you aren't able to open domoticz in your web browser even though everything else seems fine and you can access your Rpi from SSH, try this from your home directory. It seems to be a Raspbian Stretch issue related to missing openssl libraries.

Code: Select all

sudo wget http://ftp.nl.debian.org/debian/pool/main/o/openssl/libssl1.0.0_1.0.1t-1+deb8u7_armhf.deb
and then

Code: Select all

sudo dpkg -i libssl1.0.0_1.0.1t-1+deb8u7_armhf.deb
If you receive an error after the first command there may be a more recent version available and the older one has been deleted. Check the latest version on http://ftp.nl.debian.org/debian/pool/main/o/openssl/ i.e. look for something familiar but ending on a higher number such as deb8u8_armhf.deb etc, and adjust both of the above commands accordingly.

After that, try to run domoticz from the domoticz directory by sudo ./domoticz and the error message should be gone. Give it a CTRL-C and then start domoticz by sudo service domoticz.sh start and all should be working fine.

Post Reply

Who is online

Users browsing this forum: AVBoX and 8 guests