Lucci fan support with RFXCOM in Domoticz?

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
etxnegn
Posts: 2
Joined: Monday 16 January 2017 22:41
Target OS: Raspberry Pi
Domoticz version:
Contact:

Lucci fan support with RFXCOM in Domoticz?

Post by etxnegn » Monday 16 January 2017 22:51

Hi!

I'm trying to add a fan using the Lucci protocol that has now been supported by RFXCOM for a while.
Unfortunately I can not find the right protocol to activate under the RFXCOM "set mode" in Domoticz. :(

I can send commands with the RFXmngr (windows program) so I know the protocol is supported in RFXCOM, but I needs to get some guidance on how to get it to work with Domoticz.

Best regards Nick.

User avatar
gizmocuz
Posts: 8640
Joined: Thursday 11 July 2013 18:59
Target OS: Raspberry Pi
Domoticz version: beta
Location: Top of the world
Contact:

Re: Lucci fan support with RFXCOM in Domoticz?

Post by gizmocuz » Thursday 19 January 2017 10:13

What protocol did you enable under the RFXCom RFXMngr application ?
It should be the same for Domoticz

A screenshot how you configured the sensor in domoticz, and the RFXMngr application would help as well

I am not sure if this is implemented in domoticz... the 'Itho' is implemented

I think i have it working now in the new beta version #6372

From the Lights/Switches page, you now have to add a manual light, specify the 'Lucci'
Only use the last dropdown for the ID, and the value between 0 and F (like in the RFXMngr application)
Lucci1.PNG
Lucci1.PNG (19.85 KiB) Viewed 1174 times
Now you should see the following widget
Lucci2.PNG
Lucci2.PNG (11.82 KiB) Viewed 1174 times
If you press on the 'Fan' icon, you get a popup to switch to the desired modes
Lucci3.PNG
Lucci3.PNG (30.51 KiB) Viewed 1174 times
New beta version available within an hour, let me know if it's working plz
Quality outlives Quantity!

etxnegn
Posts: 2
Joined: Monday 16 January 2017 22:41
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Lucci fan support with RFXCOM in Domoticz?

Post by etxnegn » Tuesday 21 February 2017 21:35

Sorry for the late reply. :o

Yes now I got it to work after I followed your guide and updated to one of the latest betas v3.6745.

Many thanks for your help gizmocuz! :D

molvizar
Posts: 1
Joined: Sunday 15 May 2016 11:56
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Lucci fan support with RFXCOM in Domoticz?

Post by molvizar » Friday 07 April 2017 3:15

Hi.

My configuration:

- Domoticz Version: 3.7253
- RFXCOM Firmware Version: Ext/1015

My remote control is Lucci Model UC7087T (The Lucci Air Fan).

The switches:

1:ON
2:OFF
3:ON
4:ON

Following the RFXCOM User Guide, 0=ON then, really is 0100 = 4 but doesn't work.

I suppose that then is 1011 = B but either works

I suppose then that the bits are in reverse order then i try with 0010 = 2 and 1101 = D but doesn't work either.

Please, could you help me?
How am I wrong?

Thanks in advance

jjnj
Posts: 240
Joined: Thursday 31 July 2014 13:51
Target OS: Windows
Domoticz version:
Location: NL
Contact:

Re: Lucci fan support with RFXCOM in Domoticz?

Post by jjnj » Thursday 13 July 2017 19:58

gizmocuz wrote:What protocol did you enable under the RFXCom RFXMngr application ?
It should be the same for Domoticz

A screenshot how you configured the sensor in domoticz, and the RFXMngr application would help as well

I am not sure if this is implemented in domoticz... the 'Itho' is implemented

I think i have it working now in the new beta version #6372

From the Lights/Switches page, you now have to add a manual light, specify the 'Lucci'
Only use the last dropdown for the ID, and the value between 0 and F (like in the RFXMngr application)

Lucci1.PNG

Now you should see the following widget

Lucci2.PNG

If you press on the 'Fan' icon, you get a popup to switch to the desired modes

Lucci3.PNG

New beta version available within an hour, let me know if it's working plz
I'm trying to get it working too, already send you a PM. Maybe we can do some testing together?

Ralfie
Posts: 6
Joined: Sunday 03 June 2018 2:50
Target OS: Raspberry Pi
Domoticz version: 3.9673
Location: Netherlands
Contact:

Re: Lucci fan support with RFXCOM in Domoticz?

Post by Ralfie » Sunday 03 June 2018 4:09

I recently bought this Lucci Air fan: http://www.lucciair.com/airfusion-akman ... eak-4.html
I would like to add this to Domoticz.

I have the following hardware/software:
Version 3.8153
Platform: Raspberry Pi
RFXCOM - RFXtrx433 USB 433.92MHz Transceiver Version: Ext/1025

I've tried to follow the steps mentioned earlier in this topic, but I could not get it to work.

The RFXCOM manual tells this about Lucci Air fan:
Image

The fan comes with this remote:
Image

In the battery compartment of the remote you can see the settings of the switches, this is how I received the remote and it's working with the fan:
Image
According to the manual the ID is D

In Domoticz I went to switches to add the fan using these settings:
Image

Unfortunately it's not working. I've tried all the ID's. The RFXCOM is about 5 meters away from the fan without metal structures that could block the signal.
I also tried the Windows application called RFXmngrSetup.exe to see if I could get it working, but the fan is only listening to the remote.

Does anybody know how to get my Lucci Air fan working in Domoticz?

User avatar
gizmocuz
Posts: 8640
Joined: Thursday 11 July 2013 18:59
Target OS: Raspberry Pi
Domoticz version: beta
Location: Top of the world
Contact:

Re: Lucci fan support with RFXCOM in Domoticz?

Post by gizmocuz » Sunday 03 June 2018 11:58

Can you operate it from the RFXCom RFXmngr application?
If not, try to get this working first
Quality outlives Quantity!

cobra045
Posts: 35
Joined: Friday 12 February 2016 21:58
Target OS: Raspberry Pi
Domoticz version: 3.4834
Contact:

Re: Lucci fan support with RFXCOM in Domoticz?

Post by cobra045 » Sunday 03 June 2018 13:56

Hi Ralfi

Check your ID code

I think this is NOT "D" but "2"

On the picture you see 0 - 0 - 1 - 0 = 2 and 1 - 1 - 0 - 1 = D
Up = 1 and down = 0

Cobra045

Ralfie
Posts: 6
Joined: Sunday 03 June 2018 2:50
Target OS: Raspberry Pi
Domoticz version: 3.9673
Location: Netherlands
Contact:

Re: Lucci fan support with RFXCOM in Domoticz?

Post by Ralfie » Sunday 03 June 2018 23:37

Thanks for the replies.

@cobra045 I've just tried with ID 00 00 02, but that doesn't work either.
I am wondering if the switch type I'm using is correct. As you can see in the last screenshot of my previous post I use On/Off .

@gizmocuz As you could read in my previous post, in almost the last line I don't get the fan moving using the Windows application.
I've used an old 2009 HP laptop with Windows 7 32 bit for that. I had to install the drivers for the RFXCOM first. I used CDM v2.12.28 WHQL Certified.
After that the RFXCOM is visible in the Windows application.

In the screenshot below you can see that I've tried to transmit commands to the fan. In the screenshot you see ID F, that is obviously wrong, but I've tried all possibilities (there are only 16) and at the last possibility I took the screenshot.
Image

What can I do to get it working using the Windows application?

I just checked the "set mode" in devices --> RFXCOM in Domoticz.
Almost all checkboxes are marked. Is that enough or do I need more?

Image

User avatar
gizmocuz
Posts: 8640
Joined: Thursday 11 July 2013 18:59
Target OS: Raspberry Pi
Domoticz version: beta
Location: Top of the world
Contact:

Re: Lucci fan support with RFXCOM in Domoticz?

Post by gizmocuz » Monday 04 June 2018 8:27

@Ralfie,
First, please consult the RFXtrx manual.
You will see a chapter in here about protocols, some protocols (when enabled) will cause other protocols to not operate anymore
So you really should only enable what you need to !!

Next, i am no expert in Lucy, i remember something about pairing, maybe it is explained in the manual, else please email support@rfxcom.com
But keep this topic/post up to date so when you have it working, others will be helped as well

For now, as you can not get it to work with the RFXmngr application, i consider this not a domoticz issue
Quality outlives Quantity!

b_weijenberg
Posts: 671
Joined: Friday 12 July 2013 18:13
Target OS: -
Domoticz version:
Location: Netherlands
Contact:

Re: Lucci fan support with RFXCOM in Domoticz?

Post by b_weijenberg » Monday 04 June 2018 10:10

Protocol enabling is only necessary for receive mode and not necessary for LucciAir as the remote is not received.
It seems another LucciAir type if you can't control the fan with one of the possible ID's. Contact support rfxcom.com
RFXtrx433, RFXtrx433E

Ralfie
Posts: 6
Joined: Sunday 03 June 2018 2:50
Target OS: Raspberry Pi
Domoticz version: 3.9673
Location: Netherlands
Contact:

Re: Lucci fan support with RFXCOM in Domoticz?

Post by Ralfie » Monday 04 June 2018 23:30

@ gizmocuz and @ b_weijenberg Thanks for the replies. I'll contact RFXCOM and will post updates in this thread.

Goldwing1973
Posts: 111
Joined: Monday 08 August 2016 22:55
Target OS: Linux
Domoticz version: Stable
Location: Netherlands, Alphen aan den Rijn
Contact:

Re: Lucci fan support with RFXCOM in Domoticz?

Post by Goldwing1973 » Saturday 09 June 2018 14:51

Not only Lucci fans can be controlled by Domoticz.
With a little wiring work you can Control nearly any fan with the Westinghouse RF set
Just make sure that the light is set to on and the fan is on its highest speed before using it with the Westinghouse RF set (I even cut off the manual control strings from the fan)

https://www.amazon.de/gp/product/B003U6SN14/

Setting up in Domoticz is exactly the same as a Lucci Air fan.
I now have full control on 3 fans in my home from my Domoticz setup.
Over 50 Z-Wave Devices (Fibaro and Neo), 4xLogitech Hub, 2xPhilips Hue Bridge+55 Lights, 1x Nest Thermostat, 2xNetatmo Weather Station, 1xSkybell v1 Doorbell, 3 Kwikset KEVO Doorlocks and Domoticz running on a Intel NUC

b_weijenberg
Posts: 671
Joined: Friday 12 July 2013 18:13
Target OS: -
Domoticz version:
Location: Netherlands
Contact:

Re: Lucci fan support with RFXCOM in Domoticz?

Post by b_weijenberg » Saturday 09 June 2018 16:34

The Westinghouse fan 7226640 is also supported by the RFXtrx433(E). But we are talking in this thread about a problem controlling the LucciAir DC fan which has another protocol compared to the LucciAir AC. A solution will probably available soon for the LucciAir DC.
RFXtrx433, RFXtrx433E

Goldwing1973
Posts: 111
Joined: Monday 08 August 2016 22:55
Target OS: Linux
Domoticz version: Stable
Location: Netherlands, Alphen aan den Rijn
Contact:

Re: Lucci fan support with RFXCOM in Domoticz?

Post by Goldwing1973 » Saturday 09 June 2018 20:58

b_weijenberg wrote:
Saturday 09 June 2018 16:34
The Westinghouse fan 7226640 is also supported by the RFXtrx433(E). But we are talking in this thread about a problem controlling the LucciAir DC fan which has another protocol compared to the LucciAir AC. A solution will probably available soon for the LucciAir DC.
Sorry, didn’t realize that.
Over 50 Z-Wave Devices (Fibaro and Neo), 4xLogitech Hub, 2xPhilips Hue Bridge+55 Lights, 1x Nest Thermostat, 2xNetatmo Weather Station, 1xSkybell v1 Doorbell, 3 Kwikset KEVO Doorlocks and Domoticz running on a Intel NUC

Ralfie
Posts: 6
Joined: Sunday 03 June 2018 2:50
Target OS: Raspberry Pi
Domoticz version: 3.9673
Location: Netherlands
Contact:

Re: Lucci fan support with RFXCOM in Domoticz?

Post by Ralfie » Tuesday 19 June 2018 22:30

@gizmocuz You were right, it was not a Domoticz issue. Together with RFXCOM support we found out that the Lucci Air DC models use a different protocol. Because my Lucci Air fan is one of those, I could supply the raw data which is broadcasted when pressing a button.
According to the most recent e-mail of RFXCOM support you received a SDK.
My question to you is if you would like to add the Lucci Air DC fan to Domoticz?

User avatar
gizmocuz
Posts: 8640
Joined: Thursday 11 July 2013 18:59
Target OS: Raspberry Pi
Domoticz version: beta
Location: Top of the world
Contact:

Re: Lucci fan support with RFXCOM in Domoticz?

Post by gizmocuz » Wednesday 20 June 2018 8:22

@Ralfie, try the latest domoticz beta version, it should now support this type of fan
I am not keen on supporting this fan, as it does not have an On/Off option like the AC fan, it has a toggle function
So you can not use this in timers for example
Hope all works
Quality outlives Quantity!

Ralfie
Posts: 6
Joined: Sunday 03 June 2018 2:50
Target OS: Raspberry Pi
Domoticz version: 3.9673
Location: Netherlands
Contact:

Re: Lucci fan support with RFXCOM in Domoticz?

Post by Ralfie » Friday 22 June 2018 23:19

@gizmocuz, thanks for adding the fan! I've just updated my Domoticz to V3.9673 beta and added the fan the way you described at the second post in this thread.
I found out that the "Test" button doesn't work.
After adding the fan I can click on the red fan icon and can choose between POW, PLUS, MIN and LIGHT. The first 3 buttons work. I can't test the LIGHT button, because I don't have the optional light kit.
I'm missing the REVERSE and NATURAL FLOW buttons. Can you please add them?
It's not clear to me what the disadvantage is of not having a proper on/off option. Actually the PLUS button is the ON button and the POW button is the OFF button. I'd like to see the timer option.

User avatar
gizmocuz
Posts: 8640
Joined: Thursday 11 July 2013 18:59
Target OS: Raspberry Pi
Domoticz version: beta
Location: Top of the world
Contact:

Re: Lucci fan support with RFXCOM in Domoticz?

Post by gizmocuz » Saturday 23 June 2018 12:33

@Ralfie, great it almost works. Not sure if the test button should do anything, so best to not use it.
If you like, try to finish the implementation to add the two missing modes and/or timer mode
Quality outlives Quantity!

Haro
Posts: 2
Joined: Wednesday 04 July 2018 20:30
Target OS: Raspberry Pi
Domoticz version: V4.9700
Contact:

Re: Lucci fan support with RFXCOM in Domoticz?

Post by Haro » Wednesday 04 July 2018 20:42

@gizmocuz and @Ralfie, I'm having the exact same problem. I have an Lucci airfusion Climate II. At first I didn't get it to work with Rfxmngr but after I had shared the raw data that were broadcasted with Bert it now works there (ac and not dc although my fan is an dc fan). In domoticz the testcommand doesn't give a response. When I ignore that, and add the fan, it works, but only in de ip-version and not in the Domoticz app, nor in Homekit (it is visible as an on/off switch), nor in the Elgato Eve app. What am I doing wrong?

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests