FGS223 Timeouts

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post
YcKe
Posts: 19
Joined: Sunday 03 July 2016 0:53
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: FGS223 Timeouts

Postby YcKe » Friday 10 February 2017 16:57

annegerben wrote:
YcKe wrote:Hi @annegerben,

can you post a screenshot of your Groups & Network overview screen. (Including associations)

Greetz YcKe


Hi YcKe

as requested

2017-02-10 15_12_04-Domoticz.png


Hi annegerben,

is the solution of micha_pr solving your issue too?

Greetz YcKe

annegerben
Posts: 3
Joined: Wednesday 03 August 2016 12:34
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: FGS223 Timeouts

Postby annegerben » Friday 10 February 2017 17:06

micha_pr wrote:Hi all,

the source of all FGS223 problems seems to be in a Fibaro firmware "issue".
Device is reporting that it is supporting "switch multilevel" - but it is not right,... it is a binary switch only.
Spoiler: show
In Fibaro FGS config XML was inserted that's why:

Code: Select all

    <!-- COMMAND_CLASS_SWITCH_MULTILEVEL. This class is in the list reported by the device, but it does not respond to requests -->
    <CommandClass id="38" getsupported="false"/>

But it does not help in any case for Domoticz installation - depending on different things may happen
    - Switch 1 does not response (in log you can see that want to use multilevel command class....)
    - timeouts

While here is not a final solution you can edit your ZWave config file zwcfg_0xxxxxxx.xml
For that:
1) stop domoticz service
2) make a copy of your current xml file
3) edit the XML
4) start domoticz at new.

in XML look for the right node number (<Node id="xxx">) from hardware settings.
Must look like this:

Code: Select all

 <Node id="2" name="" location="" basic="4" generic="16" specific="1" roletype="5" devicetype="1792" nodetype="0" type="Binary Power Switch" listening="true" frequentListening="false" beaming="true" routing="true" max_baud
      <Manufacturer id="10f" name="FIBARO System">
            <Product type="203" id="1000" name="FGS223 Double Relay" />
        </Manufacturer>
        <CommandClasses>
            <CommandClass id="32" name="COMMAND_CLASS_BASIC" version="1" request_flags="5" mapping="37">
 ...
            </CommandClass>
            <CommandClass id="37" name="COMMAND_CLASS_SWITCH_BINARY" version="1" request_flags="5" innif="true">
 ...
            </CommandClass>
            <CommandClass id="38" name="COMMAND_CLASS_SWITCH_MULTILEVEL" version="3" request_flags="5" after_mark="true" getsupported="false" innif="true">
                <Instance index="1" endpoint="1" />
                <Instance index="2" endpoint="2" />
                <Value type="byte" genre="user" instance="1" index="0" label="Level" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="0" />
                <Value type="button" genre="user" instance="1" index="1" label="Bright" units="" read_only="false" write_only="true" verify_changes="false" poll_intensity="0" min="0" max="0" />
                <Value type="button" genre="user" instance="1" index="2" label="Dim" units="" read_only="false" write_only="true" verify_changes="false" poll_intensity="0" min="0" max="0" />
                <Value type="bool" genre="system" instance="1" index="3" label="Ignore Start Level" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" value="True" />
                <Value type="byte" genre="system" instance="1" index="4" label="Start Level" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="0" />
                <Value type="byte" genre="user" instance="2" index="0" label="Level" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="0" />
                <Value type="button" genre="user" instance="2" index="1" label="Bright" units="" read_only="false" write_only="true" verify_changes="false" poll_intensity="0" min="0" max="0" />
                <Value type="button" genre="user" instance="2" index="2" label="Dim" units="" read_only="false" write_only="true" verify_changes="false" poll_intensity="0" min="0" max="0" />
                <Value type="bool" genre="system" instance="2" index="3" label="Ignore Start Level" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" value="True" />
                <Value type="byte" genre="system" instance="2" index="4" label="Start Level" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="0" />
                <Value type="byte" genre="system" instance="2" index="5" label="Dimming Duration" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="255" />
                <Value type="byte" genre="user" instance="2" index="6" label="Step Size" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="0" />
                <Value type="button" genre="user" instance="2" index="7" label="Inc" units="" read_only="false" write_only="true" verify_changes="false" poll_intensity="0" min="0" max="0" />
                <Value type="button" genre="user" instance="2" index="8" label="Dec" units="" read_only="false" write_only="true" verify_changes="false" poll_intensity="0" min="0" max="0" />
            </CommandClass>
            <CommandClass id="39" name="COMMAND_CLASS_SWITCH_ALL" version="1" request_flags="5">
                <Instance index="1" />
....

REMOVE now all between
<CommandClass id="38" ... and next </CommandClass> - so all this wrong class.

Result should be like this:

Code: Select all

 <Node id="2" name="" location="" basic="4" generic="16" specific="1" roletype="5" devicetype="1792" nodetype="0" type="Binary Power Switch" listening="true" frequentListening="false" beaming="true" routing="true" max_baud
      <Manufacturer id="10f" name="FIBARO System">
            <Product type="203" id="1000" name="FGS223 Double Relay" />
        </Manufacturer>
        <CommandClasses>
            <CommandClass id="32" name="COMMAND_CLASS_BASIC" version="1" request_flags="5" mapping="37">
 ...
            </CommandClass>
            <CommandClass id="37" name="COMMAND_CLASS_SWITCH_BINARY" version="1" request_flags="5" innif="true">
 ...
            </CommandClass>
            <CommandClass id="39" name="COMMAND_CLASS_SWITCH_ALL" version="1" request_flags="5">
                <Instance index="1" />
....


After starting at new domoticz the FGS223 will work - at least at all our installations it was starting to work normal...

@gizmocuz: maybe we can pass this wrong command class in zwcfg file if the parameter " getsupported="false" " is inside?
It is inside the Fibaro config XML and - inside the zwcfg file.

Good luck!


I made the change suggested by micha_pr, I still see timeouts in the logs, but the switchs now seem to respond normally again.

maxtrash
Posts: 165
Joined: Tuesday 06 August 2013 1:31
Target OS: -
Domoticz version:
Contact:

Re: FGS223 Timeouts

Postby maxtrash » Friday 10 February 2017 18:46

I never had timeouts, but the switch did not respond to wireless signals.
Fortunately removing the commandclass solved my issue as well

skippy711
Posts: 8
Joined: Friday 20 January 2017 18:52
Target OS: Linux
Domoticz version: V3.6424
Contact:

Re: FGS223 Timeouts

Postby skippy711 » Saturday 11 February 2017 13:44

micha_pr wrote:Hi all,

the source of all FGS223 problems seems to be in a Fibaro firmware "issue".
Device is reporting that it is supporting "switch multilevel" - but it is not right,... it is a binary switch only.
In Fibaro FGS config XML was inserted that's why:

Code: Select all

    <!-- COMMAND_CLASS_SWITCH_MULTILEVEL. This class is in the list reported by the device, but it does not respond to requests -->
    <CommandClass id="38" getsupported="false"/>

But it does not help in any case for Domoticz installation - depending on different things may happen
    - Switch 1 does not response (in log you can see that want to use multilevel command class....)
    - timeouts

While here is not a final solution you can edit your ZWave config file zwcfg_0xxxxxxx.xml
For that:
1) stop domoticz service
2) make a copy of your current xml file
3) edit the XML
4) start domoticz at new.

in XML look for the right node number (<Node id="xxx">) from hardware settings.
Must look like this:

Code: Select all

 <Node id="2" name="" location="" basic="4" generic="16" specific="1" roletype="5" devicetype="1792" nodetype="0" type="Binary Power Switch" listening="true" frequentListening="false" beaming="true" routing="true" max_baud
      <Manufacturer id="10f" name="FIBARO System">
            <Product type="203" id="1000" name="FGS223 Double Relay" />
        </Manufacturer>
        <CommandClasses>
            <CommandClass id="32" name="COMMAND_CLASS_BASIC" version="1" request_flags="5" mapping="37">
 ...
            </CommandClass>
            <CommandClass id="37" name="COMMAND_CLASS_SWITCH_BINARY" version="1" request_flags="5" innif="true">
 ...
            </CommandClass>
            <CommandClass id="38" name="COMMAND_CLASS_SWITCH_MULTILEVEL" version="3" request_flags="5" after_mark="true" getsupported="false" innif="true">
                <Instance index="1" endpoint="1" />
                <Instance index="2" endpoint="2" />
                <Value type="byte" genre="user" instance="1" index="0" label="Level" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="0" />
                <Value type="button" genre="user" instance="1" index="1" label="Bright" units="" read_only="false" write_only="true" verify_changes="false" poll_intensity="0" min="0" max="0" />
                <Value type="button" genre="user" instance="1" index="2" label="Dim" units="" read_only="false" write_only="true" verify_changes="false" poll_intensity="0" min="0" max="0" />
                <Value type="bool" genre="system" instance="1" index="3" label="Ignore Start Level" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" value="True" />
                <Value type="byte" genre="system" instance="1" index="4" label="Start Level" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="0" />
                <Value type="byte" genre="user" instance="2" index="0" label="Level" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="0" />
                <Value type="button" genre="user" instance="2" index="1" label="Bright" units="" read_only="false" write_only="true" verify_changes="false" poll_intensity="0" min="0" max="0" />
                <Value type="button" genre="user" instance="2" index="2" label="Dim" units="" read_only="false" write_only="true" verify_changes="false" poll_intensity="0" min="0" max="0" />
                <Value type="bool" genre="system" instance="2" index="3" label="Ignore Start Level" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" value="True" />
                <Value type="byte" genre="system" instance="2" index="4" label="Start Level" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="0" />
                <Value type="byte" genre="system" instance="2" index="5" label="Dimming Duration" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="255" />
                <Value type="byte" genre="user" instance="2" index="6" label="Step Size" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="0" />
                <Value type="button" genre="user" instance="2" index="7" label="Inc" units="" read_only="false" write_only="true" verify_changes="false" poll_intensity="0" min="0" max="0" />
                <Value type="button" genre="user" instance="2" index="8" label="Dec" units="" read_only="false" write_only="true" verify_changes="false" poll_intensity="0" min="0" max="0" />
            </CommandClass>
            <CommandClass id="39" name="COMMAND_CLASS_SWITCH_ALL" version="1" request_flags="5">
                <Instance index="1" />
....

REMOVE now all between
<CommandClass id="38" ... and next </CommandClass> - so all this wrong class.

Result should be like this:

Code: Select all

 <Node id="2" name="" location="" basic="4" generic="16" specific="1" roletype="5" devicetype="1792" nodetype="0" type="Binary Power Switch" listening="true" frequentListening="false" beaming="true" routing="true" max_baud
      <Manufacturer id="10f" name="FIBARO System">
            <Product type="203" id="1000" name="FGS223 Double Relay" />
        </Manufacturer>
        <CommandClasses>
            <CommandClass id="32" name="COMMAND_CLASS_BASIC" version="1" request_flags="5" mapping="37">
 ...
            </CommandClass>
            <CommandClass id="37" name="COMMAND_CLASS_SWITCH_BINARY" version="1" request_flags="5" innif="true">
 ...
            </CommandClass>
            <CommandClass id="39" name="COMMAND_CLASS_SWITCH_ALL" version="1" request_flags="5">
                <Instance index="1" />
....


After starting at new domoticz the FGS223 will work - at least at all our installations it was starting to work normal...

@gizmocuz: maybe we can pass this wrong command class in zwcfg file if the parameter " getsupported="false" " is inside?
It is inside the Fibaro config XML and - inside the zwcfg file.

Good luck!


Hi Michael,

I am willing to give it a try in Windows. Where can I find the required files.
Grtz

micha_pr
Posts: 335
Joined: Friday 24 October 2014 12:26
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Germany, Berlin
Contact:

Re: FGS223 Timeouts

Postby micha_pr » Saturday 11 February 2017 14:00

skippy711 wrote:I am willing to give it a try in Windows. Where can I find the required files.

in domoticz/Config/ directory
Michael Pruefer
----------------------------
http://www.zwave-review.com (German only)
http://www.SmartHome-BB.de (German only)

skippy711
Posts: 8
Joined: Friday 20 January 2017 18:52
Target OS: Linux
Domoticz version: V3.6424
Contact:

Re: FGS223 Timeouts

Postby skippy711 » Saturday 11 February 2017 14:28

micha_pr wrote:
skippy711 wrote:I am willing to give it a try in Windows. Where can I find the required files.

in domoticz/Config/ directory


Don't see a Zwave.cnf or Zwave.00...,.xml. In the FIbaro folder I see the FGS223.xml, but rules are different: only Command class id 38 (which is empty) , id 112, id 96 and id 133.

Any suggestions? Would be nice if your solution als solves the windows problems ;)

Thx

micha_pr
Posts: 335
Joined: Friday 24 October 2014 12:26
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Germany, Berlin
Contact:

Re: FGS223 Timeouts

Postby micha_pr » Saturday 11 February 2017 15:50

and no
zwcfg_0xxxxxxx.xml
as I wrote? ;)
Michael Pruefer
----------------------------
http://www.zwave-review.com (German only)
http://www.SmartHome-BB.de (German only)

skippy711
Posts: 8
Joined: Friday 20 January 2017 18:52
Target OS: Linux
Domoticz version: V3.6424
Contact:

Re: FGS223 Timeouts

Postby skippy711 » Saturday 11 February 2017 16:23

micha_pr wrote:and no
zwcfg_0xxxxxxx.xml
as I wrote? ;)


This is in the config folder:
Attachments
domo.jpg
domo.jpg (219.08 KiB) Viewed 190 times

User avatar
Domosapiens
Posts: 334
Joined: Wednesday 20 August 2014 12:08
Target OS: Windows
Domoticz version: V3.5981
Location: NL
Contact:

Re: FGS223 Timeouts

Postby Domosapiens » Sunday 12 February 2017 0:27

Are your .xml files hidden ?
Win Vista&7; 1#Aeon Z-Stick S2; 1#Aeotec Z-Sick Gen5, 6#Fib.FGBS001; 24#DS18B20; 8#Everspr.AN158-2; 3#Philio PAN04; 1#Philio PAN06, 1#YouLess El; 1#Fib.FGWPE; 1#ZME_RC2; 2#FAK_ZWS230, 2#Quib.ZMNHCDx, 1#Quib.ZMNHDD1, 7#EM6555

skippy711
Posts: 8
Joined: Friday 20 January 2017 18:52
Target OS: Linux
Domoticz version: V3.6424
Contact:

Re: FGS223 Timeouts

Postby skippy711 » Sunday 12 February 2017 11:45

Nope nothing hidden there...

skippy711
Posts: 8
Joined: Friday 20 January 2017 18:52
Target OS: Linux
Domoticz version: V3.6424
Contact:

Re: FGS223 Timeouts

Postby skippy711 » Sunday 12 February 2017 23:05

Hi Michael,
Rechecked and I found the mentioned file in my linux build domoticz, but not in windows. In linux I have no problems with the Fgs223 (nor with the Fgs213) but in windows no luck with these fibaro's. I'm not a programmer, but could it be possible that the absence of this specific xml file causes the problems in the windows build?
Like I wrote: I'm by no means a programmer, but I'm willing to help out by testing on windows. (and be a happy Linux user on the side...) :lol:
Grtz

User avatar
Domosapiens
Posts: 334
Joined: Wednesday 20 August 2014 12:08
Target OS: Windows
Domoticz version: V3.5981
Location: NL
Contact:

Re: FGS223 Timeouts

Postby Domosapiens » Thursday 16 February 2017 23:01

zwcfg_0xxxxxxx.xml is a cache file created by Domoticz at start-up
Could it be that you have a "protection rights" problem and Domoticz is not allowed to create that file?

Some suggestions:
- Look at the folder permissions of the Domoticz/Config folder
- look at UAC (User Account Control) settings -> Start, search for UAC
- Run Domoticz as administrator
Win Vista&7; 1#Aeon Z-Stick S2; 1#Aeotec Z-Sick Gen5, 6#Fib.FGBS001; 24#DS18B20; 8#Everspr.AN158-2; 3#Philio PAN04; 1#Philio PAN06, 1#YouLess El; 1#Fib.FGWPE; 1#ZME_RC2; 2#FAK_ZWS230, 2#Quib.ZMNHCDx, 1#Quib.ZMNHDD1, 7#EM6555

User avatar
rolandbreedveld
Posts: 53
Joined: Wednesday 09 March 2016 12:25
Target OS: Raspberry Pi
Domoticz version: stable
Contact:

Re: FGS223 Timeouts

Postby rolandbreedveld » Friday 17 February 2017 19:17

Removed the <CommandClass id="38" section from the Fibaro 223 Node:
the number of timeouts (I still get them) is significant better.
It also looks like the switch from the fibaro is recognized faster by Domoticz.
:D :D :D
Raspberry Pi2+3 | P1 SmartMeter | Z-Wave Razberry 2.0 | 4 Greenwave devices | FIBARO FGS223 +FGRM222 | Aerotec MultiSensor 6 | 2 x Gembird Siver-Shield with sispmctl | Logitech Harmony Hub | FritzBox
Interface to 123Solar + PowerOne 3.0 and SMA SB1200

micha_pr
Posts: 335
Joined: Friday 24 October 2014 12:26
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Germany, Berlin
Contact:

Re: FGS223 Timeouts

Postby micha_pr » Friday 17 February 2017 20:20

Seems to be solved by gizmocuz now (wrong section in config):
viewtopic.php?f=6&t=13209&start=120#p120185
gizmocuz wrote:this should not be needed (i hope) if you update to the latest beta version and exclude/include the node

i did not got an class 38 here...

Thanks!
Michael Pruefer
----------------------------
http://www.zwave-review.com (German only)
http://www.SmartHome-BB.de (German only)


Return to “Bugs and Problems”

Who is online

Users browsing this forum: Bororo, JuanUil and 8 guests