Mi_light Ibox v6 (API) not working

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
CaptainSlow
Posts: 80
Joined: Thursday 08 December 2016 22:07
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bussum
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by CaptainSlow » Friday 03 February 2017 13:36

It's port 5987. IBOX2 === V6. V6 is the limitlesled name for it. Ibox2 is what is wirtten on the milightbox.
Make sure you put the box in STA mode. Default is STA + AP.
Did you configure the IBOX2 already?

regards

willem
____________________________________________________________________
Raspberry PI 3, Domoticz Beta, Open Therm Gateway with ESP wifi-bridge, Milight Ibox(V6), Wundermap

tlpeter
Posts: 409
Joined: Wednesday 26 November 2014 19:43
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by tlpeter » Friday 03 February 2017 16:04

Does anybody know how to controller a RGBW controller from Domoticz?
I have an iboxv6 (with lamp) coneected and can be controlled from Domoticz and the Android app.
I can control the RGBW controller from the app and a remote but i do not know how to add or control it from Domoticz.

DrMacabre
Posts: 20
Joined: Monday 26 December 2016 17:30
Target OS: NAS (Synology & others)
Domoticz version:
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by DrMacabre » Friday 03 February 2017 16:10

I'm currently using it with the apps. How to you set it to STA mode ? I used smart link when pairing it to my phone.

Captainslow, you posted a few screenshots from a configuratîon app, what is this app?

CaptainSlow
Posts: 80
Joined: Thursday 08 December 2016 22:07
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bussum
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by CaptainSlow » Friday 03 February 2017 17:36

When you pair the bulbs with app it actually pairs it as well with ibox (V6) I reckon. After that you will be able to send any command to the ibox.
You can access the ibox either directly or via the LAN. depends how its configured right now. STA or AP.
So go to the Ibox via the lan just typing in the ip address of the box. Deafult u/p is admin/admin. You can change that too to make sure anybody in you home accesses your ibox and change things:)
Once on the box the configuration speaks for itself.

w.
____________________________________________________________________
Raspberry PI 3, Domoticz Beta, Open Therm Gateway with ESP wifi-bridge, Milight Ibox(V6), Wundermap

DrMacabre
Posts: 20
Joined: Monday 26 December 2016 17:30
Target OS: NAS (Synology & others)
Domoticz version:
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by DrMacabre » Friday 03 February 2017 19:22

Strange, port is 8899 when im logging into it but gives an error when set to it in domoticz.

It was in STA mode already but nothing happens when using domoticz. Is it supposed to work straight of the box with the dimmer switch device in domoticz or does it need some script ?

CaptainSlow
Posts: 80
Joined: Thursday 08 December 2016 22:07
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bussum
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by CaptainSlow » Friday 03 February 2017 19:28

No script needed. Did you pair the bulbs with the app on your mobile first?...are you on the latest beta release of domoticz?
After added the hardware with the right IP and port you have to change the setup. (V6 with RBWW) I reckon you already did that. If that doesn't work then reset the ibox with sharp device and put into a hole somewhere and start over....should work!

w.
____________________________________________________________________
Raspberry PI 3, Domoticz Beta, Open Therm Gateway with ESP wifi-bridge, Milight Ibox(V6), Wundermap

DrMacabre
Posts: 20
Joined: Monday 26 December 2016 17:30
Target OS: NAS (Synology & others)
Domoticz version:
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by DrMacabre » Friday 03 February 2017 19:32

Im on latest beta yes 6595, does it works with RGB strips only ? I don't have RGBW.

CaptainSlow
Posts: 80
Joined: Thursday 08 December 2016 22:07
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bussum
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by CaptainSlow » Friday 03 February 2017 19:42

Don't know about the strips. Probably the problem. I got 2 RGBW bulbs and 1 RGBWW bulb in 1 group. All three work perfectly. Brightness, color and saturation and color warmth of the RGBWW bulb can be changed too.
Note: did you pair the strip using the app on your mobile?
The native support of the V6 box is still in dev mode.
____________________________________________________________________
Raspberry PI 3, Domoticz Beta, Open Therm Gateway with ESP wifi-bridge, Milight Ibox(V6), Wundermap

DrMacabre
Posts: 20
Joined: Monday 26 December 2016 17:30
Target OS: NAS (Synology & others)
Domoticz version:
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by DrMacabre » Friday 03 February 2017 19:45

Ok, it's workng now, settings are RGBW / V6 even with RGB only strips.
If you set it to RGB, it doesn't work.

tlpeter
Posts: 409
Joined: Wednesday 26 November 2014 19:43
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by tlpeter » Friday 03 February 2017 21:28

The iboxv6 needs port 5987.
For me that works. I cannot get the rgbw ledstrip controller to work from domoticz. I cannot add it to a group somehow. How do you that? On the mobile app there isn't a group option for the remote that came with it.

CaptainSlow
Posts: 80
Joined: Thursday 08 December 2016 22:07
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bussum
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by CaptainSlow » Friday 03 February 2017 22:29

`Did you link it first with milight ap on your phone?...see screenshot...
photo5812278258861975502.jpg
photo5812278258861975502.jpg (65.9 KiB) Viewed 1151 times
____________________________________________________________________
Raspberry PI 3, Domoticz Beta, Open Therm Gateway with ESP wifi-bridge, Milight Ibox(V6), Wundermap

tlpeter
Posts: 409
Joined: Wednesday 26 November 2014 19:43
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by tlpeter » Friday 03 February 2017 22:42

Yes i did but i could include using a remote without the zones.
I think that is the problem.

CaptainSlow
Posts: 80
Joined: Thursday 08 December 2016 22:07
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bussum
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by CaptainSlow » Friday 03 February 2017 22:55

Unlink the ledstrip first. Then link it to zone 1 with app. Not the remote.
____________________________________________________________________
Raspberry PI 3, Domoticz Beta, Open Therm Gateway with ESP wifi-bridge, Milight Ibox(V6), Wundermap

tlpeter
Posts: 409
Joined: Wednesday 26 November 2014 19:43
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by tlpeter » Saturday 04 February 2017 9:48

How would i do that?
Within the mobile app i can only link it by selecting the remote (picture) that looks like the remote that came with the controller.
This is the remote and controller that i use:

Image

I think this is an old type of controller which cannot be controlled by domoticz somehow.

CaptainSlow
Posts: 80
Joined: Thursday 08 December 2016 22:07
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bussum
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by CaptainSlow » Saturday 04 February 2017 11:42

I doubt that. You can always link and unlink. Try unlinking you remote first. Then unlink in the app, then link it using the app. Dont you have the link inlink screen like i posted of the milight app?

Willem
____________________________________________________________________
Raspberry PI 3, Domoticz Beta, Open Therm Gateway with ESP wifi-bridge, Milight Ibox(V6), Wundermap

tlpeter
Posts: 409
Joined: Wednesday 26 November 2014 19:43
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by tlpeter » Saturday 04 February 2017 13:54

It doesn't work, same story.
This controller does not link when i select a different type of remote in the app.

CaptainSlow
Posts: 80
Joined: Thursday 08 December 2016 22:07
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bussum
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by CaptainSlow » Saturday 04 February 2017 18:20

Hello Pete,

If you keep saying it doesn't work without sharing the exact steps you are executing it's kinda difficult to help you out....catch my drift?
As said...unlink the lot and start from scratch. Reset the box > configure the box > start the right milight app > connect to the box with a direct connection > the start linking your strip.

regards

w.
____________________________________________________________________
Raspberry PI 3, Domoticz Beta, Open Therm Gateway with ESP wifi-bridge, Milight Ibox(V6), Wundermap

tlpeter
Posts: 409
Joined: Wednesday 26 November 2014 19:43
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by tlpeter » Sunday 05 February 2017 11:18

I catch your drift, don't worry.
I did unlink the remote and app.
I will try to explain a bit better.
I am very new to milight and i bought a rgbw and remote at aliexpress. This remote is a type without zones.
Within the milight 3.0 app i need (at least i think) to select a remote to link the rgbw controller. The only one that i can link with is the one that looks the same as the real remote. It only has the colour disk, brightness, speed and modes buttons (on and off as well ofcourse)
So i think i cannot link it to a zone and domoticz only shows devices for zones, all or a bridge.

I ordered a different rgbw controller and remote at aliexpress to see what if i can make it work with that. This one has a remote with 4 zones.

I wonder if i can link controllers without a remote and use domoticz to link? I think not.

CaptainSlow
Posts: 80
Joined: Thursday 08 December 2016 22:07
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bussum
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by CaptainSlow » Sunday 05 February 2017 13:17

Hello Pete,

Have you read this page?....you don't need a remote to work milight and domoticz.....If you already read this page and it still doesn't work then I'm afraid I don't know what the problem is.
http://www.milight.com/support/

regards

w.
____________________________________________________________________
Raspberry PI 3, Domoticz Beta, Open Therm Gateway with ESP wifi-bridge, Milight Ibox(V6), Wundermap

deennoo
Posts: 937
Joined: Wednesday 10 December 2014 14:06
Target OS: Linux
Domoticz version: beta
Location: Bordeaux France
Contact:

Re: Mi_light Ibox v6 (API) not working

Post by deennoo » Sunday 05 February 2017 13:35

Milight 3.0 only work with v6 bridge (bulb or no bulb)

For you controler you need milight 2.0 app
Domoticz stable 3.5877 for real & Domoticz beta for test
Rfxtrxe / RFLink / Milight / Yeelight / ESP8266 / MQTT / BLE
http://domo-attitude.fr

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests