Authentication issue with multiple users

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post
Post Reply
User avatar
bueno79
Posts: 72
Joined: Wednesday 08 March 2017 11:26
Target OS: Raspberry Pi
Domoticz version: 3.5877
Location: France
Contact:

Authentication issue with multiple users

Post by bueno79 » Monday 25 December 2017 20:08

hi,

I'm using the latest stable of Domoticz. I've redirect the port of my domoticz to internet. So I can acces it from anywhere. To secure this I'm using HTTPS and add a login password on the website (website protection settings).

Then I've create a new user (login : ext) and grant him the role "user", to finally assign him few device. I tried to logon...impossible. Bad username/password. I've double check many times, tried "basic auth" and "login page" method...no way.

Can you help me ?

best regards
Bueno

peliilep
Posts: 5
Joined: Sunday 06 November 2016 9:10
Target OS: Raspberry Pi
Domoticz version: 3.8beta
Location: NL
Contact:

Re: Authentication issue with multiple users

Post by peliilep » Wednesday 27 December 2017 21:54

Be aware that usernames are case sensitive.


Verzonden vanaf mijn iPhone met Tapatalk
RFXCOM 433, RFXCOM 868, Youless, MySensors USB-GW, Landys Smartmeters, KaKu

ToxicTiger
Posts: 9
Joined: Saturday 17 June 2017 18:13
Target OS: NAS (Synology & others)
Domoticz version: 3.8153
Contact:

Re: Authentication issue with multiple users

Post by ToxicTiger » Friday 12 January 2018 16:31

Hi

Version: 3.8153
Platform: Synology
Plugin/Hardware: rflink

Did you get anywhere with this?

I have set a username (remoteuser) and password to secure the website in the "system settings" under Website Protection section, and when I log remotely the (using HTTPS / SSL) i am asked for my user name and password, which I enter and it all works OK.

What I then want to do is set up a number of additional users that have access to different switches and sensors etc. So in "More Options / Edit Users" I add some users (user1, user2), but when I log in i cant access these additional users. I can't work out how its supposed to work. How am I supposed to log in as users1 or user2? Is the Website Protection an separate login layer or is it all the same? Are the users that I add in the "Edit Users" section logged in somewhere else? Do I need to enable a multi user mode or something?

Thanks

apotropaic
Posts: 18
Joined: Friday 12 July 2013 15:18
Target OS: Raspberry Pi
Domoticz version: Stable
Location: UK
Contact:

Re: Authentication issue with multiple users

Post by apotropaic » Thursday 22 March 2018 11:58

Hi, I'm also struggling to understand the relationship between the 'Website Protection" setting and creating additional users, the wiki and previous forum posts are not very clear.

Does anyone know when you would use one and not the other?

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests