User UID raspberry pi install script & dzVents

Please use template to report bugs and problems. Post here your questions when not sure where else to post
Only for bugs in the Domoticz application! other problems go in different subforums!
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.

Use the following template when posting here:

Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....

If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly

If you are replying, please do not quote images/code from the first post

Please mark your topic as Solved when the problem is solved.
Post Reply
XelNaha
Posts: 1
Joined: Tuesday 13 February 2018 23:58
Target OS: Raspberry Pi
Domoticz version:
Contact:

User UID raspberry pi install script & dzVents

Post by XelNaha » Wednesday 14 February 2018 0:02

Hi all,

I am having an interesting issue which I didn't find on the forum yet.

I recently installed domoticz on a raspberry pi using the recommended install script, with a user which has uid 1001. the Pi user with uid 1000 I removed.

After the installation as user 1001, I found that the installation was still done under user with uid 1000 and as a result I found dzVents not working and half the files had uid 1001 and other half 1000. As a result the installation is a bit of a mess, and after an update things randomly break.

Is there any reason why the installation script wouldn't use the uid of the user installing it? and also, how would this be fixed?

many thanks!

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests