dzVents runtime problem?

Easy to use, 100% Lua-based event scripting framework.
Post Reply
MasterMD
Posts: 13
Joined: Friday 07 September 2018 16:07
Target OS: NAS (Synology & others)
Domoticz version: V3.9483
Location: Nederland
Contact:

dzVents runtime problem?

Post by MasterMD » Friday 02 November 2018 13:56

Version: V3.9483
Platform: Synology DS112+
Description:
I want to create some dzVents scripts using the web editor.
According the dzVents 2.4x version description I should get some boilerplate examples in the drip-down below the script type setting; but there aren't.
Several of the keywords as shown in the docs are not available.
When I save a new script, the log states: "dzVents: Write file: /usr/local/domoticz/var/scripts/dzVents/generated_scripts/Test.lua"
However the script isn't run because of this error: "EventSystem: in /usr/local/domoticz/var/dzVents/runtime/dzVents.lua: cannot open /usr/local/domoticz/var/dzVents/runtime/dzVents.lua: No such file or directory"

How can I fix this?

User avatar
waaren
Posts: 1356
Joined: Tuesday 03 January 2017 15:18
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: dzVents runtime problem?

Post by waaren » Friday 02 November 2018 16:54

MasterMD wrote:
Friday 02 November 2018 13:56
Version: V3.9483
Platform: Synology DS112+
Description:
I want to create some dzVents scripts using the web editor.
According the dzVents 2.4x version description I should get some boilerplate examples in the drip-down below the script type setting; but there aren't.
Several of the keywords as shown in the docs are not available.
When I save a new script, the log states: "dzVents: Write file: /usr/local/domoticz/var/scripts/dzVents/generated_scripts/Test.lua"
However the script isn't run because of this error: "EventSystem: in /usr/local/domoticz/var/dzVents/runtime/dzVents.lua: cannot open /usr/local/domoticz/var/dzVents/runtime/dzVents.lua: No such file or directory"

How can I fix this?
You are using a quite old Beta. If there are newer Beta's available at Jumbotroll's site for your NAS, I advise you to update and try again.
Raspberry (debian stretch via berryboot on Synology DS916+) , Domoticz (almost) latest Beta, , dzVents 2.6, RFLink, RFXtrx433e, P1, Youless, Harmony, Hue, Yeelight, Xiaomi, HomeWizard, Zwave, Amazon echo

MasterMD
Posts: 13
Joined: Friday 07 September 2018 16:07
Target OS: NAS (Synology & others)
Domoticz version: V3.9483
Location: Nederland
Contact:

Re: dzVents runtime problem?

Post by MasterMD » Sunday 04 November 2018 12:43

Unfortunately, this seems to be the latest version for my NAS.
Any other possibilities?

User avatar
waaren
Posts: 1356
Joined: Tuesday 03 January 2017 15:18
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: dzVents runtime problem?

Post by waaren » Sunday 04 November 2018 13:05

MasterMD wrote:
Sunday 04 November 2018 12:43
Unfortunately, this seems to be the latest version for my NAS.
Any other possibilities?
Maybe this workaround
can help you ?
Raspberry (debian stretch via berryboot on Synology DS916+) , Domoticz (almost) latest Beta, , dzVents 2.6, RFLink, RFXtrx433e, P1, Youless, Harmony, Hue, Yeelight, Xiaomi, HomeWizard, Zwave, Amazon echo

MasterMD
Posts: 13
Joined: Friday 07 September 2018 16:07
Target OS: NAS (Synology & others)
Domoticz version: V3.9483
Location: Nederland
Contact:

Re: dzVents runtime problem?

Post by MasterMD » Friday 09 November 2018 13:17

Quite a complicated workaround?
I am using an older beta for DSM6.2 (domoticz_88f6282-6.2_3.0.9483-7.spk).
The site shows a version "4.9700 stable for DSM6.1" applicable to a DS112+, but I am using DSM 6.2.
Is there any possibility to use that version or even one of the "4.9700 stable for DSM6.2" version (not showing the DS112+)?

User avatar
waaren
Posts: 1356
Joined: Tuesday 03 January 2017 15:18
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: dzVents runtime problem?

Post by waaren » Friday 09 November 2018 13:52

MasterMD wrote:
Friday 09 November 2018 13:17
Quite a complicated workaround?
No not really complicated . if you copy/paste these 4 lines while on the CLI , it will take max. 10 seconds.

Code: Select all

sudo mkdir /usr/local/domoticz/dzVents
sudo mkdir /usr/local/domoticz/dzVents/runtime
cd /usr/local/domoticz/dzVents/runtime
sudo cp -r /usr/local/domoticz/var/dzVents/runtime/* .
Raspberry (debian stretch via berryboot on Synology DS916+) , Domoticz (almost) latest Beta, , dzVents 2.6, RFLink, RFXtrx433e, P1, Youless, Harmony, Hue, Yeelight, Xiaomi, HomeWizard, Zwave, Amazon echo

MasterMD
Posts: 13
Joined: Friday 07 September 2018 16:07
Target OS: NAS (Synology & others)
Domoticz version: V3.9483
Location: Nederland
Contact:

Re: dzVents runtime problem?

Post by MasterMD » Saturday 10 November 2018 17:58

Thanks for this, but unfortunately it's not enough ...
I created several directories.
Now, when I save a scripts it is saved according the log "dzVents: Write file: /usr/local/domoticz/var/scripts/dzVents/generated_scripts/Test.lua"
However, as soon as the events are triggered this error appears:
2018-11-10 15:38:56.188 Error: EventSystem: in /usr/local/domoticz/var/dzVents/runtime/dzVents.lua: cannot open /usr/local/domoticz/var/dzVents/runtime/dzVents.lua: No such file or directory
Apparently it looks for dzVents.lua and not for another lua-script.
I searched the whole domoticz environment, but didn't find any part of dzVents.

MasterMD
Posts: 13
Joined: Friday 07 September 2018 16:07
Target OS: NAS (Synology & others)
Domoticz version: V3.9483
Location: Nederland
Contact:

Re: dzVents runtime problem?

Post by MasterMD » Saturday 10 November 2018 18:03

For fun I copied my Test1.lua into dzVents.lua.
Now Domotics logs: "Lua script /usr/local/domoticz/var/dzVents/runtime/dzVents.lua did not return a commandArray"
According the info from Domotics' About: dzVents Version: 2.4.5, but it looks an older version (or even just lua)?

User avatar
waaren
Posts: 1356
Joined: Tuesday 03 January 2017 15:18
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: dzVents runtime problem?

Post by waaren » Sunday 11 November 2018 0:59

MasterMD wrote:
Saturday 10 November 2018 18:03
For fun I copied my Test1.lua into dzVents.lua.
Now Domotics logs: "Lua script /usr/local/domoticz/var/dzVents/runtime/dzVents.lua did not return a commandArray"
According the info from Domotics' About: dzVents Version: 2.4.5, but it looks an older version (or even just lua)?
There was quite a lengthy discussion on the same or similar issue here .
If that does not help mayby @jumbotroll can help you out.
Raspberry (debian stretch via berryboot on Synology DS916+) , Domoticz (almost) latest Beta, , dzVents 2.6, RFLink, RFXtrx433e, P1, Youless, Harmony, Hue, Yeelight, Xiaomi, HomeWizard, Zwave, Amazon echo

MasterMD
Posts: 13
Joined: Friday 07 September 2018 16:07
Target OS: NAS (Synology & others)
Domoticz version: V3.9483
Location: Nederland
Contact:

Re: dzVents runtime problem?

Post by MasterMD » Monday 12 November 2018 18:18

OK, let's try to get some response over there!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest