Heatit Z-wave thermostat

Others (MiLight, Hue, Toon etc...)
alexsh1
Posts: 276
Joined: Wednesday 30 September 2015 11:50
Target OS: Raspberry Pi
Domoticz version: v3.8975
Location: United Kingdom
Contact:

Heatit Z-wave thermostat

Post by alexsh1 » Friday 02 October 2015 13:02

Hello


Did anyone manage to setup Heatit Z-wave theormostat. It is not in the DB of known device for OZW, but the problem is that it does not work.
I have "heating" under devices, but cannot switch it on/off or set the temperature.

Manufacturer's web-site:
http://www.heatit.com


From log:

2015-10-02 12:06:12.778 OpenZWave: New Node added. HomeID: 4093159266, NodeID: 6 (0x06)
2015-10-02 12:06:13.020 OpenZWave: Value_Added: Node: 6 (0x06), CommandClass: SENSOR MULTILEVEL, Label: Temperature, Instance: 1
2015-10-02 12:06:13.063 OpenZWave: Value_Added: Node: 6 (0x06), CommandClass: THERMOSTAT MODE, Label: Mode, Instance: 1
2015-10-02 12:06:13.064 (Z-Stick) General/Thermostat Mode (Unknown)
2015-10-02 12:06:13.109 OpenZWave: Value_Added: Node: 6 (0x06), CommandClass: THERMOSTAT SETPOINT, Label: Cooling 1, Instance: 2
2015-10-02 12:06:13.109 (Z-Stick) Thermostat (Unknown)
2015-10-02 12:06:13.114 OpenZWave: Value_Added: Node: 6 (0x06), CommandClass: THERMOSTAT SETPOINT, Label: Dry Air, Instance: 8

Periodically I seee
2015-10-02 12:07:05.611 (Z-Stick) General/Thermostat Mode (Unknown)


Thanks
Alex

alexsh1
Posts: 276
Joined: Wednesday 30 September 2015 11:50
Target OS: Raspberry Pi
Domoticz version: v3.8975
Location: United Kingdom
Contact:

Re: Heatit Z-wave thermostat

Post by alexsh1 » Friday 02 October 2015 15:09

For those who are interested, this is the Thermostat's full data.
I have added the following to the database XML file (manufacture_specific.xml):


<------></Manufacturer>^M
<------><Manufacturer id="019b" name="Therm-Floor(Heatit)">
<------><Product type="0001" id="0001" name="Underfloor Thermostat" config="thermofloor/multireg_thermstat.xml"/>
<------></Manufacturer>

I created the folder "thermofloor" under Config and the file named "multireg_thermstat.xml" with the following

<?xml version="1.0" encoding="utf-8"?>
<Product>
<CommandClasses>
<Class>
<id>0x20</id>
</Class> <!-- COMMAND_CLASS_BASIC -->
<Class>
<id>0x25</id>
</Class> <!-- COMMAND_CLASS_SWITCH_BINARY -->
<Class>
<id>0x26</id>
</Class> <!-- COMMAND_CLASS_SWITCH_MULTILEVEL -->
<Class>
<id>0x27</id>
</Class> <!-- COMMAND_CLASS_SWITCH_ALL -->
<Class>
<id>0x30</id>
</Class> <!-- COMMAND_CLASS_SENSOR_BINARY -->
<Class>
<id>0x31</id>
</Class> <!-- COMMAND_CLASS_SENSOR_MULTILEVEL -->
<Class>
<id>0x70</id>
</Class> <!-- COMMAND_CLASS_CONFIGURATION -->
<Class>
<id>0x72</id>
</Class> <!-- COMMAND_CLASS_MANUFACTURER_SPECIFIC -->
<Class>
<id>0x85</id>
</Class> <!-- COMMAND_CLASS_ASSOCIATION -->
<Class>
<id>0x86</id>
</Class> <!-- COMMAND_CLASS_VERSION -->
<Class>
<id>0xEF</id>
</Class> <!-- COMMAND_CLASS_MARK -->
</CommandClasses>
<Associations>
<Group>
<Index>1</Index>
<Maximum>1</Maximum>
<Label lang="en">Lifeline</Label>
<Help lang="en"></Help>
<SetToController>true</SetToController>
</Group>
<Group>
<Index>2</Index>
<Maximum>8</Maximum>
<Label lang="en">On/Off Control</Label>
<Help lang="en">This group defines the group of Z-Wave units that the thermostat controls. Control is done with BASIC_SET commands, thus all switching units can be used as auxiliary heating controllers.
</Help>
</Group>
</Associations>
</Product>


Now this is only a barebone I took from openHAB - need more time to go through all the classes.
Can somebody please help me? Do you have an XML file for another thermostat? Can you please post it here?

User avatar
Domosapiens
Posts: 371
Joined: Wednesday 20 August 2014 12:08
Target OS: Windows
Domoticz version: V3.5981
Location: NL
Contact:

Re: Heatit Z-wave thermostat

Post by Domosapiens » Friday 02 October 2015 21:27

Hello Alexsh1

But did you first try your Thermostat without a manufacturer specific file?
Most of the time Z-Wave can solve it's own parameters.
Please post the "Therm-Floor(Heatit)" section of your zwfcg_#######.xml. (without a manufacturer specific file)

Your current manufacturer specific file is not understood by OpenZwave.
OpenZwave has an other syntax and is using decimal ID's instead of the HEX ID's as in the OpenHab code


OpenHab Example:

Code: Select all

<Class>
<id>0x30</id>
</Class> <!-- COMMAND_CLASS_SENSOR_BINARY -->
For OpenZwave it has to be written as:

Code: Select all

<CommandClass id="48" name="COMMAND_CLASS_SENSOR_BINARY">
In your manufacturer specific xml you only have to solve User adaptable items, and the missing or incorrect parts.
The Config directory contains 200 examples. Search inside those files.

(Please use the Code button above your post text window, to keep your layout clear)

Hope this helps
Domosapiens
Win Vista&7; 1#Aeon Z-Stick S2; 1#Aeotec Z-Sick Gen5, 6#Fib.FGBS001; 24#DS18B20; 8#Everspr.AN158-2; 3#Philio PAN04; 1#Philio PAN06, 1#YouLess El; 1#Fib.FGWPE; 1#ZME_RC2; 2#FAK_ZWS230, 2#Quib.ZMNHCDx, 1#Quib.ZMNHDD1, 7#EM6555

alexsh1
Posts: 276
Joined: Wednesday 30 September 2015 11:50
Target OS: Raspberry Pi
Domoticz version: v3.8975
Location: United Kingdom
Contact:

Re: Heatit Z-wave thermostat

Post by alexsh1 » Sunday 04 October 2015 2:47

Domosapiens wrote:Hello Alexsh1

But did you first try your Thermostat without a manufacturer specific file?
Most of the time Z-Wave can solve it's own parameters.
Please post the "Therm-Floor(Heatit)" section of your zwfcg_#######.xml. (without a manufacturer specific file)

Thanks for your feedback Domosapiens. Firstly, the Manufacturers ID has not been recognised by OZW so I had to add it manually to the manufacturer specific xml as follows:

Code: Select all

<Manufacturer id="019b" name="Thermo-Floor (Heatit)">
<Product type="0001" id="0001" name="Underfloor Thermostat" />
Apologies, but when you say " without a manufacturer specific file?", you mean without adding extra lines in the file?
I have tried the following:

- Tried thermostat without adding anything to the manufacturer's file - no luck
- Added the above two lines firstly without config="thermofloor/heatit.xml" - no luck
- Added the above two lines as with config="thermofloor/heatit.xml' and currently in the process of looking for the right config in heatit.xml
As I am new to Domoticz, I have been doing some research and thanks for your heads up on OpenHAB vs Domoticz format, I have come up with the following heatit.xml settings so far (work in progress):

Code: Select all

/home/pi/domoticz/Config/thermofloor/heatit.xml   [-M--] 37 L:[  1+15  16/ 18] *(465 / 477b) 0010 0x00A
<?xml version="1.0" encoding="utf-8" ?>
<Product>
<------>    <CommandClass id="49" name="COMMAND_CLASS_SENSOR_MULTILEVEL" />

<------>    <CommandClass id="64" name="COMMAND_CLASS_THERMOSTAT_MODE" version="3">
<------><------><value type="list" label="Command" units="">
<------><------>    <item labal="Off"" value="0" />
<------><------>    <item label="Heat" value="1" />
<------><------>    <item label="Energy" value="11" />
<------><------> </value>
<------>    </CommndClass>
<------>    <CommandClass id="67" base="0" />
<------>    <CommandClass id="133" />
</Product>
Again so far no luck - I cannot control the thermostat properly from Domoticz
And I have "(Z-Stick) Thermostat (Unknown)" in my log file.

My zwcfg_ section related to the thermostat looks like this:

Code: Select all


<------><Node id="7" name="" location="" basic="4" generic="8" specific="6" roletype="5" devicetype="4608" nodetype="0" type="General Thermostat V2" listening="tru
<------><------><Manufacturer id="019b" name="Thermo-Floor (Heatit)">
<------><------><------><Product type="0001" id="0001" name="Underfloor Thermostat" />
<------><------></Manufacturer>
<------><------><CommandClasses>
<------><------><------><CommandClass id="32" name="COMMAND_CLASS_BASIC" version="1" request_flags="4" mapping="64">
<------><------><------><------><Instance index="1" />
<------><------><------></CommandClass>
<------><------><------><CommandClass id="49" name="COMMAND_CLASS_SENSOR_MULTILEVEL" version="6" innif="true">
<------><------><------><------><Instance index="1" />
<------><------><------><------><Value type="decimal" genre="user" instance="1" index="1" label="Temperature" units="C" read_only="true" write_only="false" verify_
<------><------><------></CommandClass>
<------><------><------><CommandClass id="64" name="COMMAND_CLASS_THERMOSTAT_MODE" version="1" request_flags="4" innif="true">
<------><------><------><------><Instance index="1" />
<------><------><------><------><Value type="list" genre="user" instance="1" index="0" label="Mode" units="" read_only="false" write_only="false" verify_changes="f
<------><------><------><------><------><Item label="Off" value="0" />
<------><------><------><------><------><Item label="Heat" value="1" />
<------><------><------><------><------><Item label="Cool" value="2" />
<------><------><------><------><------><Item label="Heat Econ" value="11" />
<------><------><------><------></Value>
<------><------><------><------><SupportedModes>
<------><------><------><------><------><Mode index="0" label="Off" />
<------><------><------><------><------><Mode index="1" label="Heat" />
<------><------><------><------><------><Mode index="2" label="Cool" />
<------><------><------><------><------><Mode index="11" label="Heat Econ" />
<------><------><------><------></SupportedModes>
<------><------><------></CommandClass>
<------><------><------><CommandClass id="67" name="COMMAND_CLASS_THERMOSTAT_SETPOINT" version="1" request_flags="4" innif="true" base="1">
<------><------><------><------><Instance index="1" />
<------><------><------><------><Value type="decimal" genre="user" instance="1" index="2" label="Cooling 1" units="C" read_only="false" write_only="false" verify_c
<------><------><------><------><Value type="decimal" genre="user" instance="1" index="8" label="Dry Air" units="C" read_only="false" write_only="false" verify_cha
<------><------><------></CommandClass>
<------><------><------><CommandClass id="90" name="COMMAND_CLASS_DEVICE_RESET_LOCALLY" version="1" request_flags="4" innif="true">
<------><------><------><------><Instance index="1" />
<------><------><------></CommandClass>
<------><------><------><CommandClass id="94" name="COMMAND_CLASS_ZWAVE_PLUS_INFO" version="1" request_flags="4" innif="true">
<------><------><------><------><Instance index="1" />
<------><------><------><------><Value type="byte" genre="system" instance="1" index="0" label="ZWave+ Version" units="" read_only="true" write_only="false" verify
<------><------><------><------><Value type="byte" genre="system" instance="1" index="1" label="InstallerIcon" units="" read_only="true" write_only="false" verify_
<------><------><------><------><Value type="byte" genre="system" instance="1" index="2" label="UserIcon" units="" read_only="true" write_only="false" verify_chang
<------><------><------></CommandClass>
<------><------><------><CommandClass id="112" name="COMMAND_CLASS_CONFIGURATION" version="1" request_flags="4" innif="true">
<------><------><------><------><Instance index="1" />
<------><------><------></CommandClass>
<------><------><------><CommandClass id="114" name="COMMAND_CLASS_MANUFACTURER_SPECIFIC" version="1" request_flags="4" innif="true">
<------><------><------><------><Instance index="1" />
<------><------><------></CommandClass>
<------><------><------><CommandClass id="115" name="COMMAND_CLASS_POWERLEVEL" version="1" request_flags="4" innif="true">
<------><------><------><------><Instance index="1" />
<------><------><------><------><Value type="list" genre="system" instance="1" index="0" label="Powerlevel" units="dB" read_only="false" write_only="false" verify_
<------><------><------><------><------><Item label="Normal" value="0" />
<------><------><------><------><------><Item label="-1dB" value="1" />
<------><------><------><------><------><Item label="-2dB" value="2" />
<------><------><------><------><------><Item label="-3dB" value="3" />
<------><------><------><------><------><Item label="-4dB" value="4" />
<------><------><------><------><------><Item label="-5dB" value="5" />
<------><------><------><------><------><Item label="-6dB" value="6" />
<------><------><------><------><------><Item label="-7dB" value="7" />
<------><------><------><------><------><Item label="-8dB" value="8" />
<------><------><------><------><------><Item label="-9dB" value="9" />
<------><------><------><------></Value>
<------><------><------><------><Value type="byte" genre="system" instance="1" index="1" label="Timeout" units="seconds" read_only="false" write_only="false" verif
<------><------><------><------><Value type="button" genre="system" instance="1" index="2" label="Set Powerlevel" units="" read_only="false" write_only="true" veri
<------><------><------><------><Value type="byte" genre="system" instance="1" index="3" label="Test Node" units="" read_only="false" write_only="false" verify_cha
<------><------><------><------><Value type="list" genre="system" instance="1" index="4" label="Test Powerlevel" units="dB" read_only="false" write_only="false" ve
<------><------><------><------><------><Item label="Normal" value="0" />
<------><------><------><------><------><Item label="-1dB" value="1" />
<------><------><------><------><------><Item label="-2dB" value="2" />
<------><------><------><------><------><Item label="-3dB" value="3" />
<------><------><------><------><------><Item label="-4dB" value="4" />
<------><------><------><------><------><Item label="-5dB" value="5" />
<------><------><------><------><------><Item label="-6dB" value="6" />
<------><------><------><------><------><Item label="-7dB" value="7" />
<------><------><------><------><------><Item label="-8dB" value="8" />
<------><------><------><------><------><Item label="-9dB" value="9" />
<------><------><------><------></Value>
<------><------><------><------><Value type="byte" genre="system" instance="1" index="5" label="Frame Count" units="" read_only="false" write_only="false" verify_c
<------><------><------><------><Value type="button" genre="system" instance="1" index="6" label="Test" units="" read_only="false" write_only="true" verify_changes
<------><------><------><------><Value type="button" genre="system" instance="1" index="7" label="Report" units="" read_only="false" write_only="true" verify_chang
<------><------><------><------><Value type="list" genre="system" instance="1" index="8" label="Test Status" units="" read_only="true" write_only="false" verify_ch
<------><------><------><------><------><Item label="Failed" value="0" />
<------><------><------><------><------><Item label="Success" value="1" />
<------><------><------><------><------><Item label="In Progress" value="2" />
<------><------><------><------></Value>
<------><------><------><------><Value type="byte" genre="system" instance="1" index="9" label="Acked Frames" units="" read_only="true" write_only="false" verify_c
<------><------><------></CommandClass>
<------><------><------><CommandClass id="133" name="COMMAND_CLASS_ASSOCIATION" version="1" request_flags="4" innif="true">
<------><------><------><------><Instance index="1" />
<------><------><------><------><Associations num_groups="2">
<------><------><------><------><------><Group index="1" max_associations="1" label="Group 1" auto="true">
<------><------><------><------><------><------><Node id="1" />
<------><------><------><------><------></Group>
<------><------><------><------><------><Group index="2" max_associations="8" label="Group 2" auto="false" />
<------><------><------><------></Associations>
<------><------><------></CommandClass>
<------><------><------><CommandClass id="134" name="COMMAND_CLASS_VERSION" version="1" request_flags="4" innif="true">
<------><------><------><------><Instance index="1" />
<------><------><------><------><Value type="string" genre="system" instance="1" index="0" label="Library Version" units="" read_only="true" write_only="false" ver
<------><------><------><------><Value type="string" genre="system" instance="1" index="1" label="Protocol Version" units="" read_only="true" write_only="false" ve
<------><------><------><------><Value type="string" genre="system" instance="1" index="2" label="Application Version" units="" read_only="true" write_only="false"
<------><------><------></CommandClass>
Last edited by alexsh1 on Sunday 04 October 2015 2:48, edited 1 time in total.

alexsh1
Posts: 276
Joined: Wednesday 30 September 2015 11:50
Target OS: Raspberry Pi
Domoticz version: v3.8975
Location: United Kingdom
Contact:

Re: Heatit Z-wave thermostat

Post by alexsh1 » Monday 05 October 2015 3:57

I manage to get the following, but this is far from being ideal.
1.jpg
1.jpg (336.13 KiB) Viewed 7395 times
2.jpg
2.jpg (149.72 KiB) Viewed 7395 times
Problem: I cannot control the heating from Pilot App on my iPhone. Neither can I adjust the temperature.
Another problem I discovered was that if I run domoticz with -verbose = 1, I have more settings under Mode (Off, Heat, Economy) (the second picture above).
I think this is a bug in beta 3219.

Gijs69
Posts: 8
Joined: Friday 06 February 2015 14:21
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Heatit Z-wave thermostat

Post by Gijs69 » Monday 12 October 2015 22:34

Hi Alex,
Did you manage to get any further? I am thinking about getting such a thermostat for my bathroom, but it makes no sense doing os if it ain't functioning with domoticz.

Regards,
Gijs
Domoticz / Raspberry Pi / Razberry / MySensors / SolarEdge API

alexsh1
Posts: 276
Joined: Wednesday 30 September 2015 11:50
Target OS: Raspberry Pi
Domoticz version: v3.8975
Location: United Kingdom
Contact:

Re: Heatit Z-wave thermostat

Post by alexsh1 » Tuesday 13 October 2015 1:24

Hello Gijs,


It is functioning - I can turn it on/off remotely, set the temp and monitor the temp, but there are a couple of issues.
1. You cannot control it from your iPhone through Pilot App.
2. You cannot set timers (see my photo above)

The same product is functioning well under Veera so I think OWZ is going to be corrected for this one shortly.
Currently, this is the only one product on the market so the choice is either Heatit or Heatit :)

Gijs69
Posts: 8
Joined: Friday 06 February 2015 14:21
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Heatit Z-wave thermostat

Post by Gijs69 » Tuesday 13 October 2015 19:33

Thank you for your response, I think I will try it myself then since my current thermostat is starting to give troubles.
Domoticz / Raspberry Pi / Razberry / MySensors / SolarEdge API

User avatar
Flyer
Posts: 9
Joined: Friday 09 October 2015 0:01
Target OS: NAS (Synology & others)
Domoticz version:
Location: Italy
Contact:

Re: Heatit Z-wave thermostat

Post by Flyer » Wednesday 14 October 2015 0:00

Hello!

You know if the problem was solved with OZW?

Flyer

alexsh1
Posts: 276
Joined: Wednesday 30 September 2015 11:50
Target OS: Raspberry Pi
Domoticz version: v3.8975
Location: United Kingdom
Contact:

Re: Heatit Z-wave thermostat

Post by alexsh1 » Saturday 17 October 2015 21:21

I do not think it has been solved. I can live with it, but this is not what one expects from a device worth £100

cogliostrio
Posts: 82
Joined: Sunday 06 September 2015 11:58
Target OS: Linux
Domoticz version:
Contact:

Re: Heatit Z-wave thermostat

Post by cogliostrio » Sunday 18 October 2015 20:44

This is what I have managed to come up with. Still not complete though, so please test and comment.

add to manufacturer_specific.xml

Code: Select all

	<Manufacturer id="019b" name="Thermo-Floor (Heatit)">
		<Product type="0001" id="0001" name="Multireg Z-Wave thermostat TF 016" config="thermofloor/multireg.xml"/>
	</Manufacturer>
multireg.xml

Code: Select all

<?xml version="1.0" encoding="utf-8" ?>
<Product xmlns='http://code.google.com/p/open-zwave/'>


  
	<CommandClass id="112" name="COMMAND_CLASS_CONFIGURATION">	 


		<Value type="list" genre="config"  index="1" label="Operation mode" units=""  value="1">
			<Item label="Off" value="0" />
			<Item label="Heat (Default)" value="1" />
			<Item label="Cool" value="2" />
			<Item label="Energy save heat." value="11" />
		</Value>
		
	<!--tested OK-->
		<Value type="list" genre="config"  index="2" label="Temperature sensor" units=""  value="1">
			<Item label="F - Floor mode: Regulation is based on the floor temperature sensor reading." value="0" />
			<Item label="A - Room temperature mode: Regulation is based on the measured room temperature using the internal sensor (Default)." value="1" />
			<Item label="AF - Room mode w/floor limitations: Regulation is based on internal room sensor but limited by the floor temperature sensor (included) ensuring that the floor temperature stays within the given limits (FLo/FHi." value="2" />
			<Item label="A2 - Room temperature mode: Regulation is based on the measured room temperature using the external sensor." value="3" />
			<Item label="P (Power regulator): Constant heating power is supplied to the floor. Power rating is selectable in 10% increments ( 0% - 100%)." value="4" />
			<Item label="FP - Floor mode with minimum power limitation: Regulation is based on the floor temperature sensor reading, but will always heat with a minimum power setting (PLo)." value="5" />
		</Value>

		<Value type="list" genre="config"  index="3" label="Floor sensor type" value="0">
			<Item label="10k ntc (Default)" value="0" />
			<Item label="12k ntc (Default)" value="1" />
			<Item label="15k ntc (Default)" value="2" />
			<Item label="22k ntc (Default)" value="3" />
			<Item label="33k ntc (Default)" value="4" />
			<Item label="47k ntc (Default)" value="5" />
		</Value>
		
	<!--tested OK-->
		<Value type="byte" index="4" genre="config" label="DIFF l. Temperature control Hysteresis" units="" min="3" max="30" size="1" value="5">
			<Help>3-30 (0,2°C - 3.0°C)
			</Help>
		</Value>
				

		<Value type="byte" index="5" genre="config" label="FLo: Floor min limit" units="" min="50" max="400" size="1" value="50">
			<Help>50-400 (5.0°C - 40.0°C)
			</Help>
		</Value>
				
		<Value type="byte" index="6" genre="config" label="FHi: Floor max limit" units="" min="50" max="400" size="1" value="400">
			<Help>50-400 (5.0°C - 40.0°C)
			</Help>
		</Value>
		
		<Value type="byte" index="7" genre="config" label="ALo: Air min limit" units="" min="50" max="400" size="1" value="50">
			<Help>50-400 (5.0°C - 40.0°C)
			</Help>
		</Value>
				
		<Value type="byte" index="8" genre="config" label="AHi: Air max limit" units="" min="50" max="400" size="1" value="400">
			<Help>50-400 (5.0°C - 40.0°C)
			</Help>
		</Value>
				
		<Value type="byte" index="9" genre="config" label="PLo: Min temperature in Power Reg Mode" units="" min="0" max="9" size="1" value="0">
			<Help>0-9. Min temperature in Power Regulator Mode (setting 2. Temperature sensor - P)
			</Help>
		</Value>
				
		<Value type="byte" index="10" genre="config" label="CO mode setpoint" units="" min="50" max="400" size="1" value="210">
			<Help>50-400 (5.0°C - 40.0°C)
			</Help>
		</Value>

	<!--tested OK-->		<!--range in manual 50-400. Range that works 50-144-->
		<Value type="byte" index="11" genre="config" label="ECO mode setpoint" units="" min="50" max="144" size="1" value="180">
			<Help>50-400 (5.0°C - 40.0°C)
			</Help>
		</Value>
				
		<Value type="byte" index="12" genre="config" label="P setting" units="" min="0" max="10" size="1" value="2">
			<Help>0-10
			</Help>
		</Value>

		
<!--	
		<Value type="list" index="81" genre="config" label="Display brightness" units="" min="0" max="11" size="1" value="5">
			<Help>Display brightness 1-11</helps>
		</Value>
-->
		
	</CommandClass>

</Product>


alexsh1
Posts: 276
Joined: Wednesday 30 September 2015 11:50
Target OS: Raspberry Pi
Domoticz version: v3.8975
Location: United Kingdom
Contact:

Re: Heatit Z-wave thermostat

Post by alexsh1 » Sunday 18 October 2015 21:09

Nice one! I am going to test it shortly. I think I have to amend zwcfg_****** file in order for the settings to be seen by domoticz. Am I correct?

cogliostrio
Posts: 82
Joined: Sunday 06 September 2015 11:58
Target OS: Linux
Domoticz version:
Contact:

Re: Heatit Z-wave thermostat

Post by cogliostrio » Sunday 18 October 2015 21:40

to test the new settings, I first stop domoticz, then delete the zwcfg_*.xml file. Then I copy over the multireg.xml, before I restart domoticz again.

Not sure if this is the right procedure, but I couldnt get domoticz to pic up the changes without deleting zwcfg_*.xml

alexsh1
Posts: 276
Joined: Wednesday 30 September 2015 11:50
Target OS: Raspberry Pi
Domoticz version: v3.8975
Location: United Kingdom
Contact:

Re: Heatit Z-wave thermostat

Post by alexsh1 » Monday 19 October 2015 0:20

I do not think deleting zwcfg_*.xml is the right thing. I have had many troubles in the past with various z-wave devices when deleting it. I think it has to be edited and any info regarding the thermostat to be removed. On RPi this file has got a root ownership, i.e. sudo has to be used before editing it.

cogliostrio
Posts: 82
Joined: Sunday 06 September 2015 11:58
Target OS: Linux
Domoticz version:
Contact:

Re: Heatit Z-wave thermostat

Post by cogliostrio » Saturday 24 October 2015 10:11

Small update to the multireg.xml. Everyhing appears to be in order now.

Code: Select all

<?xml version="1.0" encoding="utf-8" ?>
<Product xmlns='http://code.google.com/p/open-zwave/'>

	<CommandClass id="112" name="COMMAND_CLASS_CONFIGURATION">	 

		<Value type="list" genre="config"  index="1" label="Operation mode" units=""  value="1">
			<Item label="Off" value="0" />
			<Item label="Heat (Default)" value="1" />
			<Item label="Cool" value="2" />
			<Item label="Energy save heat." value="11" />
		</Value>
		
		<Value type="list" genre="config"  index="2" label="Temperature sensor" units=""  value="1">
			<Item label="F - Floor mode: Regulation is based on the floor temperature sensor reading." value="0" />
			<Item label="A - Room temperature mode: Regulation is based on the measured room temperature using the internal sensor (Default)." value="1" />
			<Item label="AF - Room mode w/floor limitations: Regulation is based on internal room sensor but limited by the floor temperature sensor (included) ensuring that the floor temperature stays within the given limits (FLo/FHi." value="2" />
			<Item label="A2 - Room temperature mode: Regulation is based on the measured room temperature using the external sensor." value="3" />
			<Item label="P (Power regulator): Constant heating power is supplied to the floor. Power rating is selectable in 10% increments ( 0% - 100%)." value="4" />
			<Item label="FP - Floor mode with minimum power limitation: Regulation is based on the floor temperature sensor reading, but will always heat with a minimum power setting (PLo)." value="5" />
		</Value>

		<Value type="list" genre="config"  index="3" label="Floor sensor type" value="0">
			<Item label="10k ntc (Default)" value="0" />
			<Item label="12k ntc (Default)" value="1" />
			<Item label="15k ntc (Default)" value="2" />
			<Item label="22k ntc (Default)" value="3" />
			<Item label="33k ntc (Default)" value="4" />
			<Item label="47k ntc (Default)" value="5" />
		</Value>
		
		<Value type="byte" index="4" genre="config" label="DIFF l. Temperature control Hysteresis" units="" min="3" max="30" size="1" value="5">
			<Help>3-30 (0,2°C - 3.0°C)
			</Help>
		</Value>

		<Value type="byte" index="5" genre="config" label="FLo: Floor min limit" units="" min="50" max="400" size="1" value="50">
			<Help>50-400 (5.0°C - 40.0°C)
			</Help>
		</Value>
				
		<Value type="byte" index="6" genre="config" label="FHi: Floor max limit" units="" min="50" max="400" size="1" value="400">
			<Help>50-400 (5.0°C - 40.0°C)
			</Help>
		</Value>
		
		<Value type="byte" index="7" genre="config" label="ALo: Air min limit" units="" min="50" max="400" size="1" value="50">
			<Help>50-400 (5.0°C - 40.0°C)
			</Help>
		</Value>
				
		<Value type="byte" index="8" genre="config" label="AHi: Air max limit" units="" min="50" max="400" size="1" value="400">
			<Help>50-400 (5.0°C - 40.0°C)
			</Help>
		</Value>
				
		<Value type="byte" index="9" genre="config" label="PLo: Min temperature in Power Reg Mode" units="" min="0" max="9" size="1" value="0">
			<Help>0-9. Min temperature in Power Regulator Mode (setting 2. Temperature sensor - P)
			</Help>
		</Value>

		<Value type="short" genre="config" instance="1" index="10" label="CO mode setpoint" size="1" min="50" max="400" value="210">
			<Help>50-400 (5.0°C - 40.0°C)</Help>
		</Value>

		<Value type="short" genre="config" instance="1" index="11" label="ECO mode setpoint" size="1" min="50" max="400" value="180">
			<Help>50-400 (5.0°C - 40.0°C)</Help>
		</Value>
		
		<Value type="short" index="12" genre="config" label="P setting" units="" min="0" max="10" size="1" value="2">
			<Help>0-10
			</Help>
		</Value>

	<CommandClass id="133" name="COMMAND_CLASS_ASSOCIATION">
		<Associations num_groups="5">
			<Group index="1" max_associations="1" label="‘Lifeline’. All run-time reporting is addressed to this group." auto="true"/>
			<Group index="2" max_associations="8" label="‘On/Off control’. This controls external heaters replicating the state of the internal relay." auto="false"/>
		</Associations>
	</CommandClass>
		
	</CommandClass>

</Product>


doms
Posts: 1
Joined: Saturday 02 January 2016 9:15
Target OS: Linux
Domoticz version:
Contact:

Re: Heatit Z-wave thermostat

Post by doms » Saturday 02 January 2016 9:20

Hello,

Best wishes the new year (from a new user).

New to domoticz and new with Heatit, I have a question about the multireg.xml. I did not get what is the "P setting". Is it only for Power Reg Mode ?
Other question, I did not manage to get the warning status, i.e. when the themostat is heating (not the heating mode). Is it possible? Maybe with LUA?

Thank you for your help.

Best regards. Doms.

rtulp
Posts: 8
Joined: Tuesday 05 January 2016 13:15
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Heatit Z-wave thermostat

Post by rtulp » Tuesday 05 January 2016 13:43

cogliostrio wrote:Small update to the multireg.xml. Everyhing appears to be in order now.
I think I have the same problems with HeatIt, I can manage the Off, Eco and Heat function, but can't set the temperature. I can set a lot parameters in Domoticz, but they're not working.

If I replace your code in the right section of zwcfg_XXXXX.xml, will it solve the problem?
Its the same code as Mutlireg.xml, do I have to change them both?
Do I have to stop Domoticz first before changing it?

Thanks!

cogliostrio
Posts: 82
Joined: Sunday 06 September 2015 11:58
Target OS: Linux
Domoticz version:
Contact:

Re: Heatit Z-wave thermostat

Post by cogliostrio » Tuesday 05 January 2016 19:52

I thought the multireg and heatit are the same product, but with different names for different markeds. From what your
writing, it sounds like the Heatit is recognized as as the multireg, somewhat confirming this.

When I created the xml setup, I tested setting the temperature both on the multireg, and in domoticz. Both updated correctly over
the network. What you can do, is check the documentation that came with your device, towards the multireg xml file, To see
if there are any differences.

rtulp
Posts: 8
Joined: Tuesday 05 January 2016 13:15
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Heatit Z-wave thermostat

Post by rtulp » Tuesday 05 January 2016 21:30

cogliostrio wrote:I thought the multireg and heatit are the same product, but with different names for different markeds. From what your
writing, it sounds like the Heatit is recognized as as the multireg, somewhat confirming this.

When I created the xml setup, I tested setting the temperature both on the multireg, and in domoticz. Both updated correctly over
the network. What you can do, is check the documentation that came with your device, towards the multireg xml file, To see
if there are any differences.
Guess you have the Heat IT as well?

What I did:
1. Stopped Domotixz
2. Added this to manufacturer_specific.xml

Code: Select all

   <Manufacturer id="019b" name="Thermo-Floor (Heatit)">
      <Product type="0001" id="0001" name="Multireg Z-Wave thermostat TF 016" config="thermofloor/multireg.xml"/>
   </Manufacturer>

3. Replaced the code posted above with the existing multireg.xml (they were almost the same)
4. Deleted zwcfg_XXXXXXXX.xml
5. Started Domoticz again.

When I start Domoticz, de zwcfg_XXXXX.xml file is created automatically. Nothing has changed yet and Im still not able to set the temperature in Domoticz.

Only thing what I can change is the mode, between Eco, Heat and OFF. What to do to change the temp in Domoticz?

Edit: The only documentation I have, is the installation guide from the manufacturer... so that won't help me...

alexsh1
Posts: 276
Joined: Wednesday 30 September 2015 11:50
Target OS: Raspberry Pi
Domoticz version: v3.8975
Location: United Kingdom
Contact:

Re: Heatit Z-wave thermostat

Post by alexsh1 » Wednesday 06 January 2016 22:41

I have two Setpoints - one I cannot change but the other one is changing the heating temp

Post Reply

Who is online

Users browsing this forum: RonaldH and 5 guests