OpenWebNet developing..?

Others (MiLight, Hue, Toon etc...)
spugna85
Posts: 50
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Sunday 17 December 2017 23:55

Hi fmal,

I changed the code so it will allow you to set alphanumeric passwords.
If Gizmocuz accepts the change, in the next beta you can enter the password you want.

A question: what do you think of the new MHS1? I only have the F454. In your opinion it is useful to change it with an MHS1?

fmal
Posts: 21
Joined: Thursday 16 February 2017 15:08
Target OS: Raspberry Pi
Domoticz version:
Location: Italy
Contact:

Re: OpenWebNet developing..?

Post by fmal » Monday 18 December 2017 10:56

Thank you! I have the MHS1 for testing purpose, I did not have any official gateway and now I'm trying to verify if it's good enough as open gateway. The new official app (My Home Up) is not very appealing, but I cannot make comparisons with the old one because I never had a supported gateway for official apps. I think I'll develop my own way using Domoticz, mainly because there is no official way to manage the alarm station 3486 and I only can activate/disactivate it using AUX commands. I'm very happy with Domoticz, the only thing I do not like in Domoticz is the use of the appcache and the bad themes management. They gives me a lot of problems because I use https connections through a reverse proxy and the cache fails to refresh, the themes do not change or change in a random way depending of the browser you use. But the rest is great!!!!!!

fmal
Posts: 21
Joined: Thursday 16 February 2017 15:08
Target OS: Raspberry Pi
Domoticz version:
Location: Italy
Contact:

Re: OpenWebNet developing..?

Post by fmal » Thursday 04 January 2018 12:49

Hi Spugna85! I downloaded two new beta releases, but it does not allow alpha passwords. What did I miss to do? TY

spugna85
Posts: 50
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Thursday 04 January 2018 13:02

Hi fmal,
you have to wait until the pull request #2001 is merged.
you can monitor the status of the request here: https://github.com/domoticz/domoticz/pull/2001

fmal
Posts: 21
Joined: Thursday 16 February 2017 15:08
Target OS: Raspberry Pi
Domoticz version:
Location: Italy
Contact:

Re: OpenWebNet developing..?

Post by fmal » Monday 08 January 2018 10:40

Ok, i saw the status of the fix, so I tried to apply it manually. Now it does accept the actual password and I can activate the hardware gateway from domoticz panel, but does not work: I do not see devices from this gw. I disabled the previous gw and enabled this one, but no new device is shown.
Error is
COpenWebNetTCP: ERROR_FRAME? 3
2018-01-08 09:33:30.002 COpenWebNetTCP: TCP/IP monitor not connected, retrying in 30 seconds...

I can reach the mhs1 hardware on network using port 20000 and it works correctly if reached from MyHome_Suite.

spugna85
Posts: 50
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Monday 08 January 2018 12:54

Hi fmal,
it is possible that the connection procedure is a bit different for the MHS1, I do not know .. maybe there is an incompatibility with the functions that guarantee the operation with the unofficial gateways.
In the next days I try to verify the problem, but without the hardware I do not know what I can do ..

fmal
Posts: 21
Joined: Thursday 16 February 2017 15:08
Target OS: Raspberry Pi
Domoticz version:
Location: Italy
Contact:

Re: OpenWebNet developing..?

Post by fmal » Monday 08 January 2018 13:05

If I may help I'm happy to do. What may you need to check/test it? I could open a "hidden" port on my fw and forward it to the port 20000 of the MHS1, if you think it's useful. I'm able to manage networks but not so much to work inside domotics, so if you like I can help you to explore this device. My Bticino man says that MHS1 is the only server they suggest today, so (if he is right) it could be useful to understand how it is working.

spugna85
Posts: 50
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Monday 08 January 2018 13:18

@fmal pm

spugna85
Posts: 50
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Thursday 25 January 2018 23:13

I added monitoring of active power and energy. Can someone test this new feature?

juliush
Posts: 2
Joined: Monday 29 January 2018 15:33
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by juliush » Monday 29 January 2018 16:00

dimk wrote:
Friday 22 September 2017 19:05
Hello together,

I have an Bticino System installed in my House.
The system included steering of the blindes and Audio System.

Steering of the blindes works perfect with domoticz but i can not Switch on or off the Bticino Audio system.

The Audio System is also controlled by Bus and openweb protocol.

Has anyone an idea to implement the Audio system in domoticz?

Thanks
Martin

Gesendet von meinem MHA-L29 mit Tapatalk
Hello Martin,
do you have now a solution for the audio system?

@spugna85
the energymanagment looks good!

dimk
Posts: 28
Joined: Sunday 17 September 2017 17:30
Target OS: -
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by dimk » Monday 29 January 2018 16:04

Hello,

Till now I have no solution.

Nobody can not help me.

Do you have a workaround?

Regards
Martin

Gesendet von meinem BLA-L29 mit Tapatalk


juliush
Posts: 2
Joined: Monday 29 January 2018 15:33
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by juliush » Monday 29 January 2018 16:42

I am sorry, I´m completly newbie in domoticz.
Domoticz is great and very simple, and respect for the developers.
For my system i want to also control the bticino sound diffusion
and perform scenes from F420.

spugna85
Posts: 50
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Wednesday 31 January 2018 15:22

Hi, I have checked the specifications of the audio system and there are many features. I could implement some simple command that can be more useful to you, for example the simple ON and OFF of the system.

But I do not have the audio system at home, so you should try via the beta versions that the changes work properly....

dimk
Posts: 28
Joined: Sunday 17 September 2017 17:30
Target OS: -
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by dimk » Wednesday 31 January 2018 16:10

Hello,

I am very interested on it, please inform us, when the audio support is implemented in the beta. Till now I can not see any bticino audio devices.

Many thanks for your support.

Martin

Gesendet von meinem BLA-L29 mit Tapatalk


dimk
Posts: 28
Joined: Sunday 17 September 2017 17:30
Target OS: -
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by dimk » Friday 02 February 2018 8:37

@spugna85:

Please inform us if the audio part is implemented in the beta.

Many thanks!

Martin

Gesendet von meinem BLA-L29 mit Tapatalk


spugna85
Posts: 50
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Friday 02 February 2018 10:50

Hi Martin,
I understand that you are very interested in the audio system,
but you must be patient because I make these changes in my free time, which is not so much ..

dimk
Posts: 28
Joined: Sunday 17 September 2017 17:30
Target OS: -
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by dimk » Friday 02 February 2018 11:19

Hello spugna85,

No problem, thanks.

Martin

Gesendet von meinem BLA-L29 mit Tapatalk


spugna85
Posts: 50
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Saturday 03 February 2018 10:56

Hi Martin,

you could write here the log of domoticz when you turn ON and OFF your audio system?
Thanks.

Matteo

dimk
Posts: 28
Joined: Sunday 17 September 2017 17:30
Target OS: -
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by dimk » Saturday 03 February 2018 11:39

Hi Spugna85,

The log directly in domoticz web page or log file on raspberry pi? If raspberry pi where can I find the domoticz log file?

Thanks
Martin

Gesendet von meinem BLA-L29 mit Tapatalk


spugna85
Posts: 50
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Saturday 03 February 2018 11:42

The log in domoticz web page is ok, thanks.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests