OpenWebNet developing..?

Others (MiLight, Hue, Toon etc...)
spugna85
Posts: 51
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

OpenWebNet developing..?

Post by spugna85 » Friday 04 November 2016 2:49

Hi,
i have a Bticino system installed in my house.

I believe that integrating most of the functionality of the OpenWebNet would be very useful.
I do not understand why now it has only been developed for the management of blinds.

Someone is working to implement features on lights / switches, temperature sensors and status of the alarm system?

If someone is doing it, I could help test the various features, but also to develop......

ps. sorry for my bad english Q_Q

User avatar
gizmocuz
Posts: 8699
Joined: Thursday 11 July 2013 18:59
Target OS: Raspberry Pi
Domoticz version: beta
Location: Top of the world
Contact:

Re: OpenWebNet developing..?

Post by gizmocuz » Friday 04 November 2016 9:25

Please have a look at our github page, click on the OpenWebNet file, and via the history button you know who developed this
Since this is an opensource project, i would say, please start developing and debugging
Could you also change the function names to english ? Else i will be forced to remove hardware support for this very soon
If possible also correct the comments, looks like it is google translated
Quality outlives Quantity!

spugna85
Posts: 51
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Sunday 06 November 2016 5:05

I already translated the functions names and I implemented the lights/switches management.
Please do not remove the hardware support, this is very useful to me

ceceghini
Posts: 2
Joined: Sunday 06 November 2016 12:50
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by ceceghini » Monday 07 November 2016 8:55

I also have a Btcino system, If you need a help for test or develop.
I have no knowledge of c++ but I'm a programmer.
we can get some idea from Grasshopper project

spugna85
Posts: 51
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Tuesday 08 November 2016 10:36

Any help is good. I sent you a private message.

ceceghini
Posts: 2
Joined: Sunday 06 November 2016 12:50
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by ceceghini » Wednesday 09 November 2016 12:16

I could not send private message.
I have downloaded last version with our modification
I you give me you email in private message we could comunicate throught email.

spugna85
Posts: 51
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Wednesday 09 November 2016 13:25

I sent you my email. I wait for your contact ..

Siem
Posts: 8
Joined: Monday 14 November 2016 19:13
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by Siem » Monday 14 November 2016 19:42

Hi guys, I just found your topic. Many thanks for taking the time to develop the OpenWebNet functionality.
How is the development going?

Perhaps this could help you get some inspiration:
https://github.com/openhab/openhab/tree ... ng.bticino

spugna85
Posts: 51
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Monday 14 November 2016 19:49

Thanks, I will check it.
Lights and blinds already work.
Right now I'm working to add the temperature sensors.

Siem
Posts: 8
Joined: Monday 14 November 2016 19:13
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by Siem » Sunday 04 December 2016 19:20

How is it going? Is it already possible to use the lights in the current release or beta version?
Currently Domoticz crashes when I setup OpenWebnet.

User avatar
Derik
Posts: 2183
Joined: Friday 18 October 2013 23:33
Target OS: Raspberry Pi
Domoticz version: BETA
Location: Arnhem/Nijmegen Nederland
Contact:

Re: OpenWebNet developing..?

Post by Derik » Sunday 04 December 2016 20:48

What are the options with Openwebnet in Domoticz?
What hardware do i need?
Xu4: Beta Extreme antenna RFXcomE,WU Fi Ping ip P1 Gen5 PVOutput Harmony HUE SolarmanPv OTG Winddelen Alive ESP Buienradar MySensors WOL Winddelen counting RPi: Beta SMAspot RFlinkTest Domoticz ...Different backups

spugna85
Posts: 51
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Wednesday 07 December 2016 3:35

@Siem
I just made a pull-request that includes:
- Scanning of shutters, lights and temperature sensors (on the hardware start)
- Automatic addition of discovered devices
- Shutters with 3 control buttons (open, stop, close)
- Other bug fixes

Now manually add a device may not work correctly

I hope that these changes will soon be included in Beta version

spugna85
Posts: 51
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Wednesday 07 December 2016 3:43

@Derik
You must have an official bticino gateway (example F454 web server) with the correct IP range set to accept openwebnet connections.
Some devices like MH202 or LN4890 may still be usable for this type of connection.

Siem
Posts: 8
Joined: Monday 14 November 2016 19:13
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by Siem » Thursday 08 December 2016 20:21

spugna85 wrote:@Siem
I just made a pull-request that includes:
- Scanning of shutters, lights and temperature sensors (on the hardware start)
- Automatic addition of discovered devices
- Shutters with 3 control buttons (open, stop, close)
- Other bug fixes

Now manually add a device may not work correctly

I hope that these changes will soon be included in Beta version
Great news!

Siem
Posts: 8
Joined: Monday 14 November 2016 19:13
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by Siem » Monday 12 December 2016 21:22

Hi Spugna,

Tonight I installed the latest beta of Domoticz (version 3.6132 - 2016-12-12).
I enabled "Myhome OpenWebNet" (Data Timeout: Disabled).

Unfortunately Domoticz crashes as soon as it receives a message from the MH200N:
*#13**22*20*43*31*001*01*12*12*2016##

The MH200N sends these kind of messages every 30 seconds:
*#13**22*20*44*01*001*01*12*12*2016##
*#13**22*20*44*31*001*01*12*12*2016##

This is what I see, when Domoticz crashes:
2016-12-12 20:14:13.005 COpenWebNet: connected to: 10.0.0.10:20000
2016-12-12 20:14:13.005 EventSystem: Started
2016-12-12 20:14:13.008 Error: COpenWebNet: Who=(null) not yet supported!
2016-12-12 20:14:13.008 COpenWebNet: received=*#*1## : ACK FRAME
terminate called after throwing an instance of 'std::out_of_range'
what(): basic_string::at: __n (which is 0) >= this->size() (which is 0)
Aborted

Could it be a bug, or is your code not in this beta yet?

Many thanks,
Siem

spugna85
Posts: 51
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Monday 12 December 2016 22:08

Hi Siem!
I confirm to you that the code is not in the beta version. I'm waiting the merge.
However, the problem that you have could not be resolved.
I have always used the F454. I have also MH202, i will try this to see if i have a problem like yours.

spugna85
Posts: 51
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Tuesday 13 December 2016 1:13

I try with my MH202 and i get this:

2016-12-12 23:55:00.000 COpenWebNet: connected to: 192.168.0.98:20000
terminate called after throwing an instance of 'std::length_error'
what(): basic_string::_S_create

But this is so because is not a official gateway.
You can connect domoticz correctly with MH200N? perhaps because is a old gataway and not required the new authentication.

I don't known if I can debug this...
I think that MH200N messages with who=WHO_GATEWAY_INTERFACES_MANAGEMENT (13), are not managed correctly.

EDIT:
I was able to replicate the problem by a time request to the gateway and the system crashed.
I added the fix for this bug to the pull-request. :)

spugna85
Posts: 51
Joined: Tuesday 29 March 2016 16:41
Target OS: Raspberry Pi
Domoticz version:
Location: Italia
Contact:

Re: OpenWebNet developing..?

Post by spugna85 » Tuesday 13 December 2016 10:27

Hi Siem,

I wanted to tell you that the beta version 3.6136 includes all the latest changes in OpenWebNet. I hope you can test everything as soon as possible, I wait for your feedback.

I warn you that when you stop the hardware openwebnet sometimes the system crashes.
I will have to correct this problem when I have have some time.

Siem
Posts: 8
Joined: Monday 14 November 2016 19:13
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by Siem » Tuesday 13 December 2016 22:40

It works now :-)
I am going to give it a thorough test tomorrow.

Siem
Posts: 8
Joined: Monday 14 November 2016 19:13
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: OpenWebNet developing..?

Post by Siem » Wednesday 14 December 2016 13:40

Siem wrote:It works now :-)
I am going to give it a thorough test tomorrow.

I tested in Domoticz 3.6147:
Switches work!
Dimming not, I can only switch dimmers on or off. Sliding doesn't work. If I slide a dimmer that has been switched on, the light will turn off instead of dimming to a certain level.
Do you have dimming already implemented in 3.6147? if so I can look into the OpenWebNet messages to see what is going on there and compare it to working dimmer messages.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests