Help Needed! (RFlink + Ubuntu 16.04)

433Mhz opensource Receiver & Transmitter.

Moderator: Stuntteam

Post Reply
Goudtik
Posts: 5
Joined: Friday 23 December 2016 15:13
Target OS: Raspberry Pi
Domoticz version:
Contact:

Help Needed! (RFlink + Ubuntu 16.04)

Post by Goudtik » Sunday 15 October 2017 21:30

I don't seem to get it...

I had Domoticz running on my Rpi3 connected to 2x RFlink devices (1x 433mhz and 1x 866mhz). Everything worked fine.

Recently I installed Domoticz on my Ubuntu server and connected both of the RFlink devices. When I view the log in Domoticz I see that both of the devices report that they are running firmware v46 and Domoticz seem to detect all of the devices in the area.

BUT when I activate or deactivate a switch in Domoticz nothing happens! (Domoticz comfirms that, for instance, the light is turned on, logs this event in the eventlog (no error).
The RFlink devices do not seem to transmit anything.....
I thought that this could have something to do with the user which it is run on.

I have a seperate user named 'domotica' with no root privilages. Domoticz runs under 'domotica'.
'domotica' is a member of the group 'dialout'. Both of the RFlink devices (connected as /dev/ttyACM0 and /dev/ttyACM1) are also dialout-member.

What could I try next?? Any suggestions would be appreciated!

User avatar
Stuntteam
Posts: 437
Joined: Wednesday 06 May 2015 16:39
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Help Needed! (RFlink + Ubuntu 16.04)

Post by Stuntteam » Sunday 15 October 2017 22:01

First install the latest firmware (rev47) and make sure with rflink loader that your device is able to transmit.
-=# RFLink Gateway Development Team #=-
Introduction: http://www.nemcon.nl/blog2/
Generic RFLink Support forum: http://www.esp8266.nu/forum/viewforum.php?f=8

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests