Domoticz crash on FreeNAS

On various Hardware and OS systems: pi / windows / routers / nas, etc
Post Reply
Posts: 1
Joined: Wednesday 19 September 2018 10:33
Target OS: NAS (Synology & others)
Domoticz version:

Domoticz crash on FreeNAS

Post by joos » Wednesday 19 September 2018 11:00

Hi all,

I am running Domoticz in a jail on my FreeNAS server. All worked ok, but last week I updated my system (via pkg update && pkg upgrade) and was left with a broken Domoticz. The service would start, but after a minute or so, it would stop running. I did some digging in the FreeBSD (FreeNAS is based on FreeBSD) installation and it appeared that the problem lies with the sqlite3 installation. Manually starting Domoticz produced the error:

Code: Select all

/usr/local/lib/ Undefined symbol "fdatasync"
It appeared that this error came up with some other packages on FreeBSD (for other users) and their solution was to downgrade their Sqlite3 intallation. I tried that, and it worked. I force-installed (and locked) the sqlite3-3.21.0_1 version of sqlite (because the *24 and *23 versions both crashed domoticz). Since then, no more problems occured.

Since I upgraded my FreeNAS version as well in the same time period (from the previous stable release to the current), I cannot pinpoint the exact cause of the events.

My question is: are more users facing this problem? Should I submit a bug through the FreeBSD bugzilla? Is there an alternative solution?

I use:
FreeNAS 11.1-U6 (latest stable)
Domoticz 4.9700_1 (latest stable)

The FreeBSD port info page ... &stype=all states the sqlite *24 version (that crashes) as required.

Hope anyone can direct me here.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests