Second raspberry

On various Hardware and OS systems: pi / windows / routers / nas, etc
Post Reply
remko2000
Posts: 48
Joined: Thursday 28 December 2017 15:38
Target OS: Raspberry Pi
Domoticz version:
Location: Broek op Langedijk
Contact:

Second raspberry

Post by remko2000 » Sunday 02 September 2018 8:56

I would like to use a second raspberry (slave) in my house on the same network. So I followed: https://www.domoticz.com/wiki/Setting_up_Device_sharing. I use two Raspberry 3's (both Domoticz version 4.9700).

I have set everything but I see in the log of my master:
2018-09-02 08:59:17.086 Error: Domoticz: TCP/IP connection closed! 10.0.1.xx
2018-09-02 08:59:47.090 Status: Domoticz: TCP connected to: 10.0.1.xx:6144
2018-09-02 08:59:47.091 Status: Domoticz: retrying in 30 seconds...
I have set everything up properly (and I updated both systems).
This does not seem to me to be a router issue because they both run on the same internet network (standard port 6144) . What can be the problem?
Last edited by remko2000 on Sunday 02 September 2018 11:53, edited 2 times in total.

User avatar
DeBaat
Posts: 35
Joined: Saturday 27 January 2018 15:52
Target OS: NAS (Synology & others)
Domoticz version: V3.8153
Contact:

Re: Second raspberry

Post by DeBaat » Sunday 02 September 2018 11:22

You mention the log:
2018-09-02 08:59:47.090 Status: Domoticz: TCP connected to: 10.0.1.xx:6144
However, you also state:
they both run on the same internet network (standard port 6644)
Looks to me there are two different port numbers involved: 6144 vs 6644...

SweetPants
Posts: 2397
Joined: Friday 12 July 2013 21:24
Target OS: Linux
Domoticz version: V4.10267
Location: The Netherlands
Contact:

Re: Second raspberry

Post by SweetPants » Sunday 02 September 2018 11:37

DeBaat wrote:
Sunday 02 September 2018 11:22
You mention the log:
2018-09-02 08:59:47.090 Status: Domoticz: TCP connected to: 10.0.1.xx:6144
However, you also state:
they both run on the same internet network (standard port 6644)
Looks to me there are two different port numbers involved: 6144 vs 6644...
There should only be one 6144
Ubuntu 16.04.5 LTS, Intel NUC, MySensors 2.3.0-alpha, Pro Mini 3.3/8M RFM69(HW), ESP8266 (SDK2.2.0), Sonoff, RFLink, RFXcom, MQTT, NodeRed, Domoticz Beta (from source)

remko2000
Posts: 48
Joined: Thursday 28 December 2017 15:38
Target OS: Raspberry Pi
Domoticz version:
Location: Broek op Langedijk
Contact:

Re: Second raspberry

Post by remko2000 » Sunday 02 September 2018 11:53

My mistake (6644 was a typo mistake). I have set everything as default (poort 6144 both master and slave). I changed it above.
What have I set:

-On the slave I add a user (the masterraspberry useraccount).

-On the master I add a remote server with the IP of the slave on port 6144 and with the useraccount of my slave.

The log keeps showing
2018-09-02 12:06:03.381 Status: Domoticz: TCP connected to: 10.0.1.xx:6144
2018-09-02 12:06:03.382 Status: Domoticz: retrying in 30 seconds...
2018-09-02 12:06:03.381 Error: Domoticz: TCP/IP connection closed! 10.0.1.xx
2018-09-02 12:06:33.385 Status: Domoticz: TCP connected to: 10.0.1.xx:6144
2018-09-02 12:06:33.386 Status: Domoticz: retrying in 30 seconds...
2018-09-02 12:06:33.386 Error: Domoticz: TCP/IP connection closed! 10.0.1.xx
2018-09-02 12:06:48.011 Error: PROXY: timeout occurred, reconnecting
2018-09-02 12:06:48.012 Error: PROXY: Connect failed, reconnecting: Network is unreachable

alanlsmith
Posts: 122
Joined: Monday 07 August 2017 17:17
Target OS: Linux
Domoticz version: Latest β
Location: Near London (Saaarf!)
Contact:

Re: Second raspberry

Post by alanlsmith » Sunday 02 September 2018 12:47

Could it be the user

If I read your post correctly. You have added a user to the slave Pi which is the main user name on your master Pi and on the master Pi you have used the main user name on your slave Pi.

If that is the case then it should be changed around as below. If I’ve got it wrong please ignore me.

The additional user that you have created on the slave is the user that should be refered to in the ‘remote pi’ hardware on the master.
Domoticz Latest β, Ubuntu 18.04 on Intel NUC i3, 8Gb ram, 70Gb drive, RFXtrx433, z-wave and a bit of Broadlink/Android

remko2000
Posts: 48
Joined: Thursday 28 December 2017 15:38
Target OS: Raspberry Pi
Domoticz version:
Location: Broek op Langedijk
Contact:

Re: Second raspberry

Post by remko2000 » Sunday 02 September 2018 20:19

alanlsmith wrote:
Sunday 02 September 2018 12:47
Could it be the user

If I read your post correctly. You have added a user to the slave Pi which is the main user name on your master Pi and on the master Pi you have used the main user name on your slave Pi.

If that is the case then it should be changed around as below. If I’ve got it wrong please ignore me.

The additional user that you have created on the slave is the user that should be refered to in the ‘remote pi’ hardware on the master.
No I don't think there is the problem. I followed excactly the instruction from the wiki. I checked it again.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest