Raspbian version, betas and python plugins

On various Hardware and OS systems: pi / windows / routers / nas, etc
Post Reply
Posts: 95
Joined: Saturday 02 May 2015 21:26
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bexleyheath, SE London, UK

Raspbian version, betas and python plugins

Post by Jem101 » Sunday 28 January 2018 14:37

I have recently been having a great deal of trouble with getting the python plugin system working with the beta releases of Domoticz. I had a RPi 2 running Stretch and the python plugin system would only work with the current stable version of Domoticz, every time I upgraded to the current beta releases, I got a 'segmentation fault' as soon as I enable either of the two python plugins I wanted to use, which were the BroadlinkRM2 plugin and the British Gas 'Hive' plugin. Running the stable version was OK but it did mean that I couldn't use the Aurora theme but I was worries that at some point the stable version would be updated which might mean that the plugins would break again or I would be forever stuck with an obsolete version.

So having read that compiling from source often gives a more stable version, I tried that, it took quite some time, involving mush trial and error, reading posts and asking for help, but finally I got a clean, working, freshly compiled Domoticz system, which promptly crashed as soon as I added the plugin!

Last week I purchase a new RPi3 and a couple of new SDCards, clean installed Raspbian Stretch lite, installed Domoticz (the easy way), upgraded to the current beta, installed the prerequisites, added the first python plugin and 'segmentation fault'. So I wiped the card, reinstalled Stretch, and compiled from source again, all worked until I added the python plugin and again 'segmentation fault'.

So just to see what would happen, I wiped the card and this time installed Raspbian Jessie lite, installed Domoticz from the precompiled binaries, updated to beta, installed the python plugin and it worked perfectly! So now I have a working beta version of Domoticz with the python plugins I want and it's been up for three days now with no errors at all.

Fine, but what concerns me is that some point in the near future Jessie is going to be deprecated in favour of Stretch, I really can't be the only person to be running Domoticz under Stretch with the python plugin system, other people must have tried the same and either had issues or got it working, so what exactly could I have been doing wrong all this time? I see that Jessie is using Python 3.4 whereas Stretch installs 3.5, could that be the issue?

I now have a spare Pi2 and some cards so I can try experimenting without messing up my 'production' system, but does anyone have any suggestions or thoughts on what I should try or look out for?

Many thanks in advance for any ideas
I firmly believe in having an open mind - although not so open that your brain falls out!

- sometimes attributed to Carl Sagan, but the original quote is much older than that

User avatar
Posts: 1358
Joined: Tuesday 03 January 2017 15:18
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands

Re: Raspbian version, betas and python plugins

Post by waaren » Sunday 28 January 2018 16:00

@Jem101. I experienced more or less the same issues as you and reported them here multiple times and on GIT, stating that I was more than willing to investigate further and providing more information on my system's setting and installed packages.
Only difference with your current state is that I managed to get a working domoticz beta for some versions by compiling locally on my test and development PI (same version and packages) Most of the time compile fail because of memory shortage but for some versions I was successful.
Current version v3.8867 compiled from source with cmake -DUSE_OPENSSL_STATIC="NO" CMakeLists.txt working on stretch and for all my plugins
( I must use the -DUSE part to prevent a connection problem with evohome web api )

I am sorry to say that I did not got many other reactions than 'I have no problems on my system....' which is not very helpful to say the least.
Some other users asking similar questions as you even got counter questions like "why are you not on stretch".
Raspberry (debian stretch via berryboot on Synology DS916+) , Domoticz (almost) latest Beta, , dzVents 2.6, RFLink, RFXtrx433e, P1, Youless, Harmony, Hue, Yeelight, Xiaomi, HomeWizard, Zwave, Amazon echo

Posts: 153
Joined: Friday 21 October 2016 9:25
Target OS: NAS (Synology & others)
Domoticz version:
Location: Netherlands

Re: Raspbian version, betas and python plugins

Post by rjblake » Thursday 08 February 2018 10:55

I had the problem too, but have simply stopped using the Python plugins for now. On a similar note, one area I cannot get my head around is the size of the locally compiled file (>2x size). I'd have thought that the make file and options would have been the 'default' options that are used to build the distributed binaries; but seems that is not the case. I can only assume it is due to static libraries (not sure how to exclude them all) instead of dynamic being used. Also, seems that my compiled version has added quite a bit in CPU load. Any ideas why this is the case?

Posts: 185
Joined: Friday 13 November 2015 10:11
Target OS: Raspberry Pi
Domoticz version: Beta
Location: The Netherlands, Emmen Area

Re: Raspbian version, betas and python plugins

Post by assenzuid » Thursday 08 February 2018 22:13

I have same kind of problems you described.
Also fresh installs (compiling from source & easy install), everything works fine (stable and beta version), but when using some plugins Domoticz stops working.

I will try it with an Jessie image and see whats happens.

Very annoying :cry:

Post Reply

Who is online

Users browsing this forum: jordipalet and 4 guests