Could not install motion package

On various Hardware and OS systems: pi / windows / routers / nas, etc
Post Reply
vgr2
Posts: 84
Joined: Monday 29 August 2016 12:02
Target OS: -
Domoticz version:
Contact:

Could not install motion package

Post by vgr2 » Thursday 22 December 2016 23:47

Hello,

with sudo apt-get install Motion, i received the following result. How can I fix it Motion is not installed.....

[email protected]:~$ sudo apt-get install motion
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
libc6-dev : Depends: libc-dev-bin (= 2.19-18+deb8u3) but 2.19-18+deb8u6 is to be installed
motion : Depends: libavcodec56 (>= 6:11~beta1) but it is not going to be installed or
libavcodec-extra-56 (>= 6:11~beta1) but it is not going to be installed
Depends: libavformat56 (>= 6:11~beta1) but it is not going to be installed
Depends: libavutil54 (>= 6:11~beta1) but it is not going to be installed
Depends: libjpeg8 (>= 8c) but it is not going to be installed
Depends: libmysqlclient18 (>= 5.5.24+dfsg-1) but it is not going to be installed
Recommends: ffmpeg but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

pvm
Posts: 824
Joined: Tuesday 17 June 2014 22:14
Target OS: Raspberry Pi
Domoticz version: Beta
Location: NL
Contact:

Re: Could not install motion package

Post by pvm » Thursday 22 December 2016 23:58

Is your system up to date?
sudo apt-get update
sudo apt-get upgrade
Raspberry Pi3

vgr2
Posts: 84
Joined: Monday 29 August 2016 12:02
Target OS: -
Domoticz version:
Contact:

Re: Could not install motion package

Post by vgr2 » Friday 23 December 2016 0:07

yes, did it before..

vgr2
Posts: 84
Joined: Monday 29 August 2016 12:02
Target OS: -
Domoticz version:
Contact:

Re: Could not install motion package

Post by vgr2 » Friday 23 December 2016 0:11

sorry, "sudo apt-get upgrade" install is also failed

[email protected]:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
libc6-dev : Depends: libc-dev-bin (= 2.19-18+deb8u3) but 2.19-18+deb8u6 is installed
E: Unmet dependencies. Try using -f.
[email protected]:~$

pvm
Posts: 824
Joined: Tuesday 17 June 2014 22:14
Target OS: Raspberry Pi
Domoticz version: Beta
Location: NL
Contact:

Re: Could not install motion package

Post by pvm » Friday 23 December 2016 15:01

What's the error report on the proposed command?
Raspberry Pi3

kubrik
Posts: 52
Joined: Wednesday 30 November 2016 16:07
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Could not install motion package

Post by kubrik » Friday 23 December 2016 20:22

Have you tried only

apt-get -f install

??

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest