Adding lan interface to RfxTrx433E

Post Reply
pj-r
Posts: 256
Joined: Wednesday 17 December 2014 18:30
Target OS: Linux
Domoticz version: V3.8650
Location: Jyväskylä, Finland
Contact:

Adding lan interface to RfxTrx433E

Post by pj-r » Thursday 20 July 2017 23:36

edit: The modification was done to RfxTrx433E version not to RfxTrx433 like the post was initially written.

A while ago I bought Qnap to act as home server. Then I had THE idea to move Domoticz from trusty old Radxa Rock on to Qnap. Problem is that the placement for Qnap is in garage and there is no way rf signals gets passed thru the brick walls. So I had to figure out how to leave my RfxTrx433E and MySensors gateway to place where they were before, in the center of house.

MySensors was an easy task. Just made ethernet gateway. RfxTrx433E was bit harder. I wanted to keep things simple as possible. There is possibility to use RPi and ser2net etc.. I had an idea that there must be some serial communication and serial(TTL) to ethernet would do the job. So I opened the box of RfxTrx433E and found there is FTDI FT232RL inside. From datasheet I found out its pins 1 and 5 are for serial comunication with MCU. Following traces on board lead to nicely labeled thru holes: T and R and these actually were TX and RX. Everything did look very promising and I did order this module: http://www.ebay.co.uk/itm/263824499135 (edit: link updated.. again)
Image
ImageImage

Next I hooked up a USB<->TTL cable and tested it. It did work! Then the same thing with Ethernet TTL module. Some weird results from serial monitor.. wtf.. spend quite some time testing thru all the baud rates etc. Then I found the needed setting from module management tool: Package len. By default it was set to value 1024(max). I did set it to 8 and suddenly everything was working. RfxTrx433E started to communicate with domoticz thru lan interface.
Image ImageImageImageImage

Second last thing to sort out was powering the ethernet module. Voltage regulators(3.3v) on RfxTrx433E are not powerful enough to power ethernet module(max 200ma). So I had to "stole" 5V right after USB connector. Ground was easy to find from JP1 connector. The middle one from 5 pins.
ImageImage

Last thing to sort out is how to get these two to same enclosure.. perhaps some drawing and 3d printing.. still on my todo list :lol:
Image

ps. To get all the existing devices to new HW at Domoticz: I created a new HW device for Lan interface and then I swapped on Hardware table the device ID's.
Image

Sorry about the language and typos. I'm not native english speaker.

Disclaimer: if you plan to make the same modification there is risk to broke your valuable RfxTrx433E. You have been warned!
Last edited by pj-r on Tuesday 31 July 2018 11:49, edited 8 times in total.
LXC(x64 Ubuntu Xenial), RFXtrx433E, MySensors

simon_rb
Posts: 709
Joined: Wednesday 07 August 2013 19:09
Target OS: -
Domoticz version:
Location: UK
Contact:

Re: Adding lan interface to RfxTrx433

Post by simon_rb » Monday 14 August 2017 19:26

Excellent, might have to try this

nigels0
Posts: 234
Joined: Thursday 23 January 2014 13:43
Target OS: Raspberry Pi
Domoticz version: 3.8153
Contact:

Re: Adding lan interface to RfxTrx433E

Post by nigels0 » Tuesday 15 August 2017 11:31

Hi,
ps. To get all the existing devices to new HW at Domoticz: I created a new HW device for Lan interface and then I swapped on Hardware table the device ID's.
What parameters in Domoticz did you use to set the new device?

Also, I hope the RFXTRX433E has similar pinouts!
Last edited by nigels0 on Tuesday 15 August 2017 17:11, edited 1 time in total.

nigels0
Posts: 234
Joined: Thursday 23 January 2014 13:43
Target OS: Raspberry Pi
Domoticz version: 3.8153
Contact:

Re: Adding lan interface to RfxTrx433E

Post by nigels0 » Tuesday 15 August 2017 16:32

Well not wanting to be a Lazy Larry, I went ahead and opened up my 433E and found pretty much the same pin options as your 433 - although I couldn't find a 5v pickup at all - everything was 3.3v, so I used a dual-powered USB cable and cut off one of the USB-A cables (the power one) and took the 5v from there. I suppose I could have also taken the 0v, but as I'd already soldered the pins on, I used the third pin on the JP1 as you did.

I've ordered the module
http://www.ebay.co.uk/itm/UART-to-Ether ... 3145000866?
(new listing)

so once I get it, I'll report as to whether it works.

pj-r
Posts: 256
Joined: Wednesday 17 December 2014 18:30
Target OS: Linux
Domoticz version: V3.8650
Location: Jyväskylä, Finland
Contact:

Re: Adding lan interface to RfxTrx433E

Post by pj-r » Thursday 17 August 2017 8:15

nigels0 wrote:
Tuesday 15 August 2017 16:32
Well not wanting to be a Lazy Larry, I went ahead and opened up my 433E and found pretty much the same pin options as your 433 - although I couldn't find a 5v pickup at all - everything was 3.3v, so I used a dual-powered USB cable and cut off one of the USB-A cables (the power one) and took the 5v from there. I suppose I could have also taken the 0v, but as I'd already soldered the pins on, I used the third pin on the JP1 as you did.
pj-r wrote:
Thursday 20 July 2017 23:36
Second last thing to sort out was powering the ethernet module. Voltage regulators(3.3v) on RfxTrx433 are not powerful enough to power ethernet module(max 200ma). So I had to "stole" 5V right after USB connector. Ground was easy to find from JP1 connector. The middle one from 5 pins.
ImageImage
There you can see the spot where I stole the 5V. There is no ready made hole for 5V. It needs quite steady hand while soldering since its made between two smd components :D
rfxlan_5v.jpg
rfxlan_5v.jpg (87.71 KiB) Viewed 4571 times
LXC(x64 Ubuntu Xenial), RFXtrx433E, MySensors

nigels0
Posts: 234
Joined: Thursday 23 January 2014 13:43
Target OS: Raspberry Pi
Domoticz version: 3.8153
Contact:

Re: Adding lan interface to RfxTrx433

Post by nigels0 » Monday 21 August 2017 23:40

OK, thanks - on the second one, I'll have a hunt for it.

Edit - looks like either the connection at the bottom of C24 or L7 will do the job. both on the lower/left part as in your picture. I had a go, and got it working, but you're right about the steady hand! It was a b*88ch to get done!
Last edited by nigels0 on Thursday 24 August 2017 1:27, edited 1 time in total.

nigels0
Posts: 234
Joined: Thursday 23 January 2014 13:43
Target OS: Raspberry Pi
Domoticz version: 3.8153
Contact:

Re: Adding lan interface to RfxTrx433

Post by nigels0 » Thursday 24 August 2017 1:26

Now you got me thinking, I'll also try out the following for wifi connection:

Code: Select all

http://www.ebay.co.uk/itm/RCmall-Serial-Port-TTL-to-Wifi-ESP-M2-ESP8285-Transmission-Webserver-Support-TCP-/332179186984?epid=8005092336&hash=item4d576c2528:g:ql4AAOSww3tY60Fd
http://www.ebay.co.uk/itm/RCmall-Serial ... Sww3tY60Fd

UPDATE.

Well I'm still waiting for the ethernet module, but the wifi unit arrived - and didn't work with the parameters you had for the serial connection - it may be the package length thing too - but there was no option in the setup to change this.

nigels0
Posts: 234
Joined: Thursday 23 January 2014 13:43
Target OS: Raspberry Pi
Domoticz version: 3.8153
Contact:

Re: Adding lan interface to RfxTrx433

Post by nigels0 » Friday 08 September 2017 12:29

Screen Shot 2017-09-08 at 11.51.00.png
Screen Shot 2017-09-08 at 11.51.00.png (65.08 KiB) Viewed 4340 times
Well I finally got the module, but it doesn't work for me.

Changed the database (using sqlite3 as sqlite wouldn't read the database)

My Hardware table looks like this:

Code: Select all

1|RFXNet|1|2|192.168.0.92|2000|2000||||83|20|40|2|0|0|0
3|Motherboard|0|23||1|1||||0|0|0|0|0|0|0
4|Presence|0|15||0|||||0|0|0|0|0|0|0
5|Power|1|15||1|||||0|0|0|0|0|0|0
10|Velux|1|15||1|1||||0|0|0|0|0|0|0
12|Domoticz Internal|1|67||1|||||0|0|0|0|0|0|0
13|Olufsen|1|15||0|||||0|0|0|0|0|0|0
14|OSMC|0|55||0|||||30|2000|0|0|0|0|0
15|Holiday|1|15||0|||||0|0|0|0|0|0|0
16|RFXCom|1|1||0|/dev/ttyUSB0||||83|20|40|2|0|0|0
17|WAN Address|1|94|https://4.ifcfg.me/ip|0||||WAN-IP-CHECKER|60|||||Normal|0
I created the new device as RFXCOM - RFXtrx shared over LAN interface, put in the correct IP and port (192.168.0.92, 2000), programmed the module with TCP+SERVER, Local Port:2000, Baud: 38400, 8 data bit, 1 stop bit, no parity and set the pack len to 8.

I tried adding a device via the usb (so using the old RFXCom setting now 16) to make sure I hadn't broken the RFXtx - and it worked fine.
Screen Shot 2017-09-08 at 11.36.07.png
Screen Shot 2017-09-08 at 11.36.07.png (42.71 KiB) Viewed 4341 times

I'm getting these errors in the log:
Screen Shot 2017-09-08 at 11.41.40.png
Screen Shot 2017-09-08 at 11.41.40.png (23.59 KiB) Viewed 4341 times
though the device respond to ping.

So maybe I'm using the wrong hardware type? or maybe I have a problem with the port - but it isn't clear how to fix.


UPDATE -

I've managed to connect by switching to DHCP (strange but true) - not a big deal, I can sort out the address at the router assigning an IP address to a MAC address. Seems like it works!!

I've noted that the RX from the RFXcom goes to the TX on the module (and the same for TX/RX) :)
Last edited by nigels0 on Friday 08 September 2017 18:06, edited 1 time in total.

nigels0
Posts: 234
Joined: Thursday 23 January 2014 13:43
Target OS: Raspberry Pi
Domoticz version: 3.8153
Contact:

Re: Adding lan interface to RfxTrx433

Post by nigels0 » Friday 08 September 2017 18:00

]Final unit.
IMG_0815.JPG
IMG_0815.JPG (54.77 KiB) Viewed 4326 times
Thanks for your work - really useful!

For others - here's the configuration file(s) (windows-based)
NetModuleConfig.zip
(60 KiB) Downloaded 108 times
SocketTest3.zip
(98.49 KiB) Downloaded 37 times
Last edited by nigels0 on Sunday 10 September 2017 13:29, edited 1 time in total.

pj-r
Posts: 256
Joined: Wednesday 17 December 2014 18:30
Target OS: Linux
Domoticz version: V3.8650
Location: Jyväskylä, Finland
Contact:

Re: Adding lan interface to RfxTrx433

Post by pj-r » Friday 08 September 2017 21:36

Good that you got it working! Looks wery nice!
Have you shared the stl file for the enclosure? I could print one :D
LXC(x64 Ubuntu Xenial), RFXtrx433E, MySensors

nigels0
Posts: 234
Joined: Thursday 23 January 2014 13:43
Target OS: Raspberry Pi
Domoticz version: 3.8153
Contact:

Re: Adding lan interface to RfxTrx433

Post by nigels0 » Saturday 09 September 2017 1:07

Ha, it wasn't a 3D print - it was just a hobby box I had lying around which I attacked with a dremmel :)

pj-r
Posts: 256
Joined: Wednesday 17 December 2014 18:30
Target OS: Linux
Domoticz version: V3.8650
Location: Jyväskylä, Finland
Contact:

Re: Adding lan interface to RfxTrx433

Post by pj-r » Saturday 09 September 2017 14:10

Oh, nice! :)
LXC(x64 Ubuntu Xenial), RFXtrx433E, MySensors

Dave21w
Posts: 15
Joined: Sunday 29 November 2015 22:55
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Adding lan interface to RfxTrx433

Post by Dave21w » Sunday 01 October 2017 11:44

Great work guys, think I might be following suite, probably struggle a bit on the software / config side but as I'm an electronics engineer by trade the rest should be easy for me, may even go one step further and do POE (power over ethernet) so I don't need a local mains plug for it.

Hopefully it will solve my current isssue, like you guys my Domoticz server is the the garage (bottom of garden - I have a 4 inch pipe buried that I can pull any network / electrical cables I need between the there and the house) so at present I'm using a USB to IP converter but it seems to randomly crash every couple of days, I've tried another one the same but still plays up so need an alternative, hopefully the above will be it !

Dave.

nigels0
Posts: 234
Joined: Thursday 23 January 2014 13:43
Target OS: Raspberry Pi
Domoticz version: 3.8153
Contact:

Re: Adding lan interface to RfxTrx433

Post by nigels0 » Monday 02 October 2017 14:25

I'm finding it very reliable. Not dropped since I installed it a week or so ago.

I've also got a RFXTRX433 - not the E version - that I was looking at converting and the R and T pinholes aren't there - the 0v is in the same place though. I don't trust my soldering skills to solder directly to the pins on the FTDI chip though!

pj-r
Posts: 256
Joined: Wednesday 17 December 2014 18:30
Target OS: Linux
Domoticz version: V3.8650
Location: Jyväskylä, Finland
Contact:

Re: Adding lan interface to RfxTrx433E

Post by pj-r » Saturday 07 October 2017 21:50

I fixed the first post. I did this modification to RfxTrx433E not to RfxTrx433. Sorry for that misleading information. Posting with little sleep can cause this sometimes..
LXC(x64 Ubuntu Xenial), RFXtrx433E, MySensors

Dave21w
Posts: 15
Joined: Sunday 29 November 2015 22:55
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Adding lan interface to RfxTrx433E

Post by Dave21w » Sunday 08 October 2017 9:42

Well I've ordered a few of these so I can give it a go:-

http://www.ebay.co.uk/itm/Ethernet-to-R ... 2447494803

Hopefully they will turn up soon, in the mean time a local electronics store to me (Maplin) had a 4 port USB to IP converter on offer for £10, original price was only £20 anyway, (wish I'd have looked there first before paying £30 each for a couple of second user single port versions from ebay!) so I thought I'd give it a go, as soon as I plugged it in my old software detected it, it only has the same chipset in it :cry:

Anyway it actually seems to be slightly bettter designed, it still crashes but must have a watchdog built in because it does restart its self !!

sebitop
Posts: 161
Joined: Sunday 08 June 2014 20:31
Target OS: Raspberry Pi
Domoticz version:
Location: Toulouse France
Contact:

Re: Adding lan interface to RfxTrx433E

Post by sebitop » Sunday 18 February 2018 13:54

hi guys

I tried to do the same on my RFXCOM V2.1 which dosen't have the R and T hole but following the PCB I found 2 pins on a chip where I was able to fix 2 cables so Rx and Tx

I bought a USR-TCP232-T24 module which is visible on the network and configured with a fixed IP

now I put the Tx from the ethernet module on the Rx of the RFXcom and same for Rx which apparently is the right way to do.

Using the RFXMGR I can connect on the rfxcom using the IP adress but when I clic "get status" nothing appears ....

So the RFXcom is visible on domotics but I can't interact with it ...when I set a mode it says like "ok" but nothing changes...

an idea why ?
domo1.jpg
domo1.jpg (24.35 KiB) Viewed 2643 times
domo2.jpg
domo2.jpg (21.32 KiB) Viewed 2643 times
domo3.jpg
domo3.jpg (20.26 KiB) Viewed 2642 times
domoticz on Raspberry Pi + RFXcom LAN moded
RSL / Blyss / DI.O / Wemos / homemade

sebitop
Posts: 161
Joined: Sunday 08 June 2014 20:31
Target OS: Raspberry Pi
Domoticz version:
Location: Toulouse France
Contact:

Re: Adding lan interface to RfxTrx433E

Post by sebitop » Monday 19 February 2018 10:39

hey all

so after a day of fight I finally found the solution (thanks to bert the creator of RFXcom)

so I bought a USR-TCP232-T24 ethernet to serial module, once configured over the network (I used port 2000 instead of 8233 proposed as it was a mess used this one)

but on my RFXCOM there is no R or T hole so I had to found a way to catch the signal (PCB version is 2.1)

then I unsoldered the 1st pin from the FTDI (Tx) and I plugged 2 cables on the 2 first pin of the PIC controler above :

pin 15 = R serial input and pin 16 serial output

so the Rx of my ethernet module is connected on T and Tx of the module on R (which is now disconneted from the FTDI chip)



I got the 5v power like Pj and everything works now on the network !


On domoticz side if you have already everything configured with your rfxcom you need to switch the hardware ID on the RFXlan

I saved the database and edited it locally with DBBROWSER for SQLITE

you can execute the command select * from hardware to check your respective IDs

so you let say you have

RFXCOM ID = 2
RFXLAN = 7

you just do a trick to replace the RFXCOM ID by the lan one and vice versa which gives :

update hardware set id = 20 where id = 2
update hardware set id = 2 where id = 7
update hardware set id = 7 where id = 20

and now you have
RFXCOM ID = 7
RFXLAN id = 2

and all your devices which worked with the RFXCOM will now work on RFXLAN


I hope it helps !

Now to all a question :

I stolen the 5v like you Nigel to power my ethernet module
but If I try to put 5v from there to remove the USB plug it dosen't work

any idea how to power the RFXCOM module without using a USB plug ?

thanks !!

seb
domoticz on Raspberry Pi + RFXcom LAN moded
RSL / Blyss / DI.O / Wemos / homemade

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests