Rfxcom stops working

Post Reply
ubee
Posts: 184
Joined: Tuesday 10 February 2015 21:38
Target OS: Raspberry Pi
Domoticz version: 3.8153
Location: Sweden
Contact:

Rfxcom stops working

Post by ubee » Thursday 20 July 2017 6:00

I have a Domoticz configuration (v3.5877) on Rasp 2 with a RFXCom433 attached(firmware version Ext/1006). It has worked fine for a while with a few temp sensors (Viking) and Nexa switches. Occasionally I miss temperature readings from one sensor due to bad coverage, but I can live with that.

However the last few days RFXCom I have run into problems. Rfxcom stops. Or at least no temp data is received and I can't control any Nexa switch either. The log does not give any info. No lines labeled Rfxcom. Sometimes I can get things working again by re-enabling the Rfxcom HW device on the HW tab. Doing so I can see in the log how the Rfxcom module is initiated and temp readings start to come in. However, yesterday RFXcom stopped again, and this time re-enabling the HW module didn't help either. Nothing showed up in the log, but after reboot everything is fine again.


??

b_weijenberg
Posts: 679
Joined: Friday 12 July 2013 18:13
Target OS: -
Domoticz version:
Location: Netherlands
Contact:

Re: Rfxcom stops working

Post by b_weijenberg » Thursday 20 July 2017 10:31

It seems the FTDI USB interface is locked. In most cases this is due to a spike on the power or a bad RPI power supply.
Possible solutions:
Do not run the USB cable along power lines,
Use a good quality power supply,
Connect the RFXtrx to a powered USB hub (with a good quality power supply).
RFXtrx433, RFXtrx433E

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests