MySensors - Gateway to Domoticz

alexsh1
Posts: 277
Joined: Wednesday 30 September 2015 11:50
Target OS: Raspberry Pi
Domoticz version: v3.8975
Location: United Kingdom
Contact:

Re: MySensors - Gateway to Domoticz

Post by alexsh1 » Thursday 14 January 2016 15:54

Derik wrote:
What is the capacity of this capacitor ?
I have 470 uf 16 volt?
Is that a good one?

No, that's too much.
Put a 1uf to 10uf capacitor. I have 10uf on three nrf24l01+ as most people do working with no probs.

User avatar
bierlaagh
Posts: 45
Joined: Friday 14 March 2014 17:15
Target OS: Raspberry Pi
Domoticz version: 4.9984
Contact:

Re: MySensors - Gateway to Domoticz

Post by bierlaagh » Thursday 14 January 2016 18:10

Little off topic: but can't wait for my stuff to arrive. Have a gateway up and running, but received the wrong radio's had the nrf24l01 instead of the plus version. So getting init failed when attached to my nano or pro mini....
But is nice en learning a lot reading this thread

Btw my gateway runs with a 470 uf


Verzonden vanaf mijn iPhone met Tapatalk
1x Raspberry PI 3 With Domoticz V.3.7318
1X RFXtrx433 USB 433.92MHz
1X Synology DS213j Nas
Toon by Eneco including Toon Zon
several KAKU switches and dimmers
Mysensors WIFI Gateway including meters, switches en humidity sensors
Wifi Dimmers (home made)

malarcy
Posts: 56
Joined: Sunday 15 November 2015 14:36
Target OS: Linux
Domoticz version:
Contact:

Re: MySensors - Gateway to Domoticz

Post by malarcy » Monday 18 January 2016 0:47

but received the wrong radio's had the nrf24l01 instead of the plus version
I seem to remember some notes on the non + version on the mysensors forum - I think a couple of "DEFINE" statements can be used to get them to work.

User avatar
bierlaagh
Posts: 45
Joined: Friday 14 March 2014 17:15
Target OS: Raspberry Pi
Domoticz version: 4.9984
Contact:

Re: MySensors - Gateway to Domoticz

Post by bierlaagh » Monday 18 January 2016 0:57

Thank you Mararcy,
I'll have a look at it. The new + version is on his way btw.
But why not try to get these working


Verzonden vanaf mijn iPhone met Tapatalk
1x Raspberry PI 3 With Domoticz V.3.7318
1X RFXtrx433 USB 433.92MHz
1X Synology DS213j Nas
Toon by Eneco including Toon Zon
several KAKU switches and dimmers
Mysensors WIFI Gateway including meters, switches en humidity sensors
Wifi Dimmers (home made)

Thomasdc
Posts: 243
Joined: Wednesday 11 March 2015 20:13
Target OS: Raspberry Pi
Domoticz version: Beta
Contact:

Re: MySensors - Gateway to Domoticz

Post by Thomasdc » Thursday 21 January 2016 22:01

Hi!


I use the MySensors PulsePower sensor for this:
http://www.mysensors.org/build/pulse_power

But what do i have to use for: "#define PULSE_FACTOR 1000 // Nummber of blinks per KWH of your meeter" ?
now i have it set to '10 000'
i use the 'imp/kWh' (and not the 'imp/kvah')

picture:
Spoiler: show
Image
like you can see in the picture there also is marked a "10 000"
but at the bottom of the device (picture) there is: "0.2Wh/imp"
(which results in : 5000 impulses /kwh if im right) so wich one do i have to use?

and have i to modify the value in the domoticz settings under 'settings' --> 'meters/counters' -->'RFXMeter/Counter Dividers:'
'Energy' is now set to "1000". should i change this?

because i have a feeling this isnt working right for now
when turn on the microwave to a "1000W" i see the value of the meter in my domoticz change from "380Watt" to "425Watt" (The 380Watt is because an industrial refrigerator ) but all these values seems to low (well i think so, i don't really know)

do you have suggestions how i should configure my settings? Pulse values?
because even when i modify my 'PULSE_FACTOR' that is now set on '10 000" into "5000" it will still be not correct i think? (it will only double which is still not enough i think? becuase now : Microwave 1000W is from 380 to 425 --> so is 45 watt.. when it would double it would still only be a 90 watt? so there is still factor 10 wrong?

or am i missing something?

thanks!

User avatar
bierlaagh
Posts: 45
Joined: Friday 14 March 2014 17:15
Target OS: Raspberry Pi
Domoticz version: 4.9984
Contact:

Re: MySensors - Gateway to Domoticz

Post by bierlaagh » Saturday 23 January 2016 22:37

I'm rather new to my sensors but started building a pulse watermeter. (https://www.mysensors.org/build/pulse_water)
It is working and finally sending information to my serial gateway(i.e. Domoticz)

I only run into a few issues (and or questions)

A few times a day I get an unusual reading (like a few cubic in a relative short time.

Image

I presume it's the meter stopping there where the sensors constantly switching between on and off (the digital pin only reports on or off)

Is there a way to work around this issue?

And second regarding the sketch in the beginning the following define is mentioned:
#define SENSOR_INTERRUPT DIGITAL_INPUT_SENSOR-2
And I can't figure out what that means or what it does.

I hope you have some answers.


Send using Tapatalk
1x Raspberry PI 3 With Domoticz V.3.7318
1X RFXtrx433 USB 433.92MHz
1X Synology DS213j Nas
Toon by Eneco including Toon Zon
several KAKU switches and dimmers
Mysensors WIFI Gateway including meters, switches en humidity sensors
Wifi Dimmers (home made)

User avatar
Derik
Posts: 2194
Joined: Friday 18 October 2013 23:33
Target OS: Raspberry Pi
Domoticz version: BETA
Location: Arnhem/Nijmegen Nederland
Contact:

Re: MySensors - Gateway to Domoticz

Post by Derik » Monday 22 February 2016 21:14

trying to build the mysensors gateway on a arduino uno...
Get errors..
With the codebenderplugin:

Code: Select all

There was an error compiling
And with the ide 1.6.5:

Code: Select all

avr-gcc: error: C:\Users\DM_PC\AppData\Local\Temp\build1012065700280000783.tmp/core.a: No such file or directory
Fout bij compileren.
Blink i can upload with the codebender...
And blink can i not upload with the ide...Error:

Code: Select all

avr-gcc: error: C:\Users\DM_PC\AppData\Local\Temp\build7908594123527930744.tmp/core.a: No such file or directory
Fout bij compileren.
Help please... ;)
Xu4: Beta Extreme antenna RFXcomE,WU Fi Ping ip P1 Gen5 PVOutput Harmony HUE SolarmanPv OTG Winddelen Alive ESP Buienradar MySensors WOL Winddelen counting RPi: Beta SMAspot RFlinkTest Domoticz ...Different backups

User avatar
Derik
Posts: 2194
Joined: Friday 18 October 2013 23:33
Target OS: Raspberry Pi
Domoticz version: BETA
Location: Arnhem/Nijmegen Nederland
Contact:

Re: MySensors - Gateway to Domoticz

Post by Derik » Tuesday 23 February 2016 14:07

pffff

I got the gateway....

And i do have 1 motion sensor..
1 probleem the motion stay on motion and there is no motion :-(
ScreenShot054.jpg
ScreenShot054.jpg (52.89 KiB) Viewed 4495 times
Is there some setting that i need to change?
ScreenShot055.jpg
ScreenShot055.jpg (107 KiB) Viewed 4495 times
Xu4: Beta Extreme antenna RFXcomE,WU Fi Ping ip P1 Gen5 PVOutput Harmony HUE SolarmanPv OTG Winddelen Alive ESP Buienradar MySensors WOL Winddelen counting RPi: Beta SMAspot RFlinkTest Domoticz ...Different backups

User avatar
gizmocuz
Posts: 8721
Joined: Thursday 11 July 2013 18:59
Target OS: Raspberry Pi
Domoticz version: beta
Location: Top of the world
Contact:

Re: MySensors - Gateway to Domoticz

Post by gizmocuz » Tuesday 23 February 2016 15:15

Does your motion sensor send an OFF when there is no motion ?
If not, edit the motion sensor and specify an off delay
Quality outlives Quantity!

User avatar
Derik
Posts: 2194
Joined: Friday 18 October 2013 23:33
Target OS: Raspberry Pi
Domoticz version: BETA
Location: Arnhem/Nijmegen Nederland
Contact:

Re: MySensors - Gateway to Domoticz

Post by Derik » Tuesday 23 February 2016 15:20

I try to do that... no succes

I think there is a other problem:
ScreenShot056.jpg
ScreenShot056.jpg (140.82 KiB) Viewed 4486 times
Connection reset.....
Xu4: Beta Extreme antenna RFXcomE,WU Fi Ping ip P1 Gen5 PVOutput Harmony HUE SolarmanPv OTG Winddelen Alive ESP Buienradar MySensors WOL Winddelen counting RPi: Beta SMAspot RFlinkTest Domoticz ...Different backups

barbaar
Posts: 68
Joined: Wednesday 24 December 2014 17:01
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MySensors - Gateway to Domoticz

Post by barbaar » Wednesday 24 February 2016 0:37

I just noticed my MySensors stopped working 2 days ago. In the hardware sector of Domoticz Mysensors appears as usual, but it does not show its version (version: ?). When I click on the configured gateway, the two connected sensors do appear (temp + humidity and pressure).

However, the two sensors are no longer updated. I am currently running the latest Domoticz build (4739). I already restarted Domoticz and reconnected the gateway. Unfortunately, no effect. Also tried restarting the Pi

One sensor is directly connected to the Pi running Domoticz, and one is elsewhere. Never had a problem with this..

Any ideas?

User avatar
bierlaagh
Posts: 45
Joined: Friday 14 March 2014 17:15
Target OS: Raspberry Pi
Domoticz version: 4.9984
Contact:

MySensors - Gateway to Domoticz

Post by bierlaagh » Wednesday 24 February 2016 10:17

I had the same issue
Solved It by using an external power supply for the serial gateway

You could also look at the output of

Code: Select all

cat /dev/ttyUSB0
If you are using a RPI or any Linux based system.

Where 0 could also another number depending on the connection of your gateway.
Dat the output give you anything?


Send using Tapatalk
1x Raspberry PI 3 With Domoticz V.3.7318
1X RFXtrx433 USB 433.92MHz
1X Synology DS213j Nas
Toon by Eneco including Toon Zon
several KAKU switches and dimmers
Mysensors WIFI Gateway including meters, switches en humidity sensors
Wifi Dimmers (home made)

barbaar
Posts: 68
Joined: Wednesday 24 December 2014 17:01
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MySensors - Gateway to Domoticz

Post by barbaar » Wednesday 24 February 2016 18:14

cat /dev/ttyUSB1 (which is the right device) shows nothing..

How did you connect de external powersupply to the MySensors Gateway?

User avatar
bierlaagh
Posts: 45
Joined: Friday 14 March 2014 17:15
Target OS: Raspberry Pi
Domoticz version: 4.9984
Contact:

Re: MySensors - Gateway to Domoticz

Post by bierlaagh » Wednesday 24 February 2016 23:08

Used an external power supply (5volt) connected to a step down converter. Contributed ground to both the ground of the radio as to the aurduino (nano in my case) aurduino is still connect to my pi trough USB.


Send using Tapatalk
1x Raspberry PI 3 With Domoticz V.3.7318
1X RFXtrx433 USB 433.92MHz
1X Synology DS213j Nas
Toon by Eneco including Toon Zon
several KAKU switches and dimmers
Mysensors WIFI Gateway including meters, switches en humidity sensors
Wifi Dimmers (home made)

barbaar
Posts: 68
Joined: Wednesday 24 December 2014 17:01
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MySensors - Gateway to Domoticz

Post by barbaar » Thursday 25 February 2016 10:46

Tnx.. I ordered a ethernet-module. This will disconnect the gateway from the pi, and allows a dedicated power-supply..

User avatar
bierlaagh
Posts: 45
Joined: Friday 14 March 2014 17:15
Target OS: Raspberry Pi
Domoticz version: 4.9984
Contact:

Re: MySensors - Gateway to Domoticz

Post by bierlaagh » Thursday 25 February 2016 23:09

I'm waiting for my ESP to arrive (ESP 12 that is, already have 2 ESP 01 dimmers in my network) to build a wireless gateway


Send using Tapatalk
1x Raspberry PI 3 With Domoticz V.3.7318
1X RFXtrx433 USB 433.92MHz
1X Synology DS213j Nas
Toon by Eneco including Toon Zon
several KAKU switches and dimmers
Mysensors WIFI Gateway including meters, switches en humidity sensors
Wifi Dimmers (home made)

User avatar
Derik
Posts: 2194
Joined: Friday 18 October 2013 23:33
Target OS: Raspberry Pi
Domoticz version: BETA
Location: Arnhem/Nijmegen Nederland
Contact:

Re: MySensors - Gateway to Domoticz

Post by Derik » Thursday 25 February 2016 23:21

How did you make this dimmers?
Xu4: Beta Extreme antenna RFXcomE,WU Fi Ping ip P1 Gen5 PVOutput Harmony HUE SolarmanPv OTG Winddelen Alive ESP Buienradar MySensors WOL Winddelen counting RPi: Beta SMAspot RFlinkTest Domoticz ...Different backups

User avatar
bierlaagh
Posts: 45
Joined: Friday 14 March 2014 17:15
Target OS: Raspberry Pi
Domoticz version: 4.9984
Contact:

Re: MySensors - Gateway to Domoticz

Post by bierlaagh » Thursday 25 February 2016 23:39

@quindor has written a blog about it: http://blog.quindorian.org/2014/12/esp8 ... x.html?m=1

You can also find some discussion on this forum: http://www.domoticz.com/forum/viewtopic ... 23&p=29800

They work flawlessly https://vimeo.com/156760961

Image




Send using Tapatalk
1x Raspberry PI 3 With Domoticz V.3.7318
1X RFXtrx433 USB 433.92MHz
1X Synology DS213j Nas
Toon by Eneco including Toon Zon
several KAKU switches and dimmers
Mysensors WIFI Gateway including meters, switches en humidity sensors
Wifi Dimmers (home made)

tlpeter
Posts: 409
Joined: Wednesday 26 November 2014 19:43
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: MySensors - Gateway to Domoticz

Post by tlpeter » Friday 26 February 2016 19:01

Can somebody help me out a bit?
I want to start using MySensors but i am having a bit of a problem understanding what i have to do.
I have a nano which i want to use as a gateway (not sure if it will be serial or ethernet) and a nano.
There are default sketches which can be used but i do not understand the "define" part.
I think it just adds the files which are mentioned but where should these be located?

Rolo
Posts: 56
Joined: Sunday 27 December 2015 20:19
Target OS: Raspberry Pi
Domoticz version: 3.8153
Location: The Netherlands
Contact:

Re: MySensors - Gateway to Domoticz

Post by Rolo » Friday 26 February 2016 20:24

You need to add the mysensors library to your arduino environment. The includes refer to this library. It' s all documented on the mysensors.org site.
http://www.mysensors.org/about/arduino

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest