MySensors - Gateway to Domoticz

rtenklooster
Posts: 44
Joined: Tuesday 23 December 2014 17:20
Target OS: Linux
Domoticz version:
Contact:

Re: MySensors - Gateway to Domoticz

Post by rtenklooster » Wednesday 11 February 2015 22:35

gizmocuz wrote:
rtenklooster wrote:Update: another small issue:
The only unit reporting battery states, is unit 4.
The battery percentage of unit 1 is also updated with unit 4's percentage.

It would be nice to be able to set notifications when a bettery level drops below xx, and show a graph of the battery level.
If possible could you keep talking in mySensors terms ?

Unit = Node_ID ? or Unit = Child_ID ?

What (i tried) todo, when you receive a battery status on for example Node_ID=2, then all sensors of this Node with ID=2 will get the battery status
In the image below you can see an overview of those sensors.
The enly sensor reporting a battery level is slaapkamer R en M
Image
MYSB = 1 mini pro, with 2 sensors, a lux and barometer

chris021
Posts: 2
Joined: Friday 13 February 2015 5:27
Target OS: Linux
Domoticz version:
Contact:

Re: MySensors - Gateway to Domoticz

Post by chris021 » Friday 13 February 2015 5:32

Hi,

I have just started using Domoticz and am loving it. Only issue i have is with my Wx sensor. IT has Indoor Temp & Humidity, Outdoor temp and pressure. Domoticz only shows one temperature. Is there a way to edit the device?

Thanks,

Chris021

deennoo
Posts: 940
Joined: Wednesday 10 December 2014 14:06
Target OS: Linux
Domoticz version: beta
Location: Bordeaux France
Contact:

Re: MySensors - Gateway to Domoticz

Post by deennoo » Sunday 15 February 2015 22:58

Hello,

i try to get Pulsesensor for water and power, using the usb gateway

got this log on domoticz :

2015-02-15 21:55:57.848 MySensors: Node: 69, Sketch Name: Water Meter

but nothing gones on unused device (of course accpet new is active).

I made a temp/hum sensor who works very well.

Any one got an idea ?
Domoticz stable 3.5877 for real & Domoticz beta for test
Rfxtrxe / RFLink / Milight / Yeelight / ESP8266 / MQTT / BLE
http://domo-attitude.fr

BluesBro
Posts: 82
Joined: Tuesday 13 August 2013 19:55
Target OS: -
Domoticz version:
Contact:

Re: MySensors - Gateway to Domoticz

Post by BluesBro » Wednesday 18 February 2015 18:12

Does Domoticz support the IR-sensor?
It showes up in the log but not show up in the list of available devices.

BluesBro
Posts: 82
Joined: Tuesday 13 August 2013 19:55
Target OS: -
Domoticz version:
Contact:

Re: MySensors - Gateway to Domoticz

Post by BluesBro » Wednesday 18 February 2015 18:33

The distance sensor comes out like this in the log:

2015-02-18 17:32:51.112 MySensors: Node: 2, Sketch Name: Distance Sensor
2015-02-18 17:32:51.121 MySensors: Node: 2, Sketch Version: 1.0
2015-02-18 17:32:51.143 Error: MySensors: Unhandled sensor (sub-type=13), please report with log!
2015-02-18 17:32:56.380 Error: MySensors: Unhandled sensor (sub-type=13), please report with log!

Any clues?

Hendrik
Posts: 148
Joined: Saturday 04 January 2014 21:20
Target OS: Raspberry Pi
Domoticz version:
Location: Netherlands
Contact:

Re: MySensors - Gateway to Domoticz

Post by Hendrik » Wednesday 18 February 2015 21:20

can anybody help me
i have connect a usb gateway, this works
when i connect a transmitter with oneWire, and connected 2 sensor to the transmitter
i get 1 new sensor in my devices
when i look into the log, is see 2 readings almost at the same time, but they have the same name
2015-02-18 20:13:05.471 (Mysensor) Temp (sensor)
2015-02-18 20:13:05.610 (Mysensor) Temp (sensor)
2015-02-18 20:13:39.754 (Mysensor) Temp (sensor)
2015-02-18 20:13:39.922 (Mysensor) Temp (sensor)
2015-02-18 20:14:14.043 (Mysensor) Temp (sensor)
2015-02-18 20:14:14.200 (Mysensor) Temp (sensor)

what do i wrong?
i have copy the code from the Mysensor website
CubieTruck with Domoticz
RfxTrx 433Mhz Usb, Rfx Sensor, Z-Wave
Slave Raspberry Pi with Domoticz, Piface, P1 usb

gus
Posts: 17
Joined: Tuesday 04 November 2014 11:01
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MySensors - Gateway to Domoticz

Post by gus » Sunday 22 February 2015 10:28

rachmat wrote:
gizmocuz wrote:Will be fixed in next beta
another issue, Domoticz doesn't create device for relayactuator. it's only create device for relaywithbuttonactuator skecth. I think because RelayActuator only send sketch once while domoticz will add device after few reading.
Any updates regarding this?
Someone who managed to control a Mysensor relay from Domoticz? I can see the switch, but it will not activate when I trigger button. It works with sw MYSController.

Regards Rickard

hansrune
Posts: 73
Joined: Monday 07 October 2013 10:51
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MySensors - Gateway to Domoticz

Post by hansrune » Wednesday 25 February 2015 20:11

On http://hansrune.net/domo/DimmableLEDActuator.ino is a sample sketch that should be very similar to a relay actuator. I have used this sketch to test a light switch and a dimmer switch, respectively. See the comment "Choose dimmer or light switch here (0 or 1)" on how to choose between the two before compiling. A useful approach is to gw.send() something relevant to the gateway during setup to make sure the device is created in Domoticz.

hansrune
Posts: 73
Joined: Monday 07 October 2013 10:51
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MySensors - Gateway to Domoticz

Post by hansrune » Wednesday 25 February 2015 20:20

I have attempted to do some level of support for mysensors gw.request() so that switch state or dimmer level can be restored on startup. On the original version, only switches was supported, and reported set to "1" to the remote unit.

I have used the demo sketch from http://hansrune.net/domo/DimmableLEDActuator.ino to test this.

My C++ skills are rather rusty, but if you can use it, I have posted a patch against revision 2292 to support gw.request() for switches and dimmers on http://hansrune.net/domo/domoticz_mysen ... uest.patch (patch -p0 < patchfile to apply to source)

chris021
Posts: 2
Joined: Friday 13 February 2015 5:27
Target OS: Linux
Domoticz version:
Contact:

Re: MySensors - Gateway to Domoticz

Post by chris021 » Saturday 28 February 2015 5:19

Has anyone managed to find a way to get 2 x temp sensors to work with Domoticz on the same node?

hansrune
Posts: 73
Joined: Monday 07 October 2013 10:51
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MySensors - Gateway to Domoticz

Post by hansrune » Saturday 28 February 2015 11:03

No. I tried that as well.

jadijkstra2000
Posts: 135
Joined: Monday 26 May 2014 10:18
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MySensors - Gateway to Domoticz

Post by jadijkstra2000 » Tuesday 03 March 2015 20:32

Not working for me neither :(

It sees the mysensor in the log, but not in devices.. :(

Anyone any idea?

yfaykya
Posts: 26
Joined: Wednesday 07 January 2015 20:16
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MySensors - Gateway to Domoticz

Post by yfaykya » Wednesday 04 March 2015 1:31

rachmat wrote:
gizmocuz wrote:Will be fixed in next beta
another issue, Domoticz doesn't create device for relayactuator. it's only create device for relaywithbuttonactuator skecth. I think because RelayActuator only send sketch once while domoticz will add device after few reading.
You ever get this working? I can't add it either (button or non button one). They do appear in the DB though.
sqlite> select * from MySensors;
2|1|Relay & Button|1.0

User avatar
Sine
Posts: 55
Joined: Monday 02 February 2015 16:57
Target OS: Raspberry Pi
Domoticz version: Beta
Contact:

Re: MySensors - Gateway to Domoticz

Post by Sine » Wednesday 04 March 2015 20:18

Something seems to be wonky, sensors show up in the log

2015-03-04 19:15:43.262 MySensors: Node: 19, Sketch Name: Humidity
2015-03-04 19:15:43.265 MySensors: Node: 19, Sketch Version: 1.0

But no devices are added.

V2.2303

jadijkstra2000
Posts: 135
Joined: Monday 26 May 2014 10:18
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MySensors - Gateway to Domoticz

Post by jadijkstra2000 » Wednesday 04 March 2015 20:27

They are added to the database right...
But how to add them to switches then? :)

Hendrik
Posts: 148
Joined: Saturday 04 January 2014 21:20
Target OS: Raspberry Pi
Domoticz version:
Location: Netherlands
Contact:

Re: MySensors - Gateway to Domoticz

Post by Hendrik » Wednesday 04 March 2015 20:43

accept new sensors for 5 minutes??
CubieTruck with Domoticz
RfxTrx 433Mhz Usb, Rfx Sensor, Z-Wave
Slave Raspberry Pi with Domoticz, Piface, P1 usb

jadijkstra2000
Posts: 135
Joined: Monday 26 May 2014 10:18
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MySensors - Gateway to Domoticz

Post by jadijkstra2000 » Wednesday 04 March 2015 20:46

Huh? then it should work?
I have a problem with my PiFace..when I do auto-learn for new devices it only finds a PiFace device always..not the intention and other devices it won't find.
Maybe I should disable that device for PiFace and then try again....:)

jadijkstra2000
Posts: 135
Joined: Monday 26 May 2014 10:18
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MySensors - Gateway to Domoticz

Post by jadijkstra2000 » Wednesday 04 March 2015 21:45

Tried to accept new sensors for 5 minutes.. but unfortunately it does not work :(

User avatar
Sine
Posts: 55
Joined: Monday 02 February 2015 16:57
Target OS: Raspberry Pi
Domoticz version: Beta
Contact:

Re: MySensors - Gateway to Domoticz

Post by Sine » Thursday 05 March 2015 23:50

Hendrik wrote:accept new sensors for 5 minutes??
Nope, that is of course necessary, but it doesn't add the device.

jadijkstra2000
Posts: 135
Joined: Monday 26 May 2014 10:18
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: MySensors - Gateway to Domoticz

Post by jadijkstra2000 » Saturday 07 March 2015 1:21

I have it working After a tip of someone. ..

Add a physical switch to the actuator and make sure the actuator can be switched with that physical switch through the arduino. Then it is visible in domoticz!

My next goal is to have a arduino mysensors device with a display so that I can send status updates from domoticz through the arduino gateway to a remote actuator / display

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests