NodeMCU ESP8266 + MySensors WiFi Gateway + Domoticz: can't import the sensor Topic is solved

Subforum for the 'MySensors' project.
http://www.mysensors.org/
Post Reply
NeoMod
Posts: 2
Joined: Friday 07 July 2017 22:02
Target OS: Raspberry Pi
Domoticz version:
Contact:

NodeMCU ESP8266 + MySensors WiFi Gateway + Domoticz: can't import the sensor

Post by NeoMod » Friday 07 July 2017 22:19

Hi everyone,

I have a NODEMCU ESP8266 dev. board which runs MySensors WiFi Gateway and reads the data provided by the only one sensor connected to it, a soil moisture capacitive sensor by DFROBOT.

Everything works fine on the WiFi side of the things: the gateway connects to my network and pulls the value from the sensor.

I want to send this value to Domoticz, and so I added the Gateway under the Hardware settings as a “MySensors Lan Gateway”.

Image

As you can see from the image, Domoticz recognizes perfectly the Gateway and under Gateway Setup I can seed the Node and Children details.

Image

I know, I’m presenting the value as V_HUM but that’s because the best thing I could come up with (I’m a newbie at all this!).

The problem is that I can’t really add this sensor to Domoticz! Although it shows the sensor, together with the Value, I can’t find it in in the Devices.

Image

I’m sure I’m doing something wrong…but really can’t figure out what. :?

NeoMod
Posts: 2
Joined: Friday 07 July 2017 22:02
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: NodeMCU ESP8266 + MySensors WiFi Gateway + Domoticz: can't import the sensor

Post by NeoMod » Saturday 08 July 2017 1:58

Update:

I was able to figure it out by also improving the sketch.

Now everything works fine.

bertbigb
Posts: 137
Joined: Thursday 13 August 2015 13:36
Target OS: NAS (Synology & others)
Domoticz version: beta
Location: Netherlands
Contact:

NodeMCU ESP8266 + MySensors WiFi Gateway + Domoticz: can't import the sensor

Post by bertbigb » Saturday 08 July 2017 9:35

NeoMod wrote:Update:

I was able to figure it out by also improving the sketch.

Now everything works fine.
Can you tell what you changed
Can be helpful for others

Probably the sketch you used?

Verzonden vanaf mijn iPhone met Tapatalk
Best regards Bert

Synology DS1515+ - DSM 6.1
Raspberry PI2 - B, Raspberry Nano - Raspberry PI3 - model B
Xiaomi Gateway - Philips HUE Lights - Zwave - RFXCom(E) with KaKu and other 433MHz devices - Yeelight Lights - Toon

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest