NodeMCU with OneWire

Post Reply
User avatar
emme
Posts: 798
Joined: Monday 27 June 2016 11:02
Target OS: Raspberry Pi
Domoticz version: latest
Location: Milano, Italy
Contact:

NodeMCU with OneWire

Post by emme » Monday 08 May 2017 8:26

Ciao,

I'm optimizing my MySensors network (actually a controller, a rain device and 4 temps devices) and I'm willing to install a new gateway (reving the old one running on a PI2), replace the rain device (a simple ON/OFF switch) and since the new gateway will be installed on my balcony, add a DS18B20 to gather external temp

I chiose to use NodeMCU (not a real reason why... just... got it :P) and since I was able to install the gateway and the switch... I getting severe problems with the onewire bus....

Uploading the sketch with Arduino IDE, the code is made by catching different condes from the MySensors site for gateway (esp8266), door window and Thermo (with the modified OneWire library)

The sketch is compiled and upload correctly... the WiFI gateway works, the switch works... onewire does not see any device (just one is installed)
Wiring is not the issue: the 4k7 resistor is in place, I'm using D1 pin and 3,3v power is supplied by an external 5v 2A power supply with a voltage regualtor, but it did not work even if I get the 3.3v from the node board

I made some other tries... like reupload everyting with just the onewire library (either the modifies and the other one) but still unable to use the DS18B20...

Is anyone aware about a problem with nodeMCU and onewire?! I tried to search over the internet... the only link I found was a guy who used a different resitor (maybe 1k5) but lost the link and unable to find it again :(

Thanks
ciao
M
That's one small step for a programmer, one giant leap for me!
- - - - -
Raspberry Pi3 + AeonStick G5 + RFXCOMM433 + iRTrans Server + NodeJS
There's no stress in the mess!!

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests