Unable to setup Kodi for Domoticz

Post Reply
Posts: 28
Joined: Saturday 27 February 2016 21:39
Target OS: NAS (Synology & others)
Domoticz version:

Unable to setup Kodi for Domoticz

Post by Pierryck » Sunday 05 June 2016 10:39

I have follow the domoticz wiki to install Kodi.

My Kodi is installed on a Android TV Box (Miami Box for French users).

And in the Domoticz log I have:
2016-06-05 10:32:49.008 Kodi: (Salon) Sending data: '{"jsonrpc":"2.0","method":"JSONRPC.Ping","id":1001}'
2016-06-05 10:32:59.009 Kodi: (Salon) Missed 1 pings, assumed off.
2016-06-05 10:32:59.010 Kodi: (Salon) Event: 'Off'.
2016-06-05 10:32:59.010 Kodi: (Salon) Disonnected.
2016-06-05 10:33:00.010 Kodi: (Salon) Connected to ''.
2016-06-05 10:33:00.011 Kodi: (Salon) Event: 'On'.
2016-06-05 10:33:00.012 Kodi: (Salon) Sending data: '{"jsonrpc":"2.0","method":"System.GetProperties","params":{"properties":["canhibernate","cansuspend","canshutdown"]},"id":1007}'
2016-06-05 10:33:01.012 Kodi: (Salon) Sending data: '{"jsonrpc":"2.0","method":"JSONRPC.Ping","id":1001}'
2016-06-05 10:33:05.122 Kodi: Restarting I/O service thread.

I have tried to change several times port: 9090 then 8080 then 9091 but it changes nothing at all.
When I type on a web browser a page kodi appears but it's very slow (may be it's a timeout issue ?!?)

When I tried to send a notification to Kodi to port 9777, it works.

Do you have a clue ?

Posts: 1
Joined: Tuesday 16 August 2016 16:35
Target OS: -
Domoticz version:

Re: Unable to setup Kodi for Domoticz

Post by jirm » Friday 19 August 2016 23:11

Pierryck You have solved the issue?
I have similar (same messages on Domoticz log), and seems I do similar workarround like you too without result (following wiki for kodi plugin, triying changing web kodi port 80 and 9090, etc...) and still without luck to make kodi plugin working on Domoticz.

I only have connection status (on/off) and can send messages pop-up on kodi, but seems not working any other thing (not any command on remote send to kodi work, not showing reported media playing on kodi switch, and in log I have these messages:

2016-08-19 21:08:54.422 Kodi: (Kodi-Comedor) Missed 10 pings, assumed off.
2016-08-19 21:08:54.485 Kodi: (Kodi-Comedor) Event: 'Off'.
2016-08-19 21:08:54.492 Kodi: (Kodi-Comedor) Disonnected.
2016-08-19 21:08:55.448 Kodi: (Kodi-Comedor) Connected to ''.
2016-08-19 21:08:55.457 Kodi: (Kodi-Comedor) Event: 'On'.
2016-08-19 21:08:55.462 Kodi: (Kodi-Comedor) Sending data: '{"jsonrpc":"2.0","method":"System.GetProperties","params":{"properties":["canhibernate","cansuspend","canshutdown"]},"id":1007}'
2016-08-19 21:08:56.472 Kodi: (Kodi-Comedor) Sending data: '{"jsonrpc":"2.0","method":"JSONRPC.Ping","id":1001}'
2016-08-19 21:09:11.892 Kodi: Restarting I/O service thread.
2016-08-19 21:09:26.754 Kodi: (Kodi-Comedor) Sending data: '{"jsonrpc":"2.0","method":"JSONRPC.Ping","id":1001}'
2016-08-19 21:09:57.052 Kodi: (Kodi-Comedor) Sending data: '{"jsonrpc":"2.0","method":"JSONRPC.Ping","id":1001}'
2016-08-19 21:10:27.343 Kodi: (Kodi-Comedor) Sending data: '{"jsonrpc":"2.0","method":"JSONRPC.Ping","id":1001}'
2016-08-19 21:10:45.764 Kodi: (Kodi-Comedor) Sending data: '{"jsonrpc":"2.0","method":"Input.ExecuteAction","params":{"action":"playpause"},"id":1006}'
2016-08-19 21:10:45.766 Kodi: (Kodi-Comedor) Sent command: 'Input.ExecuteAction playpause'.
2016-08-19 21:10:46.833 Kodi: (Kodi-Comedor) Sending data: '{"jsonrpc":"2.0","method":"Input.ExecuteAction","params":{"action":"stop"},"id":1006}'
2016-08-19 21:10:46.834 Kodi: (Kodi-Comedor) Sent command: 'Input.ExecuteAction stop'.
2016-08-19 21:10:57.643 Kodi: (Kodi-Comedor) Sending data: '{"jsonrpc":"2.0","method":"JSONRPC.Ping","id":1001}'

If change name on kodi device settings, I have some error messages:

2016-08-19 21:12:25.369 Kodi: (Kodi-Comedor) Starting thread.
2016-08-19 21:12:25.370 Kodi: (Kodi-Comedor) Entering work loop.
2016-08-19 21:12:25.387 Kodi: (Kodi-Comedor) Connected to ''.
2016-08-19 21:12:25.388 Kodi: (Kodi-Comedor) Sending data: '{"jsonrpc":"2.0","method":"System.GetProperties","params":{"properties":["canhibernate","cansuspend","canshutdown"]},"id":1007}'
2016-08-19 21:12:25.473 Kodi: Starting I/O service thread.
2016-08-19 21:12:25.476 Error: Kodi: (Kodi-Comedor) Async Read Exception: 125, Operation canceled
2016-08-19 21:12:25.484 Kodi: (Kodi-Comedor) Event: 'Off'.
2016-08-19 21:12:26.395 Kodi: (Kodi-Comedor) Sending data: '{"jsonrpc":"2.0","method":"JSONRPC.Ping","id":1001}'
2016-08-19 21:12:56.676 Kodi: (Kodi-Comedor) Sending data: '{"jsonrpc":"2.0","method":"JSONRPC.Ping","id":1001}'
2016-08-19 21:13:26.974 Kodi: (Kodi-Comedor) Sending data: '{"jsonrpc":"2.0","method":"JSONRPC.Ping","id":1001}'
2016-08-19 21:13:57.275 Kodi: (Kodi-Comedor) Sending data: '{"jsonrpc":"2.0","method":"JSONRPC.Ping","id":1001}'

My Domoticsz installation is Raspberry pi 2 (over qemu emulator), downloading the last Domoticz rpi image avaible, and then updated Domoticz to last the beta version:
Version: 3.5510
Build Hash: ee70f67
Compile Date: 2016-08-17 06:36:23

Please will be super any help.


User avatar
Posts: 766
Joined: Sunday 23 March 2014 10:00
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Melbourne, Australia

Re: Unable to setup Kodi for Domoticz

Post by Dnpwwo » Saturday 20 August 2016 1:08

@jirm, if the Kodi is ignoring you or actively closing connections on you ('Async Read Exception: 125, Operation canceled') my guess would be that you haven't configured it to allow remote control:
Your Kodi media Player must be configured to allow control by remote programs to work with Domoticz. To see where to do this using the default Confluence skin see: Allow Remote Control.
The reasonable man adapts himself to the world; the unreasonable one persists to adapt the world to himself. Therefore all progress depends on the unreasonable man. George Bernard Shaw

User avatar
Posts: 239
Joined: Tuesday 12 January 2016 12:40
Target OS: Raspberry Pi
Domoticz version: latest β
Location: The Netherlands (Alkmaar)

Re: Unable to setup Kodi for Domoticz

Post by gielie » Tuesday 07 February 2017 23:44

I have the same problem, I've used kodi in domotica for a long time without any problems but now suddenly is doesn't work anymore.
- Vision ZU1401 USB Stick
- Aeotec MultiSensor 6
- Everspring AN157
- Neo CoolCam Power plug
- Neo CoolCam PIR Sensor
- Popp Smoke Detector
- Toon
- Kodi Media Server

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest