Reacticz dashboard: no install, no hassle

In this subforum you can show projects you have made, or you are busy with. Please create your own topic.
ptitneo
Posts: 68
Joined: Tuesday 06 December 2016 23:42
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Reacticz dashboard: no install, no hassle

Post by ptitneo » Wednesday 15 February 2017 14:42

Well, I liked it too, but it was bad design ;)

Theming in Reacticz is limited to color swatches at the moment (selector in the Info screen), and I'm not focusing on that area because there are many other things to fix and implement, and I don't have that much time... If you want more powerful theming options, feel free to fiddle with the source code and contribute to it, some CSS override could probably do the trick. Thanks for your understanding!

ptitneo
Posts: 68
Joined: Tuesday 06 December 2016 23:42
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Reacticz dashboard: no install, no hassle

Post by ptitneo » Friday 24 February 2017 14:34

Hi everyone, a new pre-build package (v0.1.11) has been released: https://github.com/t0mg/reacticz/releases

It introduces a new multi-dashboard support (switch between your layouts with prev/next buttons), new dark themes, and new dimmer and rgbw widgets.

Cheers,

User avatar
EdwinK
Posts: 795
Joined: Sunday 22 January 2017 22:46
Target OS: NAS (Synology & others)
Domoticz version: 3.8552
Location: Rhoon
Contact:

Re: Reacticz dashboard: no install, no hassle

Post by EdwinK » Saturday 04 March 2017 14:54

Have been trying this but
Then publish a temperature measurement to the virtual sensor idx noted above (example idx 1) like:

mosquitto_pub -h localhost -m '{ "idx" : 1, "nvalue" : 0, "svalue" : "25.0" }' -t 'domoticz/in'
If the mosquitto_pub command is not found install the mosquitto client:

sudo apt-get install mosquitto-clients
is giving me problem with apt-get command not found. Using a terminal/telnet client from Macbook. Domoticz and Mosquitto are both installed on my Synology.
Running latest STABLE on a NAS Synology 413j | Toon Thermostat | RFxcom | Dashticz V2 |

domotest7766
Posts: 37
Joined: Monday 14 April 2014 18:28
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Reacticz dashboard: no install, no hassle

Post by domotest7766 » Tuesday 14 March 2017 21:35

Hi,

Very nice project. Could it be possible to add cameras and the protected mode (for switches) ?

That would be awesome :-)

ptitneo
Posts: 68
Joined: Tuesday 06 December 2016 23:42
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Reacticz dashboard: no install, no hassle

Post by ptitneo » Tuesday 21 March 2017 1:56

EdKo66 wrote: is giving me problem with apt-get command not found. Using a terminal/telnet client from Macbook. Domoticz and Mosquitto are both installed on my Synology.
I don't think you can use apt to install stuff on a synology. Maybe ask for help on the mqtt thread of the forum?
domotest7766 wrote:Could it be possible to add cameras and the protected mode (for switches) ?
I have no idea how cameras work but it's probably not though MQTT... I'm not sure it would fit well in Reacticz as I'd like to keep it as light and simple as possible, and cameras seem a bit tricky to configure. But I can't really tell as don't actually have any camera myself, so if anyone feels like contributing, pull requests are most welcome ;)

I also don't know what the protected mode is :) Could you give me some pointers?

ptitneo
Posts: 68
Joined: Tuesday 06 December 2016 23:42
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Reacticz dashboard: no install, no hassle

Post by ptitneo » Friday 24 March 2017 2:11

Hi everyone, just a quick update to let you know that the project has moved to https://github.com/domoticz/Reacticz :)
From now on, please use this repo to get the code, download builds, or file issues. Thanks!

PS: the public server is still reacticz.t0m.fr and was updated to 0.1.14 introducing a font size selector!

domotest7766
Posts: 37
Joined: Monday 14 April 2014 18:28
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Reacticz dashboard: no install, no hassle

Post by domotest7766 » Friday 24 March 2017 18:16

I have no idea how cameras work but it's probably not though MQTT... I'm not sure it would fit well in Reacticz as I'd like to keep it as light and simple as possible, and cameras seem a bit tricky to configure. But I can't really tell as don't actually have any camera myself, so if anyone feels like contributing, pull requests are most welcome ;)

I also don't know what the protected mode is :) Could you give me some pointers?

Hello,

The camera can be listed with json.htm?type=cameras and each camera has an URL like /camsnapshot.jpg?idx=1. So it is like a picture to display. I tried to implement but I am not a JavaScript addict :-)

Also, for any switch, domoticz allows to define a protected mode in order to submit a passcode when we want to switch on/off a device. This passcode is sent in the GET parameter (&passcode=xxxx). So that could be cool to have a popup to set this passcode :-)

Regards,

Snowtiger
Posts: 83
Joined: Tuesday 18 October 2016 13:15
Target OS: Raspberry Pi
Domoticz version: 3.8363
Contact:

Re: Reacticz dashboard: no install, no hassle

Post by Snowtiger » Friday 24 March 2017 21:56

ptitneo wrote:Hi everyone, just a quick update to let you know that the project has moved to https://github.com/domoticz/Reacticz :)
From now on, please use this repo to get the code, download builds, or file issues. Thanks!

PS: the public server is still reacticz.t0m.fr and was updated to 0.1.14 introducing a font size selector!
Will you also move the gh-pages branch to this new github? I am using it for running Reacticz in my Nginx server ;)

ptitneo
Posts: 68
Joined: Tuesday 06 December 2016 23:42
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Reacticz dashboard: no install, no hassle

Post by ptitneo » Saturday 25 March 2017 0:28

No, because the public server still uses my domain name, so it still points at the gh-pages branch on my repository. I'll keep it in sync.

Note that the Reacticz project on domoticz' GitHub now builds for a local install in domoticz www folder by default (I've updated the readme)

@domotest7766 contributor davidlb created a ticket for your password protected switch feature request: https://github.com/domoticz/Reacticz/issues/10
Looks like it's doable, but not in a fancy way (JSON API call seems inevitable). Personally I don't really understand the point since it's pretty weak from a security point of view, unless you are using https :)

Snowtiger
Posts: 83
Joined: Tuesday 18 October 2016 13:15
Target OS: Raspberry Pi
Domoticz version: 3.8363
Contact:

Re: Reacticz dashboard: no install, no hassle

Post by Snowtiger » Saturday 25 March 2017 1:03

ptitneo wrote:No, because the public server still uses my domain name, so it still points at the gh-pages branch on my repository. I'll keep it in sync.

Note that the Reacticz project on domoticz' GitHub now builds for a local install in domoticz www folder by default (I've updated the readme)
Thx for the update and keeping it active - like it separate from the Domoticz stuff ;)

brian
Posts: 6
Joined: Saturday 04 April 2015 18:04
Target OS: Linux
Domoticz version: beta
Location: Italy
Contact:

Re: Reacticz dashboard: no install, no hassle

Post by brian » Tuesday 11 April 2017 16:33

ptitneo,
thanks for the super-awesome reacticz!

a little issue though: it can't seem connect to MQTT broker websockets when reacticz is invoked via https, on my webserver but also on yours - "MQTT unavailable". it's all good when plain http is used.

cheers!
B

ptitneo
Posts: 68
Joined: Tuesday 06 December 2016 23:42
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Reacticz dashboard: no install, no hassle

Post by ptitneo » Tuesday 11 April 2017 17:08

Hi brian, thanks for your feedback. If you want to use https you need to host both reacticz and MQTT broker on an SSL enabled server with valid certificates, because if the Reacticz dashboard is served through https, the web browser will only accept secure websockets (wss://...). This is why the public Reacticz server doesn't use https: most MQTT brokers in local Domoticz setups won't support it.

In other words, if you have an MQTT broker with proper SSL setup (and certificates), you should also host Reacticz on an https-enabled server. Then once the whole chain uses https, it should work as expected (and it would be more secure too, I just didn't do that because it's a lot more effort to setup everything).

brian
Posts: 6
Joined: Saturday 04 April 2015 18:04
Target OS: Linux
Domoticz version: beta
Location: Italy
Contact:

Re: Reacticz dashboard: no install, no hassle

Post by brian » Tuesday 11 April 2017 19:04

wsS! I was missing an S...
just to let you know it works flawlessly now, domoticz wiki for letsencrypt and

certfile /etc/letsencrypt/live/yourdomain.com/cert.pem
cafile /etc/letsencrypt/live/yourdomain.com/chain.pem
keyfile /etc/letsencrypt/live/yourdomain.com/privkey.pem

in mosquitto.conf

thanks again!

ptitneo
Posts: 68
Joined: Tuesday 06 December 2016 23:42
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Reacticz dashboard: no install, no hassle

Post by ptitneo » Tuesday 11 April 2017 19:11

Hey brian, glad you worked it out, that's really nice to know! Maybe you could drop a note on how to do this in the wiki (https://github.com/domoticz/Reacticz/wiki) ?

Thanks!

MYLE
Posts: 23
Joined: Monday 10 April 2017 8:29
Target OS: Linux
Domoticz version:
Contact:

Re: Reacticz dashboard: no install, no hassle

Post by MYLE » Thursday 13 April 2017 2:07

This is cool have my weekend project sorted lol

sylar
Posts: 6
Joined: Saturday 15 April 2017 14:06
Target OS: NAS (Synology & others)
Domoticz version: 3.7067
Contact:

Re: Reacticz dashboard: no install, no hassle

Post by sylar » Saturday 15 April 2017 14:26

Hi there,

I have some issues with reacticz regarding my installation. I'm using a Synology NAS (IP address 192.168.1.2), with the following setup:
- Domoticz is running on a docker container, exposing port 8080 (http). I can access domoticz from outside my home network thanks to the DSM integrated inverse proxy, forwarding home.mydomain.com on port 443 (https) to port 8080. This is working very well.
- I have then installed Mosquitto on another container, exposing ports 1883 and 9883 (configured with websockets). Domoticz is correctly interfaced with Mosquitto, and both are working well together (this is confirmed in Mosquitto log files).
- I have installed the pre-build release v0.1.11 of reacticz inside the www/ folder of domoticz.

Here is now my problem:
- accessing reacticz from my home network, from the address http://192.168.1.2:8080/reacticz/, and configuring both MQTT and domoticz connections by specifying their local address (ws://192.168.1.2:9883 and http://192.168.1.2:8080 respectively) works well, and I'm able to make reacticz working well.
- but, if I try to access reacticz from outside my home network, from https://home.mydomain.com/reacticz/, I'm not able to make it access my MQTT broker (which is not accessible from the outside, since this is not required for now). For domoticz, using http://192.168.1.2:8080 does not work anymore, I have to specify the "public" address (https://home.mydomain.com) for the pairing to be OK. For Mosquitto, using ws://192.168.1.2:9883 does not work anymore, and I have no idea on what I can use here now.

Do you have any hints on what's happening? Reacticz seems confused by the way i'm connecting to it: from my local home network, or from the outside.

ptitneo
Posts: 68
Joined: Tuesday 06 December 2016 23:42
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Reacticz dashboard: no install, no hassle

Post by ptitneo » Saturday 15 April 2017 17:41

Hi sylar,

Interesting setup. Reacticz needs to talk to your MQTT broker in order to work, so if you are outside your home network and the MQTT broker is not available from there, then Reacticz won't be able to listen to it and send messages. You'll need to also make you MQTT broker accessible from outside and update the url just like you did for the domoticz url. Not sure excactly how as I'm not familiar with that kind of setup. However if you manage do this, you should reall enable authentication on MQTT as well.

Cheers,

sylar
Posts: 6
Joined: Saturday 15 April 2017 14:06
Target OS: NAS (Synology & others)
Domoticz version: 3.7067
Contact:

Re: Reacticz dashboard: no install, no hassle

Post by sylar » Saturday 15 April 2017 21:18

Hi Ptitneo,

I understand that Reactiz needs access to my MQTT broker, but both are installed locally and can communicate on my local network.
For instance, imagine I'm using a webserver from the outside, which requires a MySQL server to operate. I do not have to make the MySQL server visible from the outside, as long as the webserver and the MySQL are able to communicate with each other, on their local common network.
EDIT: Domoticz itself works this way: I can access it from the outside, while it is still able to communicate with Mosquitto.
So why would this not be possible with Reacticz? Is there any technical limitations which can explain that? I could of course make my Mosquitto server "opened" to the world (but with ssl and authentication, of course ;) ! BTW: is SSL connection supported?), but I would like to avoid this.

Thanks for your help!

ptitneo
Posts: 68
Joined: Tuesday 06 December 2016 23:42
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Reacticz dashboard: no install, no hassle

Post by ptitneo » Sunday 16 April 2017 0:55

It's different here because Reacticz is just a static web page: it is your web browser that talks directly to the MQTT broker, not the server that serves the Reacticz files. That's why you need to enable websockets in the MQTT configuration and why your web browser needs to be able to access your MQTT broker. So if your web browser is outside your home network, then you need to make your MQTT broker reachable from there too.

SSL is supported (see here), but I don't know if you can make it work through the Synology reverse proxy. If you do please let us know!

sylar
Posts: 6
Joined: Saturday 15 April 2017 14:06
Target OS: NAS (Synology & others)
Domoticz version: 3.7067
Contact:

Re: Reacticz dashboard: no install, no hassle

Post by sylar » Sunday 16 April 2017 9:23

ptitneo wrote:It's different here because Reacticz is just a static web page: it is your web browser that talks directly to the MQTT broker, not the server that serves the Reacticz files. That's why you need to enable websockets in the MQTT configuration and why your web browser needs to be able to access your MQTT broker. So if your web browser is outside your home network, then you need to make your MQTT broker reachable from there too.
OK, I get it. Everything is working on the web browser side, not on the server side. This is what I didn't catch in the first place. This is clear now, thank you.
ptitneo wrote: SSL is supported (see here), but I don't know if you can make it work through the Synology reverse proxy. If you do please let us know!
I don't thing I will make it pass through the inverse proxy. Plus, I don't know yet if websockets are supported by DSM nginx inverse proxy configuration. I will try ;)

Anyway, thank you for the precisions!

Another thing I just noticed with my rain gauge from Netatmo:
- in Domoticz, I can reed 0mm, with a rate of 0.0mm/h,
- while in Reacticz, I reed 0.4mm, with a rate of 0.0mm/h.
The value 0.4mm seems to be related to the total week mm, and not to the current day as indicated in Domoticz. Is this on purpose?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest