Siri acts with wrong state when state is changed by Domoticz

Post Reply
aukedejong
Posts: 2
Joined: Monday 27 November 2017 22:32
Target OS: Raspberry Pi
Domoticz version:
Contact:

Siri acts with wrong state when state is changed by Domoticz

Post by aukedejong » Wednesday 27 December 2017 16:02

Domoticz: v3.8153
Homebridge: 0.4.33
homebridge-edomoticz: 2.0.11
Z-wave Fibaro modules
Zwave.me USB stick
RaspberryPi

The problem is that Siri doesn't know the state changes not done by Siri itself.
I like to run around in my house and tell Siri to switch lights on and off. But when I leave home or go to bed, I turn everything off by a triple click on a Fibaro dimmer.
When I come home I have to tell Siri first to turn off the lights, then on again, before the lights turn on.

Is there a way to fix this?

Thanks.

rjblake
Posts: 153
Joined: Friday 21 October 2016 9:25
Target OS: NAS (Synology & others)
Domoticz version:
Location: Netherlands
Contact:

Re: Siri acts with wrong state when state is changed by Domoticz

Post by rjblake » Friday 05 January 2018 17:38

Did you install Mosquitto and change the MQTT Parameter to "1" in your config.json and configure MQTT interface in Domoticz? If this is running correctly, states of devices are synchronised across Domoticz and Homekit.

aukedejong
Posts: 2
Joined: Monday 27 November 2017 22:32
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Siri acts with wrong state when state is changed by Domoticz

Post by aukedejong » Friday 05 January 2018 21:01

MQTT fixed it.
Thanks rjblake!!

Now, when I switch a light, or change the dim level, I see the result almost instantly on my iPhone.

For others having the same 'problem'.
Only three steps are needed:
- Install Mosquitto, there are plenty tutorials.
- Add the MQTT hardware in domoticz, see Domoticz wiki
- Set mqtt parameter to 1 in homebridge's config.json

I did restart Homebridge, but I'm not sure it's really needed.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest