Foscam FI9903P issue.

Post Reply
Freddy315pk
Posts: 2
Joined: Thursday 10 March 2016 20:12
Target OS: Raspberry Pi
Domoticz version: V3.5010
Location: Sint Jansteen, Netherlands
Contact:

Foscam FI9903P issue.

Post by Freddy315pk » Thursday 10 March 2016 20:35

I have a strange problem with a Foscam FI9903P ip camera and I am hoping someone here can help.

I can configure it and I get a picture with "Test Connection" button:
Foscam edit camera.jpg
Foscam edit camera.jpg (91.75 KiB) Viewed 1915 times
But, there is no preview:
Foscam overzicht camera.jpg
Foscam overzicht camera.jpg (153.64 KiB) Viewed 1915 times
If I click on the webcam icon, there is also no image:
Foscam voordeur camera.jpg
Foscam voordeur camera.jpg (34.64 KiB) Viewed 1915 times
My other camera, a Foscam FI9818W V2, connected on the same lan-switch, does work.
Does anyone here have any idea what can possible be wrong?
The "voordeur" camera is linked to my kaku doorbell and is supposed to send a picture when pressed.
But because, I think, since there is no image, no picture is sent.
If I login to the camera through a web browser, everything is also fine.
Raspberry Pi 3b - RFXCOM-E RFY - Foscam FI9818W V2 - Foscam FI9903P - ThermoSmart - P1 USB Smartmeter - Bunch of CoCo - Onkyo TX-NR525 - Kodi NUC

oliviers
Posts: 78
Joined: Wednesday 16 September 2015 22:10
Target OS: Raspberry Pi
Domoticz version: Stable
Location: Paris area, France
Contact:

Re: Foscam FI9903P issue.

Post by oliviers » Wednesday 23 March 2016 22:56

Hello,
Just to say that I have exactly the same problem with a FOSCAM FI8910W.
This is not the solution to your issue, but at least, you're not alone....
Oliviers
Paris area
Raspberry Pi 2B - RFXComm 433 - IrTrans - Zwave

RutgerBo
Posts: 2
Joined: Monday 21 March 2016 0:27
Target OS: Raspberry Pi
Domoticz version: V2.3530
Contact:

Re: Foscam FI9903P issue.

Post by RutgerBo » Thursday 24 March 2016 23:34

I've a FI9903EP, and the stream is working fine, only the preview is taken from the other cam I have added first (Dericam m601w, a Foscam dome clone (640x480). But the image button is working.
Besided the username and password in the url, it's only working for me when I add both username and password in the desired fields too.

Freddy315pk
Posts: 2
Joined: Thursday 10 March 2016 20:12
Target OS: Raspberry Pi
Domoticz version: V3.5010
Location: Sint Jansteen, Netherlands
Contact:

Re: Foscam FI9903P issue.

Post by Freddy315pk » Friday 25 March 2016 10:07

After some "tinkering" I got my camera working again.
When I updated to the latest beta version, my camera is working again. Tried to go back to the latest stable version, problem came back.
So I assume there is a bug in the latest stable version, latest beta version is working fine (3.5010).
Raspberry Pi 3b - RFXCOM-E RFY - Foscam FI9818W V2 - Foscam FI9903P - ThermoSmart - P1 USB Smartmeter - Bunch of CoCo - Onkyo TX-NR525 - Kodi NUC

marmachine
Posts: 76
Joined: Saturday 26 March 2016 11:19
Target OS: Raspberry Pi
Domoticz version: 3.4834
Location: Netherlands
Contact:

Re: Foscam FI9903P issue.

Post by marmachine » Sunday 27 March 2016 16:29

Hi Freddy,

Did you also setup motion for your cam? (using your camera as motion sensor?)
I'm kinda stuck with that, however i have my camera FOSCAM FI9900P added to Domoticz.

nigels0
Posts: 229
Joined: Thursday 23 January 2014 13:43
Target OS: Raspberry Pi
Domoticz version: 3.8153
Contact:

Re: Foscam FI9903P issue.

Post by nigels0 » Wednesday 12 July 2017 0:38

Late response - sorry, but the problem is the firmware. The call is returning the HTML response, not the image. Foscam knew about this and fixed it in the firmware - relatively recently.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest