PRi + MotionEye + Domoticz Setup - Help Please

Post Reply
husar
Posts: 11
Joined: Wednesday 18 January 2017 17:34
Target OS: Raspberry Pi
Domoticz version:
Contact:

PRi + MotionEye + Domoticz Setup - Help Please

Post by husar » Wednesday 18 January 2017 20:22

I am not sure if it possible to get my current setup working in Domoticz but I am half way there and looking for some assistance. I have looked to the camera wiki page and it has allowed some success.

My current setup has several USB camera attached to their own RPI and an RPi running MotionEye as the main controller. This works great.
myscreen.png
myscreen.png (303.25 KiB) Viewed 3401 times
Now I'd like to see about getting the cameras added to Domoticz. I can access each camera's direct feed in the browser by doing the following.

Live feed: http://10.0.xxx.xx:xxxx
List image: http://10.0.xxx.xx:xxxxx/picture/1/current/

Testing the live feed link in the More Options >> Cameras does show the feed when I test it during setup.
myscreen2.png
myscreen2.png (207.79 KiB) Viewed 3401 times
Back on the Camera page the image to the far left is broken. If I right click and look at the locaion it is the Domoitcz server with /camsnapshot.jpg?idx=1 after it. Clciking on the web cam icon brings up the live feed overlay window but the stream loads as a broken image.

Is this the correct way to get my setup working in Domoticz or is it just not possible with my setup?

Thank you.

fabix68
Posts: 14
Joined: Tuesday 22 December 2015 7:20
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: PRi + MotionEye + Domoticz Setup - Help Please

Post by fabix68 » Monday 13 February 2017 0:00

I have the same problem.
You've solved?

pepijn
Posts: 512
Joined: Friday 12 July 2013 13:19
Target OS: Raspberry Pi
Domoticz version:
Location: The Netherlands
Contact:

Re: PRi + MotionEye + Domoticz Setup - Help Please

Post by pepijn » Monday 13 February 2017 1:08

Set mjpg_client_idle_timeout to 0 in your motioneye.conf file and you'll no longer get empty JPEGs (except for the very first request after you restart the server).

DaWauZ
Posts: 70
Joined: Wednesday 05 November 2014 11:14
Target OS: Raspberry Pi
Domoticz version:
Location: Netherlands
Contact:

Re: PRi + MotionEye + Domoticz Setup - Help Please

Post by DaWauZ » Thursday 29 June 2017 21:53

pepijn wrote:Set mjpg_client_idle_timeout to 0 in your motioneye.conf file and you'll no longer get empty JPEGs (except for the very first request after you restart the server).
I tried this, but still no stream or snapshot taken.
Test image is good though.
Raspberry Pi 2 model B with domoticz
OMV NAS installed on thin client HP T610
Openelec Kodi Mediaplayer on thin client HP T520 (and with multiboot windows 10)

armine
Posts: 1
Joined: Sunday 20 August 2017 22:39
Target OS: Raspberry Pi
Domoticz version:
Contact:

PRi + MotionEye + Domoticz Setup - Help Please

Post by armine » Sunday 20 August 2017 22:47

Plase help me.I've got Domoticz on one Pi and my 2 Raspberry Pi Cam on another. Eyemotion and PiKellCam.How do I add this cam to Domoticz?I have another raspberry running the web interface, and the connection made i Domoticz with the following settings. No Dmotocz not detect camera stream.

TDK20
Posts: 8
Joined: Wednesday 16 August 2017 11:04
Target OS: Raspberry Pi
Domoticz version: 3.8367
Location: Frankfurt, FRG
Contact:

Re: PRi + MotionEye + Domoticz Setup - Help Please

Post by TDK20 » Tuesday 22 August 2017 0:08

Anybody who has solved this? Please share.

TDK20
Posts: 8
Joined: Wednesday 16 August 2017 11:04
Target OS: Raspberry Pi
Domoticz version: 3.8367
Location: Frankfurt, FRG
Contact:

Re: PRi + MotionEye + Domoticz Setup - Help Please

Post by TDK20 » Saturday 26 August 2017 22:51

Simple solution, had to omit the leading slash.

Mozart
Posts: 82
Joined: Monday 19 January 2015 15:35
Target OS: Raspberry Pi
Domoticz version: Beta
Location: The Netherlands
Contact:

Re: PRi + MotionEye + Domoticz Setup - Help Please

Post by Mozart » Sunday 27 August 2017 5:18

husar wrote:
Wednesday 18 January 2017 20:22
I am not sure if it possible to get my current setup working in Domoticz but I am half way there and looking for some assistance. I have looked to the camera wiki page and it has allowed some success.

My current setup has several USB camera attached to their own RPI and an RPi running MotionEye as the main controller. This works great.

myscreen.png

Now I'd like to see about getting the cameras added to Domoticz. I can access each camera's direct feed in the browser by doing the following.

Live feed: http://10.0.xxx.xx:xxxx
List image: http://10.0.xxx.xx:xxxxx/picture/1/current/

Testing the live feed link in the More Options >> Cameras does show the feed when I test it during setup.

myscreen2.png

Back on the Camera page the image to the far left is broken. If I right click and look at the locaion it is the Domoitcz server with /camsnapshot.jpg?idx=1 after it. Clciking on the web cam icon brings up the live feed overlay window but the stream loads as a broken image.

Is this the correct way to get my setup working in Domoticz or is it just not possible with my setup?

Thank you.
In Domoticz you should not add the http://10.0.x.x in the ImageURL box, only this:
picture/1/current/
Raspberry 3
Aeon Labs Z-Wave Stick Series 2 - RFLink USB Gateway
Z-Wave switches
433 MHz Temperature + Humidity sensors
Philips Hue Lights
Mi-Light WiFi Bridge + RGBW Controllers

DaWauZ
Posts: 70
Joined: Wednesday 05 November 2014 11:14
Target OS: Raspberry Pi
Domoticz version:
Location: Netherlands
Contact:

Re: PRi + MotionEye + Domoticz Setup - Help Please

Post by DaWauZ » Sunday 27 August 2017 7:42

well @ my setup it just wont work. With or without slash, with or without image url, only the test image succeeds.

the streaming url should be http://ipadress:8081
The embedd url should be http://ipadress/picture/1/frame/

well tell me what I should fill in domoticz, I tried everything, also with or withouth usernames
Raspberry Pi 2 model B with domoticz
OMV NAS installed on thin client HP T610
Openelec Kodi Mediaplayer on thin client HP T520 (and with multiboot windows 10)

TDK20
Posts: 8
Joined: Wednesday 16 August 2017 11:04
Target OS: Raspberry Pi
Domoticz version: 3.8367
Location: Frankfurt, FRG
Contact:

Re: PRi + MotionEye + Domoticz Setup - Help Please

Post by TDK20 » Sunday 27 August 2017 11:20

As mozart mentioned, just use
picture/1/current/
as the image URL no leading backslash or anything else. I tried a few variations, only the previous mentioned one worked.

DaWauZ
Posts: 70
Joined: Wednesday 05 November 2014 11:14
Target OS: Raspberry Pi
Domoticz version:
Location: Netherlands
Contact:

Re: PRi + MotionEye + Domoticz Setup - Help Please

Post by DaWauZ » Sunday 27 August 2017 16:03

does not work. Only test image works.
Raspberry Pi 2 model B with domoticz
OMV NAS installed on thin client HP T610
Openelec Kodi Mediaplayer on thin client HP T520 (and with multiboot windows 10)

User avatar
heggink
Posts: 455
Joined: Tuesday 08 September 2015 21:44
Target OS: Raspberry Pi
Domoticz version: V3.9530
Location: NL
Contact:

Re: PRi + MotionEye + Domoticz Setup - Help Please

Post by heggink » Sunday 04 February 2018 22:49

Anyone ever got this to work?
Pi3, latest beta
RFXCOM, z-wave (AEOTEC, switches, temhum, pir, contacts),
Plugwise2py, P1 'smart'meter & solar panel
Alexa, Wifi Cams motion detection
ESP: relays, PIR & Temp/TempHum
Geofence iCloud, Bluetooth & Wifi ping
Harmony hub, Nest

alexsh1
Posts: 274
Joined: Wednesday 30 September 2015 11:50
Target OS: Raspberry Pi
Domoticz version: v3.8975
Location: United Kingdom
Contact:

Re: PRi + MotionEye + Domoticz Setup - Help Please

Post by alexsh1 » Monday 12 March 2018 22:22

heggink wrote:
Sunday 04 February 2018 22:49
Anyone ever got this to work?
Yes. I did.
You should add a different URL:

Code: Select all

picture/1/current/?_username=admin&_signature=[whatever your signature is]
You can get your exact URL in Video Streaming - Snapshot URL in the motionEye settings. Make sure there is no "/" in front of the image URL.
Works fine in the latest Domoticz.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests