Evohome client (August 2017 update)

For heating/cooling related questions in Domoticz
tonbor
Posts: 23
Joined: Monday 17 February 2014 10:12
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Evohome client (August 2017 update)

Post by tonbor » Tuesday 22 August 2017 15:14

latest correct reading 1317 evohome 2121076 1 Woonkamer Heating Zone 21.5 C, (5.0 C), HeatingOff 10 - Zet als ongebruiktNaam wijzigen 2017-08-20 22:20:42

tonbor
Posts: 23
Joined: Monday 17 February 2014 10:12
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Evohome client (August 2017 update)

Post by tonbor » Tuesday 22 August 2017 15:16

latest reading 1317 evohome 2121076 1 Woonkamer Heating Zone 21.5 C, (5.0 C), HeatingOff 2017-08-20 22:20:42

tonbor
Posts: 23
Joined: Monday 17 February 2014 10:12
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Evohome client (August 2017 update)

Post by tonbor » Tuesday 22 August 2017 15:29

probleem zat niet bij de Api of Domoticz. Zat in de instellingen de taal was per ongeluk van Nederland naar Hongaars overgezet. De app is Nederlands. Kennelijk ern beveiliging van Honeywell.

Problem was the language settings. Changed from dutch to hungarian. Blocked entrance at Honeywell probably.

gordonb3
Posts: 567
Joined: Friday 22 January 2016 11:15
Target OS: Linux
Domoticz version: custom
Location: The Netherlands
Contact:

Re: Evohome client (August 2017 update)

Post by gordonb3 » Tuesday 22 August 2017 16:18

Amazing. Wouldn't be on the Honeywell side though because the error message would be different. The login itself is in fact successful. The most likely cause for your error is that the wrong language setting causes some characters of the session key that is returned by the login to be transcoded, thus making it invalid. I've marked this as a point of interest that should be investigated.
Excito B3 running Gentoo Linux, P1, Rfxtrx433 to read and control TFA, KaKu, EvoHome RFG100
Custom patched Domoticz v3.8000

tonbor
Posts: 23
Joined: Monday 17 February 2014 10:12
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Evohome client (August 2017 update)

Post by tonbor » Wednesday 23 August 2017 13:26

Thanx

fecus
Posts: 14
Joined: Monday 20 February 2017 16:24
Target OS: Linux
Domoticz version: 3.7708
Location: Hungary
Contact:

Re: Evohome client (August 2017 update)

Post by fecus » Thursday 19 October 2017 20:22

gordonb3 wrote:
Tuesday 22 August 2017 16:18
Amazing. Wouldn't be on the Honeywell side though because the error message would be different. The login itself is in fact successful. The most likely cause for your error is that the wrong language setting causes some characters of the session key that is returned by the login to be transcoded, thus making it invalid. I've marked this as a point of interest that should be investigated.
I'm from Hungary. My Domoticz language is Hungarian. Maybe my problem stems from this?
Would you have even investigate afterwards?

Soulplayer
Posts: 29
Joined: Saturday 05 November 2016 17:54
Target OS: -
Domoticz version:
Contact:

Re: Evohome client (August 2017 update)

Post by Soulplayer » Thursday 09 November 2017 14:05

I also have a question: I have two controllers but I cannot seem to select both it always gives me the first location although I select 1 or 2 or ... It creates those zones.

I use the Evohome via Web Api. Do I have to change something else?

gordonb3
Posts: 567
Joined: Friday 22 January 2016 11:15
Target OS: Linux
Domoticz version: custom
Location: The Netherlands
Contact:

Re: Evohome client (August 2017 update)

Post by gordonb3 » Thursday 09 November 2017 18:00

So essentially what you're saying is that the location settings are ignored. Are they even remembered between sessions? i.e. oiof you return to settings are these still set to the value you selected or are they reset to 0?
Excito B3 running Gentoo Linux, P1, Rfxtrx433 to read and control TFA, KaKu, EvoHome RFG100
Custom patched Domoticz v3.8000

Soulplayer
Posts: 29
Joined: Saturday 05 November 2016 17:54
Target OS: -
Domoticz version:
Contact:

Re: Evohome client (August 2017 update)

Post by Soulplayer » Thursday 09 November 2017 18:06

Settings are saved and it gets the information. It just seem to ignore the location setting

gordonb3
Posts: 567
Joined: Friday 22 January 2016 11:15
Target OS: Linux
Domoticz version: custom
Location: The Netherlands
Contact:

Re: Evohome client (August 2017 update)

Post by gordonb3 » Friday 10 November 2017 12:11

Right. I see what you mean. Something changed...
Excito B3 running Gentoo Linux, P1, Rfxtrx433 to read and control TFA, KaKu, EvoHome RFG100
Custom patched Domoticz v3.8000

gordonb3
Posts: 567
Joined: Friday 22 January 2016 11:15
Target OS: Linux
Domoticz version: custom
Location: The Netherlands
Contact:

Re: Evohome client (August 2017 update)

Post by gordonb3 » Friday 10 November 2017 12:49

Okay. Looks like someone changed the calling parameters to the hardware class, feeding an empty hardware property into the Evohome installation fields. Not good :(
Excito B3 running Gentoo Linux, P1, Rfxtrx433 to read and control TFA, KaKu, EvoHome RFG100
Custom patched Domoticz v3.8000

Soulplayer
Posts: 29
Joined: Saturday 05 November 2016 17:54
Target OS: -
Domoticz version:
Contact:

Re: Evohome client (August 2017 update)

Post by Soulplayer » Sunday 12 November 2017 19:06

So nothing I can do probably?

gordonb3
Posts: 567
Joined: Friday 22 January 2016 11:15
Target OS: Linux
Domoticz version: custom
Location: The Netherlands
Contact:

Re: Evohome client (August 2017 update)

Post by gordonb3 » Sunday 12 November 2017 19:53

Well yes, you can install the new beta ;)
Excito B3 running Gentoo Linux, P1, Rfxtrx433 to read and control TFA, KaKu, EvoHome RFG100
Custom patched Domoticz v3.8000

Soulplayer
Posts: 29
Joined: Saturday 05 November 2016 17:54
Target OS: -
Domoticz version:
Contact:

Re: Evohome client (August 2017 update)

Post by Soulplayer » Sunday 12 November 2017 20:45

Guess I'll have to wait a bit until it reaches the stable version. I'm using docker so I can't update to the beta :(.

gordonb3
Posts: 567
Joined: Friday 22 January 2016 11:15
Target OS: Linux
Domoticz version: custom
Location: The Netherlands
Contact:

Re: Evohome client (August 2017 update)

Post by gordonb3 » Monday 13 November 2017 19:26

Can you open the database with sqlite? Then find the correct entry in table `hardware` and copy the value of field `Mode5` to `Mode3` (value will be 4096).
Excito B3 running Gentoo Linux, P1, Rfxtrx433 to read and control TFA, KaKu, EvoHome RFG100
Custom patched Domoticz v3.8000

User avatar
waaren
Posts: 56
Joined: Tuesday 03 January 2017 15:18
Target OS: NAS (Synology & others)
Domoticz version: Beta
Location: Netherlands
Contact:

Re: Evohome client (August 2017 update)

Post by waaren » Friday 24 November 2017 18:11

With every new Domoticz Beta version following 8627 is get the following error

2017-11-24 17:02:49.230 (Evohome) connect to Evohome server
2017-11-24 17:02:49.389 Error: (Evohome) HTTP client error at login!

I compile from source using a spare RPI. If I try to update using the updatebeta script I got segmentation fault (when run from command line) or Fatal signal 11 (daemon)

If I copy my version 8627 back it will connect and update my temperatures and setpoints so I assume settings in domoticz database are correct.

Is there a way to solve this ?
Raspberry (debian via berryboot) on Synology DS916+ , Domoticz 3.8, RFXtrx433e, P1, Youless, Harmony, Hue, HomeWizard, Zwave , dzVents, Bash, PHP, Python, Amazon echo

gordonb3
Posts: 567
Joined: Friday 22 January 2016 11:15
Target OS: Linux
Domoticz version: custom
Location: The Netherlands
Contact:

Re: Evohome client (August 2017 update)

Post by gordonb3 » Saturday 25 November 2017 23:56

Can't really answer that. That particular message is generated on account of the very first web call made by the client failing. You could try tcpdump to see what traffic is generated (if any) and what response is given.
Excito B3 running Gentoo Linux, P1, Rfxtrx433 to read and control TFA, KaKu, EvoHome RFG100
Custom patched Domoticz v3.8000

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests