Remotec ZRC-90 Scene Master

Use this forum to discuss possible implementation of a new feature before opening a ticket.
A developer shall edit the topic title with "[xxx]" where xxx is the id of the accompanying tracker id.
Duplicate posts about the same id. +1 posts are not allowed.
AlexCr
Posts: 2
Joined: Thursday 21 December 2017 21:15
Target OS: Raspberry Pi
Domoticz version: Stable
Location: France
Contact:

Re: Remotec ZRC-90 Scene Master

Post by AlexCr » Thursday 21 December 2017 21:26

Hi,

I've just installed this remote, it works pretty well when you have limited needs, basically 8 push buttons.
For those who ask on how to use it, I've used 2 methods:

1) In the Switch representing one of the remote buttons:
In the "Action On", I've entered the URL the the switch I want to control in toggle mode:
"http://192.168.0.12:8080/json.htm?type= ... cmd=Toggle"

2) Using Blockly command like:

If Device(button 1) = On
Do Set Devide (Target Device) = On.

And another

If Device(button 2) = On
Do Set Devide (Target Device) = Off.

Well it uses 2 button of the remote, but works.
Domoticz on RPi 2
1Wire / TeleInfo / GPIO / RFXCOM / ZWAVE

marin849
Posts: 75
Joined: Tuesday 27 May 2014 10:36
Target OS: Raspberry Pi
Domoticz version: 2.4xxx
Location: Sweden
Contact:

Re: Remotec ZRC-90 Scene Master

Post by marin849 » Thursday 21 December 2017 22:22

You can also directly activate scenes with it, by editing a scene and pressing the learn button in Domoticz, then press the button on the remote that you want.

Deydier
Posts: 5
Joined: Saturday 30 January 2016 1:00
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Remotec ZRC-90 Scene Master

Post by Deydier » Monday 29 January 2018 10:37

Done !
I was a bit afraid rebuilding openzwave and domoticz... but that's not so hard, and everything is quite well explained here.
Backuping and restoring the domoticz database worked like a charm (furthermore and changed from a raspberry 2 to a raspberry 3, and everything went well)

One little disappointment : it's a bit slow... when a press a button on the ZRC-90 remote, it takes about 1 seconds before the linked light switches on.
It's frustrating... I would like an instantaneous action !
I know the problem doesn't come from activation : when I switch the same light through an URL (http://) it's very, very fast.

Any idea ?
Thanks everybody for all your messages which helped me to use my ZRC-90 remote which has been sleeping in my drawer for 1 year...

Yann
(french)

AlexCr
Posts: 2
Joined: Thursday 21 December 2017 21:15
Target OS: Raspberry Pi
Domoticz version: Stable
Location: France
Contact:

Re: Remotec ZRC-90 Scene Master

Post by AlexCr » Thursday 08 February 2018 1:41

I know the problem doesn't come from activation : when I switch the same light through an URL (http://) it's very, very fast.

Any idea ?
I have the same, this is most likely the latency of domoticz picking up the event of the utton pushed and then doing the action.
I've had pretty much the same latency no matter the solution used in domoticz (blockly, device with toggle url, scene activation,..)

Don't think it is possible with the curent OZW version in domoticz, but I guess setting up scenes directly at the OZW level and assign the remotec scenes to those would have a better response time. I was not able to set this up in the current version.
Domoticz on RPi 2
1Wire / TeleInfo / GPIO / RFXCOM / ZWAVE

User avatar
Egregius
Posts: 2747
Joined: Thursday 09 April 2015 12:19
Target OS: Linux
Domoticz version: Beta
Location: Beitem, BE
Contact:

Re: Remotec ZRC-90 Scene Master

Post by Egregius » Thursday 12 April 2018 18:03

I also notice the delay with multiple Scene masters on 2 different domoticz installations, guess it's really the hardware that's a bit slow to send the command.
My biggest issue is that only a single click is functional in domoticz. Not the double click or the long press. Any idea how we can activate those?

larsosca
Posts: 2
Joined: Wednesday 04 January 2017 17:53
Target OS: Windows
Domoticz version:
Contact:

Re: Remotec ZRC-90 Scene Master

Post by larsosca » Wednesday 13 June 2018 16:41

Hi

I know this thread is kind of old but anyway I'll give it a try.

I have the ZRC-90 working with blocky for all buttons, 1 to 8 are each activating its own scene.

It works as long as the remote does not go into sleep mode.
After half a day or so I have to open the battery lid and press the button W to have it activated again.

Does anyone have the same problem and does anyone solved this problem?

//Lasse

User avatar
Egregius
Posts: 2747
Joined: Thursday 09 April 2015 12:19
Target OS: Linux
Domoticz version: Beta
Location: Beitem, BE
Contact:

Re: Remotec ZRC-90 Scene Master

Post by Egregius » Wednesday 13 June 2018 18:09

No, not noticed yet. Both remotes work as expected here.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest