Ziggo Horizonbox support

Use this forum to discuss possible implementation of a new feature before opening a ticket.
A developer shall edit the topic title with "[xxx]" where xxx is the id of the accompanying tracker id.
Duplicate posts about the same id. +1 posts are not allowed.
User avatar
Cletus
Posts: 47
Joined: Wednesday 17 August 2016 9:32
Target OS: Raspberry Pi
Domoticz version: Latest
Location: Purmerend, Netherlands
Contact:

Re: Ziggo Horizonbox support

Postby Cletus » Friday 19 May 2017 20:25

Trying to edit the Wiki to add this text. Could not be processed. Can somebody add this?
In order to make your Horizon Box accept connection on the DeviceDescription.xml URL you need to make sure that you've enabled home network on your horizon box and configure that as you wish. Halfway you will get a question about media sharing, enable that and the URL becomes active.
This is our world now... the world of the electron and the switch, the beauty of the baud.

noppes123
Posts: 14
Joined: Sunday 23 April 2017 10:04
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Ziggo Horizonbox support

Postby noppes123 » Friday 19 May 2017 21:13

I've tested accessing the DeviceDescription.xml 'page' through port 62137 while the Horizon is on and it replies with OK. When in standby, I receive 'connection refused'. That confirms Paul's findings.
It feels a bit clumsy to determine the device status by the fact that it does not respond properly... :(

Next step is to show the on/off status in Domoticz by running a little script every now and then (like 30 seconds or so).

User avatar
Cletus
Posts: 47
Joined: Wednesday 17 August 2016 9:32
Target OS: Raspberry Pi
Domoticz version: Latest
Location: Purmerend, Netherlands
Contact:

Re: Ziggo Horizonbox support

Postby Cletus » Friday 19 May 2017 22:04

Maybe you can create a script like i did with Curl?

On the one side it's responding with 200 to a variable if it's on, and the variable is empty when its not responding thus making it $null

Makes sense?
This is our world now... the world of the electron and the switch, the beauty of the baud.

noppes123
Posts: 14
Joined: Sunday 23 April 2017 10:04
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Ziggo Horizonbox support

Postby noppes123 » Friday 19 May 2017 22:15

Cletus wrote:Maybe you can create a script like i did with Curl?

On the one side it's responding with 200 to a variable if it's on, and the variable is empty when its not responding thus making it $null

Makes sense?


Sure, the script is working. But the Horizon is not very cooperative. After a few tests with the status script and switching on/off with the ZiggoGo App a few times, the box is no longer visible on the network, not even for the ZiggoApp. :? It doesn't show the time on the display, just an orange LED.

A hard power cycle was necessary to get it going again...

User avatar
Cletus
Posts: 47
Joined: Wednesday 17 August 2016 9:32
Target OS: Raspberry Pi
Domoticz version: Latest
Location: Purmerend, Netherlands
Contact:

Re: Ziggo Horizonbox support

Postby Cletus » Friday 19 May 2017 22:39

Hmm that's weird...

Judging from your username i pressume you are from the Netherlands.

First of all, did you had the same problem before?

Second, take the box under your arm, go to a Ziggo store, dump it on the counter and say that it is not working. If they don't want to replace put the device in the microwave for 3 seconds on full watts and the circuitry is fried ^^

I had stability issues with the 7400 version of the box, i took it under my arm, went to a Ziggo store and said that i was fed up with that thing, without blinking they gave me a new one within 2 minutes or so...

There is also a full reset sequence but i can't remind that anymore, something with holding the power button on the front of the device and let it go within 1 second of the fans spinning up or something. This will factory reset the device, removes the firmware and downloads the new firmware from the Ziggo network.
This is our world now... the world of the electron and the switch, the beauty of the baud.

noppes123
Posts: 14
Joined: Sunday 23 April 2017 10:04
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Ziggo Horizonbox support

Postby noppes123 » Saturday 20 May 2017 7:54

I had no stability issues before (let's forget the first year of introduction... :( ).
Will do a few more tests and maybe a factory reset and see if still occurs. Next step, microwave oven.....? ;o)


Return to “Suggestions”

Who is online

Users browsing this forum: No registered users and 1 guest