Page 7 of 10

Re: Domoticz version 4.9700 released (Stable)

Posted: Friday 06 July 2018 13:45
by moi427
Update: wow, there's progress! :D
After deleting both giant logfiles I was able to run Raspi-Config and expand the file system for certainty (although I thought that was done when installing everything). I rebooted and already Domoticz started with showing all hardware I formerly installed. Only the NibeUplink RPC hasn't updated yet (for my Nibe heatpump) , so I'll have to look at that but this already is hopefull!I guess I have to authenticate again with the Nibe heatpump, I'll do that next.
I also notice that the Domoticz version indeed is 4.9700, so it seems somehow these logfiles ate all remaining space of the SD-card after which Domoticz stopped working.
Thanx sofar Jos and Christophe!

Re: Domoticz version 4.9700 released (Stable)

Posted: Friday 06 July 2018 14:00
by jvdz
Good you got that going again. 8-)
When time permits you could have a look at your logrotate config and change it to inlude the logfiles that grow too big, so they are auto-maintained.

Jos

Re: Domoticz version 4.9700 released (Stable)

Posted: Friday 06 July 2018 14:07
by moi427
Ok Jos, that's a good idea. I'll check our friend Google to see how that needs to be done.
Btw.: most sensors of the Nibe heatpump are also properly read into Domoticz again after re-authentication. The rest will follow I guess, so everything seems to be normall again. Pfieuwww, much better feeling!

Re: Domoticz version 4.9700 released (Stable)

Posted: Friday 06 July 2018 14:53
by moi427
Created /etc/logrotate.d/local according what I found in https://www.domoticz.com/wiki/Set_up_Domoticz_to_syslog, only changed to rotate 2 as trial.
Will check what happens/if this works during the next period :mrgreen:

Re: Domoticz version 4.9700 released (Stable)

Posted: Saturday 07 July 2018 12:28
by Kasvand
For me all Virtual sensors/Switches don't work!! They all give an Undefined error when trying to edit them and in the Switches panel I get a lot of random data or something.... (instead of the normal name and statusses I created). All other switches work fine it seems, however when I try to edit them I also get "Undefined". Clearing the Cache of the browsers doesn't solve it

Found it: clearing all Domoticz related entries here chrome://appcache-internals solved the issue.

Re: Domoticz version 4.9700 released (Stable)

Posted: Saturday 07 July 2018 22:56
by Dingetje2004
Kasvand wrote:
Monday 02 July 2018 22:42
Well... This is quite a disaster...

I had perfect scripts controlling all the lights using motion sensors etc. But after the update all I get is disco! Lights are blinking all over the place. Lights also seem to turn on and off pretty random, and logging gives no single clue why. :(
No idea what's going on here..... It seems the system is completely messed up. Some groups aren't functioning at all (if I activate them just nothing happens). When I turn the lights off (using a dummy switch) most lights turn off but two of them start blinking and another random light turns on after some time and remains on. There does seem to be some pattern - but there's absolutely nothing in the scripts that can be causing this.... (nb. all Xiaomi lights and sensors...)

Going back to the old release. Don't even have an idea where to start solving this...
Forgot to do a back-up... :( (stupid!), but still have a quite recent one fortunately. Lost an hour of work max. Shame.

Well... we're back online. On the old release that is. Will have to give it another go when I have a few hours time to do debugging. Anyone know if things have changed in this release concerning controlling groups? Cause that's all I can think off that might be causing the strange behaviour of lights...
can you plz tell how you went back on the old release? Having same issues... blocky not workin anymore and light....looks like a disco in my house! (I do have the mi-light) Going on vacation and I do not have time to go debug.... backup from 2 weeks ago, looks like it goes back to the new version all the time.. I must be doing something wrong. Thanks!

Re: Domoticz version 4.9700 released (Stable)

Posted: Sunday 08 July 2018 9:26
by niki_lauda
Dingetje2004 wrote:
Saturday 07 July 2018 22:56
Kasvand wrote:
Monday 02 July 2018 22:42
Well... This is quite a disaster...

I had perfect scripts controlling all the lights using motion sensors etc. But after the update all I get is disco! Lights are blinking all over the place. Lights also seem to turn on and off pretty random, and logging gives no single clue why. :(
No idea what's going on here..... It seems the system is completely messed up. Some groups aren't functioning at all (if I activate them just nothing happens). When I turn the lights off (using a dummy switch) most lights turn off but two of them start blinking and another random light turns on after some time and remains on. There does seem to be some pattern - but there's absolutely nothing in the scripts that can be causing this.... (nb. all Xiaomi lights and sensors...)

Going back to the old release. Don't even have an idea where to start solving this...
Forgot to do a back-up... :( (stupid!), but still have a quite recent one fortunately. Lost an hour of work max. Shame.

Well... we're back online. On the old release that is. Will have to give it another go when I have a few hours time to do debugging. Anyone know if things have changed in this release concerning controlling groups? Cause that's all I can think off that might be causing the strange behaviour of lights...
can you plz tell how you went back on the old release? Having same issues... blocky not workin anymore and light....looks like a disco in my house! (I do have the mi-light) Going on vacation and I do not have time to go debug.... backup from 2 weeks ago, looks like it goes back to the new version all the time.. I must be doing something wrong. Thanks!
https://egregius.be/2018/previous-domoticz-versions/ ?

Re: Domoticz version 4.9700 released (Stable)

Posted: Sunday 08 July 2018 10:28
by Dingetje2004
Thnks! Just copy these files over the others, fe with file transfer? Don't want to mess it up again.

Re: Domoticz version 4.9700 released (Stable)

Posted: Sunday 08 July 2018 13:29
by sennheiser
Hi,

I'm on raspberry pi 3, with Zwave+ (Z stick get 5) and Rm Pro Broadlink,

Since this version, domoticz doesn't work if I plug my Zwave stick...

Could you help me please ?

Jay

Re: Domoticz version 4.9700 released (Stable)

Posted: Sunday 08 July 2018 21:02
by Skwi
Hi, in the previous version of domoticz I could put an rgb code in hexa for my yeelight rgb. Since the update to 4.9700 it just show the pannel with colors but no sign of the hexa code.
Does anyone know where I can find it on the web site? Or if I can change it directly into db/file (rpi)?
Thanks

Re: Domoticz version 4.9700 released (Stable)

Posted: Monday 09 July 2018 12:37
by cato
Dahl1632 wrote:
Sunday 24 June 2018 16:28
After upgrade my system dosnt work anymore.
I was running the stable version on my Rpi2 Wheezy.

Now i get:
domoticz: error while loading shared libraries: libudev.so.1: cannot open shared object file: No such file or directory
Same problem here from an updated Wheezy. Domoticz does not start. Apparently there is no libudev.so in Wheezy. Any package that we should install? Any file to edit in config folder to avoid the problem?

Thanks!

Re: Domoticz version 4.9700 released (Stable)

Posted: Monday 09 July 2018 12:59
by moi427
Just a little addition to my former problems: apparently the logrotation as I installed it doesn't work properly: Domoticz again doesn't work anymore, the RaspiBackup sundaynight didn't run and since I now know that command to check for large logfiles that caused problems (filled up SD card, checked with ls -l /var/log/*) it shows again the same two logfiles ate all space.
They are /var/log/daemon.log (about 280Mb), /var/log/daemon.log.1 (about 430Mb) and /var/log/syslog, /var/log/syslog.1 (same sizes).
So I have to look into that logrotation again, somehow not yet properly working. :?:

Re: Domoticz version 4.9700 released (Stable)

Posted: Monday 09 July 2018 13:31
by jvdz
A couple of thing you could check.
1: Volume sizes and space available: df - k
2: Look in /var/log/daemon.log and check why it is growing this fast.
3: same for /var/log/syslog

Jos

Re: Domoticz version 4.9700 released (Stable)

Posted: Monday 09 July 2018 20:49
by Bernd
cato wrote:
Monday 09 July 2018 12:37
Dahl1632 wrote:
Sunday 24 June 2018 16:28
After upgrade my system dosnt work anymore.
I was running the stable version on my Rpi2 Wheezy.

Now i get:
domoticz: error while loading shared libraries: libudev.so.1: cannot open shared object file: No such file or directory
Same problem here from an updated Wheezy. Domoticz does not start. Apparently there is no libudev.so in Wheezy. Any package that we should install? Any file to edit in config folder to avoid the problem?

Thanks!
Read the first post. You have to use Stretch. Follow the quidelines and it will work.

Re: Domoticz version 4.9700 released (Stable)

Posted: Monday 09 July 2018 20:56
by Bernd
I started from scratch.
First I installed, on a new USB stick, the latest version of Stretch, then curled Domoticz on it, copied the old database (just created a couple of minutes before), just followed the steps from the first post.
How amazed I was that it worked !!
Lula scripts, Weather Underground, RFXTRX433E.

THANK YOU!!

Re: Domoticz version 4.9700 released (Stable)

Posted: Monday 09 July 2018 22:16
by wonder24
On the web page I can see different installations but not a link to download it for Asustor. Can you provide a download link for a the latest stable version to be used with Asustor intel chips.
I have tried updating it from within the application, but it fails replying there is no update available.
What is needed to use the final and the beta versions on Asustor. I have tried contacting Asustor support but it seems they are waiting on your feedback.
Would like to start using the nice extra's implemented into the this version

Re: Domoticz version 4.9700 released (Stable)

Posted: Tuesday 10 July 2018 10:39
by atagesson
My Domoticz is not running after update!

The command:
sudo /etc/init.d/domoticz.sh start

Gives me:
/home/pi¨'/domoticz/domoticz: error while loading shared libraries: libudev.so.1: cannot open shared object file: No such file or directory

Any ideas???

Thanks in advance

/// AndreaS

Re: Domoticz version 4.9700 released (Stable)

Posted: Tuesday 10 July 2018 11:20
by Rainman
Three posts higher is the answer, please read before posting
My Domoticz is not running after update!

The command:
sudo /etc/init.d/domoticz.sh start

Gives me:
/home/pi¨'/domoticz/domoticz: error while loading shared libraries: libudev.so.1: cannot open shared object file: No such file or directory

Any ideas???

Thanks in advance

/// AndreaS

Re: Domoticz version 4.9700 released (Stable)

Posted: Tuesday 10 July 2018 13:34
by moi427
One more update after remaining problem of logfiles eating up all space on my SD-card.
After looking into both large logfiles, I noticed regularly errors on mysql occurred for the Innodb. Have removed mysql since I didn't use it yet after having problems before about half a year ago when I installed it to use it for my Youless and looking into the Domoticz database. But after first trials it didn't work anymore (no idea why), so now finally removed it because it might be causing these growing logfiles. Anyway, hope this caused the space problems, although I have a doubt since this problem only started after updating to this new Domoticz release... Also changed a few thing in log rotation again, perhaps that will work now.

Can't install MySql anymore though and that's a bit weird, perhaps someone similar problems?
What I did plus message:
pi@raspberrypi:~ $ sudo apt-get install mysql-server -y
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
mysql-server
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/1,706 B of archives.
After this operation, 8,192 B of additional disk space will be used.
Segmentation fault
E: Sub-process /usr/bin/apt-listchanges --apt || test $? -lt 10 returned an error code (1)
E: Failure running script /usr/bin/apt-listchanges --apt || test $? -lt 10


That segmentation fault is very persistant, don't know why or how to solve.

Re: Domoticz version 4.9700 released (Stable)

Posted: Tuesday 10 July 2018 22:28
by iganin
I'm updating electricity counters using JSON method from a php file:

Code: Select all

http://192.168.1.7:8080/json.htm?type=command&param=udevice&idx=1&svalue=745;1241
In the new version, i do not see the updates in the log anymore while counters are updating correctly.
Therefore, the master domoticz server doesn't see the changes.

Am i overlooking something?