New (beta) version library requirement (Arm/Debian)

News and/or updates regarding Domoticz or things related to Domoticz will be placed here.
Twitter: https://twitter.com/Domoticz | Facebook: https://www.facebook.com/domoticz | Changelog: Github
Jan Jansen
Posts: 156
Joined: Wednesday 30 April 2014 20:27
Target OS: Raspberry Pi
Domoticz version: Stable
Location: The Netherlands
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by Jan Jansen » Monday 04 December 2017 21:04

Yesterday i did a fresh install (RPI 1B BCM2835), cause I wanted get rid of the libssl1.0.0.

After curl -L install.domoticz.com | sudo bash, I did:

cd domoticz
./updatebeta

Domoticz works as desired.

jankeeso
Posts: 2
Joined: Thursday 02 November 2017 17:34
Target OS: Raspberry Pi
Domoticz version: 3.8833
Location: netherlands
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by jankeeso » Friday 19 January 2018 14:49

@Jan Jansen: You are my hero.....domoticz starts....at last.....thnx

Jan Jansen
Posts: 156
Joined: Wednesday 30 April 2014 20:27
Target OS: Raspberry Pi
Domoticz version: Stable
Location: The Netherlands
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by Jan Jansen » Saturday 20 January 2018 8:51

Gizmocuz deserves your compliments (see start of this topic).

User avatar
Derik
Posts: 2005
Joined: Friday 18 October 2013 23:33
Target OS: Raspberry Pi
Domoticz version: BETA
Location: Arnhem/Nijmegen Nederland
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by Derik » Sunday 21 January 2018 14:27

Dear All:

Code: Select all

domoticz.service - LSB: Home Automation System
   Loaded: loaded (/etc/init.d/domoticz.sh; bad; vendor preset: enabled)
   Active: active (exited) since Sun 2018-01-21 13:23:04 CET; 38s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 32470 ExecStop=/etc/init.d/domoticz.sh stop (code=exited, status=0/SUCCESS)
  Process: 32561 ExecStart=/etc/init.d/domoticz.sh start (code=exited, status=0/SUCCESS)

Jan 21 13:23:04 odroidxu4 systemd[1]: Starting LSB: Home Automation System...
Jan 21 13:23:04 odroidxu4 domoticz.sh[32561]: 2018-01-21 13:23:04.919  Domoticz V3.8833 (c)2012-2018 GizMoCuz
Jan 21 13:23:04 odroidxu4 domoticz.sh[32561]: 2018-01-21 13:23:04.919  Build Hash: 60050638, Date: 2018-01-19 13:22:13
Jan 21 13:23:04 odroidxu4 domoticz.sh[32561]: 2018-01-21 13:23:04.919  Startup Path: /home/root/domoticz/
Jan 21 13:23:04 odroidxu4 domoticz.sh[32561]: domoticz: Domoticz is starting up....
Jan 21 13:23:04 odroidxu4 domoticz[32566]: Domoticz is starting up....
Jan 21 13:23:04 odroidxu4 domoticz[32567]: Domoticz running...
Jan 21 13:23:04 odroidxu4 systemd[1]: Started LSB: Home Automation System.
[email protected]:~#

I do have the great problem....
When i run the latest release no problem..
When ir run the latest beta grrr get this error and not working domoticz

Did all the thing here
Only every time the error...

Code: Select all

[email protected]:~# cat /etc/os-release
NAME="Ubuntu"
VERSION="16.04.3 LTS (Xenial Xerus)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 16.04.3 LTS"
VERSION_ID="16.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
VERSION_CODENAME=xenial
UBUNTU_CODENAME=xenial
[email protected]:~#
Help or something..:-)
Xu4: Beta Extreme antenna RFXcomE,WU Fi Ping ip P1 Gen5 PVOutput Harmony HUE SolarmanPv OTG Winddelen Alive ESP Buienradar MySensors WOL Winddelen counting RPi: Beta SMAspot RFlinkTest Domoticz ...Different backups

Schorschi
Posts: 28
Joined: Thursday 30 November 2017 23:09
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by Schorschi » Wednesday 24 January 2018 11:37

I hope we get an new running beta today :)

Schorschi
Posts: 28
Joined: Thursday 30 November 2017 23:09
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by Schorschi » Wednesday 24 January 2018 15:45

News...

I can't wait until next beta so i compiled last source files by my self and now domoticz running again.

:D ;)

User avatar
waaren
Posts: 148
Joined: Tuesday 03 January 2017 15:18
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by waaren » Wednesday 24 January 2018 16:14

Is this on Jessie or on Stretch ?
Raspberry (debian stretch via berryboot) on Synology DS916+ , Domoticz 3.9, RFXtrx433e, P1, Youless, Harmony, Hue, HomeWizard, Zwave , dzVents 3.4, Bash, Python plugins, Amazon echo

Schorschi
Posts: 28
Joined: Thursday 30 November 2017 23:09
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by Schorschi » Wednesday 24 January 2018 22:22

I use Raspi-Stretch.

User avatar
waaren
Posts: 148
Joined: Tuesday 03 January 2017 15:18
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by waaren » Thursday 25 January 2018 1:05

Just finished compiling version 3.8841 on my development Raspberry PI3 . Unfortunately it still stops with fatal signal 11

2018-01-24 23:23:48.183 Error: Domoticz received fatal signal 11 !...
2018-01-24 23:23:48.185 Error: /opt/domoticz/domoticz() [0x243b50]
2018-01-24 23:23:48.186 Error: /opt/domoticz/domoticz(_Z14signal_handleri+0x4c) [0x243c08]
2018-01-24 23:23:48.186 Error: /lib/arm-linux-gnueabihf/libc.so.6(__default_sa_restorer+0) [0x76c476b0]

Both production and development Debian stretch and Python 3.5.3

several Python plugins (Sonos, Buienradar amonigst others)
Raspberry (debian stretch via berryboot) on Synology DS916+ , Domoticz 3.9, RFXtrx433e, P1, Youless, Harmony, Hue, HomeWizard, Zwave , dzVents 3.4, Bash, Python plugins, Amazon echo

User avatar
Derik
Posts: 2005
Joined: Friday 18 October 2013 23:33
Target OS: Raspberry Pi
Domoticz version: BETA
Location: Arnhem/Nijmegen Nederland
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by Derik » Thursday 25 January 2018 9:20

try to remove the plugins first...
then again..
My setup fuckup with buienradar plugin remove from plugin map the buienradar.
Then reboot the board..

For me without buienradar everything works great..
Xu4: Beta Extreme antenna RFXcomE,WU Fi Ping ip P1 Gen5 PVOutput Harmony HUE SolarmanPv OTG Winddelen Alive ESP Buienradar MySensors WOL Winddelen counting RPi: Beta SMAspot RFlinkTest Domoticz ...Different backups

User avatar
waaren
Posts: 148
Joined: Tuesday 03 January 2017 15:18
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by waaren » Thursday 25 January 2018 10:06

Derik wrote:
Thursday 25 January 2018 9:20
try to remove the plugins first...
then again..
My setup fuckup with buienradar plugin remove from plugin map the buienradar.
Then reboot the board..

For me without buienradar everything works great..
Thanks for your answer.

When I remove Buienradar, Sonos and Homewizard plugin (leaving NUT_UPS, PI-monitor and batterylevel plugins) ./updatebeta (V3.8841) works.
When I remove Buienradar, Sonos plugin (leaving Homewizard, NUT_UPS, PI-monitor and batterylevel plugins) my compiled from source with option -DUSE_OPENSSL_STATIC="NO" works.
With my compiled from source (V3.9032 from Dannybloe's GIT) with option -DUSE_OPENSSL_STATIC="NO" everything works.

Thing is; I kind of like all of my plugins to work and I am a big fan of dzVents but also like the idea of simple updates. But hé that's life, you don't always get what you want :D
Raspberry (debian stretch via berryboot) on Synology DS916+ , Domoticz 3.9, RFXtrx433e, P1, Youless, Harmony, Hue, HomeWizard, Zwave , dzVents 3.4, Bash, Python plugins, Amazon echo

SteGe
Posts: 37
Joined: Saturday 02 July 2016 13:54
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by SteGe » Thursday 25 January 2018 11:52

+1 for me Derik...


Verzonden vanaf mijn iPhone met Tapatalk
Raspberry pi 3b
RFXtrx433E
Sompfy sunscreen
Cresta weatherstation
4 elro power switches
Doorbell/chime
Letterbox "reader"
Eneco Toon (also for reading smartmeter by P1)
MySensors (Humidity, Temperature, Lux)

User avatar
Derik
Posts: 2005
Joined: Friday 18 October 2013 23:33
Target OS: Raspberry Pi
Domoticz version: BETA
Location: Arnhem/Nijmegen Nederland
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by Derik » Thursday 08 February 2018 23:10

Is there perhaps a solution for the older version raspberry model b..
Running only see:
Active: active (exited) since xxx

grr
:-(

Code: Select all

[email protected]:~# cat /etc/*-release
PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
[email protected]:~#
Xu4: Beta Extreme antenna RFXcomE,WU Fi Ping ip P1 Gen5 PVOutput Harmony HUE SolarmanPv OTG Winddelen Alive ESP Buienradar MySensors WOL Winddelen counting RPi: Beta SMAspot RFlinkTest Domoticz ...Different backups

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests