New (beta) version library requirement (Arm/Debian)

News and/or updates regarding Domoticz or things related to Domoticz will be placed here.
Twitter: https://twitter.com/Domoticz | Facebook: https://www.facebook.com/domoticz | Changelog: Github
Jan Jansen
Posts: 147
Joined: Wednesday 30 April 2014 20:27
Target OS: Raspberry Pi
Domoticz version: Stable
Location: The Netherlands
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by Jan Jansen » Monday 16 October 2017 15:45

@pvangorp

After following your step by step instruction everything seemed OK. But after "cd domoticz" and "./updatebeta" it was impossible to connect again via the web interface. I went back to Strectch in combination with the latest stable.

pvangorp
Posts: 121
Joined: Tuesday 28 March 2017 10:18
Target OS: Raspberry Pi
Domoticz version: Latest B
Location: The Netherlands
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by pvangorp » Monday 16 October 2017 15:53

You can’t update like that. You’ll go back to stock Domoticz. You need to update like this:

Code: Select all

# git pull
# make -j 4

vmb
Posts: 33
Joined: Thursday 02 October 2014 14:35
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by vmb » Monday 16 October 2017 15:55

@pvangorp Also updating by webinterface aint possible?

pvangorp
Posts: 121
Joined: Tuesday 28 March 2017 10:18
Target OS: Raspberry Pi
Domoticz version: Latest B
Location: The Netherlands
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by pvangorp » Monday 16 October 2017 15:57

Correct, you’ll go back to stock. It doesn’t take as long as the initial build, but longer than the integrated update.

Jan Jansen
Posts: 147
Joined: Wednesday 30 April 2014 20:27
Target OS: Raspberry Pi
Domoticz version: Stable
Location: The Netherlands
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by Jan Jansen » Monday 16 October 2017 20:51

Your step by step instruction is clear about updating, so is the wiki. Unfortunately, I got stuck again.
After:
cd domoticz
git pull
make -j 4
>>putty shows the next last line
[ 21%] Linking CXX executable domoticz

The next 3 hours nothing happened. It looks like the issue described in my mail of October 12th.

My production machine runs the latest stable version of domoticz on stretch. At the moment there is no need for the beta version. But I wanted to try to install it from the source, unfortunately, without success.

Thanks so far

anconakip
Posts: 16
Joined: Tuesday 30 September 2014 12:41
Target OS: Raspberry Pi
Domoticz version: 7722
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by anconakip » Tuesday 17 October 2017 7:10

here also problems. When is update my libssl de pi say it is already the newest. Help!!

Patrickwit
Posts: 8
Joined: Sunday 22 October 2017 10:29
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by Patrickwit » Sunday 22 October 2017 13:42

something goes wrong with getting the beta version I think?
nog I have the stable version. 3.8153 and I tought maybe the beta version is better.

but when I doe de command

Code: Select all

./updatebeta
the raspberry says:

Code: Select all

Updating to latest beta version...
Please Standby...
--2017-10-21 07:03:52--  http://www.domoticz.com/download.php?channel=beta&type=release&system=linux&machine=armv7l
Resolving www.domoticz.com (www.domoticz.com)... failed: Name or service not known.
wget: unable to resolve host address ‘www.domoticz.com’

gzip: stdin: unexpected end of file
tar: Child returned status 1
tar: Error is not recoverable: exiting now
Restarting Domoticz... (please standby...)

mosjonathan
Posts: 64
Joined: Friday 24 February 2017 22:20
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by mosjonathan » Sunday 22 October 2017 13:46

looks like a dns problem the script cannot resolve www.domoticz.com

Patrickwit
Posts: 8
Joined: Sunday 22 October 2017 10:29
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by Patrickwit » Monday 23 October 2017 8:22

mosjonathan wrote:
Sunday 22 October 2017 13:46
looks like a dns problem the script cannot resolve www.domoticz.com
what can be the solution?

Patrickwit
Posts: 8
Joined: Sunday 22 October 2017 10:29
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by Patrickwit » Monday 23 October 2017 8:22

. something went wrong with this post.
Last edited by Patrickwit on Monday 23 October 2017 14:28, edited 2 times in total.

mosjonathan
Posts: 64
Joined: Friday 24 February 2017 22:20
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by mosjonathan » Tuesday 24 October 2017 15:46

does your raspberry have a static address or do you use dhcp?

if you use static than probably your dns servers are not properly configured.

DannyElfman
Posts: 43
Joined: Monday 13 October 2014 14:05
Target OS: Linux
Domoticz version: 3.8136
Location: France
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by DannyElfman » Saturday 04 November 2017 18:53

Does anyone have installed the latest stable or beta on a Debian 9 ?

I am running a Debian 9.2.1 64bits on a Xeon server and I get the same error :

Code: Select all

domoticz.sh[1397]: /home/root/domoticz/domoticz: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory
Domoticz is looking for libssl 1.0.0 when I have 1.0.2l-2+deb9u1

Code: Select all

 ldd domoticz
        libssl.so.1.0.0 => not found
        libcrypto.so.1.0.0 => not found
Any idea ?
Debian Jessie VM on EsxI on a Gen 8 Proliant + RFXCom + AeonLabs Zwave+ + Fibaro eye + Fibaro Smoke + Fibaro FGS211 Philips Hue + Harmony Hub + Somfy RTS + Oregon Temp sensors + Xiaomi Gateway + Xiaomi sensors + Sonoff basic

DannyElfman
Posts: 43
Joined: Monday 13 October 2014 14:05
Target OS: Linux
Domoticz version: 3.8136
Location: France
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by DannyElfman » Saturday 04 November 2017 22:04

FYI, the fix has been explained in some other posts bt just in case :

Code: Select all

wget http://ftp.nl.debian.org/debian/pool/main/o/openssl/libssl1.0.0_1.0.1t-1%2Bdeb8u6_amd64.deb

dpkg -i libssl1.0.0_1.0.1t-1+deb8u6_amd64.deb

systemctl restart domoticz
Et voilà !
Debian Jessie VM on EsxI on a Gen 8 Proliant + RFXCom + AeonLabs Zwave+ + Fibaro eye + Fibaro Smoke + Fibaro FGS211 Philips Hue + Harmony Hub + Somfy RTS + Oregon Temp sensors + Xiaomi Gateway + Xiaomi sensors + Sonoff basic

roblom
Posts: 565
Joined: Wednesday 26 February 2014 16:28
Target OS: Raspberry Pi
Domoticz version:
Location: the Netherlands
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by roblom » Sunday 05 November 2017 22:06

gizmocuz wrote:
Saturday 09 September 2017 12:28
For new (beta) versions it is required that libssl 1.0.0 is installed.
This might not be at your current system (for example a raspberry running rasbian jessy or older)

To install this, issue:

Code: Select all

sudo apt-get install libssl1.0.0
After this you should be able to upgrade to the new beta via the web interface, or via the command line

Code: Select all

cd domoticz
./updatebeta
for people running an armv6 system (raspberry pi 2 or below) you might need to issue

Code: Select all

wget http://mirrordirector.raspbian.org/raspbian/pool/main/o/openssl/libssl1.0.0_1.0.1t-1+deb8u6_armhf.deb
sudo dpkg -i libssl1.0.0_1.0.1t-1+deb8u6_armhf.deb
If i'm right the libssl1.0.0_1.0.1t-1+deb8u6_armhf.deb isn't there anymore. Can i just use the libssl1.0.0_1.0.1t-1+deb8u7_armhf.deb then?

DannyElfman
Posts: 43
Joined: Monday 13 October 2014 14:05
Target OS: Linux
Domoticz version: 3.8136
Location: France
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by DannyElfman » Monday 06 November 2017 18:48

Debian Jessie VM on EsxI on a Gen 8 Proliant + RFXCom + AeonLabs Zwave+ + Fibaro eye + Fibaro Smoke + Fibaro FGS211 Philips Hue + Harmony Hub + Somfy RTS + Oregon Temp sensors + Xiaomi Gateway + Xiaomi sensors + Sonoff basic

roblom
Posts: 565
Joined: Wednesday 26 February 2014 16:28
Target OS: Raspberry Pi
Domoticz version:
Location: the Netherlands
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by roblom » Monday 06 November 2017 19:34

Ignore my stupidity but is the file from the debian source the same as the one from the raspbian source?
I recently screwed up my system again by another attempt to fixed the "illegal instruction" and our the missing lines errors. It's probably my fault but at the moment I fix one problem and get 2 other problems back. And the more I fix the more unstable Domoticz gets.

DannyElfman
Posts: 43
Joined: Monday 13 October 2014 14:05
Target OS: Linux
Domoticz version: 3.8136
Location: France
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by DannyElfman » Wednesday 08 November 2017 16:30

One piece of advice : Make a clone of you sdcard using clonezilla for instance (or dd command but that might sound a bit complicated) or any other software, anytime you are touching the system (installing libraries and so).

This link is a reliable one as it is one of the official Debian repository and the version is the ARM one for any PI device :

libssl1.0.0_1.0.1t-1+deb8u6_armhf.deb

The official official info is here but it is mentionning the lateste version, u7 :

https://packages.debian.org/jessie/armh ... 0/download
Debian Jessie VM on EsxI on a Gen 8 Proliant + RFXCom + AeonLabs Zwave+ + Fibaro eye + Fibaro Smoke + Fibaro FGS211 Philips Hue + Harmony Hub + Somfy RTS + Oregon Temp sensors + Xiaomi Gateway + Xiaomi sensors + Sonoff basic

DannyElfman
Posts: 43
Joined: Monday 13 October 2014 14:05
Target OS: Linux
Domoticz version: 3.8136
Location: France
Contact:

Re: New (beta) version library requirement (Arm/Debian)

Post by DannyElfman » Wednesday 08 November 2017 17:19

Note that I understand your are reluctant to use another source, that is completely understandable.

I guess, apart from the version number, you have the checksum on both side to make sure this is the one ;)
Debian Jessie VM on EsxI on a Gen 8 Proliant + RFXCom + AeonLabs Zwave+ + Fibaro eye + Fibaro Smoke + Fibaro FGS211 Philips Hue + Harmony Hub + Somfy RTS + Oregon Temp sensors + Xiaomi Gateway + Xiaomi sensors + Sonoff basic

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests