Fibaro Keyfob 601 FGKF-601

Topics (not sure which fora)
when not sure where to post, post here and mods will move it to right forum.
Post Reply
Mankan
Posts: 19
Joined: Wednesday 23 November 2016 7:10
Target OS: Raspberry Pi
Domoticz version:
Contact:

Fibaro Keyfob 601 FGKF-601

Post by Mankan » Monday 29 May 2017 19:34

Hello!
I've bought a Fibaro Keyfob 601, i had no problems with adding the control but I can not add the buttons, is there anyone who knows how to add buttons in Domoticz, trinangel, square, circle, etc.

Thx!

boomrang
Posts: 1
Joined: Wednesday 19 July 2017 8:27
Target OS: NAS (Synology & others)
Domoticz version:
Contact:

Re: Fibaro Keyfob 601 FGKF-601

Post by boomrang » Wednesday 19 July 2017 8:29

Hi,

I've exactly the same problem. The device has been added in hardware but the buttons are not detected.

Have you found the way to work with it ?

Thanks

paulzuurbier
Posts: 2
Joined: Monday 24 July 2017 21:40
Target OS: -
Domoticz version:
Contact:

Re: Fibaro Keyfob 601 FGKF-601

Post by paulzuurbier » Wednesday 26 July 2017 8:52

how to install z-wave fibaro keyfob fgkf-601 on synology precompiled domoticz

- Remove the device from your z-wave network, you will find it in settings|hardware|OpenZWave it has id 1000 and type 1001.
- Download the configuration file fgkf601.xml from github and store it on your synology
- use putty to login on synology as admin, use 'sudo sh' to get full rights, consider yourself responsible if something bad happens.
- use the cp command to copy the file fgkf601.xml to /usr/local/domoticz/Config/fibaro
- use 'ls -l' to see the owner and rights of the other files in the fibaro folder.
- use the chown command and chmod command to give the file fgkf601.xml the same owner and rights.
- go to /usr/local/domoticz/Config , you will see the file manufacturer_specific.xml . You will need to add your keyfob in the fibaro manufacturer section, between the other fibaro products. You do this by adding this line:
<Product type="1001" id="1000" name="FGKF601 Keyfob" config="fibaro/fgkf601.xml"/>
You can use vi or copy the file to a public folder, change it there and copy it back.
- I think it is time to restart Synology to make sure the new Config file is used.
- Add your device to your z-wave network
- In domoticz go to settings|hardware|OpenZwave|Node administration(Node beheer in Dutch)|command panel (bedieningspaneel in Dutch)
- Click on configuration, select the fgkf601, in functions, select group, in groups you select the key and the number corresponds to the node id of the device that is controlled with this key. Click on submit to program your keyfob.
To check the current values, click on current values instead of configuration.

I think this was it, please let me and others know if it worked.

Verstuurd vanaf mijn STF-L09 met Tapatalk

bwydoogh
Posts: 10
Joined: Monday 26 December 2016 12:21
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Fibaro Keyfob 601 FGKF-601

Post by bwydoogh » Friday 08 September 2017 14:16

Hi.

I don't get this up-and-running on my Domoticz installation.

I can include the Fibaro Keyfob correctly but no new devices (switches / button (or combination of buttons) ? ) are added to the list of available devices. And I don't understand what exactly you are meaning with that group configuration. Does that have any influence? Or what am I doing wrong or goes wrong here with my installation? I've attached some print screens of how the configuration looks like right now.

I would like to trigger the execution of some bash scripts from those buttons (for various kind of stuff, for example starting a radio stream on my Pi).

Any help is welcome.
Attachments
Screen Shot 2017-09-08 at 14.07.19.png
Screen Shot 2017-09-08 at 14.07.19.png (181.69 KiB) Viewed 330 times
Screen Shot 2017-09-08 at 14.09.08.png
Screen Shot 2017-09-08 at 14.09.08.png (221.37 KiB) Viewed 330 times

fosius
Posts: 1
Joined: Monday 23 October 2017 19:38
Target OS: -
Domoticz version:
Contact:

Re: Fibaro Keyfob 601 FGKF-601

Post by fosius » Monday 23 October 2017 19:40

Hi there,
I have the same problem as you.. Keyfob is included but I cannot see any new devices nor when creating a scene and I try to add activation device, it times out.

Kostunix
Posts: 5
Joined: Monday 25 April 2016 22:10
Target OS: Raspberry Pi
Domoticz version: V3.8153
Location: Utrecht
Contact:

Re: Fibaro Keyfob 601 FGKF-601

Post by Kostunix » Friday 03 November 2017 15:37

Stuck in the same problem as described above.

The Fibaro Keyfob is recognised (hardware tab) and I can create switches but with the switches I can not communicate.
Adding a device to a scene (Being one of the Fibaro Keyfob switches) does not work, timeout.

What do I have to do (step by step) to define a scene to be executed when I press a button on the Keyfob?

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests