Water (Pool) Temperature Sensor

Topics (not sure which fora)
when not sure where to post, post here and mods will move it to right forum.
aleph0
Posts: 60
Joined: Thursday 12 May 2016 15:47
Target OS: Linux
Domoticz version: 3.8564
Location: South of France
Contact:

Re: Water (Pool) Temperature Sensor

Post by aleph0 » Friday 11 May 2018 10:59

@multinet :
You can forget the 10k pull-up on the flowmeter, nothing change if it's there or not. I also advise NOT to use this flowmeter solution with a wemos as it creates a lot of reboot and I cannot find the reason for it. it's fine to use it with a *-Pi, but not with a wemos. Use a pressure sensor instead, it's easier to get it work reliably.

To link the dosing pumps to the pool, I'm using this kind of hardware : https://www.piscinemateriel.fr/traiteme ... ro-rx.html which is screwed in something like this https://www.piscinemateriel.fr/traiteme ... x1-2-.html It's a french only site, but I guess you can find the equivalent in any swimming pool shop

Custom sensors are fine for pH and ORP, that's what I'm using too

multinet
Posts: 122
Joined: Friday 05 December 2014 23:52
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Water (Pool) Temperature Sensor

Post by multinet » Friday 11 May 2018 20:27

Thanks Aleph for all you Help

unfortunatly I'm have a bug now : my sensors PH and Redox have value at the highest : 41 for ph and -9400 for redox

I remove the formula in wemos and i saw that value in mv are both at 65535 on wemos ads115 device page

I don't know why and i've checked all my links they seem OK

Do you have a trick to find where my bug could be. I've checked all my link they are OK
Capture d’écran 2018-05-11 à 20.26.19.jpg
Capture d’écran 2018-05-11 à 20.26.19.jpg (29.72 KiB) Viewed 260 times
Multinet
PI 2 - Domoticz 3.9208
RFXCOM - RFXtrx433 USB 433.92MHz Transceiver (5 DIO 54755 + 2 DIO 54756 + 3 DIO 54798)
Z-Wave.Me ZME_UZB1 USB Stick (6 FGSD002 + 2 FGRM222 + 1 FGS223 + 1 FGMS001-ZW5 + 1 FGRGBWM441 + 1 FGBS001 + 2 FGFS101)
6 sondes DS18B20

randytsuch
Posts: 95
Joined: Sunday 20 March 2016 19:56
Target OS: Raspberry Pi
Domoticz version: Beta
Location: LA, Ca USA
Contact:

Re: Water (Pool) Temperature Sensor

Post by randytsuch » Friday 11 May 2018 22:26

@aleph0
Thanks very much for the long, detailed reply.
Your results are very impressive. You should be proud of this system.

The issues with acid is why I don't plan to try adding an acid pump. I have a fiberglass pool, and don't have to add acid very often. If I could just automate chlorine, I would be very happy. I may get a ph probe later, to at least automate the ph checking and alert me when it's time to add acid.

Time to start collecting the pieces I will need to put this together.

Randy

aleph0
Posts: 60
Joined: Thursday 12 May 2016 15:47
Target OS: Linux
Domoticz version: 3.8564
Location: South of France
Contact:

Re: Water (Pool) Temperature Sensor

Post by aleph0 » Wednesday 16 May 2018 10:37

@multinet

I've had this behavior then I first built my pcb. I was a very thin piece of copper who short circuit the SDA or SCL (can't remember) track to the ground. Something so thin that I had to use a magnifier to find it

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests