Domoticz on Synology sometimes crashes from Zwave stick

Topics (not sure which fora)
when not sure where to post, post here and mods will move it to right forum.
Post Reply
sandeman684
Posts: 2
Joined: Sunday 08 January 2017 11:37
Target OS: NAS (Synology & others)
Domoticz version:
Contact:

Domoticz on Synology sometimes crashes from Zwave stick

Post by sandeman684 » Sunday 08 January 2017 11:46

Hi,

My Domoticz system (V3.5877) on my Synology NAS is usually working fine, but now and then (once or twice a week) it crashes and I have to manually restart it. When looking at the logs, it seems that it has something to do with my Zwave stick. Below are the last log lines from the crash last night:

Code: Select all

2017-01-08 00:38:30.495  Error: Z-Stick hardware (7) nothing received for more then 1 Hour!....
2017-01-08 00:38:31.495  Error: Restarting: Z-Stick
2017-01-08 00:38:31.629  OpenZWave: Closed
[32m2017-01-08 00:38:32.629 Always, ***************************************************************************
[39m[32m2017-01-08 00:38:32.629 Always, *********************  Cumulative Network Statistics  *********************
[39m[32m2017-01-08 00:38:32.630 Always, *** General
[39m[32m2017-01-08 00:38:32.630 Always, Driver run time: . .  . 0 days, 1 hours, 14 minutes
[39m[32m2017-01-08 00:38:32.630 Always, Frames processed: . . . . . . . . . . . . . . . . . . . . 51
[39m[32m2017-01-08 00:38:32.630 Always, Total messages successfully received: . . . . . . . . . . 51
[39m[32m2017-01-08 00:38:32.630 Always, Total Messages successfully sent: . . . . . . . . . . . . 24
[39m[32m2017-01-08 00:38:32.630 Always, ACKs received from controller:  . . . . . . . . . . . . . 24
[39m[32m2017-01-08 00:38:32.630 Always, *** Errors
[39m[32m2017-01-08 00:38:32.630 Always, Unsolicited messages received while waiting for ACK:  . . 0
[39m[32m2017-01-08 00:38:32.630 Always, Reads aborted due to timeouts:  . . . . . . . . . . . . . 0
[39m[32m2017-01-08 00:38:32.630 Always, Bad checksum errors:  . . . . . . . . . . . . . . . . . . 0
[39m[32m2017-01-08 00:38:32.630 Always, CANs received from controller:  . . . . . . . . . . . . . 0
[39m[32m2017-01-08 00:38:32.630 Always, NAKs received from controller:  . . . . . . . . . . . . . 0
[39m[32m2017-01-08 00:38:32.630 Always, Out of frame data flow errors:  . . . . . . . . . . . . . 0
[39m[32m2017-01-08 00:38:32.630 Always, Messages retransmitted: . . . . . . . . . . . . . . . . . 0
[39m[32m2017-01-08 00:38:32.630 Always, Messages dropped and not delivered: . . . . . . . . . . . 1
[39m[32m2017-01-08 00:38:32.630 Always, ***************************************************************************
[39m2017-01-08 00:38:35.149  OpenZWave: Starting...
2017-01-08 00:38:35.149  OpenZWave: Version: 1.4-2246-ga583ba8-dirty
2017-01-08 00:38:35.149  OpenZWave: using config in: /usr/local/domoticz/Config/
[32m2017-01-08 00:38:35.151 Always, OpenZwave Version 1.4.2246 Starting Up
[39m2017-01-08 00:38:35.331  OpenZWave: Driver Ready
2017-01-08 00:38:35.333  OpenZWave: Value_Added: Node: 6 (0x06), CommandClass: SWITCH BINARY, Label: Switch, Instance: 1
2017-01-08 00:38:35.333  OpenZWave: Value_Added: Node: 6 (0x06), CommandClass: SWITCH TOGGLE BINARY, Label: Toggle Switch, Instance: 1
2017-01-08 00:38:35.333  OpenZWave: Unhandled class: 0x28 (SWITCH TOGGLE BINARY), NodeID: 6 (0x06), Index: 0, Instance: 1
2017-01-08 00:38:35.334  OpenZWave: Value_Added: Node: 11 (0x0b), CommandClass: SWITCH BINARY, Label: Switch, Instance: 1
2017-01-08 00:38:35.334  OpenZWave: Value_Added: Node: 11 (0x0b), CommandClass: SWITCH TOGGLE BINARY, Label: Toggle Switch, Instance: 1
2017-01-08 00:38:35.334  OpenZWave: Unhandled class: 0x28 (SWITCH TOGGLE BINARY), NodeID: 11 (0x0b), Index: 0, Instance: 1
2017-01-08 00:38:37.709  OpenZWave: Awake Nodes queried
terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::thread_resource_error> >'
  what():  boost::thread_resource_error: Resource temporarily unavailable
Does anybody have any idea how to fix this?

Thnx, Sander.

sandeman684
Posts: 2
Joined: Sunday 08 January 2017 11:37
Target OS: NAS (Synology & others)
Domoticz version:
Contact:

Re: Domoticz on Synology sometimes crashes from Zwave stick

Post by sandeman684 » Saturday 14 January 2017 14:48

Anybody any idea about this issue? Should I post it in the bugs forum?

dirkiededeur
Posts: 2
Joined: Saturday 08 April 2017 9:46
Target OS: NAS (Synology & others)
Domoticz version:
Contact:

Re: Domoticz on Synology sometimes crashes from Zwave stick

Post by dirkiededeur » Saturday 20 January 2018 12:23

Hi Sandeman684,

I'm having exactly the same problem. Did you find a solution?

febalci
Posts: 339
Joined: Monday 03 July 2017 19:58
Target OS: NAS (Synology & others)
Domoticz version:
Contact:

Re: Domoticz on Synology sometimes crashes from Zwave stick

Post by febalci » Saturday 20 January 2018 12:32

Sounds like an issue with boost (python module); i remember some issues compiling domoticz on osx. I solved it by downgrading boost package from 1.66 to 1.59. Maybe you can give it a try??

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests