Missing settings for IFTTT notifications

Topics (not sure which fora)
when not sure where to post, post here and mods will move it to right forum.
Post Reply
tgg3
Posts: 9
Joined: Monday 14 May 2018 9:42
Target OS: Raspberry Pi
Domoticz version: 4.9700
Contact:

Missing settings for IFTTT notifications

Post by tgg3 » Wednesday 16 May 2018 16:18

I don't see the IFTTT settings in Settings->Notifications. I'm running the latest beta (3.9443), although I'd prefer to be on the stable version. I'm a new Domoticz user, so perhaps I doing something stupid. Any help would be appreciated.

Thanks much.
Tom

User avatar
waaren
Posts: 687
Joined: Tuesday 03 January 2017 15:18
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: Missing settings for IFTTT notifications

Post by waaren » Wednesday 16 May 2018 16:55

tgg3 wrote:
Wednesday 16 May 2018 16:18
I don't see the IFTTT settings in Settings->Notifications. I'm running the latest beta (3.9443), although I'd prefer to be on the stable version. I'm a new Domoticz user, so perhaps I doing something stupid. Any help would be appreciated.

Thanks much.
It should be there
Notification settings.PNG
Notification settings screen
Notification settings.PNG (293.65 KiB) Viewed 288 times
Raspberry (debian stretch via berryboot on Synology DS916+) , Domoticz (almost) latest Beta, , dzVents 2.6, RFLink, RFXtrx433e, P1, Youless, Harmony, Hue, Yeelight, Xiaomi, HomeWizard, Zwave, Amazon echo

tgg3
Posts: 9
Joined: Monday 14 May 2018 9:42
Target OS: Raspberry Pi
Domoticz version: 4.9700
Contact:

Re: Missing settings for IFTTT notifications

Post by tgg3 » Wednesday 16 May 2018 17:14

Unfortunately, it is missing from my installation. For a few days I had 3.9424 installed and it was there. I reinstalled Raspbian Stretch on a new Ras Pi 3 B+ (along with libssl1.0.0), then installed the latest stable release, then updated to the current beta. I didn't see it in the stable either.

Is there something in my installation of Domoticz or Stretch that could prevent the IFTTT settings from showing?
Attachments
2018-05-16 23_05_32-Domoticz.png
2018-05-16 23_05_32-Domoticz.png (235.21 KiB) Viewed 287 times
Tom

User avatar
waaren
Posts: 687
Joined: Tuesday 03 January 2017 15:18
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: Missing settings for IFTTT notifications

Post by waaren » Wednesday 16 May 2018 18:11

I can only think of a cache related problem. Did you clear all the caches ? including chrome://appcache-internals/#

you could also check the domoticz database

sqlite3 domoticz.db
select * from Preferences where key like "%IFTT%";
Raspberry (debian stretch via berryboot on Synology DS916+) , Domoticz (almost) latest Beta, , dzVents 2.6, RFLink, RFXtrx433e, P1, Youless, Harmony, Hue, Yeelight, Xiaomi, HomeWizard, Zwave, Amazon echo

tgg3
Posts: 9
Joined: Monday 14 May 2018 9:42
Target OS: Raspberry Pi
Domoticz version: 4.9700
Contact:

Re: Missing settings for IFTTT notifications

Post by tgg3 » Thursday 17 May 2018 4:57

Bingo! It was a cache problem. Plus, I can now see the Telegram notification settings too.

More details for anyone else that might have this problem:
I was using Firefox on Windows 10 (sorry I didn't mention that). After your last message I tried Chrome and Edge and they both worked correctly. Just clearing the cache in Firefox didn't fix the problem. I had to go into Options->Privacy & Security->Cookies and Site Data->Manage Data->search for the IP address of my Domoticz server->click on the server->Remove Selected->Save Changes.

Thanks much @waaren for the help!
Tom

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests