OTGW: No messages in the log..only timesatamp with OTGW:

For OpenTherm-gateway related questions in Domoticz
CaptainSlow
Posts: 27
Joined: Thursday 08 December 2016 22:07
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bussum
Contact:

OTGW: No messages in the log..only timesatamp with OTGW:

Postby CaptainSlow » Saturday 07 January 2017 11:06

Gents,

I've got ESP-12 with ESP-Link + OTGW + Remeha Tzerra with built in gateway and eTwist thermostat setup. Wifi to serial connection to the OTGW is no problem as I can in the logs. Every minute I see "OTGW:" passing by.....but I don't see any messages!.... Also on the ESP-Link embedded website when I check the uC console I see no messages at all.

Both the boiler and the thermostat have been connected to the OTGW at the OT terminals but somehow no messages are picked up.

any idea's...I would love to make this work but I haven't seen anybody else with a Remeha Tzerra yet....

Willem

CaptainSlow
Posts: 27
Joined: Thursday 08 December 2016 22:07
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bussum
Contact:

Re: OTGW: No messages in the log..only timesatamp with OTGW:

Postby CaptainSlow » Saturday 07 January 2017 11:39

I changed the baudrate in esp-link to 9600 and hten I got this in uC console and pretty much the same in th elogs of domoticz
Image

any idea's

willem

CaptainSlow
Posts: 27
Joined: Thursday 08 December 2016 22:07
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bussum
Contact:

Re: OTGW: No messages in the log..only timesatamp with OTGW:

Postby CaptainSlow » Saturday 07 January 2017 11:40

logs.PNG
logs.PNG (29.68 KiB) Viewed 158 times
console.PNG
console.PNG (34.85 KiB) Viewed 158 times

sincze
Posts: 521
Joined: Monday 02 June 2014 22:46
Target OS: Linux
Domoticz version: 3.6179
Location: Netherlands
Contact:

Re: OTGW: No messages in the log..only timesatamp with OTGW:

Postby sincze » Saturday 07 January 2017 12:27

Yo have the diagnostic firmware. Not the 4.2.5 :) please complete the tests and update firmware

Sent from my SM-G925F using Tapatalk

CaptainSlow
Posts: 27
Joined: Thursday 08 December 2016 22:07
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bussum
Contact:

Re: OTGW: No messages in the log..only timesatamp with OTGW:

Postby CaptainSlow » Saturday 07 January 2017 14:56

Ok thx...thought it came automatically with the lastest firmware. I uploaded the 4.2.5 gateway.hex to the gateway. I had to reset it manually before the upload started.
That worked out and the error 03 messages came flying in :lol: :lol:
Had to fidle with the voltage on the gateway. I tested all 10 possible postitions and it turned out only VR=1 gave me zero error 03's
It looks ok as it is now but I need to check the actual displayed values. I've got a lot of devices showing up at least.
Capture.PNG
Capture.PNG (150.18 KiB) Viewed 138 times
photo65853222177321789.jpg
photo65853222177321789.jpg (128.97 KiB) Viewed 138 times

sincze
Posts: 521
Joined: Monday 02 June 2014 22:46
Target OS: Linux
Domoticz version: 3.6179
Location: Netherlands
Contact:

Re: OTGW: No messages in the log..only timesatamp with OTGW:

Postby sincze » Sunday 08 January 2017 3:32

Great news. Looks okay :) you don't need them all :)

Sent from my SM-G925F using Tapatalk

sincze
Posts: 521
Joined: Monday 02 June 2014 22:46
Target OS: Linux
Domoticz version: 3.6179
Location: Netherlands
Contact:

Re: OTGW: No messages in the log..only timesatamp with OTGW:

Postby sincze » Sunday 08 January 2017 3:35

Was it hard to convert to esp??

Sent from my SM-G925F using Tapatalk

CaptainSlow
Posts: 27
Joined: Thursday 08 December 2016 22:07
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bussum
Contact:

Re: OTGW: No messages in the log..only timesatamp with OTGW:

Postby CaptainSlow » Sunday 08 January 2017 11:31

No, it wasn't although I had to sort out and install quite some stuff to get it all working.
I used the ESP-12 wifi to serial bridge in conjunction with https://github.com/jeelabs/esp-link/releases/tag/v2.2.3
In order to get that firmware ON the ESP-12 I had to install this bootloader utility https://github.com/espressif/esptool....but..in order to install this utility I first had to install python and pip :twisted: :twisted: :twisted: on the Rasp PI 3. I used python 2.7 systemwide (as root).
Together with USB to serial cable which came nicely with the OTGW (usb-type) from kiwi I could flash the ESP-LINK firmware quite easily on to the wifi bridge.
All in all quite a hassle if you don't have all the software tools and knowledge how to install run or operate them but in the end it went reasonable smooth.
ws.jpg
ws.jpg (49.91 KiB) Viewed 115 times
ustoserial.jpg
ustoserial.jpg (52.28 KiB) Viewed 115 times
OTGW-KIT-USB-2-1000x667.jpg
OTGW-KIT-USB-2-1000x667.jpg (170.62 KiB) Viewed 115 times

sincze
Posts: 521
Joined: Monday 02 June 2014 22:46
Target OS: Linux
Domoticz version: 3.6179
Location: Netherlands
Contact:

Re: OTGW: No messages in the log..only timesatamp with OTGW:

Postby sincze » Sunday 08 January 2017 12:09

Aha nice. That means I can convert my OTGW - USB to ESP as well. Only have esp-01 so I will have to buy the 12. Connect all the wires to main pcb and esp? . I believe with usb cable 1 should not be attached

Sent from my SM-G925F using Tapatalk

sincze
Posts: 521
Joined: Monday 02 June 2014 22:46
Target OS: Linux
Domoticz version: 3.6179
Location: Netherlands
Contact:

Re: OTGW: No messages in the log..only timesatamp with OTGW:

Postby sincze » Sunday 08 January 2017 12:13

https://balk.tweakblogs.net/blog/13147/ ... r-domoticz this I have to study as well

Sent from my SM-G925F using Tapatalk

sincze
Posts: 521
Joined: Monday 02 June 2014 22:46
Target OS: Linux
Domoticz version: 3.6179
Location: Netherlands
Contact:

Re: OTGW: No messages in the log..only timesatamp with OTGW:

Postby sincze » Sunday 08 January 2017 12:30

Aha and esp 01 should be able to do the trick as well. http://rayshobby.net/first-impression-o ... fi-module/

Sent from my SM-G925F using Tapatalk

CaptainSlow
Posts: 27
Joined: Thursday 08 December 2016 22:07
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bussum
Contact:

Re: OTGW: No messages in the log..only timesatamp with OTGW:

Postby CaptainSlow » Sunday 08 January 2017 13:33

I'm pretty sure it will. The ESP-01 is also supported by ESP-LINK. https://github.com/jeelabs/esp-link/blo ... LASHING.md

goldman541
Posts: 8
Joined: Saturday 19 November 2016 16:20
Target OS: Raspberry Pi
Domoticz version: 3.5877
Contact:

Re: OTGW: No messages in the log..only timesatamp with OTGW:

Postby goldman541 » Sunday 08 January 2017 16:40

I have the same esp8266mod but i didn't get it flasht with the esp-link software can you help me with that?

Verstuurd vanaf mijn SM-G920F met Tapatalk

CaptainSlow
Posts: 27
Joined: Thursday 08 December 2016 22:07
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bussum
Contact:

Re: OTGW: No messages in the log..only timesatamp with OTGW:

Postby CaptainSlow » Monday 09 January 2017 10:56

Sure what kind of setup are you running?
I have a raspberry PI 3 on which I run domoticz beta (jessie image). I had to install python 2.7 and pip first on order to install the esptool / bootloader utility which actually does the flashing.
You also need a USB to serial cable to connect the wifi to serial bridge to your raspberry / pc or whatever machine you will be running the esptool on.

First you download the ESP-Link software with this command

Code: Select all

curl -L https://github.com/jeelabs/esp-link/releases/download/v2.2.3/esp-link-v2.2.3.tgz | \
    tar xzf -


For installation of the esptool check this first and follow the instructions
https://github.com/espressif/esptool

To check if the esptool is working correctly type in the command

Code: Select all

esptool.py -h

If you see something like this you're all fine:)
esptool.jpg
esptool.jpg (189.8 KiB) Viewed 84 times


Put the wifi to serial bridge in programming mode with the switch on the board and reset it by pushing the reset button
The execute these commands which initiates the actually flashing....
Done....

Code: Select all

cd esp-link-v2.2.3
esptool.py --port /dev/ttyUSB0 --baud 460800 write_flash -fs 32m -ff 80m \
    0x00000 boot_v1.5.bin 0x1000 user1.bin 0x3FE000 blank.bin

goldman541
Posts: 8
Joined: Saturday 19 November 2016 16:20
Target OS: Raspberry Pi
Domoticz version: 3.5877
Contact:

Re: OTGW: No messages in the log..only timesatamp with OTGW:

Postby goldman541 » Monday 09 January 2017 21:37

I have also a raspberry 3 with domoticz on it, but with debian and have esptool installed with pip
bet when put in the last code i get this

Code: Select all

[email protected]:~/esp-link-v2.2.3 $ esptool.py --port /dev/ttyUSB0 --baud 460800 write_flash -fs 32m -ff 80m \
>     0x00000 boot_v1.5.bin 0x1000 user1.bin 0x3FE000 blank.bin
esptool.py v1.3-dev
Connecting...

A fatal error occurred: Failed to connect to ESP8266


I've also changed the target to a different USB,
but then I get the same error
this is the dmesg from the pi

Code: Select all

[email protected]:~ $ dmesg | grep tty
[    0.000000] Kernel command line: 8250.nr_uarts=1 dma.dmachans=0x7f35 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2709.boardrev=0xa02082 bcm2709.serial=0xe0ab1191 smsc95xx.macaddr=B8:27:EB:AB:11:91 bcm2708_fb.fbswap=1 bcm2709.uart_clock=48000000 vc_mem.mem_base=0x3dc00000 vc_mem.mem_size=0x3f000000  dwc_otg.lpm_enable=0 console=tty1 console=ttyS0,115200 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
[    0.001338] console [tty1] enabled
[    0.281610] console [ttyS0] disabled
[    0.284049] 3f215040.uart: ttyS0 at MMIO 0x3f215040 (irq = 59, base_baud = 31250000) is a 16550
[    1.019884] console [ttyS0] enabled
[    3.019848] 3f201000.uart: ttyAMA0 at MMIO 0x3f201000 (irq = 87, base_baud = 0) is a PL011 rev2
[    4.428012] systemd[1]: Expecting device dev-ttyS0.device...
[    5.093496] systemd[1]: Starting system-serial\x2dgetty.slice.
[    5.102164] systemd[1]: Created slice system-serial\x2dgetty.slice.
[    7.884257] usb 1-1.3: FTDI USB Serial Device converter now attached to ttyUSB0
[108961.433001] usb 1-1.2: pl2303 converter now attached to ttyUSB1

CaptainSlow
Posts: 27
Joined: Thursday 08 December 2016 22:07
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bussum
Contact:

Re: OTGW: No messages in the log..only timesatamp with OTGW:

Postby CaptainSlow » Monday 09 January 2017 23:25

The only difference I see is that I run esptool 1.2.1 and you run 1.3 dev.
I reckon you have resetted the wifi bridge a couple of times and put the switch in program mode.
Are you sure you have wired the TX to RX and RX to TX on the header of the wifi bridge?

willem

goldman541
Posts: 8
Joined: Saturday 19 November 2016 16:20
Target OS: Raspberry Pi
Domoticz version: 3.5877
Contact:

Re: OTGW: No messages in the log..only timesatamp with OTGW:

Postby goldman541 » Monday 09 January 2017 23:31

it was the tx and the rx :oops:
but can i now chance the switch and reset esp ?

rjblake
Posts: 41
Joined: Friday 21 October 2016 9:25
Target OS: -
Domoticz version:
Contact:

Re: OTGW: No messages in the log..only timesatamp with OTGW:

Postby rjblake » Monday 09 January 2017 23:55

Watch out using the ESP-01 connected directly to any of the 5VDC connection on the OTGW - they are mainly rated no higher than 3.6VDC, unless you have a version rated at >5VDC. If so, you'll need a level shifter or risk frying the ESP :(

Also note that there is on occassion a strange boot sequencing problem that puts the OTGW into an 'unknown' state. To correct this, power on OTGW & ESP (if powered by OTGW) then reset the OTGW (either momentary switch connected to the RST pins, or short them briefly), then reset the ESP

CaptainSlow
Posts: 27
Joined: Thursday 08 December 2016 22:07
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Bussum
Contact:

Re: OTGW: No messages in the log..only timesatamp with OTGW:

Postby CaptainSlow » Tuesday 10 January 2017 6:33

goldman541 wrote:it was the tx and the rx :oops:
but can i now chance the switch and reset esp ?


Glad you found that quickly. You can now put the switch back to uart and reset the button as many times as you want. Basically the reset button cuts the power and the controller boots up. I doesn't affect the firmware you just loaded.

w.

goldman541
Posts: 8
Joined: Saturday 19 November 2016 16:20
Target OS: Raspberry Pi
Domoticz version: 3.5877
Contact:

Re: OTGW: No messages in the log..only timesatamp with OTGW:

Postby goldman541 » Tuesday 10 January 2017 22:22

the esp is working thanks for that.
but the thermostat is giving a error: aansluit fout
and the boiler is not working but i get the messages in domoticz

Code: Select all

2017-01-10 21:36:24.239 OTGW: PR: BV
2017-01-10 21:36:24.242 (thermostaat) Temp (Control Setpoint)
2017-01-10 21:36:24.245 (thermostaat) Thermostat (Room Setpoint)
2017-01-10 21:36:24.248 (thermostaat) Temp (Room Temperature)
2017-01-10 21:36:24.250 (thermostaat) Temp (Boiler Water Temperature)
2017-01-10 21:36:24.251 (thermostaat) Temp (DHW Temperature)
2017-01-10 21:36:24.253 (thermostaat) Temp (Outside Temperature)
2017-01-10 21:36:24.255 (thermostaat) Temp (Return Water Temperature)
2017-01-10 21:36:24.256 (thermostaat) Thermostat (DHW Setpoint)
2017-01-10 21:36:24.260 (thermostaat) Thermostat (Max_CH Water Setpoint)


Return to “OpenTherm gateway”

Who is online

Users browsing this forum: No registered users and 1 guest