Razberry Getting your device supported (deprecated)

For Z-Wave related questions in Domoticz
Post Reply
User avatar
gizmocuz
Posts: 8704
Joined: Thursday 11 July 2013 18:59
Target OS: Raspberry Pi
Domoticz version: beta
Location: Top of the world
Contact:

Razberry Getting your device supported (deprecated)

Post by gizmocuz » Friday 01 November 2013 10:11

Support for the native Razberry implementation is deprecated, you have to use the OpenZWave method

There are a lot of Z-Wave hardware, and it could be your device is not included (yet).

This is an example for a switch, make sure the switch if off

To get your device supported email/attach the below results ( info @ domoticz . com):
http://IPADDRESS:8083/ZWaveAPI/Data/0

then copy the value of 'updateTime' that you can find at the bottom.

press the switch (ON), then send me the output of:
http://IPADDRESS:8083/ZWaveAPI/Data/UPDATETIMEVALUE

then copy the value of 'updateTime' that you can find at the bottom.

switch the switch (OFF), then send me the output of:
http://IPADDRESS:8083/ZWaveAPI/Data/UPDATETIMEVALUE

User avatar
ro.
Posts: 104
Joined: Thursday 10 October 2013 16:05
Target OS: Linux
Domoticz version: 2.3476
Location: UK
Contact:

Re: Getting your device supported

Post by ro. » Friday 14 February 2014 13:22

Are these instructions only for some specific z-wave hardware? I have domoticz working with an Aeon Labs Z-Stick but don't see anything listening on port 8083. I have set "Enable Debug" to 1 on the controller and see stuff in the output log from a Philio multi-sensor (below), is this helpful?

(When I trigger reed switch)
2014-02-14 09:45:03.458 Node005, Received: 0x01, 0x0a, 0x00, 0x04, 0x00, 0x05, 0x04, 0x30, 0x03, 0xff, 0x0a, 0x36
2014-02-14 09:45:03.458 Node005, Received SensorBinary report: State=On
2014-02-14 09:45:03.458 Node005, Refreshed Value: old value=false, new value=true, type=bool
Fri Feb 14 09:45:03 2014 (Aeon) Lighting 2 (philio)

(When I trigger PIR)
2014-02-14 10:03:03.646 Node005, Received: 0x01, 0x0a, 0x00, 0x04, 0x00, 0x05, 0x04, 0x30, 0x03, 0xff, 0x0c, 0x30
2014-02-14 10:03:03.646 Node005, Received SensorBinary report: State=On
2014-02-14 10:03:03.646 Node005, Refreshed Value: old value=true, new value=true, type=bool

glassen
Posts: 9
Joined: Thursday 13 February 2014 16:48
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Getting your device supported

Post by glassen » Friday 14 February 2014 13:46

gizmocuz wrote:There are a lot of Z-Wave hardware, and it could be your device is not included (yet).

This is an example for a switch, make sure the switch if off

To get your device supported email/attach the below results ( info @ domoticz . com):
http://IPADDRESS:8083/ZWaveAPI/Data/0

then copy the value of 'updateTime' that you can find at the bottom.

press the switch (ON), then send me the output of:
http://IPADDRESS:8083/ZWaveAPI/Data/UPDATETIMEVALUE

then copy the value of 'updateTime' that you can find at the bottom.

switch the switch (OFF), then send me the output of:
http://IPADDRESS:8083/ZWaveAPI/Data/UPDATETIMEVALUE
I believe these instructions are only for those who have a Raspberry Pi with the Zwave.me RaZberry ZWave module (http://razberry.z-wave.me/)

gertjuhh

Re: Getting your device supported

Post by gertjuhh » Tuesday 25 February 2014 17:17

Could these instructions please be updated to include how to get devices supported thru OpenZWave?

Robert
Posts: 83
Joined: Saturday 01 March 2014 19:48
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Getting your device supported

Post by Robert » Saturday 01 March 2014 20:02

Same request by me. I'm using Aeon "Aeotec z-stick S2" with Fibaro and X10 devices in combination with Raspberry.
Because my first careful steps with Domoticz, I'm already missing some important features. No, Dimming with X10 modules and windows shutters can only open complete or closing complete :D .
I appreciate any help!

jili
Posts: 78
Joined: Sunday 09 February 2014 16:27
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Getting your device supported

Post by jili » Sunday 23 March 2014 17:03

Same thing I'm owner of an aeon z2 stick.

I've got some zwave devices not known like fibaro roller shutter first version "FIBARO System Unknown: type=0300, id=0104".

For users which don't have a razberry what is the awy please ?

User avatar
gizmocuz
Posts: 8704
Joined: Thursday 11 July 2013 18:59
Target OS: Raspberry Pi
Domoticz version: beta
Location: Top of the world
Contact:

Re: Getting your device supported

Post by gizmocuz » Sunday 23 March 2014 17:36

you have to ask this on the openzwave forum

about x10, this is known and can be found on our forum/wiki

roller shutters, buy the new fibaro (version2) this can be controlled by percentage
Quality outlives Quantity!

jili
Posts: 78
Joined: Sunday 09 February 2014 16:27
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Getting your device supported

Post by jili » Sunday 23 March 2014 21:58

Gizmocuz,

Do you know the best way to update domoticz if the file "manufacturer_specific.xml" is changed.

As I said "FIBARO System Unknown: type=0300, id=0104". is in fact for id a version of my fgr221.

So I modify my file how update that in domoticz ?

User avatar
gizmocuz
Posts: 8704
Joined: Thursday 11 July 2013 18:59
Target OS: Raspberry Pi
Domoticz version: beta
Location: Top of the world
Contact:

Re: Getting your device supported

Post by gizmocuz » Sunday 23 March 2014 22:02

You have to ask this question on the openzwave Forum else it will be overwritten on the next update, propose the new device
Quality outlives Quantity!

jili
Posts: 78
Joined: Sunday 09 February 2014 16:27
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Getting your device supported

Post by jili » Thursday 27 March 2014 14:30

Hi Gizmocuz,

I will see with openzwave guys but the problem is that some zwave devices like fibaro use the id to show a version (if I'm not wrong).

I saw in openzwave group that for the moment they will do nothing as they don't agree together.

So I'm trapped. I'm between your dev and openzwave.

Like linux system with "conf.d" when you upgrade domoticz can you use a directory which isn't write and override your default conf for manufacturer ?

User avatar
gizmocuz
Posts: 8704
Joined: Thursday 11 July 2013 18:59
Target OS: Raspberry Pi
Domoticz version: beta
Location: Top of the world
Contact:

Re: Getting your device supported

Post by gizmocuz » Thursday 27 March 2014 15:31

according this website the ID is 0x300 / 0x103

http://www.pepper1.net/zwavedb/device/335

This is also used in Razberry
Quality outlives Quantity!

jili
Posts: 78
Joined: Sunday 09 February 2014 16:27
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Getting your device supported

Post by jili » Thursday 03 April 2014 22:04

Exactly according to this website (which is not complete for all countries) and for that country 0x300 has 0x103 but mine is 0x104 as in EU zone (868 MHz frequency).

Many product had differents product id, it depend of country,etc ...

I Ask openzwave team to update their manufacturers datas but it seems to be long to be update as no answer for the moment.

thaui
Posts: 61
Joined: Sunday 15 March 2015 20:53
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Getting your device supported

Post by thaui » Sunday 05 April 2015 21:00

I guess that the most critical question at the moment. Since we see the Gen5 Sensors with many good features but they are more or less not supported at all. I tried to get my sensonsors added to the OZW database but I was not very successful. I guess the OZW guys have to many requests. Currently they are working on AEON devices because this company made a donation on devices. Maybe also EU Versions are not their topic. However until now I have no good impression on Gen 5 devices from Philio and Vision. Let's hope it will change in the next months otherwise an excellent tool like Domoticz will suffer under the lack of missing devices.

jensc
Posts: 47
Joined: Saturday 12 March 2016 2:49
Target OS: Windows
Domoticz version: 3.5494
Location: Columbia City, Oregon, USA
Contact:

Re: Getting your device supported

Post by jensc » Saturday 12 March 2016 3:08

Giz,

The GE 456xx line of products (dimmers, switches, etc.) has now been replaced with the GE 127xx line. Same products with different packaging for consumer and commercial customers. I can't add the new GE "12718 Z-Wave Wireless Lighting Lamp Module with Dimmer Control" I just bought though it's control variables are identical to GE 45602 Lamp Dimmer Module. Is there some way to tell Domoticz to treat it like a 45602, of which I already have many. It's in the "products.xml" file at OpenZwave so they at least know about it. It's currently recognized by the ZStick as "GE Unknown: type=5044, id=3031".

venyv
Posts: 27
Joined: Thursday 05 November 2015 4:37
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Getting your device supported

Post by venyv » Monday 21 March 2016 16:11

Is there a similar URL that works on Synology to see the Data of a node?

tontze
Posts: 335
Joined: Thursday 12 January 2017 16:30
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Getting your device supported

Post by tontze » Thursday 09 February 2017 21:57

About Fibaro FGK-10x with temp sensor ..

According to http://products.z-wavealliance.org/products/1356

It says Product Type ID: 0x0702, Product ID: 0x1002, but in Domoticz : type 0x0701, ID 0x1001

Could this be reason, that my attached temp sensor is not shown as a device at all ? How can i fix this ?

-T
-----------------------------------------
Rpi 3 / Razberry 2
RFLink 433mhz / Nrf 2.4Ghz
Mi Light
ESP82xx

jensc
Posts: 47
Joined: Saturday 12 March 2016 2:49
Target OS: Windows
Domoticz version: 3.5494
Location: Columbia City, Oregon, USA
Contact:

Re: Getting your device supported

Post by jensc » Sunday 12 February 2017 8:24

Bump.

tontze
Posts: 335
Joined: Thursday 12 January 2017 16:30
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Razberry Getting your device supported (deprecated)

Post by tontze » Sunday 25 February 2018 11:09

Here is instructions how do you do your own .xml and add it to OZW, and if it works, send it to OZW staff also.

https://github.com/OpenZWave/open-zwave ... ng-Devices

For me, guide is too complex tho :)
-----------------------------------------
Rpi 3 / Razberry 2
RFLink 433mhz / Nrf 2.4Ghz
Mi Light
ESP82xx

klirik
Posts: 5
Joined: Tuesday 10 July 2018 5:00
Target OS: Linux
Domoticz version: Beta
Location: Novosibirsk, RU
Contact:

Re: Razberry Getting your device supported (deprecated)

Post by klirik » Tuesday 17 July 2018 16:15

Well, I've moved my razberry card from raspberry pi driven by z-way server into cubietruck with domotics.
Without being reset the card keeped whole topology memorized, so in domoticz it immediately found all my devices (but many with vid/gid = 000/000).
I've just initiated inclusion for these devices - and they were 'refreshed' by actual values.

However one thing which I love on z-way I can't still run on ozw: that is automation on events.
I mean, any events, not only defined scenes.
Say, I had the rule on z-way to run predefined (soft) scene when double-clicking one of the switches (switch is simple fibaro without scene functionality); it just sends usual basic 'double clicked' event to controller as if it is an actuator - and z-way catches such event and allows me to react any way I want. Another simple events - like 'begin dimming' 'end dimming' - when long press the button on the dimmer - is also able to be catched by z-way and so, authomatized.

Does something like it possible with ozw? For now I see that for nodes just some sensors/switches may be auto-created, but if they omited - how could I 'catch' the events? For example, 0x0012/0x0003 - which is DSC18103 Aeotec micro smart switch - when added creates only the switch. But actually I see in the log many reports from this device ' OpenZWave: Value_Added: Node: 36 (0x24), CommandClass: METER, Label: Unknown, Instance: 1', and I know in z-way it reported different metrics like power, volts, consumed energy, etc. Here no extra dev (sensor) is created, however events still reported! How can I catch them?

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 2 guests