New Aeon Labs Multisensor Gen5 not supported in OpenZwave ?

For Z-Wave related questions in Domoticz
Het-Licht
Posts: 33
Joined: Monday 14 July 2014 21:16
Target OS: Raspberry Pi
Domoticz version:
Location: Nederland
Contact:

Re: New Aeon Labs Multisensor Gen5 not supported in OpenZwav

Post by Het-Licht » Monday 02 March 2015 11:31

Will do, when I'm home tonight...

xces
Posts: 56
Joined: Thursday 05 February 2015 10:02
Target OS: Raspberry Pi
Domoticz version:
Location: Netherlands
Contact:

Re: New Aeon Labs Multisensor Gen5 not supported in OpenZwav

Post by xces » Monday 02 March 2015 21:30

Can you also post the zwave version you are using and the domoticz version you are using, just to exclude that my 'newest' version might be the problem...

Het-Licht
Posts: 33
Joined: Monday 14 July 2014 21:16
Target OS: Raspberry Pi
Domoticz version:
Location: Nederland
Contact:

Re: New Aeon Labs Multisensor Gen5 not supported in OpenZwav

Post by Het-Licht » Monday 02 March 2015 23:51

<?xml version="1.0" encoding="utf-8"?>
<!-- Aeon Labs Multi Sensor -->
<Product xmlns='http://code.google.com/p/open-zwave/'>

<!-- Configuration Parameters -->
<CommandClass id="112">
<Value type="list" index="2" genre="config" label="Wake up 10 minutes when batteries are inserted" min="0" max="1" value="0" size="1">
<Help>Stay awake for 10 minutes after batteries are inserted</Help>
<Item label="No" value="0" />
<Item label="Yes" value="1" />
</Value>
<Value type="short" index="3" genre="config" label="On time" units="seconds" min="1" max="15300" value="240">
<Help>How long should the device associated to multi sensor keep state On before sending it Off command (if the value is bigger than 255, the value would be rounded to next integer in minutes)</Help>
</Value>
<Value type="list" index="4" genre="config" label="Enable Motion Sensor" min="0" max="1" value="1" size="1">
<Help>Enable Motion Sensor</Help>
<Item label="Disabled" value="0" />
<Item label="Enabled" value="1" />
</Value>
<Value type="list" index="5" genre="config" label="Command Options" min="1" max="2" value="1" size="1">
<Help>Which commands to send when PIR motion sensor triggered</Help>
<Item label="Basic Set (default) " value="1" />
<Item label="Binary Sensor Report" value="2" />
</Value>
<Value type="int" index="100" genre="config" label="Reset #101-103" value="0" write_only="true" affects="101,102,103">
<Help>Reset to default parameters number 101-103. Any value other then 0 will initiate this reset.</Help>
</Value>
<Value type="int" index="101" genre="config" label="Group 1 Reports" units="" value="0">
<Help>Which reports need to send automatically in timing intervals for group 1. Bitsets: 0 -> Battery report, 5 -> Temperature, 6 -> Humidity, 7 -> Luminosity</Help>
</Value>
<Value type="int" index="102" genre="config" label="Group 2 Reports" value="0">
<Help>Which reports need to send automatically in timing intervals for group 2. Bitsets: 0 -> Battery report, 5 -> Temperature, 6 -> Humidity, 7 -> Luminosity</Help>
</Value>
<Value type="int" index="103" genre="config" label="Group 3 Reports" value="0">
<Help>Which reports need to send automatically in timing intervals for group 3. Bitsets: 0 -> Battery report, 5 -> Temperature, 6 -> Humidity, 7 -> Luminosity</Help>
</Value>
<Value type="int" index="110" genre="config" label="Reset #111-113" value="0" write_only="true" affects="111,112,113">
<Help>Reset to default parameters number 111-113. Any value other then 0 will initiate this reset.</Help>
</Value>
<Value type="int" index="111" genre="config" label="Group 1 Interval" units="seconds" min="1" max="2678400" value="720">
<Help>The interval of sending report group 1. 1 to 2678400 seconds</Help>
</Value>
<Value type="int" index="112" genre="config" label="Group 2 Interval" units="seconds" min="1" max="2678400" value="720">
<Help>The interval of sending report group 2. 1 to 2678400 seconds</Help>
</Value>
<Value type="int" index="113" genre="config" label="Group 3 Interval" units="seconds" min="1" max="2678400" value="720">
<Help>The interval of sending report group 3. 1 to 2678400 seconds</Help>
</Value>
<Value type="button" index="255" genre="config" label="Reset to default" write_only="true" value="0" >
<Help>Reset to factory defaults.</Help>
</Value>
</CommandClass>

<!-- Basic set as report -->
<CommandClass id="32" setasreport="true"/>

<!-- Association Groups -->
<CommandClass id="133">
<Associations num_groups="1">
<Group index="1" max_associations="4" label="Reports" auto="true"/>
</Associations>
</CommandClass>

</Product>
<Manufacturer id="0086" name="Aeon Labs">
<Product type="0000" id="0000" name="Z-Wave Extender"/>
<Product type="0001" id="0001" name="Z-Stick"/>
<Product type="0001" id="0002" name="Z-Stick S2"/>
<Product type="0001" id="0003" name="Minimote" config="aeon_labs/minimote.xml"/>
<Product type="0001" id="0007" name="Z-Stick S2 Lite"/>
<Product type="0001" id="0016" name="Key Fob" config="aeon_labs/keyfob.xml"/>
<Product type="0002" id="0001" name="Z-Stick S2"/>
<Product type="0002" id="0004" name="Door/Window Sensor" config="aeon_labs/doorwindow.xml"/>
<Product type="0002" id="0005" name="Multi Sensor" config="aeon_labs/alms.xml"/>
<Product type="0002" id="0009" name="Home Energy Meter" config="aeon_labs/hem.xml"/>
<Product type="0002" id="001c" name="Home Energy Meter G2" config="aeon_labs/hemg2.xml"/>
<Product type="0002" id="001d" name="Door/Window Sensor" config="aeon_labs/doorwindow.xml"/>
<Product type="0002" id="0036" name="Recessed Door Sensor" config="aeon_labs/recessed_doorsensor.xml"/>
<Product type="0003" id="0006" name="Smart Energy Switch" config="aeon_labs/ses.xml"/>
<Product type="0003" id="0008" name="Smart Energy Illuminator"/>
<Product type="0003" id="000a" name="Smart Energy 220V Utility Switch"/>
<Product type="0003" id="000b" name="Smart Energy Strip"/>
<Product type="0003" id="000c" name="Micro Smart Energy Switch"/>
<Product type="0003" id="000d" name="Micro Smart Energy Illuminator"/>
<Product type="0003" id="000e" name="Micro Motor Controller"/>
<Product type="0003" id="0011" name="Micro Double Switch" />
<Product type="0003" id="001a" name="Micro Switch (2nd Edition)"/>
<Product type="0003" id="001b" name="Micro Smart Energy Illuminator G2"/>
<Product type="0003" id="0012" name="Micro Smart Energy Switch G2" config="aeon_labs/ses.xml" />
<Product type="0003" id="0013" name="Micro Smart Energy Dimmer"/>
<Product type="0003" id="004b" name="Smart Energy Switch v2" config="aeon_labs/ses2.xml"/>
<Product type="0004" id="0025" name="Z-Wave Repeater"/>
<Product type="0004" id="0050" name="Siren Gen5"/>
<Product type="0002" id="004a" name="Multi Sensor G5" config="aeon_labs/alms.xml"/>

Het-Licht
Posts: 33
Joined: Monday 14 July 2014 21:16
Target OS: Raspberry Pi
Domoticz version:
Location: Nederland
Contact:

Re: New Aeon Labs Multisensor Gen5 not supported in OpenZwav

Post by Het-Licht » Tuesday 03 March 2015 0:04

I'm using Domoticz V2.2284 and OpenZwave 1.3.1021

Het-Licht
Posts: 33
Joined: Monday 14 July 2014 21:16
Target OS: Raspberry Pi
Domoticz version:
Location: Nederland
Contact:

Re: New Aeon Labs Multisensor Gen5 not supported in OpenZwav

Post by Het-Licht » Tuesday 03 March 2015 0:46

Got these from Aeon Labs :
MultisensorGen5-1.PNG
MultisensorGen5-1.PNG (106.97 KiB) Viewed 5350 times
MultisensorGen5-2.PNG
MultisensorGen5-2.PNG (160.67 KiB) Viewed 5350 times
MultisensorGen5-3.PNG
MultisensorGen5-3.PNG (104.1 KiB) Viewed 5350 times

BoneyCheng
Posts: 1
Joined: Tuesday 03 March 2015 7:33
Target OS: -
Domoticz version:
Contact:

Re: New Aeon Labs Multisensor Gen5 not supported in OpenZwav

Post by BoneyCheng » Tuesday 03 March 2015 10:47

If you are having issues getting motion sensing, you should use Binary Sensor Reports instead. Theres some sort of issue with the security command class and Basic Set Reports.

It was suggested to me that parameter 5 [1 byte dec] should be set to 2 (report binary sensor) or 3 (report binary sensor and basic set).

xces
Posts: 56
Joined: Thursday 05 February 2015 10:02
Target OS: Raspberry Pi
Domoticz version:
Location: Netherlands
Contact:

Re: New Aeon Labs Multisensor Gen5 not supported in OpenZwav

Post by xces » Tuesday 03 March 2015 11:39

I got thesame info from aeotec. I will post my current findings later today.

Edit, reaction from Christopher Chen
The Multisensor Gen5 devices are fully updated as is, they do not have new firmware to update as they are a new line of products. I will be updating the support page in the near future to reflect that.

The guide that you looked at is most likely for the older generation Multisensor. All new firmwares will be OTA (Over The Air) updatable. If you've purchased the Multisensor Gen5, then you have the latest version at the moment.

Wake up Gen5 Multisensor:
Press and hold for 3 seconds on the Multisensor, this should send a wake up notification to your controller.

Problems with Motion Sensor:
Since the Multisensor Gen5 uses a security command class, you may have to modify the Motion sensing parameters. Sending a Basic Set CC will hold issues with the new security CC.

To fix this, we need to change what the Multisensor sends when it triggers motion:

Parameter 5 [1 byte dec]: 2 (Send Sensor Binary Report)

OR

Parameter 5 [1 byte dec]: 3 (Send Sensor Binary and Basic Set CC Report) [In my opinion, it is better to have the Multisensor send both reports at the same time

There are more added parameter settings in the Multisensor Gen5 vs the older Gen5 version than what is shown in the pepper1 site (and he included above pictures as welk).

Het-Licht
Posts: 33
Joined: Monday 14 July 2014 21:16
Target OS: Raspberry Pi
Domoticz version:
Location: Nederland
Contact:

Re: New Aeon Labs Multisensor Gen5 not supported in OpenZwav

Post by Het-Licht » Wednesday 04 March 2015 0:23

And any luck ?

Gettingthere
Posts: 18
Joined: Wednesday 04 March 2015 21:57
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: New Aeon Labs Multisensor Gen5 not supported in OpenZwav

Post by Gettingthere » Wednesday 04 March 2015 22:14

Gentlemen,

After thoroughly reading this specific topic, I still can't get to the Configuration as shown by IDavid on the 27th of Feb. Included you can see what I see for Configuration. Since it's impossible to connect with my new Multisensor through the usb-cable, I need to get to any interface through Domoticz. What I read here was promising, but for me: it still won't work. Can anybody please tell me what I am doing wrong here?
Attachments
Screenshot.jpg
Screenshot.jpg (337.27 KiB) Viewed 5270 times

Het-Licht
Posts: 33
Joined: Monday 14 July 2014 21:16
Target OS: Raspberry Pi
Domoticz version:
Location: Nederland
Contact:

Re: New Aeon Labs Multisensor Gen5 not supported in OpenZwav

Post by Het-Licht » Wednesday 04 March 2015 23:04

I'll post and manual tomorrow night.
Be aware, it will still not work properly...

Gettingthere
Posts: 18
Joined: Wednesday 04 March 2015 21:57
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: New Aeon Labs Multisensor Gen5 not supported in OpenZwav

Post by Gettingthere » Wednesday 04 March 2015 23:42

Thanks, that would be of great help. But I've read some frustrations over here indeed...
(As for the added line in the manufacturer_specific.xml: I did that and rebooted my Pi, which didn't work. Obviously that was before posting my reaction on the topic.)

Gettingthere
Posts: 18
Joined: Wednesday 04 March 2015 21:57
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: New Aeon Labs Multisensor Gen5 not supported in OpenZwav

Post by Gettingthere » Friday 06 March 2015 3:13

Got it! Simply never used the inclusion button correctly! This is one hell of a brilliant feat. from Domotics to be able to include without using the stick! I couldn't find it anywhere, so for anyone else looking for this:

Inclusion of a (new or excluded) node is done by leaving yer Z2 Stick in your hardware device (Raspberry for me) and just press 'Include node' and then the inclusion button on yer Sensor. Through this, it will not only include in yer Zwave network, but also in Domoticz.

Now let's see what to control...

xces
Posts: 56
Joined: Thursday 05 February 2015 10:02
Target OS: Raspberry Pi
Domoticz version:
Location: Netherlands
Contact:

Re: New Aeon Labs Multisensor Gen5 not supported in OpenZwav

Post by xces » Friday 06 March 2015 14:08

wow did that work for you?

Het-Licht
Posts: 33
Joined: Monday 14 July 2014 21:16
Target OS: Raspberry Pi
Domoticz version:
Location: Nederland
Contact:

Re: New Aeon Labs Multisensor Gen5 not supported in OpenZwav

Post by Het-Licht » Saturday 07 March 2015 14:21

Well, I included the sensor using the button in Domoticz from the start. Temp and Lux are working sort off. Reports from Temp, HX and Lux are very random. It can take a few hours to change and than 3 times in an hour.

Motion wil NOT work...

The sensor is using the battery like mental, I'm already at 72% and sensor is 2 weeks old now! At this rate I'll be changing battery's every 8 weeks !

I reset 1 sensor yesterday, pushing the button for 20 seconds. Left the battery's out for 12 hours and than starten again. Battery's in, included the sensor. Put it awake by pushing the button 3 times in quick succesion, Programmed it. Still bad result.

My advice to people at this moment, don't buy this sensor yet, not before it's supported by openZwave...

Gettingthere
Posts: 18
Joined: Wednesday 04 March 2015 21:57
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: New Aeon Labs Multisensor Gen5 not supported in OpenZwav

Post by Gettingthere » Saturday 07 March 2015 23:28

It works... but I gotta admit: far from perfect, just like Het-Licht says... Reports only from Temp, Humidity and Lux, and all very random. Best results so far I got from including through the Z-Stick: Reports in Domoticz (1) from Temp, Humidity and Lux on a regular basis, but also pretty fast draining the batteries. The only thing I could change was parameter 2000... I still think its quite a fabulous sensor, but obviously the OZW support is quite poor.

So for now I'm thinking about including through the Z-Stick, and powered through USB, to keep my life easy...

brakc
Posts: 35
Joined: Friday 13 March 2015 13:36
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: New Aeon Labs Multisensor Gen5 not supported in OpenZwav

Post by brakc » Friday 13 March 2015 13:43

Hi

I'm french, it's possible to post learly 1 message with exactly process to configure Domoticz and Aeon Labs Multisensor Gen5 with OpenZwave please?

mine it's doesn't work!!!

packstlaurent
Posts: 10
Joined: Monday 16 March 2015 21:47
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: New Aeon Labs Multisensor Gen5 not supported in OpenZwav

Post by packstlaurent » Monday 16 March 2015 21:58

Hi,
I have recently bought a starter kit for zwave (Eon labs Z-stick S2 with a pi) and a G5 mutli sensor.

But after 2 weeks and a lot of tries, I cannot to use the motion sensor :( .
@IDavid : you seem to be able to use the motion sensor. Can you post all config file and information about your system (version and os) to this thread ?

And just few questions :

Does the G5 module will be functional with domoticz ?
How can i verify before buying anything that will be supported by Domoticz ?
Which motion sensor and door sensor do you recommend ?


Thanks in advance.

Pack

packstlaurent
Posts: 10
Joined: Monday 16 March 2015 21:47
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: New Aeon Labs Multisensor Gen5 not supported in OpenZwav

Post by packstlaurent » Friday 20 March 2015 11:17

Nobody knows ?

Ron
Posts: 129
Joined: Saturday 28 December 2013 0:29
Target OS: Raspberry Pi
Domoticz version: 2.2284
Location: Nederland
Contact:

Re: New Aeon Labs Multisensor Gen5 not supported in OpenZwav

Post by Ron » Friday 20 March 2015 23:50

Same problem here.
I have the previous version which works fine (should have bought two in stead of one) and now a second one GEN5.
Including was simple, shut down The Domoticz Pi, removed the Aeon Zwave stick, included the sensor and rebooted the Pi.
Pretty soon i was able to include the new sensors, but motion doesn't work yet and other sensors are not working or randomly.
I must admit i am not over experienced with Zwave, but with the other sensor i have other results.

vauhallan
Posts: 11
Joined: Tuesday 04 March 2014 0:09
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: New Aeon Labs Multisensor Gen5 not supported in OpenZwav

Post by vauhallan » Saturday 21 March 2015 19:02

Very Good news, the support for Aeon Labs Gen5 is on progress :
http://www.openzwave.net/home/news/2015 ... n/comments

Post Reply

Who is online

Users browsing this forum: Wolfgang and 2 guests