fibaro wall plug receive work, send doesn't

For Z-Wave related questions in Domoticz
Post Reply
elgringo
Posts: 128
Joined: Thursday 18 May 2017 8:08
Target OS: Raspberry Pi
Domoticz version: Left
Contact:

fibaro wall plug receive work, send doesn't

Post by elgringo » Wednesday 18 April 2018 18:59

So I got a fibaro wall plug, is only has link with another wall plug which can reach the z-wave stick:
Knipsel.PNG
z wave
Knipsel.PNG (51.67 KiB) Viewed 646 times
The second wall plug data is recedived by domoticz. But when I want to toggle the wall plug I get a timeout:
Domoticz reports a timeout.

I tried healing the network but this didn't work. What could I do to solve this?

jake
Posts: 439
Joined: Saturday 30 May 2015 22:40
Target OS: Raspberry Pi
Domoticz version: beta
Contact:

Re: fibaro wall plug receive work, send doesn't

Post by jake » Thursday 19 April 2018 14:09

Most times you get the devices to life by manually operating them once or twice.

elgringo
Posts: 128
Joined: Thursday 18 May 2017 8:08
Target OS: Raspberry Pi
Domoticz version: Left
Contact:

Re: fibaro wall plug receive work, send doesn't

Post by elgringo » Friday 20 April 2018 7:14

Tried this, but also a total reset of controller and wallplugs. Put them into the same room (5cm apart) and re-added them. The first one always works without problems. The second on does not.

It look like the controller only can connect to 1 device, it never connected directly to both. So the topology always looks as above.
Pushing the button on the plug doesn't make any difference.
Last edited by elgringo on Friday 20 April 2018 10:04, edited 1 time in total.

tontze
Posts: 329
Joined: Thursday 12 January 2017 16:30
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: fibaro wall plug receive work, send doesn't

Post by tontze » Friday 20 April 2018 7:16

and including order, allways first one works ?
-----------------------------------------
Rpi 3 / Razberry 2
RFLink 433mhz / Nrf 2.4Ghz
Mi Light
ESP82xx

elgringo
Posts: 128
Joined: Thursday 18 May 2017 8:08
Target OS: Raspberry Pi
Domoticz version: Left
Contact:

Re: fibaro wall plug receive work, send doesn't

Post by elgringo » Friday 20 April 2018 7:32

The first (when 1 conencted) does always work, when the second is added the second is more instable than the first, however the first also gets timeouts. So I don't think the problem is in the wallplug since they act the same depending on the including order. Both are added a secure node.

Are there any open z wave settings which I might check? Or could there be a configuring setting wrong?

elgringo
Posts: 128
Joined: Thursday 18 May 2017 8:08
Target OS: Raspberry Pi
Domoticz version: Left
Contact:

Re: fibaro wall plug receive work, send doesn't

Post by elgringo » Friday 20 April 2018 19:58

Swapped the Z-wave stick. Problem is a bit more related to one wallplug.

The 'bad' plug works normally but after switching it on/off via domotica I get a timeout:

Code: Select all

2018-04-20 19:41:44.149 OpenZWave: Received timeout notification from HomeID: 3588394851, NodeID: 3 (0x03)
The 'good' plug is places upstairs and works normally (node 4). So the controller can communicate with the bad plug, node 3, and node 4 communicates with node 3 only (according the topology)

Node 4 does not get any timeouts.

Why do I get timeouts while the wallplug doe respond? Complete log when turning it on and off:

Code: Select all

2018-04-22 08:37:18.998 User: pi initiated a switch command (107/Media Power/On)
2018-04-22 08:37:18.999 OpenZWave: Domoticz has send a Switch command! NodeID: 3 (0x03)
2018-04-22 08:37:19.013 (Zwave) Light/Switch (Media Power)
2018-04-22 08:37:19.863 (Zwave) Usage (Media Verbruik)
2018-04-22 08:37:19.864 (Zwave) General/kWh (kWh Meter)
2018-04-22 08:37:21.869 (Zwave) Usage (Media Verbruik)
2018-04-22 08:37:21.871 (Zwave) General/kWh (kWh Meter)
2018-04-22 08:37:25.869 (Zwave) Usage (Media Verbruik)
2018-04-22 08:37:25.871 (Zwave) General/kWh (kWh Meter)
2018-04-22 08:37:28.490 User: pi initiated a switch command (107/Media Power/Off)
2018-04-22 08:37:28.491 OpenZWave: Domoticz has send a Switch command! NodeID: 3 (0x03)
2018-04-22 08:37:28.492 (Zwave) Usage (Unknown)
2018-04-22 08:37:28.493 (Zwave) General/kWh (kWh Meter)
2018-04-22 08:37:28.506 (Zwave) Light/Switch (Media Power)
2018-04-22 08:37:29.068 OpenZWave: Received timeout notification from HomeID: 3588394851, NodeID: 3 (0x03)
2018-04-22 08:37:29.968 (Zwave) Usage (Media Verbruik)
2018-04-22 08:37:29.970 (Zwave) General/kWh (kWh Meter)
WHen switching the wallplug rapidly after each other (within 5 seconds) the timeout reproduces and the wallplug is toggled a bit later.

commentator
Posts: 87
Joined: Thursday 23 June 2016 14:41
Target OS: Raspberry Pi
Domoticz version: beta
Location: NL
Contact:

Re: fibaro wall plug receive work, send doesn't

Post by commentator » Tuesday 24 April 2018 14:58

same problem here

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests