fibaro fgs-213 ZW5 not able to control in Domoticz

For Z-Wave related questions in Domoticz
Post Reply
SVdHeyden
Posts: 16
Joined: Monday 23 January 2017 8:05
Target OS: Linux
Domoticz version:
Contact:

fibaro fgs-213 ZW5 not able to control in Domoticz

Post by SVdHeyden » Thursday 14 December 2017 21:33

System configuration:
Cubietruck with OS Debian GNU/Linux 8.10 (jessie)
Domotics version 3.8153 Build Hash: 494fff7

In the Zwave setup the following is found concerning the FGS213

Code: Select all

node id      Name      Description                   Manufacture     id       Type     Last seen             polling
029 (0x1d) Badkamer_Ventilator FIBARO System FGS213 Switch FIBARO System 0x1000 0x0403 2017-12-14 19:27:48 No 
According to me everything is recognised well however I can't control the FGS213 switch.. When I change the status of the FGS213 with the with the connected switch the status is updated in web page but when I change the status in the web page nothing happens.

under the devices the switch is given as follow:
picture_1.PNG
seen in Devices
picture_1.PNG (2.84 KiB) Viewed 1250 times
The icon is not indicating a switch but rather something measuring power

In attach the z-wave cache file can be found.

When I want to control the switch with the blockly script
Blockly.PNG
Blockly script
Blockly.PNG (14.54 KiB) Viewed 1248 times
the following is written in the log

The condition is made with a Fibaro FGBS001 universal sensor which is working fine.

Code: Select all

 2017-12-14 21:04:11.333 EventSystem: Event triggered: Side_Camera_Alert_1 
 2017-12-14 21:04:11.337 (Z-Wave ) Light/Switch (Side_Camera_Alert) 
 
 2017-12-14 21:04:11.345 OpenZWave: Domoticz has send a Switch command!, Level: 255, NodeID: 29(0x1d)
 
 2017-12-14 21:04:11.367 (Z-Wave ) Light/Switch (Badkamer_Ventilator) 
 2017-12-14 21:04:15.943 EventSystem: Event triggered: Side_Camera_Alert_2 
 2017-12-14 21:04:15.947 (Z-Wave ) Light/Switch (Side_Camera_Alert) 
 
 2017-12-14 21:04:15.981 OpenZWave: Domoticz has send a Switch command!, Level: 0, NodeID: 29 (0x1d) 
 
 2017-12-14 21:04:16.008 (Z-Wave ) Light/Switch (Badkamer_Ventilator) 


In the log the device is controlled with dim values instead of on/off.
At the end the switch is not changing state.

When in the 'OpenZWave Control Panel'
I'm able to control the switch.


So I'm not able to control the switch fgs-213 via Domoticz.
Can someone give some advice how to get this working?

Thanks
Attachments
zwcfg_0x0184dea9.xml
(334.01 KiB) Downloaded 38 times

SVdHeyden
Posts: 16
Joined: Monday 23 January 2017 8:05
Target OS: Linux
Domoticz version:
Contact:

Re: fibaro fgs-213 ZW5 not able to control in Domoticz

Post by SVdHeyden » Friday 15 December 2017 20:02

Somebody out there to explain how to get control over the fgs-213?

Many thanks

SVdHeyden
Posts: 16
Joined: Monday 23 January 2017 8:05
Target OS: Linux
Domoticz version:
Contact:

Re: fibaro fgs-213 ZW5 not able to control in Domoticz

Post by SVdHeyden » Wednesday 20 December 2017 11:09

No solution for this issue?

Can this be solved by controlling the device via json interface?

for those listening thanks for replying....

Bostjan
Posts: 38
Joined: Thursday 21 January 2016 20:54
Target OS: Windows
Domoticz version:
Contact:

Re: fibaro fgs-213 ZW5 not able to control in Domoticz

Post by Bostjan » Thursday 21 December 2017 21:53

I had a similar problem with similar symptoms a while ago. It could be the problem that your device hasn't been seen by controller for a while and therefore controller moved it to it's "failed node list" (OZW also has such list). Depending on the exact situation solution could be to try execute "Has node failed" and/or "Replace dead node" in OZW control panel. Finally you could re-add device to network.

BTW, you were also attaching image where you show device list with device 29. This is wrong as you've confused device IDX with zwave node ID, which are two different things. Screenshot you posted is for node 0x12, as seen from device ID 0001204

Bostjan
Posts: 38
Joined: Thursday 21 January 2016 20:54
Target OS: Windows
Domoticz version:
Contact:

Re: fibaro fgs-213 ZW5 not able to control in Domoticz

Post by Bostjan » Friday 22 December 2017 1:48

Hmm, I've update for my previous post. After I re-included my FGS-213 it worked perfectly, sending On/Off command. Then I restarted Domoticz and had exactly the same symptoms, Domoticz send level command and consequently module did not respond to command. Further I restarted Domoticz again and started to work again, sending On/Off command and module responded.

This exceeded my knowledge and experience and have no idea what is going on :shock:

SVdHeyden
Posts: 16
Joined: Monday 23 January 2017 8:05
Target OS: Linux
Domoticz version:
Contact:

Re: fibaro fgs-213 ZW5 not able to control in Domoticz

Post by SVdHeyden » Saturday 30 December 2017 14:26

When I removed the FGS213.xml from the directory domoticz/Config/fibaro and rebuild the zwcfg_0x******.xml file then the FGS-213 is working fine. Now I have to compare the original FGS213.xml with what is currently in zwcfg_0x******.xml to see what is causing the incompatibility.

Cosmo88
Posts: 2
Joined: Saturday 06 January 2018 12:06
Target OS: Linux
Domoticz version:
Contact:

Re: fibaro fgs-213 ZW5 not able to control in Domoticz

Post by Cosmo88 » Thursday 18 January 2018 10:53

You can't stop, for instance, web site indexing robots from trying to figure-out is there is something to index!


รูเล็ต

Darralius
Posts: 6
Joined: Sunday 11 September 2016 4:52
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: fibaro fgs-213 ZW5 not able to control in Domoticz

Post by Darralius » Saturday 07 April 2018 6:48

Did you find a solution to this at all? I am having the same problem.

Initially I had trouble including the device. Domoticz and Open Zwave both reported unknown device with a type and Id code. I checked the manufacture_specific.xml file and found that my switch was reporting the same type but different ID (3000 instead of 2000 or 1000) to the listed FGS-213. I added a line to direct this switch type and ID to the same FGS-213 config file as the other types. I assume this a region thing, AU region device.

I can manually switch the switch from the open zwave control panel and it works correctly. When I select auto add on the switch page in Domoticz and manually flick the switch it registers and adds its correctly. Changing the state of this switch in Domoticz makes no physical change.

Logs show the user request etc as usual.
2018-04-07 16:24:16.918 User: T initiated a switch command (142/Garage Lights/On)
2018-04-07 16:24:16.918 OpenZWave: Domoticz has send a Switch command!, Level: 255, NodeID: 24 (0x18)
2018-04-07 16:24:16.932 (Aeotech) Light/Switch (Garage Lights)
2018-04-07 16:24:18.963 User: T initiated a switch command (142/Garage Lights/Off)
2018-04-07 16:24:18.964 OpenZWave: Domoticz has send a Switch command!, Level: 0, NodeID: 24 (0x18)

Maes
Posts: 52
Joined: Tuesday 05 April 2016 20:45
Target OS: -
Domoticz version:
Contact:

Re: fibaro fgs-213 ZW5 not able to control in Domoticz

Post by Maes » Saturday 07 April 2018 11:17

I had the same problem.
I just did what SVdHeyden said and it works:
Remove FGS213.xml from the directory domoticz/Config/fibaro and rebuild the zwcfg_0x******.xml file then the FGS-213 is working fine. 
The only problem is that when you do this, domoticz won't show any parameters for the node anymore. But I couldn't care less about those.

Darralius
Posts: 6
Joined: Sunday 11 September 2016 4:52
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: fibaro fgs-213 ZW5 not able to control in Domoticz

Post by Darralius » Sunday 08 April 2018 3:07

Thanks,

I stopped Domoticz, renamed the fgs-213.xml file and the zwcfg_0x******.xml file, then restarted Domoticz.
It has auto built the zwcfg_0x******.xml file.

Still can't control the switch, will keep messing with it.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests