Open zwave control panel empty Topic is solved

For Z-Wave related questions in Domoticz
Post Reply
joneng
Posts: 10
Joined: Wednesday 14 December 2016 14:55
Target OS: Raspberry Pi
Domoticz version:
Contact:

Open zwave control panel empty

Post by joneng » Sunday 18 June 2017 8:47

Hi,

I can´t get my install of open zwave to work. I have domoticz on rpi with z-stick gen 5.

Something happened earlier but I don´t know what, because it worked to begin with for several months and I had zwave devises added.

When starting domoticz I get the following lines in the log related to openzwave:
2017-06-18 07:53:37.440 OpenZWave: Starting...
2017-06-18 07:53:37.440 OpenZWave: Version: 1.4-2228-gbce4a88-dirty
2017-06-18 07:53:37.440 OpenZWave: using config in: /home/pi/domoticz/Config/
2017-06-18 07:53:38.488 OpenZWave: Received timeout notification from HomeID: 0, NodeID: 255 (0xff)
2017-06-18 07:53:39.498 OpenZWave: Received timeout notification from HomeID: 0, NodeID: 255 (0xff)
2017-06-18 07:53:40.503 OpenZWave: Received timeout notification from HomeID: 0, NodeID: 255 (0xff)
2017-06-18 07:53:41.507 OpenZWave: Received timeout notification from HomeID: 0, NodeID: 255 (0xff)
2017-06-18 07:53:42.512 OpenZWave: Received timeout notification from HomeID: 0, NodeID: 255 (0xff)
and
2017-06-18 07:57:03.824 Error: Webserver: File '/ozwcp/devpost.html': No such file or directory (2)
2017-06-18 07:57:05.042 Error: Webserver: File '/ozwcp/devpost.html': No such file or directory (2)

The control panel looks like this:
Screen Shot 2017-06-18 at 08.35.49.png
Screen Shot 2017-06-18 at 08.35.49.png (64.21 KiB) Viewed 1378 times
I have no idea on what to do to solve this - can someone help me?

regards Jonas
Domoticz on Rpi and MySensors - both amazing projects :-)

joneng
Posts: 10
Joined: Wednesday 14 December 2016 14:55
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Open zwave control panel empty

Post by joneng » Monday 19 June 2017 10:49

Is there for example a smart way to reinstall open zwave, so that everything is set back to default?

/Jonas
Domoticz on Rpi and MySensors - both amazing projects :-)

User avatar
EddyG
Posts: 228
Joined: Monday 02 November 2015 6:54
Target OS: Raspberry Pi
Domoticz version: 3.9327
Location: Rhenen, Netherlands
Contact:

Re: Open zwave control panel empty

Post by EddyG » Monday 19 June 2017 10:55

How did you install it?
The '/ozwcp/devpost.html' is missing from the domoticz install, at least I don't have it either in both production as beta.
Regards,
Eddy

User avatar
blacksn0w
Posts: 118
Joined: Friday 10 March 2017 23:27
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Germany
Contact:

Re: Open zwave control panel empty

Post by blacksn0w » Monday 19 June 2017 11:03

Have you restarted your machine recently?
Had the same problem, the port of the z-wave stick have changed.
Not your devices are missing, your controller is not recognised at all.
Migration in progress, hello Home Assistant.

User avatar
Egregius
Posts: 2623
Joined: Thursday 09 April 2015 12:19
Target OS: Linux
Domoticz version: Beta
Location: Beitem, BE
Contact:

Re: Open zwave control panel empty

Post by Egregius » Monday 19 June 2017 11:30

Try this before opening OZWCP:
In domoticz goto settings -> hardware
select setup for your zwave controller

joneng
Posts: 10
Joined: Wednesday 14 December 2016 14:55
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Open zwave control panel empty

Post by joneng » Monday 19 June 2017 13:06

blacksn0w: You were so right - the usb port had changed! So simple! But now it works again,

thank you all for helping me out!

Regards Jonas
Domoticz on Rpi and MySensors - both amazing projects :-)

Andree
Posts: 80
Joined: Wednesday 07 June 2017 11:19
Target OS: Windows
Domoticz version:
Contact:

Re: Open zwave control panel empty

Post by Andree » Tuesday 16 January 2018 16:39

Hi to all, i have the same problem but in my case the port is not changed and, if I try to change (from 1 to 7), nothing happen.
I use Domoticz on Windows and i have update some version in the last year but this problem remain.
Can anyone help me?

dextm80
Posts: 72
Joined: Tuesday 24 October 2017 18:32
Target OS: Linux
Domoticz version: 3.8153
Contact:

Re: Open zwave control panel empty

Post by dextm80 » Tuesday 16 January 2018 17:21

hi guys, same problem, i follow this guide: https://www.domoticz.com/wiki/PersistentUSBDevices

all ok,add my device....... since i restart, and then this is the log:

Code: Select all

 2018-01-16 16:11:09.940 Domoticz V3.8809 (c)2012-2018 GizMoCuz
2018-01-16 16:11:09.940 Build Hash: 4ec5e16, Date: 2018-01-15 13:01:28
2018-01-16 16:11:09.941 Startup Path: /xxx/xxx/domoticz/
2018-01-16 16:11:09.975 Sunrise: 07:47:00 SunSet: 17:24:00
2018-01-16 16:11:09.975 Day length: 09:37:00 Sun at south: 12:35:00
2018-01-16 16:11:09.975 Civil twilight start: 07:17:00 Civil twilight end: 17:54:00
2018-01-16 16:11:09.975 Nautical twilight start: 06:43:00 Nautical twilight end: 18:28:00
2018-01-16 16:11:09.975 Astronomical twilight start: 06:11:00 Astronomical twilight end: 19:00:00
2018-01-16 16:11:09.975 EventSystem: reset all events...
2018-01-16 16:11:10.106 PluginSystem: Started, Python version '3.5.2'.
2018-01-16 16:11:10.110 Active notification Subsystems: (0/14)
2018-01-16 16:11:10.115 WebServer(HTTP) started on address: :: with port xxx
2018-01-16 16:11:10.129 WebServer(SSL) started on address: :: with port xxx
2018-01-16 16:11:10.130 Proxymanager started.
2018-01-16 16:11:10.136 Starting shared server on: :::xxx
2018-01-16 16:11:10.137 TCPServer: shared server started...
2018-01-16 16:11:10.137 RxQueue: queue worker started...
2018-01-16 16:11:12.138 EventSystem: reset all events...
2018-01-16 16:11:12.138 EventSystem: reset all device statuses...
2018-01-16 16:11:12.170 Python EventSystem: Initalizing event module.
2018-01-16 16:11:12.170 EventSystem: Started
2018-01-16 16:11:12.170 EventSystem: Queue thread started...
2018-01-16 16:11:12.338 RFLink: Using serial port: /dev/ttyUSB-RFLink
2018-01-16 16:11:12.494 PluginSystem: Entering work loop.
2018-01-16 16:11:12.638 OpenZWave: using config in: /xxx/xxx/domoticz/Config/
2018-01-16 16:11:12.640 OpenZWave: Starting...
2018-01-16 16:11:12.640 OpenZWave: Version: 1.4-2888-g5468237-dirty
2018-01-16 16:11:13.263 RFLink: Controller Initialized!...
2018-01-16 16:11:13.339 RFLink Detected, Version: 1.1 Revision: 48 Build: 4
2018-01-16 16:11:18.635 Incoming connection from: 192.168.1.59
2018-01-16 16:11:22.641 OpenZWave: Received timeout notification from HomeID: 0, NodeID: 255 (0xff)
2018-01-16 16:11:23.642 OpenZWave: Received timeout notification from HomeID: 0, NodeID: 255 (0xff)
2018-01-16 16:11:24.642 OpenZWave: Received timeout notification from HomeID: 0, NodeID: 255 (0xff)
2018-01-16 16:11:25.643 OpenZWave: Received timeout notification from HomeID: 0, NodeID: 255 (0xff)
2018-01-16 16:11:26.643 OpenZWave: Received timeout notification from HomeID: 0, NodeID: 255 (0xff) 
i try a lot of times, reset controller, reset node,change usb port, nothing change.
Schermata 2018-01-16 alle 16.19.09.png
Schermata 2018-01-16 alle 16.19.09.png (98.17 KiB) Viewed 580 times
ports seems right configured

since i d install rflink all gone ok, now with rflink i've this issue.

if i disable and (after reboot) enable it all back ok............

Cany you help me?
Thanks

ps: why i've beta version? i follow official wiki instruction to install it :(
Domoticz on AsRock j3455-ITX 8gb ram - Aeotec ZWave Usb Stick - RFLink 433Mhz
1x Fibaro Wall Plug
1x Fibaro Motion Sensor
2x NeoCoolcam Wall Plug
Netatmo Weather Station - Netatmo Thermostat
Philips Hue Bridge

dextm80
Posts: 72
Joined: Tuesday 24 October 2017 18:32
Target OS: Linux
Domoticz version: 3.8153
Contact:

Re: Open zwave control panel empty

Post by dextm80 » Tuesday 16 January 2018 18:19

Domoticz on AsRock j3455-ITX 8gb ram - Aeotec ZWave Usb Stick - RFLink 433Mhz
1x Fibaro Wall Plug
1x Fibaro Motion Sensor
2x NeoCoolcam Wall Plug
Netatmo Weather Station - Netatmo Thermostat
Philips Hue Bridge

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests