Zwave.me wall switches (single and double)

For Z-Wave related questions in Domoticz
Post Reply
wjv999
Posts: 3
Joined: Sunday 22 January 2017 18:25
Target OS: Raspberry Pi
Domoticz version:
Contact:

Zwave.me wall switches (single and double)

Post by wjv999 » Sunday 22 January 2017 18:33

I have two wall z-wave.me battery operated wall switches, a single and a double. (WALLC-2 and WALLC-S)

Inluding it into the zwave confiuration is no problem. They are recognized as a Poll (double) and Devolo battery wall controller.
However, after that nothing happens when the buttons are pressed.
In the zwave config on Domoticz, the Command to Control A-D, all are set to:
Central scene to gateway

Is there something special what I need to do with either the configuration in domoticz or with the wall switches?

The setup is:

Raspberry Pi3 B with Domoticz 3.5877
Zwave.me USB controller

Thanks!

Willem-Jan

swevm
Posts: 24
Joined: Friday 16 September 2016 20:04
Target OS: Raspberry Pi
Domoticz version: 8718
Location: Sweden
Contact:

Re: Zwave.me wall switches (single and double)

Post by swevm » Sunday 22 January 2017 23:46

Hi,

I recommend you search this forum for "009303" as that's how the duals paddle sensors are recognised. You're correct saying they are configured with "central scene to gateway" by default. However domoticz do not handle central scenes.

As these sensors don't actually control load directly they need to be configured in one of two ways to work with domoticz.
Preferred: use Zwave groups and assign for example a Zwave relay module to a group that belong to you WallC. As long as the relay module is recognised by domoticz you will see its state change when you press assigned buttons on your WallC. Keep in mind WallC devices are remotes and do not maintain state.
Second option:
Set group in WallC to send "scene". In this scenario domoticz will create a new device for the button you pressed. Unfortunately this device cannot change state as the WallC remotes always send "On" command when configured in scene mode. This can be handled with domoticz scenes. One that trigger On and the other scene that trigger Off. each scene need to be configured to trigger on "on" command that is send by respective WallC button.

Happy to help
/Magnus
Domoticz on RPi3 with Razberry: 10xZME WALLC-S, 14x Fib Switch, 6x Fib Wallplug, 1x Fib Motion Sensor, 2x Fib Smoke Sensor, 1x Fib Universal sensor (with 1-wire), 3x SwiidInter cordsw, ESPEasy [1-wire and relay], Kodi, Node-Red [Onkyo NR-828, UI etc]

wjv999
Posts: 3
Joined: Sunday 22 January 2017 18:25
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Zwave.me wall switches (single and double)

Post by wjv999 » Monday 23 January 2017 21:01

Magnus, thanks so much. This solved the issue!

It's a bit strange that you need to do the manual update in the group...
The limitation of only the "On" command is not a big issue. I will couple them on an scene in Domoticz.

WilvdAalst
Posts: 1
Joined: Wednesday 18 January 2017 13:08
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Zwave.me wall switches (single and double)

Post by WilvdAalst » Friday 17 March 2017 23:23

I am struggling already fo more than 2 months. I Can include the wallcs but don't have 4buttons to link actions. Any one ideas?
B.t.w. what is meant with "It's a bit strange that you need to do the manual update in the group..."

Rikdev
Posts: 2
Joined: Sunday 30 April 2017 13:56
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Zwave.me wall switches (single and double)

Post by Rikdev » Monday 01 May 2017 18:50

reading this issue today. i have the same problem with a ZME_Wallc wall controller. perfect included in the domoticz but the buttons don't work on te wall controller. I'm not technical skilled enough to understand all the explanations about groups and scenes. Is there no one to explain the process of configuring the wall controller in clear steps. for example in a Youtube movie, how to make a wall controller configure in Domoticz?

MrPenthouse
Posts: 2
Joined: Tuesday 06 March 2018 22:48
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Zwave.me wall switches (single and double)

Post by MrPenthouse » Wednesday 09 May 2018 18:35

Not sure if this response is still relevant for the topic posters.

I installed a WALLC-S switch today and was also experiencing problems. Same as above, inclusion worked but no switched in the Devices tab to assign to scenes or groups.

This is what i did to make it work:

In Domoticz delete the Switch, then factory reset the WALLC-S by pressing and holding all 4 buttons for 5-6 seconds until the led light comes on. Then hit 3 and 4 and hold for 5 seconds again, now after the led flashes your device has been reset. Set Domotics in Add Node mode. Next is including it again in Management mode! Enter management mode, press and hold all 4 for 5-6 seconds, and hit button 1. Now it was included. I now still did not have any switched in teh Devices tab and tried to force it by a tip from someone on another forum. In management mode, hit button 2. Repeat this a couple of times as it wakes the device and sends a wake command to Domoticz. After doing this a couple of times it worked, I noticed 2 switches, not all 4 yet.

Now when I tried to assign a activation device in a scene Domoticz asks you to press a button on the switch, I tried this with all 4 buttons and now suddenly they were all available. I then renamed them in the Devices tab and it is all working now, I can assign 4 scenes in total to the 4 different buttons.

Hope this helps.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests