Aeotec Siren Gen5 parameters Topic is solved

For Z-Wave related questions in Domoticz
Mecallie
Posts: 3
Joined: Monday 19 June 2017 23:56
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Aeotec Siren Gen5 parameters

Post by Mecallie » Friday 23 June 2017 9:34

mrdata wrote:<SNIP> Something in French</SNIP>
Capture1.JPG
Capture2.JPG
I have tried your json commands mrdata. At first I did not think they worked, until I noticed the "applyzwavenodeconfig" part in the URL. It seems it only works once: when the initial config is applied. For instance: when I set the sound to 3 and the volume to 1 in Domoticz my siren sounds. When I replay that json command it does not, because it is already set. When I play a different sound, say sound 4 volume 1, it works. Again: only once.

I think the applyzwavenodeconfig needs to be replaced by some kind of alarm command, but I have no idea what it would be :)

Until then I do not think you can use this for an alarm. If it has been triggered once, it will not trigger again. Unless you reset it to something different every x time. But that would get annoying since the siren would sound every time you did that. Now that I think of it: it would only sound if there was an alarm event. Otherwise it would ofcourse still be on the original setting and not sound...

bvhoesel
Posts: 2
Joined: Sunday 13 August 2017 20:29
Target OS: Linux
Domoticz version:
Contact:

Re: Aeotec Siren Gen5 parameters

Post by bvhoesel » Sunday 13 August 2017 20:49

The following urls (shown here send with curl) will switch the sounds:

Code: Select all

// "Sound 1 - Low Volume"
curl 'http://<DOMOTICZ-SERVER>:8080/json.htm?type=command&param=applyzwavenodeconfig&idx=<NODE-ID>&valuelist=37_U291bmQgMSAtIExvdyBWb2x1bWU%3D'
// "Sound 1 - Mid Volume"
curl 'http://<DOMOTICZ-SERVER>:8080/json.htm?type=command&param=applyzwavenodeconfig&idx=<NODE-ID>&valuelist=37_U291bmQgMSAtIE1pZCBWb2x1bWU%3D'
// "Sound 1 - High Volume"
curl 'http://<DOMOTICZ-SERVER>:8080/json.htm?type=command&param=applyzwavenodeconfig&idx=<NODE-ID>&valuelist=37_U291bmQgMSAtIEhpZ2ggVm9sdW1l'
// "Sound 2 - Low Volume"
curl 'http://<DOMOTICZ-SERVER>:8080/json.htm?type=command&param=applyzwavenodeconfig&idx=<NODE-ID>&valuelist=37_U291bmQgMiAtIExvdyBWb2x1bWU%3D'
// "Sound 2 - Mid Volume"
curl 'http://<DOMOTICZ-SERVER>:8080/json.htm?type=command&param=applyzwavenodeconfig&idx=<NODE-ID>&valuelist=37_U291bmQgMiAtIE1pZCBWb2x1bWU%3D'
// "Sound 2 - High Volume"
curl 'http://<DOMOTICZ-SERVER>:8080/json.htm?type=command&param=applyzwavenodeconfig&idx=<NODE-ID>&valuelist=37_U291bmQgMiAtIEhpZ2ggVm9sdW1l'
// "Sound 3 - Low Volume"
curl 'http://<DOMOTICZ-SERVER>:8080/json.htm?type=command&param=applyzwavenodeconfig&idx=<NODE-ID>&valuelist=37_U291bmQgMyAtIExvdyBWb2x1bWU%3D'
// "Sound 3 - Mid Volume"
curl 'http://<DOMOTICZ-SERVER>:8080/json.htm?type=command&param=applyzwavenodeconfig&idx=<NODE-ID>&valuelist=37_U291bmQgMyAtIE1pZCBWb2x1bWU%3D'
// "Sound 3 - High Volume"
curl 'http://<DOMOTICZ-SERVER>:8080/json.htm?type=command&param=applyzwavenodeconfig&idx=<NODE-ID>&valuelist=37_U291bmQgMyAtIEhpZ2ggVm9sdW1l'
// "Sound 4 - Low Volume"
curl 'http://<DOMOTICZ-SERVER>:8080/json.htm?type=command&param=applyzwavenodeconfig&idx=<NODE-ID>&valuelist=37_U291bmQgNCAtIExvdyBWb2x1bWU%3D'
// "Sound 4 - Mid Volume"
curl 'http://<DOMOTICZ-SERVER>:8080/json.htm?type=command&param=applyzwavenodeconfig&idx=<NODE-ID>&valuelist=37_U291bmQgNCAtIE1pZCBWb2x1bWU%3D'
// "Sound 4 - High Volume"
curl 'http://<DOMOTICZ-SERVER>:8080/json.htm?type=command&param=applyzwavenodeconfig&idx=<NODE-ID>&valuelist=37_U291bmQgNCAtIEhpZ2ggVm9sdW1l'
// "Sound 5 - Low Volume"
curl 'http://<DOMOTICZ-SERVER>:8080/json.htm?type=command&param=applyzwavenodeconfig&idx=<NODE-ID>&valuelist=37_U291bmQgNSAtIExvdyBWb2x1bWU%3D'
// "Sound 5 - Mid Volume"
curl 'http://<DOMOTICZ-SERVER>:8080/json.htm?type=command&param=applyzwavenodeconfig&idx=<NODE-ID>&valuelist=37_U291bmQgNSAtIE1pZCBWb2x1bWU%3D'
// "Sound 5 - High Volume"
curl 'http://<DOMOTICZ-SERVER>:8080/json.htm?type=command&param=applyzwavenodeconfig&idx=<NODE-ID>&valuelist=37_U291bmQgNSAtIEhpZ2ggVm9sdW1l'
To be sure the selected sound is heard (if you set it to the same sound as before) just switch the siren on (and later off) with:

Code: Select all

// ON
curl 'http://<DOMOTICZ-SERVER>:8080/json.htm?type=command&param=switchlight&idx=<DEVICE-IDX>&switchcmd=On'
// OFF
curl 'http://<DOMOTICZ-SERVER>:8080/json.htm?type=command&param=switchlight&idx=<DEVICE-IDX>&switchcmd=Off'
Where <DOMOTICZ-SERVER> needs to be replaced with your domoticz server IP or name. And <NODE-ID> is the z-wave NodeID of the siren. And <DEVICE-IDX> is the index of the corresponding switch device.

The base64 and url encoded part after valuelist=37_ is the description of the sound as seen in de config page, for example "Sound 5 - High Volume" (without the double quotes). I dit not test all the urls so there might be a typo. But if so you know how to check and correct it.

Just incorporates these in you preferred language and then "Happy sound switching".

Ries
Posts: 33
Joined: Tuesday 01 December 2015 9:47
Target OS: Raspberry Pi
Domoticz version: 3.9639
Location: Netherlands
Contact:

Re: Aeotec Siren Gen5 parameters

Post by Ries » Friday 18 August 2017 11:08

I checked all the urls, but none of them worked even though the json call reported success.
Version 3.9639
Platform: Jessie lite
Hardware: Raspberry pi 3B; RFXCOM; Weather Underground; Dummy; OpenZwave USB; Fritzbox Callmonitor via LAN interface; System Alive Checker (Ping); Philips Hue Bridge; Atag One Thermostat

bvhoesel
Posts: 2
Joined: Sunday 13 August 2017 20:29
Target OS: Linux
Domoticz version:
Contact:

Re: Aeotec Siren Gen5 parameters

Post by bvhoesel » Sunday 17 September 2017 13:58

Ries wrote:
Friday 18 August 2017 11:08
I checked all the urls, but none of them worked even though the json call reported success.
They do work for me. Can you switch sound from the z-wave device config page? If so, did you check you have the correct z-wave NODE-ID (for sound setting) and Domoticz DEVICE-ID (for on/off)? You cannot rely on the json return status as indication of a correctly executed action on the intended device. As I saw, it is most of the time "OK". If I mangle a working url it shows OK as return status but no sound. So double check all values to be substituted in the example url's and try again. Where did you execute the curl command from? It definitely works for me when executed from the PI itself.

renerene
Posts: 150
Joined: Wednesday 03 August 2016 11:36
Target OS: -
Domoticz version:
Contact:

Re: Aeotec Siren Gen5 parameters

Post by renerene » Sunday 25 February 2018 13:56

Only swtich on/off works for me.
The other command

Code: Select all

http://192.xxx.0.xxx:8080/json.htm?type=command&param=applyzwavenodeconfig&idx=96&valuelist=37_U291bmQgMSAtIEhpZ2ggVm9sdW1l
gives error in browser:

Code: Select all

{
   "status" : "ERR"
}
what is the 'U291bmQgMSAtIEhpZ2ggVm9sdW1l' part at the end? Is it unique per device?

Ries
Posts: 33
Joined: Tuesday 01 December 2015 9:47
Target OS: Raspberry Pi
Domoticz version: 3.9639
Location: Netherlands
Contact:

Re: Aeotec Siren Gen5 parameters

Post by Ries » Tuesday 12 June 2018 10:06

Still no result
Attachments
3F7FAE1B-0238-440E-8218-8D6BC6C763AE.png
3F7FAE1B-0238-440E-8218-8D6BC6C763AE.png (295.93 KiB) Viewed 514 times
5CB8861B-C4CC-4E43-9020-6BEC78665B2F.png
5CB8861B-C4CC-4E43-9020-6BEC78665B2F.png (347.1 KiB) Viewed 514 times
Version 3.9639
Platform: Jessie lite
Hardware: Raspberry pi 3B; RFXCOM; Weather Underground; Dummy; OpenZwave USB; Fritzbox Callmonitor via LAN interface; System Alive Checker (Ping); Philips Hue Bridge; Atag One Thermostat

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests