Events system thread (questions and feedback)

Must be cleaned all topics go to the right subforum
sebquid
Posts: 8
Joined: Wednesday 07 August 2013 12:31
Target OS: -
Domoticz version:
Location: France
Contact:

Re: Events system feedback thread

Post by sebquid » Monday 12 August 2013 23:46

I tried what you said and it is not working also. We can not save events with such url.

Skippiemanz
Posts: 283
Joined: Sunday 14 July 2013 20:21
Target OS: Raspberry Pi
Domoticz version: 3.5859
Location: Alkmaar, The Netherlands
Contact:

Re: Events system feedback thread

Post by Skippiemanz » Saturday 17 August 2013 1:03

Does anyone have the solution for this problem?

User avatar
CopyCatz
Developer
Posts: 751
Joined: Thursday 11 July 2013 17:28
Target OS: -
Domoticz version:
Location: Outer Heaven
Contact:

Re: Events system feedback thread

Post by CopyCatz » Saturday 17 August 2013 6:43

I put a fix in 996, could you test please?

Skippiemanz
Posts: 283
Joined: Sunday 14 July 2013 20:21
Target OS: Raspberry Pi
Domoticz version: 3.5859
Location: Alkmaar, The Netherlands
Contact:

Re: Events system feedback thread

Post by Skippiemanz » Monday 19 August 2013 23:24

Thanks, i will check a soon as an update is placed online

Skippiemanz
Posts: 283
Joined: Sunday 14 July 2013 20:21
Target OS: Raspberry Pi
Domoticz version: 3.5859
Location: Alkmaar, The Netherlands
Contact:

Re: Events system feedback thread

Post by Skippiemanz » Thursday 22 August 2013 14:14

Unfortunetly i still got the same error in rev 999.

Any ideas?

User avatar
CopyCatz
Developer
Posts: 751
Joined: Thursday 11 July 2013 17:28
Target OS: -
Domoticz version:
Location: Outer Heaven
Contact:

Re: Events system feedback thread

Post by CopyCatz » Friday 23 August 2013 3:29

You have to open your event and save it again for the new url storage to kick in. It works this way with most event fixes/upgrades.

Skippiemanz
Posts: 283
Joined: Sunday 14 July 2013 20:21
Target OS: Raspberry Pi
Domoticz version: 3.5859
Location: Alkmaar, The Netherlands
Contact:

Re: Events system feedback thread

Post by Skippiemanz » Friday 23 August 2013 10:35

I deleted the event and try to create the ne event but still unable to save :(

matra-manni
Posts: 9
Joined: Saturday 13 July 2013 13:53
Target OS: -
Domoticz version:
Location: Germany; Vettweiß
Contact:

Open / close in Blockly not work

Post by matra-manni » Sunday 25 August 2013 15:23

Hello

"On" and "Off" function properly. (inverted blinds)
"Open" / "Close" doesn´t switch.

Events also work if they are not activated. (Text is red).
Only when all events disabled, they are turned off.
This is very difficult when testing.

Es grüßt ... Manni

kallej
Posts: 5
Joined: Thursday 05 September 2013 22:43
Target OS: Raspberry Pi
Domoticz version:
Contact:

Problem using temperature in events

Post by kallej » Thursday 05 September 2013 22:49

Hi,

I have created an event using the block editor, it goes like this:
If "Höyrysauna" temperature < 26 do set "ventilation" on

both above devices are working nicely and I can get the temperature and control the ventilation, but once I activate the event
i start to get following log entries every time the "device" sends new temp and humidity information:

Error: Thu Sep 5 23:44:31 2013 Lua script error: [string "result = 0; weekday = os.date('*t')['wday']; ..."]:1: attempt to index global 'humiditydevice' (a nil value)
Error: Thu Sep 5 23:44:31 2013 Lua script error: [string "result = 0; weekday = os.date('*t')['wday']; ..."]:1: attempt to index global 'temperaturedevice' (a nil value)
Thu Sep 5 23:44:31 2013 (RFX-Dongle) Temperature + Humidity (Höyrysauna)

Just did an update, so domoticz version is the latest available.

Could you help me out on this one ?

User avatar
CopyCatz
Developer
Posts: 751
Joined: Thursday 11 July 2013 17:28
Target OS: -
Domoticz version:
Location: Outer Heaven
Contact:

Re: Events system feedback thread

Post by CopyCatz » Thursday 12 September 2013 8:48

Can you post a screenshot of your blockly event please?

spaanplaat
Posts: 34
Joined: Friday 12 July 2013 16:21
Target OS: -
Domoticz version:
Contact:

Re: Events system feedback thread

Post by spaanplaat » Friday 13 September 2013 12:01

Some of us are trying to get xbmc and domoticz to interact with each other. The plugin in XBMC works great to interact with domoticz but it does not work the other way around.
When I try to pause XBMC with the following url it works but when I attach this URL to a blocky example and a dummy switch we receive the following error.

Code: Select all

http://(user:password)@(ip address xbmc):(port)/jsonrpc?request={"jsonrpc": "2.0", "method": "Player.PlayPause", "params": { "playerid": 1 }, "id": 1}
Of course I replaced the user, password and ip with my own credentials.

Code: Select all

Fetching url: xbmc:[email protected]:80/jsonrpc?request={"jsonrpc":"2.0
Error: Wed Sep 4 03:23:06 2013 Malformed action sequence!
I already tried to replace the comma's in the url with %2c but I still receive the same error. Is this type of URL not possible with blocky? Or is it to long? I'm running V1.1009.

User avatar
Keptenkurk
Posts: 440
Joined: Wednesday 21 August 2013 17:24
Target OS: -
Domoticz version:
Location: Waalre, The Netherlands
Contact:

Re: Events system feedback thread

Post by Keptenkurk » Saturday 14 September 2013 14:04

Piotr, how about calling the url with curl from a shell script and call this script from your lua script? Could be a work around for the time being...

niki_lauda
Posts: 103
Joined: Saturday 31 August 2013 14:48
Target OS: Raspberry Pi
Domoticz version: beta
Location: Eindhoven (NL)
Contact:

Re: Events system feedback thread

Post by niki_lauda » Saturday 14 September 2013 20:56

i,

I have created an event using the block editor, it goes like this:
If "Höyrysauna" temperature < 26 do set "ventilation" on

both above devices are working nicely and I can get the temperature and control the ventilation, but once I activate the event
i start to get following log entries every time the "device" sends new temp and humidity information:

Error: Thu Sep 5 23:44:31 2013 Lua script error: [string "result = 0; weekday = os.date('*t')['wday']; ..."]:1: attempt to index global 'humiditydevice' (a nil value)
Error: Thu Sep 5 23:44:31 2013 Lua script error: [string "result = 0; weekday = os.date('*t')['wday']; ..."]:1: attempt to index global 'temperaturedevice' (a nil value)
Thu Sep 5 23:44:31 2013 (RFX-Dongle) Temperature + Humidity (Höyrysauna)

Just did an update, so domoticz version is the latest available.

Could you help me out on this one ?
"CopyCatz"]Can you post a screenshot of your blockly event please?
Same problem here
error in the log
Error: Sat Sep 14 20:53:30 2013 Lua script error: [string "result = 0; weekday = os.date('*t')['wday']; ..."]:1: attempt to compare nil with number

Image

kallej
Posts: 5
Joined: Thursday 05 September 2013 22:43
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Events system feedback thread

Post by kallej » Thursday 19 September 2013 9:30

HI,

Some more information on this one.
seems that this happens only when I'm trying to evaluate humidity and it actually had something to do with my device
after swapping the thermometer, everything seems to work nicely.

alfred_j_kwak
Posts: 253
Joined: Friday 20 September 2013 18:49
Target OS: Raspberry Pi
Domoticz version: 2.3530
Location: Finland
Contact:

Re: Events system feedback thread

Post by alfred_j_kwak » Friday 20 September 2013 19:04

Hi everyone. New member/user and first post.
I tried to control bathroom exhaust fan. I have switch to switch it on and off.
What I liked to do is use delay for fan. If I switch it on it runs 30 minutes and stop and also 'turn' switch off.
If I liked to stop it earlier I just turn switch off.
I tried to do Event, but it seems that when delay is set it is impossible to reset it again?

Here is simple block diagram where fan is set to run 1 min.

-Jussi-

EDIT: Now when I have stared my plan for a while it seems to be mission impossible...
Attachments
screenshot.64.jpg
screenshot.64.jpg (71.64 KiB) Viewed 2404 times

User avatar
CopyCatz
Developer
Posts: 751
Joined: Thursday 11 July 2013 17:28
Target OS: -
Domoticz version:
Location: Outer Heaven
Contact:

Re: Events system feedback thread

Post by CopyCatz » Tuesday 24 September 2013 23:45

- v1.1023: Scenes and groups on/off/active/inactive via events, fixed bug where inactive event would still trigger
when multiple events apply. Comma now supported in event OpenURL. events now triggered by security state change
implemented script_security_name.lua for sec panel triggers in lua.

NiklasO
Posts: 132
Joined: Friday 16 August 2013 18:34
Target OS: -
Domoticz version:
Location: Stockholm, Sweden
Contact:

Re: Events system feedback thread

Post by NiklasO » Wednesday 25 September 2013 11:21

I have no Scenes/Groups in the list.. but I DO have some groups. :)
Sorry if this has been answered beore..

https://dl.dropboxusercontent.com/u/900 ... hot119.jpg
https://dl.dropboxusercontent.com/u/900 ... hot120.jpg

User avatar
CopyCatz
Developer
Posts: 751
Joined: Thursday 11 July 2013 17:28
Target OS: -
Domoticz version:
Location: Outer Heaven
Contact:

Re: Events system feedback thread

Post by CopyCatz » Wednesday 25 September 2013 11:30

weird, they are retrieved using the standard json.htm?type=scenes&order=Name. Can you post the output of that api call?

NiklasO
Posts: 132
Joined: Friday 16 August 2013 18:34
Target OS: -
Domoticz version:
Location: Stockholm, Sweden
Contact:

Re: Events system feedback thread

Post by NiklasO » Wednesday 25 September 2013 11:35

CopyCatz wrote:weird, they are retrieved using the standard json.htm?type=scenes&order=Name. Can you post the output of that api call?

Code: Select all

{
   "result" : [
      {
         "Favorite" : 1,
         "HardwareID" : 1,
         "LastUpdate" : "2013-09-23 22:15:49",
         "Name" : "Vardagsrum, lampor",
         "Status" : "Off",
         "Timers" : "false",
         "Type" : "Group",
         "idx" : "3"
      },
      {
         "Favorite" : 1,
         "HardwareID" : 1,
         "LastUpdate" : "2013-09-25 06:38:01",
         "Name" : "Fönsterbelysning",
         "Status" : "Off",
         "Timers" : "true",
         "Type" : "Group",
         "idx" : "4"
      }
   ],
   "status" : "OK",
   "title" : "Scenes"
}
Does this look right btw?
https://dl.dropboxusercontent.com/u/900 ... hot121.jpg

When done with groups it should turn the scene/group on when the power goes down below 1400mW and groupstatus = Off
The other way around when over 1500mW.

NiklasO
Posts: 132
Joined: Friday 16 August 2013 18:34
Target OS: -
Domoticz version:
Location: Stockholm, Sweden
Contact:

Re: Events system feedback thread

Post by NiklasO » Wednesday 25 September 2013 13:31

Also,
The event i posted in my last url does not work.
With the event active, manually turning on "Fönsterlampa, kök" this happens in the log:

Code: Select all

Error: Wed Sep 25 13:26:34 2013 Lua script error: [string "result = 0; weekday = os.date('*t')['wday']; ..."]:1: ')' expected near 'comparevariable'
Error: Wed Sep 25 13:26:34 2013 Lua script error: [string "result = 0; weekday = os.date('*t')['wday']; ..."]:1: ')' expected near 'comparevariable'
Wed Sep 25 13:26:33 2013 (RFXtrx) Lighting 2 (Fönster, kök)
Wed Sep 25 13:26:34 2013 (RFXtrx) Receiver/Transmitter Message
subtype = Transmitter Response
Sequence nbr = 3
response = ACK, data correct transmitted
With the event disabled, turning on gives me this:

Code: Select all

Wed Sep 25 13:27:03 2013 (RFXtrx) Lighting 2 (Fönster, kök)
Wed Sep 25 13:27:03 2013 (RFXtrx) Receiver/Transmitter Message
subtype = Transmitter Response
Sequence nbr = 4
response = ACK, data correct transmitted
Works as it should. But as I said. Not with the event activated.

The event does nothing if I leave the lamp on and waits for it to turn it off.

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests