Aeon labs AEO-ZW089 recessed door sensor support.

Compatibility (hardware, devices and OS)
spudgunman
Posts: 148
Joined: Tuesday 26 May 2015 18:59
Target OS: Raspberry Pi
Domoticz version: beta
Location: Seattle WA, USA
Contact:

Aeon labs AEO-ZW089 recessed door sensor support.

Post by spudgunman » Tuesday 09 June 2015 17:43

I think one is for the battery? I also think they may be unsupported in OZW i thought i read that somewhere - they publish the developer docs somewhere.

roblom
Posts: 557
Joined: Wednesday 26 February 2014 16:28
Target OS: Raspberry Pi
Domoticz version:
Location: the Netherlands
Contact:

Re: Aeon labs AEO-ZW089 recessed door sensor support.

Post by roblom » Thursday 18 June 2015 22:36

I still have trouble in getting this sensor to work. It is included in the z-wave network but it does not change his state when I swipe the magnet in front of it (the red led does light up).
Tried excluding, including, excluding including. Wait several days. Added it with the button, added it with the "add sensor" and also the "add secure sensor" functions, Removed it from domoticz, reincluded it but it all doesn't change anything, it is seen and updated but doesn't send a signal. I have a RPi with the very latest domoticz (version 2.2573at this moment) and a Aeotec USB V2 stick.

roblom
Posts: 557
Joined: Wednesday 26 February 2014 16:28
Target OS: Raspberry Pi
Domoticz version:
Location: the Netherlands
Contact:

Re: Aeon labs AEO-ZW089 recessed door sensor support.

Post by roblom » Thursday 18 June 2015 22:36

In the "OpenZWave Control Panel" the date and time is directly updated when I switch the sensor (by moving the magnet above it) but the " Value" stays also "on" and never became "off".

roblom
Posts: 557
Joined: Wednesday 26 February 2014 16:28
Target OS: Raspberry Pi
Domoticz version:
Location: the Netherlands
Contact:

Re: Aeon labs AEO-ZW089 recessed door sensor support.

Post by roblom » Thursday 18 June 2015 23:13

mm I think it works... it's probably because the sensor is so fast i didn't noticed it switched. When I put the magnet on top of it, the signal stays off. Sorry for bothering :-)

geezerrr
Posts: 124
Joined: Tuesday 02 December 2014 23:16
Target OS: Raspberry Pi
Domoticz version: Beta
Location: Netherlands
Contact:

Re: Aeon labs AEO-ZW089 recessed door sensor support.

Post by geezerrr » Thursday 18 June 2015 23:14

You should set the report type to 16 (setting 121)w
ImageUploadedByTapatalk1434662057.245545.jpg
ImageUploadedByTapatalk1434662057.245545.jpg (249.1 KiB) Viewed 1534 times

spudgunman
Posts: 148
Joined: Tuesday 26 May 2015 18:59
Target OS: Raspberry Pi
Domoticz version: beta
Location: Seattle WA, USA
Contact:

Re: Aeon labs AEO-ZW089 recessed door sensor support.

Post by spudgunman » Saturday 20 June 2015 6:58

this should be fixed in the newest code version of demoticz and OZW have this working - the OZW-CP wont display correctly for this sensor?

cokelid
Posts: 3
Joined: Sunday 05 April 2015 18:32
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Aeon labs AEO-ZW089 recessed door sensor support.

Post by cokelid » Sunday 13 September 2015 13:54

Has anyone got the AEO-ZW089 (door sensor) working properly?

I've just done a fresh install of Domoticz, I can see the device config is installed in Config/aeotec/recessed_doorsensor_gen5.xml

I'm using an Aeotec Z-Stick S2, and it paired with the door sensor perfectly.

However, in Domoticz, the Node appears as "Unknown". It is working to some degree since the "Last Seen" time changes whenever the door is opened.

I've turned on debugging and it seems only "basic" data is being returned:

OpenZwave Version 1.3.293

Code: Select all

2015-09-13 12:12:30.052 Detail, Node004,   Received: 0x01, 0x09, 0x00, 0x04, 0x00, 0x04, 0x03, 0x20, 0x01, 0xff, 0x2b
2015-09-13 12:12:30.052 Detail,
2015-09-13 12:12:30.052 Info, Node004, Received Basic set from node 4: level=255.  Sending event notification.
2015-09-13 12:12:30.053 Detail, Node004, Notification: NodeEvent
2015-09-13 12:12:31.903 Detail, Node004,   Received: 0x01, 0x09, 0x00, 0x04, 0x00, 0x04, 0x03, 0x20, 0x01, 0x00, 0xd4
2015-09-13 12:12:31.903 Detail,
2015-09-13 12:12:31.903 Info, Node004, Received Basic set from node 4: level=0.  Sending event notification.
2015-09-13 12:12:31.903 Detail, Node004, Notification: NodeEvent
So can anyone confirm this actually works with Domoticz? And any advice on getting it working?

Cheers,
Justin

spudgunman
Posts: 148
Joined: Tuesday 26 May 2015 18:59
Target OS: Raspberry Pi
Domoticz version: beta
Location: Seattle WA, USA
Contact:

Re: Aeon labs AEO-ZW089 recessed door sensor support.

Post by spudgunman » Thursday 17 September 2015 23:29

i can confirm it works - make sure your using the latest builds of OZW on the platform.

as for the unknown any switch that is unnamed shows up as unknown as the name just need to name it.

if your only getting basic click the button to wake it up and open and close the door a few times normally all it takes to make everything work for my systems, then you dont have to mess with it again till the battery dies.

bartman236
Posts: 1
Joined: Thursday 13 October 2016 23:47
Target OS: NAS (Synology & others)
Domoticz version:
Contact:

Re: Aeon labs AEO-ZW089 recessed door sensor support.

Post by bartman236 » Friday 14 October 2016 9:55

I also had some troubles but eventually I got it to work.

My setup:
I have Domoticz V3.5763 installed on my Synology NAS together with an Aeon Z-Stick Gen5 and ZW089 Door sensor.

This is what I did:

First I linked the ZW089 sensor with the USB stick by taking the Z-Stick out, pressing the blue button and the the internal button on the ZW089 sensor with a small pin.

Then I inserted the stick into my Sinology USB port, opened the Domoticz app and selected Setup -> Hardware -> OpenZWave USB with serial port /dev/ttyACM0 or 1 depending on the USB port I use. The stick is then recognised as type 'OpenZWave USB Version: 1.4-2188-gd1c5218-dirty'. From there I can select a red setup icon to get to the Nodes page where I find my 'Aeotec ZW090 Z-Stick Gen5' controller with status 'Active'.
Screen Shot 2016-10-14 at 17.36.36.png
Screen Shot 2016-10-14 at 17.36.36.png (68.66 KiB) Viewed 893 times
From the Nodes page, I can click the 'Node management' button and 'Include Node' to add the ZW-089 sensor by clicking the internal button on the door sensor with a small pin. Both 'Include Node' and 'Include Node Secure' work. The red light on the sensor blinks a few times quickly, remains red and then turns off. When I bring the magnet close, it responds.
Screen Shot 2016-10-14 at 17.37.45.png
Screen Shot 2016-10-14 at 17.37.45.png (307.19 KiB) Viewed 893 times
To get the sensor to actually work, you need to change the settings. This can be done by clicking the line in which the sensor is mentioned
Screen Shot 2016-10-14 at 17.39.27.png
Screen Shot 2016-10-14 at 17.39.27.png (305.1 KiB) Viewed 893 times
I used the following settings:

1. Normal
2. Normal
101. Disabled
121. Sensor Binary Report -> This seems to be important because the Basic set did not work for me. Both Basic set and Binary report could also work.
252. Unlock
254. 1 -> Not sure if it also works with 0.
2000. 0

Apply configuration for this device. If this does not work or your sensor is asleep, you can wake it up by pressing the internal button with a pin.

Now I want the sensor to actually work within Domoticz so I open the Devices page under Setup.

Not sure what it all means, but the sensor is there. When I activate the sensor by bringing the magnet close you don't see a response. To see it change you have to refresh by clicking 'All devices'. The graph (by clicking log icon) gives you the history.

Hope this helps.

chrominator
Posts: 7
Joined: Sunday 25 December 2016 8:27
Target OS: Raspberry Pi
Domoticz version: 3.8007
Contact:

Re: Aeon labs AEO-ZW089 recessed door sensor support.

Post by chrominator » Saturday 31 December 2016 21:28

Great !

After having replaced the exhausted battery from my ZW089, I wasted this afternoon in trying to get this module working again, until I finally find your post here.
Many thanks, it works now.
The workaround for this issue is definitely to change the 121. Sensor Binary Report parameter.

User avatar
remb0
Posts: 809
Joined: Thursday 11 July 2013 22:21
Target OS: Raspberry Pi
Domoticz version: Beta
Location: The Netherlands
Contact:

Re: Aeon labs AEO-ZW089 recessed door sensor support.

Post by remb0 » Tuesday 03 January 2017 18:56

When I try to change my domoticz crashes. even when the sensor is awake. do you have a workaround?

leoncornelissen
Posts: 30
Joined: Monday 27 April 2015 20:33
Target OS: Raspberry Pi
Domoticz version: 3.8258
Location: Netherlands
Contact:

Re: Aeon labs AEO-ZW089 recessed door sensor support.

Post by leoncornelissen » Monday 23 January 2017 23:21

I have the same problem here,
I got it working that domoticz is not crashing but the values are not updated anyhow. I got two door sensors which don't work at the moment.

fransiefrans
Posts: 73
Joined: Sunday 14 June 2015 13:22
Target OS: Raspberry Pi
Domoticz version: stable
Location: Netherlands
Contact:

Re: Aeon labs AEO-ZW089 recessed door sensor support.

Post by fransiefrans » Sunday 08 October 2017 22:27

Hi,
I still got te same problem. I tried to change setting 121 to Sensor Binary Report parameter. But after updating the settings to de device it's not saved as the device is in sleep mode again. I change in the xml file setting 121 but that didnt work either. I hope somebody got the fix

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests