ZXT-120

Compatibility (hardware, devices and OS)
ulf_slask
Posts: 44
Joined: Monday 15 September 2014 21:09
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: ZXT-120

Post by ulf_slask » Friday 16 January 2015 20:34

Hi!

Is this problem solved in LUA and BLOCKY

I cant get it to work in blocky

Kind regards
Ulf

Christian
Posts: 19
Joined: Friday 01 August 2014 13:35
Target OS: Raspberry Pi
Domoticz version:
Location: France
Contact:

Re: ZXT-120

Post by Christian » Saturday 17 January 2015 7:54

Hello
To make the zxt120 working, i use the following Json orders :

To Heat :
http://192.168.xx.yy:8080/json.htm?type ... alue='Heat'
To Stop :
http://192.168.xx.yy:8080/json.htm?type ... value='Off'
To cool :
http://192.168.xx.yy:8080/json.htm?type ... alue='Cool'

ZZ is your idx for ZXT120 device in Domoticz.
RPI B (Domoticz slave + Razberry + RFXComUSB) + 1 RPI model 2 (Domoticz master) + 2 RPI B+ (Openelec)
5 THGR122+THWR800 + 3 OWL180
Oregon Rain + wind + UV meters
FGBS001 + FGMS001
3 blinds BLYSS + 3 blinds Fibaro + 14 switches+ 2 dimers
2 remotec ZXT120

ulf_slask
Posts: 44
Joined: Monday 15 September 2014 21:09
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: ZXT-120

Post by ulf_slask » Sunday 18 January 2015 8:18

I have never used Json!
Is it tricky to do that?

Is it possible to adjust speed and temperature in the same way.

Kind regards

Ulf

ulf_slask
Posts: 44
Joined: Monday 15 September 2014 21:09
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: ZXT-120

Post by ulf_slask » Sunday 18 January 2015 9:27

I started with a bash file in my domoticz/script/ folder

---------------
#!/bin/bash
SERVER="172.16.1.10:8080"
IDX="111"
NVALUE="1"
SVALUE=24

curl -s -i -H "Accept: application/json" "http://$SERVER/json.htm?type=command&param=udevice&idx=$IDX&nvalue=$NVALUE&svalue=$SVALUE"
-------------------

But when i run the script i get this output
--------------------
[email protected] ~/domoticz/scripts $ ./LvPumpUppe.sh
HTTP/1.0 401 Unauthorized
Content-Length: 91
Content-Type: text/html

<html><head><title>Unauthorized</title></head><body><h1>401 Unauthorized</h1></body></html>[email protected] ~/domoticz/scripts $
-------------------------------------------

It works fine when i'm running this command in webbrowser!

Can anyone help me!

Kind regards
Ulf

ulf_slask
Posts: 44
Joined: Monday 15 September 2014 21:09
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: ZXT-120

Post by ulf_slask » Sunday 18 January 2015 9:32


User avatar
Arkie
Posts: 91
Joined: Tuesday 03 December 2013 16:24
Target OS: NAS (Synology & others)
Domoticz version: beta
Location: The Netherlands
Contact:

Re: ZXT-120

Post by Arkie » Friday 19 June 2015 23:05

Just bought a zxt-120 and want to read my unknowen Zibro ac unit, it's not in de code list!
I've tried a lot, but nothing works. They say every AC is compatible!
Is there anybody who can tell me how the IR Code learning function works in Domoticz?

Regards
Synology DS412+ DSM 6.0.2-8451 update2(Domoticz 3.05753-7)
LightwaveRF dimmers
kaku switches/dimmers
Fibaro switches
Logitech Hamony elite
Foscam 9804 ip cam
RFXtrx433E USB 433.92MHz
ZXT 120 eu AC controller
Heatmiser NEO stat thermostats and Hub

loakus
Posts: 7
Joined: Sunday 19 July 2015 1:56
Target OS: Raspberry Pi
Domoticz version: V3.5877
Contact:

Re: ZXT-120

Post by loakus » Sunday 19 July 2015 2:10

Hello guys,
I bought one ZXT-120 and managed to configure it through Domoticz control panel: http://192.168.Y.Z:8080/ozwcp/cp.html.
I'm trying to control my Toshiba AC and so far I can just set the heat or cool mode while having a temperature in the right range; 19 to 23.
I'm frustrated to not be able to switch off the AC. I noticed that the FAN & mode selections aren't changing anything on the AC.
Do you know how to make it working ?
Thanks,
Loic

elmortero
Posts: 126
Joined: Sunday 29 November 2015 21:46
Target OS: Raspberry Pi
Domoticz version: 2.3852
Location: Spain
Contact:

Re: ZXT-120

Post by elmortero » Thursday 23 June 2016 10:56

Hi all,

My ZXT-120 arrived yesterday, I was able to include it (Thermostat Mode) but when I try to enter the "IR code number for built-in code library" (parameter 27).
I enter it and try to submit but it is not stored. It always goes back to "0".

Can someone help me with that?

maurool
Posts: 9
Joined: Tuesday 05 January 2016 1:26
Target OS: Windows
Domoticz version:
Contact:

Re: ZXT-120

Post by maurool » Monday 04 July 2016 1:35

I had the same problem, I was unable to set the value for IR code (also other parameters does not set). Surprisingly this was due to a power supply problem!
If you are using USB, try with a different 5V adapter and with the supplied USB cable. To debug the problem also try to use batteries instead of the USB and see if the problem is solved.

This worked for me. Probably some 5V adapters have unstable voltage or emit some spurius.

Mauro

elmortero
Posts: 126
Joined: Sunday 29 November 2015 21:46
Target OS: Raspberry Pi
Domoticz version: 2.3852
Location: Spain
Contact:

Re: ZXT-120

Post by elmortero » Tuesday 12 July 2016 13:00

Thanks for the tip Mauro, but still not working.
Tried both on batteries and power supply but no use, the parameter 27 keeps resetting to 0.
No clue what to do next, probably going to try the learn function and just configure the basics.

User avatar
emme
Posts: 507
Joined: Monday 27 June 2016 11:02
Target OS: Raspberry Pi
Domoticz version: latest
Location: Milano, Italy
Contact:

Re: ZXT-120

Post by emme » Tuesday 19 July 2016 17:39

ulf_slask wrote: [email protected] ~/domoticz/scripts $ ./LvPumpUppe.sh
HTTP/1.0 401 Unauthorized
Content-Length: 91
Content-Type: text/html

<html><head><title>Unauthorized</title></head><body><h1>401 Unauthorized</h1></body></html>[email protected] ~/domoticz/scripts $
-------------------------------------------

It works fine when i'm running this command in webbrowser!
f
did you add the IP address in the whitelist under SETUP -> Settings -> Local Networks (no username/password)
you should enter 127.0.0.1 for requests coming from the server itself, and any other IP requesting commends within your network or Wan access (but I do not reccomend it)
Ciao
M
That's one small step for a programmer, one giant leap for me!
- - - - -
Raspberry Pi3 + AeonStick G5 + RFXCOMM433 + iRTrans Server + NodeJS
There's no stress in the mess!!

vervoto1
Posts: 16
Joined: Wednesday 24 December 2014 1:03
Target OS: Linux
Domoticz version: lastbeta
Location: NL
Contact:

Re: ZXT-120

Post by vervoto1 » Thursday 25 August 2016 11:13

elmortero wrote:Thanks for the tip Mauro, but still not working.
Tried both on batteries and power supply but no use, the parameter 27 keeps resetting to 0.
No clue what to do next, probably going to try the learn function and just configure the basics.
yup..extremely annoying, had that a number of times too.. I fixed it by putting the zwave controller (USB stick in my case) within 'hearing' distance of the ZXT 120, let's say 2 meters.. and then update the value a few times before it stuck. For some reason, if it needs to propagate throughout the Zwave mesh network it doesn't stick.. at least not for me. strange thing is that the temperature setting propagates without issues, the config settings just dont. These ZXT 120's seem to be a bit buggy, but once you get them to work they're ok.

antares
Posts: 56
Joined: Saturday 24 September 2016 9:25
Target OS: Raspberry Pi
Domoticz version: beta
Location: Germany
Contact:

Re: ZXT-120

Post by antares » Thursday 29 September 2016 14:38

Has there been any progress on the ZXT-120? I have it running more or less flawlessly in openHAB (set temperature, fan speed and operating mode) but cannot get it running in Domoticz. Even if I manually change the mode, nothing happens. No reaction. Yet, if I set a temperature in "Cooling" mode it turns on (but I cannot turn the AC off again).

Is there a chance to have it as "AC" widget in Domoticz? I would be glad to help, but I have no idea of how to do it. Yet, I can help and provide how I got it in openHAB:

This is from my sitemap

Code: Select all

{
  Frame label="Mitsubishi Heavy Industries AC" {
	Setpoint item=HVAC_HeatSetPoint step=1 minValue=18 maxValue=30
	Setpoint item=HVAC_CoolSetPoint step=1 minValue=18 maxValue=30
	Text item=HVAC_Temperature
	Selection item=HVAC_Mode mappings=[0="Off",1="Heating",2="Cooling", 3="Auto", 5="Resume", 6="Venting", 8="Dehumid"]
	Selection item=HVAC_Fan_Mode mappings=[0="Auto Low",1="Low", 2="Auto high", 3="High", 4="Auto medium", 5="Medium"]
	}
}
and this from my items file:

Code: Select all

Number HVAC_HeatSetPoint "Heating [%.1f °C]" <thermostat> { zwave="16:command=thermostat_setpoint,setpoint_type=1,setpoint_scale=0" }
Number HVAC_CoolSetPoint "Cooling [%.1f °C]" <thermostat> { zwave="16:command=thermostat_setpoint,setpoint_type=2,setpoint_scale=0" }
Number HVAC_Temperature "Temperature [%.1f °C]" <temperature> { zwave="16:command=sensor_multilevel,sensor_type=1,refresh_interval=60" }
Number HVAC_Mode "Mode [%s]" { zwave="16:command=thermostat_mode" }
Number HVAC_Fan_Mode "Fan mode [%s]"{zwave="16:command=thermostat_fan_mode" }
while obviously the ZXT-120 is the 16th Z-Wave device on my dongle (0x10).

User avatar
Ben0it
Posts: 19
Joined: Sunday 31 January 2016 22:22
Target OS: Linux
Domoticz version: 3.6745
Location: France
Contact:

Re: ZXT-120

Post by Ben0it » Sunday 16 October 2016 10:45

Hello,

I have the same problem here: my module ZXT-120 does not respond to basic commands. The only way to trigger it is to use the OpenZWave control panel and after a refresh of the node, it sometimes accepts to change mode (Off/Heat/Cool).

Before using Domoticz (about one year ago), I used Jeedom which was perfectly controlling this Remotec ZXT-120 module, so the problem doesn't seem to come from the hardware itself.

Best Regards,
-
Benoît.

juankar
Posts: 498
Joined: Saturday 30 August 2014 20:20
Target OS: Raspberry Pi
Domoticz version:
Location: Spain
Contact:

Re: ZXT-120

Post by juankar » Wednesday 28 December 2016 0:45

With ZwavePlus and a Aeotec GEN5. this device fails. When you send a commandSET (for setting mode or setpoint or fanmode for instance) a commandSET is sent to the device followed by a CommandGET (to refresh the value). And, in this way Remotec fails. Some times it works if you send the same command about 10 times.
It's necesary to change OpenZwave, but it's a tircky patcha. Meanwhile I'm waiting for a feedback from Remotec since about four days ago.

antares
Posts: 56
Joined: Saturday 24 September 2016 9:25
Target OS: Raspberry Pi
Domoticz version: beta
Location: Germany
Contact:

Re: ZXT-120

Post by antares » Wednesday 28 December 2016 9:29

juankar wrote:It's necesary to change OpenZwave, but it's a tircky patcha. Meanwhile I'm waiting for a feedback from Remotec since about four days ago.
Hi juankar!

Many thanks for your findings. Do you have a guide for how to patch OpenZwave or can you provide it to the devs to integrate it?

User avatar
Ben0it
Posts: 19
Joined: Sunday 31 January 2016 22:22
Target OS: Linux
Domoticz version: 3.6745
Location: France
Contact:

Re: ZXT-120

Post by Ben0it » Wednesday 28 December 2016 9:50

Hi,

@Juankar: Thanks for the information, it gives hope again to have working ZXT-120 inside Domoticz.

I also use a « AEOTEC ZW090 "Z-Stick" GEN5 - Dongle USB adapter » with my Domoticz installation.

It has the following USB IDs:

Code: Select all

Bus 006 Device 003: ID 0658:0200 Sigma Designs, Inc.
Now that you mention this, when I was using Jeedom at the begining, the Z-Wave controller was a different one (integrated to a customized Raspberry Pi board).

Would you have a different Z-Wave USB adapter to suggest allowing full ZXT-120 operation with Domoticz?

In the mean time, I'll give a try on the Sigma Designs Z-Wave+ USB controller.

Best Regards,
-
Benoît.

juankar
Posts: 498
Joined: Saturday 30 August 2014 20:20
Target OS: Raspberry Pi
Domoticz version:
Location: Spain
Contact:

Re: ZXT-120

Post by juankar » Wednesday 28 December 2016 20:09

I've tested Remotec with an Aeotec Z-Stick S2 and It worked. It was in a Zwave (not plus) net with just the Remotec device.
Now I've modified openZwave library to exclude the Get command for this device and It can be used with Domoticz.
I did a change in file value_classes/Value.cpp, about at line 377 :

Code: Select all

          if( res )
                {
//These if sentence is just for avoid commandGet after CommandSet  (4 Lines)
                if (node->GetProductName() == "ZXT-120EU")
                        {
                            return res;
                        }
                    if( !IsWriteOnly())
Now I can change mode or fan mode and Remotecz send the proper IR to AC, but it doesn't update the value in Control Panel, but you can use it, I haven't found any problem. You can try it.
This path is a tricky fix, but I consider it's valid until somebody (or me) find a solution with more info from Remotec.
Bye.

User avatar
Ben0it
Posts: 19
Joined: Sunday 31 January 2016 22:22
Target OS: Linux
Domoticz version: 3.6745
Location: France
Contact:

Re: ZXT-120

Post by Ben0it » Thursday 29 December 2016 14:21

Hi Juankar,

I just tried your patch, it works: I can send multiple commands to the ZXT-120 and they are properly transmitted.

Thanks for your investigation! Let's hope Remotec will help with a permanent fix on OpenZWave stack.

Best Regards,
-
Benoît.

juankar
Posts: 498
Joined: Saturday 30 August 2014 20:20
Target OS: Raspberry Pi
Domoticz version:
Location: Spain
Contact:

Re: ZXT-120

Post by juankar » Thursday 29 December 2016 14:52

Thanks
I'm working in other patch more "elegant".

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests