Support for Steinel

Others (MiLight, Hue, Toon etc...)
Post Reply
Ivanhoe1
Posts: 11
Joined: Monday 19 December 2016 21:42
Target OS: Windows
Domoticz version:
Contact:

Support for Steinel

Post by Ivanhoe1 » Tuesday 21 November 2017 23:15

Does domoticz have support for Steinels new z-wave products? Like the Xled: http://www.steinel.de/en/smart-home/sma ... -wave.html

dolusystem
Posts: 2
Joined: Monday 02 March 2015 16:40
Target OS: Raspberry Pi
Domoticz version: 2.3530
Location: Geneva
Contact:

Re: Support for Steinel

Post by dolusystem » Friday 01 December 2017 14:46

Hello I will be very interested to get the configuration xml file for Steinel devices which are very nice.
I found that file but too complex to handle for me
http://contenido.steinel.de/brand/uploa ... 5_2017.pdf

sailmich
Posts: 50
Joined: Wednesday 17 February 2016 23:55
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Support for Steinel

Post by sailmich » Sunday 10 December 2017 9:29

Hello here is the xml file. I use the file for xledh2 and is140-2. PIR / switch and Lux is working. When you don't want to change settings of the devices no need to have the xml. They working out of the Box.
xledh2.xml
(9.6 KiB) Downloaded 57 times

sailmich
Posts: 50
Joined: Wednesday 17 February 2016 23:55
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Support for Steinel

Post by sailmich » Tuesday 12 December 2017 12:50

sailmich wrote:
Sunday 10 December 2017 9:29
Hello here is the xml file. I use the file for xledh2 and is140-2. PIR / switch and Lux is working. When you don't want to change settings of the devices no need to have the xml. They working out of the Box.
xledh2.xml
edit: After a while they lost connection and stop to report. I have that mostly with just one out of three devices. I will check if it is a problem of distance.

GammaKappa
Posts: 1
Joined: Friday 12 January 2018 12:57
Target OS: Raspberry Pi
Domoticz version:
Contact:

Re: Support for Steinel

Post by GammaKappa » Saturday 13 January 2018 0:14

I am running Domoticz V3.8153 on a RasPi 3 with an Aeotec GEN5 stick controller.
I managed to get the z-wave part up and running with a Fibaro Wall Plug, a NeoCool PIR sensor and a Qubino relay, all working fine.
I added a Steinel XLED home 2 Z-wave using the xledh2.xml from sailmich. Switching and parameter setting is working.

However after a number of on/off switching of the lamp, the system seems to go crazy and get in an endless communication loop between the controller and the Steinel.
When I monitor the 868 Mhz channel with sdr# I can see it is flooded by continuous rf transmissions that only stops when I cut the power from the Steinel.

The OZW_log file is mostly filled with lines like :
...
2018-01-12 14:06:34.491 Info, Node008, Received Basic set from node 8: level=0. Sending event notification.
2018-01-12 14:06:34.491 Detail, Node008, Notification: NodeEvent
2018-01-12 14:06:34.516 Detail, Node008, Received: 0x01, 0x09, 0x00, 0x04, 0x00, 0x08, 0x03, 0x20, 0x01, 0x00, 0xd8
2018-01-12 14:06:34.516 Detail,
2018-01-12 14:06:34.516 Info, Node008, Received Basic set from node 8: level=0. Sending event notification.
2018-01-12 14:06:34.516 Detail, Node008, Notification: NodeEvent
2018-01-12 14:06:34.541 Detail, Node008, Received: 0x01, 0x09, 0x00, 0x04, 0x00, 0x08, 0x03, 0x20, 0x01, 0x00, 0xd8
2018-01-12 14:06:34.541 Detail,
...
at a rate of one per 25 msec !

Can anybody point me in a direction to find a solution ?

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests